Github messages for voidlinux
 help / color / mirror / Atom feed
* [PR PATCH] New package: UxPlay-1.65
@ 2023-07-06 11:59 T0mstone
  2023-07-06 20:52 ` [PR REVIEW] " classabbyamp
                   ` (14 more replies)
  0 siblings, 15 replies; 16+ messages in thread
From: T0mstone @ 2023-07-06 11:59 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1817 bytes --]

There is a new pull request by T0mstone against master on the void-packages repository

https://github.com/T0mstone/void-packages uxplay
https://github.com/void-linux/void-packages/pull/44875

New package: UxPlay-1.65
<!-- Uncomment relevant sections and delete options which are not applicable -->
Spiritual successor to #33191.

#### Testing the changes
- I tested the changes in this PR: **YES**

#### New package
- This new package conforms to the [package requirements](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#package-requirements): **YES**

<!-- Note: If the build is likely to take more than 2 hours, please add ci skip tag as described in
https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->

#### Local build testing
- I built this PR locally for my native architecture, (x86_64-glibc)

#### OpenSSL
> UxPlay's GPLv3 license does not have an added "GPL exception" explicitly allowing it to be distributed in compiled form when linked to OpenSSL versions prior to v. 3.0.0 (older versions of OpenSSL have a license clause incompatible with the GPL unless OpenSSL can be regarded as a "System Library", which it is in *BSD). Many Linux distributions treat OpenSSL as a "System Library", but some (e.g. Debian) do not: in this case, the issue is solved by linking with OpenSSL-3.0.0 or later.
How does Void handle this? Can OpenSSL be considered a "System Library"? Once #37681 lands, this won't be a concern anymore, of course. Until then, I've made the package `restricted=yes` for now.


A patch file from https://github.com/void-linux/void-packages/pull/44875.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-uxplay-44875.patch --]
[-- Type: text/x-diff, Size: 2150 bytes --]

From 35592c31d03ce346da3d4c9a6fe0fbaf99b3af00 Mon Sep 17 00:00:00 2001
From: T0mstone <realt0mstone@gmail.com>
Date: Wed, 5 Jul 2023 18:08:11 +0200
Subject: [PATCH] New package: UxPlay-1.65

---
 srcpkgs/UxPlay/INSTALL.msg |  5 +++++
 srcpkgs/UxPlay/template    | 21 +++++++++++++++++++++
 2 files changed, 26 insertions(+)
 create mode 100644 srcpkgs/UxPlay/INSTALL.msg
 create mode 100644 srcpkgs/UxPlay/template

diff --git a/srcpkgs/UxPlay/INSTALL.msg b/srcpkgs/UxPlay/INSTALL.msg
new file mode 100644
index 000000000000..c4866c21ec50
--- /dev/null
+++ b/srcpkgs/UxPlay/INSTALL.msg
@@ -0,0 +1,5 @@
+Additional GStreamer plugins you may need to install:
+- "vaapi" is needed for hardware-accelerated h264 video decoding by Intel or AMD graphics (but not for use with NVIDIA using proprietary drivers)
+- "pipewire" may be needed for audio sharing when your system is set up to use pipewire
+
+Additionally, UxPlay requires a running DNS-SD server (for example "avahi").
diff --git a/srcpkgs/UxPlay/template b/srcpkgs/UxPlay/template
new file mode 100644
index 000000000000..81405c3de763
--- /dev/null
+++ b/srcpkgs/UxPlay/template
@@ -0,0 +1,21 @@
+# Template file for 'UxPlay'
+pkgname=UxPlay
+version=1.65
+revision=1
+build_style=cmake
+configure_args="$(vopt_if native_build '' '-DNO_MARCH_NATIVE=ON') $(vopt_if x11 '' '-DNO_X11_DEPS=ON')"
+hostmakedepends="pkg-config"
+makedepends="openssl-devel libplist-devel avahi-compat-libs-devel gstreamer1-devel gst-plugins-base1-devel $(vopt_if x11 libX11-devel)"
+depends="gst-plugins-base1 gst-libav gst-plugins-good1 gst-plugins-bad1"
+short_desc="AirPlay Unix mirroring server"
+maintainer="T0mstone <realt0mstone@gmail.com>"
+license="GPL-3.0-or-later"
+homepage="https://github.com/FDH2/UxPlay"
+changelog="https://github.com/FDH2/UxPlay/releases/tag/v${version}"
+distfiles="https://github.com/FDH2/UxPlay/archive/refs/tags/v${version}.tar.gz"
+checksum=aeb6458ab4208fc188b66a95a8c88523bb8fd642a45b6a9b45f99aac7ee548af
+# UxPlay forbids binary redistribution when linked with OpenSSL <3.0.0 (not GPL-compatible)
+restricted=yes
+
+build_options="x11 native_build"
+build_options_default="x11"

^ permalink raw reply	[flat|nested] 16+ messages in thread

* Re: [PR REVIEW] New package: UxPlay-1.65
  2023-07-06 11:59 [PR PATCH] New package: UxPlay-1.65 T0mstone
@ 2023-07-06 20:52 ` classabbyamp
  2023-07-07 16:33 ` [PR PATCH] [Updated] " T0mstone
                   ` (13 subsequent siblings)
  14 siblings, 0 replies; 16+ messages in thread
From: classabbyamp @ 2023-07-06 20:52 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 214 bytes --]

New review comment by classabbyamp on void-packages repository

https://github.com/void-linux/void-packages/pull/44875#discussion_r1254905074

Comment:
this should be files/README.voidlinux, not an install message

^ permalink raw reply	[flat|nested] 16+ messages in thread

* Re: [PR PATCH] [Updated] New package: UxPlay-1.65
  2023-07-06 11:59 [PR PATCH] New package: UxPlay-1.65 T0mstone
  2023-07-06 20:52 ` [PR REVIEW] " classabbyamp
@ 2023-07-07 16:33 ` T0mstone
  2023-09-11 20:17 ` T0mstone
                   ` (12 subsequent siblings)
  14 siblings, 0 replies; 16+ messages in thread
From: T0mstone @ 2023-07-07 16:33 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1824 bytes --]

There is an updated pull request by T0mstone against master on the void-packages repository

https://github.com/T0mstone/void-packages uxplay
https://github.com/void-linux/void-packages/pull/44875

New package: UxPlay-1.65
<!-- Uncomment relevant sections and delete options which are not applicable -->
Spiritual successor to #33191.

#### Testing the changes
- I tested the changes in this PR: **YES**

#### New package
- This new package conforms to the [package requirements](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#package-requirements): **YES**

<!-- Note: If the build is likely to take more than 2 hours, please add ci skip tag as described in
https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->

#### Local build testing
- I built this PR locally for my native architecture, (x86_64-glibc)

#### OpenSSL
> UxPlay's GPLv3 license does not have an added "GPL exception" explicitly allowing it to be distributed in compiled form when linked to OpenSSL versions prior to v. 3.0.0 (older versions of OpenSSL have a license clause incompatible with the GPL unless OpenSSL can be regarded as a "System Library", which it is in *BSD). Many Linux distributions treat OpenSSL as a "System Library", but some (e.g. Debian) do not: in this case, the issue is solved by linking with OpenSSL-3.0.0 or later.

How does Void handle this? Can OpenSSL be considered a "System Library"? Once #37681 lands, this won't be a concern anymore, of course. Until then, I've made the package `restricted=yes` for now.


A patch file from https://github.com/void-linux/void-packages/pull/44875.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-uxplay-44875.patch --]
[-- Type: text/x-diff, Size: 2300 bytes --]

From 187d80359386fb38f54905bdac321cd64bb2cf3c Mon Sep 17 00:00:00 2001
From: T0mstone <realt0mstone@gmail.com>
Date: Wed, 5 Jul 2023 18:08:11 +0200
Subject: [PATCH] New package: UxPlay-1.65

---
 srcpkgs/UxPlay/files/README.voidlinux |  5 +++++
 srcpkgs/UxPlay/template               | 25 +++++++++++++++++++++++++
 2 files changed, 30 insertions(+)
 create mode 100644 srcpkgs/UxPlay/files/README.voidlinux
 create mode 100644 srcpkgs/UxPlay/template

diff --git a/srcpkgs/UxPlay/files/README.voidlinux b/srcpkgs/UxPlay/files/README.voidlinux
new file mode 100644
index 000000000000..f67a85659e50
--- /dev/null
+++ b/srcpkgs/UxPlay/files/README.voidlinux
@@ -0,0 +1,5 @@
+Additional GStreamer plugins you may need to install:
+- `gstreamer-vaapi` is needed for hardware-accelerated h264 video decoding by Intel or AMD graphics (but not for use with NVIDIA using proprietary drivers)
+- `gstreamer1-pipewire` may be needed for audio sharing when your system is set up to use pipewire
+
+Additionally, UxPlay requires a running DNS-SD server (for example `avahi`).
diff --git a/srcpkgs/UxPlay/template b/srcpkgs/UxPlay/template
new file mode 100644
index 000000000000..510a245fb85d
--- /dev/null
+++ b/srcpkgs/UxPlay/template
@@ -0,0 +1,25 @@
+# Template file for 'UxPlay'
+pkgname=UxPlay
+version=1.65
+revision=1
+build_style=cmake
+configure_args="$(vopt_if native_build '' '-DNO_MARCH_NATIVE=ON') $(vopt_if x11 '' '-DNO_X11_DEPS=ON')"
+hostmakedepends="pkg-config"
+makedepends="openssl-devel libplist-devel avahi-compat-libs-devel gstreamer1-devel gst-plugins-base1-devel $(vopt_if x11 libX11-devel)"
+depends="gst-plugins-base1 gst-libav gst-plugins-good1 gst-plugins-bad1"
+short_desc="AirPlay Unix mirroring server"
+maintainer="T0mstone <realt0mstone@gmail.com>"
+license="GPL-3.0-or-later"
+homepage="https://github.com/FDH2/UxPlay"
+changelog="https://github.com/FDH2/UxPlay/releases/tag/v${version}"
+distfiles="https://github.com/FDH2/UxPlay/archive/refs/tags/v${version}.tar.gz"
+checksum=aeb6458ab4208fc188b66a95a8c88523bb8fd642a45b6a9b45f99aac7ee548af
+# UxPlay forbids binary redistribution when linked with OpenSSL <3.0.0 (not GPL-compatible)
+restricted=yes
+
+build_options="x11 native_build"
+build_options_default="x11"
+
+post_install() {
+	vdoc ${FILESDIR}/README.voidlinux
+}

^ permalink raw reply	[flat|nested] 16+ messages in thread

* Re: [PR PATCH] [Updated] New package: UxPlay-1.65
  2023-07-06 11:59 [PR PATCH] New package: UxPlay-1.65 T0mstone
  2023-07-06 20:52 ` [PR REVIEW] " classabbyamp
  2023-07-07 16:33 ` [PR PATCH] [Updated] " T0mstone
@ 2023-09-11 20:17 ` T0mstone
  2023-09-11 20:19 ` [PR PATCH] [Updated] New package: UxPlay-1.66 T0mstone
                   ` (11 subsequent siblings)
  14 siblings, 0 replies; 16+ messages in thread
From: T0mstone @ 2023-09-11 20:17 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1824 bytes --]

There is an updated pull request by T0mstone against master on the void-packages repository

https://github.com/T0mstone/void-packages uxplay
https://github.com/void-linux/void-packages/pull/44875

New package: UxPlay-1.65
<!-- Uncomment relevant sections and delete options which are not applicable -->
Spiritual successor to #33191.

#### Testing the changes
- I tested the changes in this PR: **YES**

#### New package
- This new package conforms to the [package requirements](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#package-requirements): **YES**

<!-- Note: If the build is likely to take more than 2 hours, please add ci skip tag as described in
https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->

#### Local build testing
- I built this PR locally for my native architecture, (x86_64-glibc)

#### OpenSSL
> UxPlay's GPLv3 license does not have an added "GPL exception" explicitly allowing it to be distributed in compiled form when linked to OpenSSL versions prior to v. 3.0.0 (older versions of OpenSSL have a license clause incompatible with the GPL unless OpenSSL can be regarded as a "System Library", which it is in *BSD). Many Linux distributions treat OpenSSL as a "System Library", but some (e.g. Debian) do not: in this case, the issue is solved by linking with OpenSSL-3.0.0 or later.

How does Void handle this? Can OpenSSL be considered a "System Library"? Once #37681 lands, this won't be a concern anymore, of course. Until then, I've made the package `restricted=yes` for now.


A patch file from https://github.com/void-linux/void-packages/pull/44875.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-uxplay-44875.patch --]
[-- Type: text/x-diff, Size: 2304 bytes --]

From 5e909f8f2acd132988fec7a3c3220b1c0287aaba Mon Sep 17 00:00:00 2001
From: T0mstone <realt0mstone@gmail.com>
Date: Wed, 5 Jul 2023 18:08:11 +0200
Subject: [PATCH] New package: UxPlay-1.66

---
 srcpkgs/UxPlay/files/README.voidlinux |  5 +++++
 srcpkgs/UxPlay/template               | 25 +++++++++++++++++++++++++
 2 files changed, 30 insertions(+)
 create mode 100644 srcpkgs/UxPlay/files/README.voidlinux
 create mode 100644 srcpkgs/UxPlay/template

diff --git a/srcpkgs/UxPlay/files/README.voidlinux b/srcpkgs/UxPlay/files/README.voidlinux
new file mode 100644
index 0000000000000..f67a85659e506
--- /dev/null
+++ b/srcpkgs/UxPlay/files/README.voidlinux
@@ -0,0 +1,5 @@
+Additional GStreamer plugins you may need to install:
+- `gstreamer-vaapi` is needed for hardware-accelerated h264 video decoding by Intel or AMD graphics (but not for use with NVIDIA using proprietary drivers)
+- `gstreamer1-pipewire` may be needed for audio sharing when your system is set up to use pipewire
+
+Additionally, UxPlay requires a running DNS-SD server (for example `avahi`).
diff --git a/srcpkgs/UxPlay/template b/srcpkgs/UxPlay/template
new file mode 100644
index 0000000000000..510a245fb85db
--- /dev/null
+++ b/srcpkgs/UxPlay/template
@@ -0,0 +1,25 @@
+# Template file for 'UxPlay'
+pkgname=UxPlay
+version=1.65
+revision=1
+build_style=cmake
+configure_args="$(vopt_if native_build '' '-DNO_MARCH_NATIVE=ON') $(vopt_if x11 '' '-DNO_X11_DEPS=ON')"
+hostmakedepends="pkg-config"
+makedepends="openssl-devel libplist-devel avahi-compat-libs-devel gstreamer1-devel gst-plugins-base1-devel $(vopt_if x11 libX11-devel)"
+depends="gst-plugins-base1 gst-libav gst-plugins-good1 gst-plugins-bad1"
+short_desc="AirPlay Unix mirroring server"
+maintainer="T0mstone <realt0mstone@gmail.com>"
+license="GPL-3.0-or-later"
+homepage="https://github.com/FDH2/UxPlay"
+changelog="https://github.com/FDH2/UxPlay/releases/tag/v${version}"
+distfiles="https://github.com/FDH2/UxPlay/archive/refs/tags/v${version}.tar.gz"
+checksum=aeb6458ab4208fc188b66a95a8c88523bb8fd642a45b6a9b45f99aac7ee548af
+# UxPlay forbids binary redistribution when linked with OpenSSL <3.0.0 (not GPL-compatible)
+restricted=yes
+
+build_options="x11 native_build"
+build_options_default="x11"
+
+post_install() {
+	vdoc ${FILESDIR}/README.voidlinux
+}

^ permalink raw reply	[flat|nested] 16+ messages in thread

* Re: [PR PATCH] [Updated] New package: UxPlay-1.66
  2023-07-06 11:59 [PR PATCH] New package: UxPlay-1.65 T0mstone
                   ` (2 preceding siblings ...)
  2023-09-11 20:17 ` T0mstone
@ 2023-09-11 20:19 ` T0mstone
  2023-09-11 20:44 ` T0mstone
                   ` (10 subsequent siblings)
  14 siblings, 0 replies; 16+ messages in thread
From: T0mstone @ 2023-09-11 20:19 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1906 bytes --]

There is an updated pull request by T0mstone against master on the void-packages repository

https://github.com/T0mstone/void-packages uxplay
https://github.com/void-linux/void-packages/pull/44875

New package: UxPlay-1.66
<!-- Uncomment relevant sections and delete options which are not applicable -->
Spiritual successor to #33191.

#### Testing the changes
- I tested the changes in this PR: **YES**

#### New package
- This new package conforms to the [package requirements](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#package-requirements): **YES**

<!-- Note: If the build is likely to take more than 2 hours, please add ci skip tag as described in
https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->

#### Local build testing
- I built this PR locally for my native architecture, (x86_64-glibc)

#### OpenSSL
> UxPlay's GPLv3 license does not have an added "GPL exception" explicitly allowing it to be distributed in compiled form when linked to OpenSSL versions prior to v. 3.0.0 (older versions of OpenSSL have a license clause incompatible with the GPL unless OpenSSL can be regarded as a "System Library", which it is in *BSD). Many Linux distributions treat OpenSSL as a "System Library", but some (e.g. Debian) do not: in this case, the issue is solved by linking with OpenSSL-3.0.0 or later.

~~How does Void handle this? Can OpenSSL be considered a "System Library"? Once #37681 lands, this won't be a concern anymore, of course. Until then, I've made the package `restricted=yes` for now.~~

*Update*: Since OpenSSL is now on version 3, I have removed the restriction.

A patch file from https://github.com/void-linux/void-packages/pull/44875.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-uxplay-44875.patch --]
[-- Type: text/x-diff, Size: 2193 bytes --]

From d4eb411dde8228f9eb6cf287e16ce56a30fe346f Mon Sep 17 00:00:00 2001
From: T0mstone <realt0mstone@gmail.com>
Date: Wed, 5 Jul 2023 18:08:11 +0200
Subject: [PATCH] New package: UxPlay-1.66

---
 srcpkgs/UxPlay/files/README.voidlinux |  5 +++++
 srcpkgs/UxPlay/template               | 23 +++++++++++++++++++++++
 2 files changed, 28 insertions(+)
 create mode 100644 srcpkgs/UxPlay/files/README.voidlinux
 create mode 100644 srcpkgs/UxPlay/template

diff --git a/srcpkgs/UxPlay/files/README.voidlinux b/srcpkgs/UxPlay/files/README.voidlinux
new file mode 100644
index 0000000000000..f67a85659e506
--- /dev/null
+++ b/srcpkgs/UxPlay/files/README.voidlinux
@@ -0,0 +1,5 @@
+Additional GStreamer plugins you may need to install:
+- `gstreamer-vaapi` is needed for hardware-accelerated h264 video decoding by Intel or AMD graphics (but not for use with NVIDIA using proprietary drivers)
+- `gstreamer1-pipewire` may be needed for audio sharing when your system is set up to use pipewire
+
+Additionally, UxPlay requires a running DNS-SD server (for example `avahi`).
diff --git a/srcpkgs/UxPlay/template b/srcpkgs/UxPlay/template
new file mode 100644
index 0000000000000..d3482fc5b9780
--- /dev/null
+++ b/srcpkgs/UxPlay/template
@@ -0,0 +1,23 @@
+# Template file for 'UxPlay'
+pkgname=UxPlay
+version=1.66
+revision=1
+build_style=cmake
+configure_args="$(vopt_if native_build '' '-DNO_MARCH_NATIVE=ON') $(vopt_if x11 '' '-DNO_X11_DEPS=ON')"
+hostmakedepends="pkg-config"
+makedepends="openssl-devel libplist-devel avahi-compat-libs-devel gstreamer1-devel gst-plugins-base1-devel $(vopt_if x11 libX11-devel)"
+depends="gst-plugins-base1 gst-libav gst-plugins-good1 gst-plugins-bad1"
+short_desc="AirPlay Unix mirroring server"
+maintainer="T0mstone <realt0mstone@gmail.com>"
+license="GPL-3.0-or-later"
+homepage="https://github.com/FDH2/UxPlay"
+changelog="https://github.com/FDH2/UxPlay/releases/tag/v${version}"
+distfiles="https://github.com/FDH2/UxPlay/archive/refs/tags/v${version}.tar.gz"
+checksum=46b456a16dbfe2df992d9ab14bb72cdb63a1ae49b8f7b7a68629025fec8d774e
+
+build_options="x11 native_build"
+build_options_default="x11"
+
+post_install() {
+	vdoc ${FILESDIR}/README.voidlinux
+}

^ permalink raw reply	[flat|nested] 16+ messages in thread

* Re: [PR PATCH] [Updated] New package: UxPlay-1.66
  2023-07-06 11:59 [PR PATCH] New package: UxPlay-1.65 T0mstone
                   ` (3 preceding siblings ...)
  2023-09-11 20:19 ` [PR PATCH] [Updated] New package: UxPlay-1.66 T0mstone
@ 2023-09-11 20:44 ` T0mstone
  2023-12-09  4:54 ` T0mstone
                   ` (9 subsequent siblings)
  14 siblings, 0 replies; 16+ messages in thread
From: T0mstone @ 2023-09-11 20:44 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1908 bytes --]

There is an updated pull request by T0mstone against master on the void-packages repository

https://github.com/T0mstone/void-packages uxplay
https://github.com/void-linux/void-packages/pull/44875

New package: UxPlay-1.66
<!-- Uncomment relevant sections and delete options which are not applicable -->
Spiritual successor to #33191.

#### Testing the changes
- I tested the changes in this PR: **YES**

#### New package
- This new package conforms to the [package requirements](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#package-requirements): **YES**

<!-- Note: If the build is likely to take more than 2 hours, please add ci skip tag as described in
https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->

#### Local build testing
- I built this PR locally for my native architecture, (x86_64-glibc)

#### OpenSSL
> UxPlay's GPLv3 license does not have an added "GPL exception" explicitly allowing it to be distributed in compiled form when linked to OpenSSL versions prior to v. 3.0.0 (older versions of OpenSSL have a license clause incompatible with the GPL unless OpenSSL can be regarded as a "System Library", which it is in *BSD). Many Linux distributions treat OpenSSL as a "System Library", but some (e.g. Debian) do not: in this case, the issue is solved by linking with OpenSSL-3.0.0 or later.

~~How does Void handle this? Can OpenSSL be considered a "System Library"? Once #37681 lands, this won't be a concern anymore, of course. Until then, I've made the package `restricted=yes` for now.~~

**Update**: Since OpenSSL is now on version 3, I have removed the restriction.

A patch file from https://github.com/void-linux/void-packages/pull/44875.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-uxplay-44875.patch --]
[-- Type: text/x-diff, Size: 2193 bytes --]

From f45c237812f188692aca78549fd20422ddacf727 Mon Sep 17 00:00:00 2001
From: T0mstone <realt0mstone@gmail.com>
Date: Wed, 5 Jul 2023 18:08:11 +0200
Subject: [PATCH] New package: UxPlay-1.66

---
 srcpkgs/UxPlay/files/README.voidlinux |  5 +++++
 srcpkgs/UxPlay/template               | 23 +++++++++++++++++++++++
 2 files changed, 28 insertions(+)
 create mode 100644 srcpkgs/UxPlay/files/README.voidlinux
 create mode 100644 srcpkgs/UxPlay/template

diff --git a/srcpkgs/UxPlay/files/README.voidlinux b/srcpkgs/UxPlay/files/README.voidlinux
new file mode 100644
index 0000000000000..f67a85659e506
--- /dev/null
+++ b/srcpkgs/UxPlay/files/README.voidlinux
@@ -0,0 +1,5 @@
+Additional GStreamer plugins you may need to install:
+- `gstreamer-vaapi` is needed for hardware-accelerated h264 video decoding by Intel or AMD graphics (but not for use with NVIDIA using proprietary drivers)
+- `gstreamer1-pipewire` may be needed for audio sharing when your system is set up to use pipewire
+
+Additionally, UxPlay requires a running DNS-SD server (for example `avahi`).
diff --git a/srcpkgs/UxPlay/template b/srcpkgs/UxPlay/template
new file mode 100644
index 0000000000000..d3482fc5b9780
--- /dev/null
+++ b/srcpkgs/UxPlay/template
@@ -0,0 +1,23 @@
+# Template file for 'UxPlay'
+pkgname=UxPlay
+version=1.66
+revision=1
+build_style=cmake
+configure_args="$(vopt_if native_build '' '-DNO_MARCH_NATIVE=ON') $(vopt_if x11 '' '-DNO_X11_DEPS=ON')"
+hostmakedepends="pkg-config"
+makedepends="openssl-devel libplist-devel avahi-compat-libs-devel gstreamer1-devel gst-plugins-base1-devel $(vopt_if x11 libX11-devel)"
+depends="gst-plugins-base1 gst-libav gst-plugins-good1 gst-plugins-bad1"
+short_desc="AirPlay Unix mirroring server"
+maintainer="T0mstone <realt0mstone@gmail.com>"
+license="GPL-3.0-or-later"
+homepage="https://github.com/FDH2/UxPlay"
+changelog="https://github.com/FDH2/UxPlay/releases/tag/v${version}"
+distfiles="https://github.com/FDH2/UxPlay/archive/refs/tags/v${version}.tar.gz"
+checksum=46b456a16dbfe2df992d9ab14bb72cdb63a1ae49b8f7b7a68629025fec8d774e
+
+build_options="x11 native_build"
+build_options_default="x11"
+
+post_install() {
+	vdoc ${FILESDIR}/README.voidlinux
+}

^ permalink raw reply	[flat|nested] 16+ messages in thread

* Re: [PR PATCH] [Updated] New package: UxPlay-1.66
  2023-07-06 11:59 [PR PATCH] New package: UxPlay-1.65 T0mstone
                   ` (4 preceding siblings ...)
  2023-09-11 20:44 ` T0mstone
@ 2023-12-09  4:54 ` T0mstone
  2024-01-01 20:22 ` [PR PATCH] [Updated] New package: UxPlay-1.67 T0mstone
                   ` (8 subsequent siblings)
  14 siblings, 0 replies; 16+ messages in thread
From: T0mstone @ 2023-12-09  4:54 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1908 bytes --]

There is an updated pull request by T0mstone against master on the void-packages repository

https://github.com/T0mstone/void-packages uxplay
https://github.com/void-linux/void-packages/pull/44875

New package: UxPlay-1.66
<!-- Uncomment relevant sections and delete options which are not applicable -->
Spiritual successor to #33191.

#### Testing the changes
- I tested the changes in this PR: **YES**

#### New package
- This new package conforms to the [package requirements](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#package-requirements): **YES**

<!-- Note: If the build is likely to take more than 2 hours, please add ci skip tag as described in
https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->

#### Local build testing
- I built this PR locally for my native architecture, (x86_64-glibc)

#### OpenSSL
> UxPlay's GPLv3 license does not have an added "GPL exception" explicitly allowing it to be distributed in compiled form when linked to OpenSSL versions prior to v. 3.0.0 (older versions of OpenSSL have a license clause incompatible with the GPL unless OpenSSL can be regarded as a "System Library", which it is in *BSD). Many Linux distributions treat OpenSSL as a "System Library", but some (e.g. Debian) do not: in this case, the issue is solved by linking with OpenSSL-3.0.0 or later.

~~How does Void handle this? Can OpenSSL be considered a "System Library"? Once #37681 lands, this won't be a concern anymore, of course. Until then, I've made the package `restricted=yes` for now.~~

**Update**: Since OpenSSL is now on version 3, I have removed the restriction.

A patch file from https://github.com/void-linux/void-packages/pull/44875.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-uxplay-44875.patch --]
[-- Type: text/x-diff, Size: 2193 bytes --]

From 1327699940299f8d84eb8481cf204a5e4b907df9 Mon Sep 17 00:00:00 2001
From: T0mstone <realt0mstone@gmail.com>
Date: Wed, 5 Jul 2023 18:08:11 +0200
Subject: [PATCH] New package: UxPlay-1.67

---
 srcpkgs/UxPlay/files/README.voidlinux |  5 +++++
 srcpkgs/UxPlay/template               | 23 +++++++++++++++++++++++
 2 files changed, 28 insertions(+)
 create mode 100644 srcpkgs/UxPlay/files/README.voidlinux
 create mode 100644 srcpkgs/UxPlay/template

diff --git a/srcpkgs/UxPlay/files/README.voidlinux b/srcpkgs/UxPlay/files/README.voidlinux
new file mode 100644
index 0000000000000..f67a85659e506
--- /dev/null
+++ b/srcpkgs/UxPlay/files/README.voidlinux
@@ -0,0 +1,5 @@
+Additional GStreamer plugins you may need to install:
+- `gstreamer-vaapi` is needed for hardware-accelerated h264 video decoding by Intel or AMD graphics (but not for use with NVIDIA using proprietary drivers)
+- `gstreamer1-pipewire` may be needed for audio sharing when your system is set up to use pipewire
+
+Additionally, UxPlay requires a running DNS-SD server (for example `avahi`).
diff --git a/srcpkgs/UxPlay/template b/srcpkgs/UxPlay/template
new file mode 100644
index 0000000000000..d589d859a19fa
--- /dev/null
+++ b/srcpkgs/UxPlay/template
@@ -0,0 +1,23 @@
+# Template file for 'UxPlay'
+pkgname=UxPlay
+version=1.67
+revision=1
+build_style=cmake
+configure_args="$(vopt_if native_build '' '-DNO_MARCH_NATIVE=ON') $(vopt_if x11 '' '-DNO_X11_DEPS=ON')"
+hostmakedepends="pkg-config"
+makedepends="openssl-devel libplist-devel avahi-compat-libs-devel gstreamer1-devel gst-plugins-base1-devel $(vopt_if x11 libX11-devel)"
+depends="gst-plugins-base1 gst-libav gst-plugins-good1 gst-plugins-bad1"
+short_desc="AirPlay Unix mirroring server"
+maintainer="T0mstone <realt0mstone@gmail.com>"
+license="GPL-3.0-or-later"
+homepage="https://github.com/FDH2/UxPlay"
+changelog="https://github.com/FDH2/UxPlay/releases/tag/v${version}"
+distfiles="https://github.com/FDH2/UxPlay/archive/refs/tags/v${version}.tar.gz"
+checksum=2296715470f98040415e077e47382b7ee128a12ae86ae50ff68f02b21d45d6a4
+
+build_options="x11 native_build"
+build_options_default="x11"
+
+post_install() {
+	vdoc ${FILESDIR}/README.voidlinux
+}

^ permalink raw reply	[flat|nested] 16+ messages in thread

* Re: [PR PATCH] [Updated] New package: UxPlay-1.67
  2023-07-06 11:59 [PR PATCH] New package: UxPlay-1.65 T0mstone
                   ` (5 preceding siblings ...)
  2023-12-09  4:54 ` T0mstone
@ 2024-01-01 20:22 ` T0mstone
  2024-01-08 18:45 ` [PR PATCH] [Updated] New package: UxPlay-1.68.1 T0mstone
                   ` (7 subsequent siblings)
  14 siblings, 0 replies; 16+ messages in thread
From: T0mstone @ 2024-01-01 20:22 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 2010 bytes --]

There is an updated pull request by T0mstone against master on the void-packages repository

https://github.com/T0mstone/void-packages uxplay
https://github.com/void-linux/void-packages/pull/44875

New package: UxPlay-1.67
<!-- Uncomment relevant sections and delete options which are not applicable -->
Spiritual successor to #33191.

#### Testing the changes
- I tested the changes in this PR: **YES**

#### New package
- This new package conforms to the [package requirements](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#package-requirements): **YES**

<!-- Note: If the build is likely to take more than 2 hours, please add ci skip tag as described in
https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->

#### Local build testing
- I built this PR locally for my native architecture, (x86_64-glibc)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - x86_64-musl

#### OpenSSL
> UxPlay's GPLv3 license does not have an added "GPL exception" explicitly allowing it to be distributed in compiled form when linked to OpenSSL versions prior to v. 3.0.0 (older versions of OpenSSL have a license clause incompatible with the GPL unless OpenSSL can be regarded as a "System Library", which it is in *BSD). Many Linux distributions treat OpenSSL as a "System Library", but some (e.g. Debian) do not: in this case, the issue is solved by linking with OpenSSL-3.0.0 or later.

~~How does Void handle this? Can OpenSSL be considered a "System Library"? Once #37681 lands, this won't be a concern anymore, of course. Until then, I've made the package `restricted=yes` for now.~~

**Update**: Since OpenSSL is now on version 3, I have removed the restriction.

A patch file from https://github.com/void-linux/void-packages/pull/44875.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-uxplay-44875.patch --]
[-- Type: text/x-diff, Size: 2197 bytes --]

From fcfc07340d2c334293af8d5a8f9f09b20ba91abf Mon Sep 17 00:00:00 2001
From: T0mstone <realt0mstone@gmail.com>
Date: Wed, 5 Jul 2023 18:08:11 +0200
Subject: [PATCH] New package: UxPlay-1.68.1

---
 srcpkgs/UxPlay/files/README.voidlinux |  5 +++++
 srcpkgs/UxPlay/template               | 23 +++++++++++++++++++++++
 2 files changed, 28 insertions(+)
 create mode 100644 srcpkgs/UxPlay/files/README.voidlinux
 create mode 100644 srcpkgs/UxPlay/template

diff --git a/srcpkgs/UxPlay/files/README.voidlinux b/srcpkgs/UxPlay/files/README.voidlinux
new file mode 100644
index 0000000000000..f67a85659e506
--- /dev/null
+++ b/srcpkgs/UxPlay/files/README.voidlinux
@@ -0,0 +1,5 @@
+Additional GStreamer plugins you may need to install:
+- `gstreamer-vaapi` is needed for hardware-accelerated h264 video decoding by Intel or AMD graphics (but not for use with NVIDIA using proprietary drivers)
+- `gstreamer1-pipewire` may be needed for audio sharing when your system is set up to use pipewire
+
+Additionally, UxPlay requires a running DNS-SD server (for example `avahi`).
diff --git a/srcpkgs/UxPlay/template b/srcpkgs/UxPlay/template
new file mode 100644
index 0000000000000..6ee0b1e66464b
--- /dev/null
+++ b/srcpkgs/UxPlay/template
@@ -0,0 +1,23 @@
+# Template file for 'UxPlay'
+pkgname=UxPlay
+version=1.68.1
+revision=1
+build_style=cmake
+configure_args="$(vopt_if native_build '' '-DNO_MARCH_NATIVE=ON') $(vopt_if x11 '' '-DNO_X11_DEPS=ON')"
+hostmakedepends="pkg-config"
+makedepends="openssl-devel libplist-devel avahi-compat-libs-devel gstreamer1-devel gst-plugins-base1-devel $(vopt_if x11 libX11-devel)"
+depends="gst-plugins-base1 gst-libav gst-plugins-good1 gst-plugins-bad1"
+short_desc="AirPlay Unix mirroring server"
+maintainer="T0mstone <realt0mstone@gmail.com>"
+license="GPL-3.0-or-later"
+homepage="https://github.com/FDH2/UxPlay"
+changelog="https://github.com/FDH2/UxPlay/releases/tag/v${version}"
+distfiles="https://github.com/FDH2/UxPlay/archive/refs/tags/v${version}.tar.gz"
+checksum=cfbf06025ea7b150b1b71f829d64594708abfaa5660515a8b8a861e148b9522a
+
+build_options="x11 native_build"
+build_options_default="x11"
+
+post_install() {
+	vdoc ${FILESDIR}/README.voidlinux
+}

^ permalink raw reply	[flat|nested] 16+ messages in thread

* Re: [PR PATCH] [Updated] New package: UxPlay-1.68.1
  2023-07-06 11:59 [PR PATCH] New package: UxPlay-1.65 T0mstone
                   ` (6 preceding siblings ...)
  2024-01-01 20:22 ` [PR PATCH] [Updated] New package: UxPlay-1.67 T0mstone
@ 2024-01-08 18:45 ` T0mstone
  2024-04-08  1:45 ` New package: UxPlay-1.68.2 github-actions
                   ` (6 subsequent siblings)
  14 siblings, 0 replies; 16+ messages in thread
From: T0mstone @ 2024-01-08 18:45 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 2012 bytes --]

There is an updated pull request by T0mstone against master on the void-packages repository

https://github.com/T0mstone/void-packages uxplay
https://github.com/void-linux/void-packages/pull/44875

New package: UxPlay-1.68.1
<!-- Uncomment relevant sections and delete options which are not applicable -->
Spiritual successor to #33191.

#### Testing the changes
- I tested the changes in this PR: **YES**

#### New package
- This new package conforms to the [package requirements](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#package-requirements): **YES**

<!-- Note: If the build is likely to take more than 2 hours, please add ci skip tag as described in
https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->

#### Local build testing
- I built this PR locally for my native architecture, (x86_64-glibc)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - x86_64-musl

#### OpenSSL
> UxPlay's GPLv3 license does not have an added "GPL exception" explicitly allowing it to be distributed in compiled form when linked to OpenSSL versions prior to v. 3.0.0 (older versions of OpenSSL have a license clause incompatible with the GPL unless OpenSSL can be regarded as a "System Library", which it is in *BSD). Many Linux distributions treat OpenSSL as a "System Library", but some (e.g. Debian) do not: in this case, the issue is solved by linking with OpenSSL-3.0.0 or later.

~~How does Void handle this? Can OpenSSL be considered a "System Library"? Once #37681 lands, this won't be a concern anymore, of course. Until then, I've made the package `restricted=yes` for now.~~

**Update**: Since OpenSSL is now on version 3, I have removed the restriction.

A patch file from https://github.com/void-linux/void-packages/pull/44875.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-uxplay-44875.patch --]
[-- Type: text/x-diff, Size: 2197 bytes --]

From aed0aa602ba0f858f8720538d8962ae7aeecfba5 Mon Sep 17 00:00:00 2001
From: T0mstone <realt0mstone@gmail.com>
Date: Wed, 5 Jul 2023 18:08:11 +0200
Subject: [PATCH] New package: UxPlay-1.68.2

---
 srcpkgs/UxPlay/files/README.voidlinux |  5 +++++
 srcpkgs/UxPlay/template               | 23 +++++++++++++++++++++++
 2 files changed, 28 insertions(+)
 create mode 100644 srcpkgs/UxPlay/files/README.voidlinux
 create mode 100644 srcpkgs/UxPlay/template

diff --git a/srcpkgs/UxPlay/files/README.voidlinux b/srcpkgs/UxPlay/files/README.voidlinux
new file mode 100644
index 0000000000000..f67a85659e506
--- /dev/null
+++ b/srcpkgs/UxPlay/files/README.voidlinux
@@ -0,0 +1,5 @@
+Additional GStreamer plugins you may need to install:
+- `gstreamer-vaapi` is needed for hardware-accelerated h264 video decoding by Intel or AMD graphics (but not for use with NVIDIA using proprietary drivers)
+- `gstreamer1-pipewire` may be needed for audio sharing when your system is set up to use pipewire
+
+Additionally, UxPlay requires a running DNS-SD server (for example `avahi`).
diff --git a/srcpkgs/UxPlay/template b/srcpkgs/UxPlay/template
new file mode 100644
index 0000000000000..ab619777ad92f
--- /dev/null
+++ b/srcpkgs/UxPlay/template
@@ -0,0 +1,23 @@
+# Template file for 'UxPlay'
+pkgname=UxPlay
+version=1.68.2
+revision=1
+build_style=cmake
+configure_args="$(vopt_if native_build '' '-DNO_MARCH_NATIVE=ON') $(vopt_if x11 '' '-DNO_X11_DEPS=ON')"
+hostmakedepends="pkg-config"
+makedepends="openssl-devel libplist-devel avahi-compat-libs-devel gstreamer1-devel gst-plugins-base1-devel $(vopt_if x11 libX11-devel)"
+depends="gst-plugins-base1 gst-libav gst-plugins-good1 gst-plugins-bad1"
+short_desc="AirPlay Unix mirroring server"
+maintainer="T0mstone <realt0mstone@gmail.com>"
+license="GPL-3.0-or-later"
+homepage="https://github.com/FDH2/UxPlay"
+changelog="https://github.com/FDH2/UxPlay/releases/tag/v${version}"
+distfiles="https://github.com/FDH2/UxPlay/archive/refs/tags/v${version}.tar.gz"
+checksum=7016d8800b89d3dec2139cc21b779cd61fd49b0d1456311ca3c5182c086ec8ed
+
+build_options="x11 native_build"
+build_options_default="x11"
+
+post_install() {
+	vdoc ${FILESDIR}/README.voidlinux
+}

^ permalink raw reply	[flat|nested] 16+ messages in thread

* Re: New package: UxPlay-1.68.2
  2023-07-06 11:59 [PR PATCH] New package: UxPlay-1.65 T0mstone
                   ` (7 preceding siblings ...)
  2024-01-08 18:45 ` [PR PATCH] [Updated] New package: UxPlay-1.68.1 T0mstone
@ 2024-04-08  1:45 ` github-actions
  2024-04-09 17:46 ` T0mstone
                   ` (5 subsequent siblings)
  14 siblings, 0 replies; 16+ messages in thread
From: github-actions @ 2024-04-08  1:45 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 305 bytes --]

New comment by github-actions[bot] on void-packages repository

https://github.com/void-linux/void-packages/pull/44875#issuecomment-2041721030

Comment:
Pull Requests become stale 90 days after last activity and are closed 14 days after that.  If this pull request is still relevant bump it or assign it.

^ permalink raw reply	[flat|nested] 16+ messages in thread

* Re: New package: UxPlay-1.68.2
  2023-07-06 11:59 [PR PATCH] New package: UxPlay-1.65 T0mstone
                   ` (8 preceding siblings ...)
  2024-04-08  1:45 ` New package: UxPlay-1.68.2 github-actions
@ 2024-04-09 17:46 ` T0mstone
  2024-04-09 17:47 ` [PR PATCH] [Updated] " T0mstone
                   ` (4 subsequent siblings)
  14 siblings, 0 replies; 16+ messages in thread
From: T0mstone @ 2024-04-09 17:46 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 147 bytes --]

New comment by T0mstone on void-packages repository

https://github.com/void-linux/void-packages/pull/44875#issuecomment-2045773739

Comment:
bump

^ permalink raw reply	[flat|nested] 16+ messages in thread

* Re: [PR PATCH] [Updated] New package: UxPlay-1.68.2
  2023-07-06 11:59 [PR PATCH] New package: UxPlay-1.65 T0mstone
                   ` (9 preceding siblings ...)
  2024-04-09 17:46 ` T0mstone
@ 2024-04-09 17:47 ` T0mstone
  2024-04-24  9:25 ` T0mstone
                   ` (3 subsequent siblings)
  14 siblings, 0 replies; 16+ messages in thread
From: T0mstone @ 2024-04-09 17:47 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 2012 bytes --]

There is an updated pull request by T0mstone against master on the void-packages repository

https://github.com/T0mstone/void-packages uxplay
https://github.com/void-linux/void-packages/pull/44875

New package: UxPlay-1.68.2
<!-- Uncomment relevant sections and delete options which are not applicable -->
Spiritual successor to #33191.

#### Testing the changes
- I tested the changes in this PR: **YES**

#### New package
- This new package conforms to the [package requirements](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#package-requirements): **YES**

<!-- Note: If the build is likely to take more than 2 hours, please add ci skip tag as described in
https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->

#### Local build testing
- I built this PR locally for my native architecture, (x86_64-glibc)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - x86_64-musl

#### OpenSSL
> UxPlay's GPLv3 license does not have an added "GPL exception" explicitly allowing it to be distributed in compiled form when linked to OpenSSL versions prior to v. 3.0.0 (older versions of OpenSSL have a license clause incompatible with the GPL unless OpenSSL can be regarded as a "System Library", which it is in *BSD). Many Linux distributions treat OpenSSL as a "System Library", but some (e.g. Debian) do not: in this case, the issue is solved by linking with OpenSSL-3.0.0 or later.

~~How does Void handle this? Can OpenSSL be considered a "System Library"? Once #37681 lands, this won't be a concern anymore, of course. Until then, I've made the package `restricted=yes` for now.~~

**Update**: Since OpenSSL is now on version 3, I have removed the restriction.

A patch file from https://github.com/void-linux/void-packages/pull/44875.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-uxplay-44875.patch --]
[-- Type: text/x-diff, Size: 2201 bytes --]

From 91a6f0af7aae1702230f051941415c97d257066e Mon Sep 17 00:00:00 2001
From: T0mstone <realt0mstone@gmail.com>
Date: Wed, 5 Jul 2023 18:08:11 +0200
Subject: [PATCH] New package: UxPlay-1.68.2

---
 srcpkgs/UxPlay/files/README.voidlinux |  5 +++++
 srcpkgs/UxPlay/template               | 23 +++++++++++++++++++++++
 2 files changed, 28 insertions(+)
 create mode 100644 srcpkgs/UxPlay/files/README.voidlinux
 create mode 100644 srcpkgs/UxPlay/template

diff --git a/srcpkgs/UxPlay/files/README.voidlinux b/srcpkgs/UxPlay/files/README.voidlinux
new file mode 100644
index 00000000000000..f67a85659e506c
--- /dev/null
+++ b/srcpkgs/UxPlay/files/README.voidlinux
@@ -0,0 +1,5 @@
+Additional GStreamer plugins you may need to install:
+- `gstreamer-vaapi` is needed for hardware-accelerated h264 video decoding by Intel or AMD graphics (but not for use with NVIDIA using proprietary drivers)
+- `gstreamer1-pipewire` may be needed for audio sharing when your system is set up to use pipewire
+
+Additionally, UxPlay requires a running DNS-SD server (for example `avahi`).
diff --git a/srcpkgs/UxPlay/template b/srcpkgs/UxPlay/template
new file mode 100644
index 00000000000000..ab619777ad92fe
--- /dev/null
+++ b/srcpkgs/UxPlay/template
@@ -0,0 +1,23 @@
+# Template file for 'UxPlay'
+pkgname=UxPlay
+version=1.68.2
+revision=1
+build_style=cmake
+configure_args="$(vopt_if native_build '' '-DNO_MARCH_NATIVE=ON') $(vopt_if x11 '' '-DNO_X11_DEPS=ON')"
+hostmakedepends="pkg-config"
+makedepends="openssl-devel libplist-devel avahi-compat-libs-devel gstreamer1-devel gst-plugins-base1-devel $(vopt_if x11 libX11-devel)"
+depends="gst-plugins-base1 gst-libav gst-plugins-good1 gst-plugins-bad1"
+short_desc="AirPlay Unix mirroring server"
+maintainer="T0mstone <realt0mstone@gmail.com>"
+license="GPL-3.0-or-later"
+homepage="https://github.com/FDH2/UxPlay"
+changelog="https://github.com/FDH2/UxPlay/releases/tag/v${version}"
+distfiles="https://github.com/FDH2/UxPlay/archive/refs/tags/v${version}.tar.gz"
+checksum=7016d8800b89d3dec2139cc21b779cd61fd49b0d1456311ca3c5182c086ec8ed
+
+build_options="x11 native_build"
+build_options_default="x11"
+
+post_install() {
+	vdoc ${FILESDIR}/README.voidlinux
+}

^ permalink raw reply	[flat|nested] 16+ messages in thread

* Re: [PR PATCH] [Updated] New package: UxPlay-1.68.2
  2023-07-06 11:59 [PR PATCH] New package: UxPlay-1.65 T0mstone
                   ` (10 preceding siblings ...)
  2024-04-09 17:47 ` [PR PATCH] [Updated] " T0mstone
@ 2024-04-24  9:25 ` T0mstone
  2024-04-24  9:25 ` T0mstone
                   ` (2 subsequent siblings)
  14 siblings, 0 replies; 16+ messages in thread
From: T0mstone @ 2024-04-24  9:25 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 2012 bytes --]

There is an updated pull request by T0mstone against master on the void-packages repository

https://github.com/T0mstone/void-packages uxplay
https://github.com/void-linux/void-packages/pull/44875

New package: UxPlay-1.68.2
<!-- Uncomment relevant sections and delete options which are not applicable -->
Spiritual successor to #33191.

#### Testing the changes
- I tested the changes in this PR: **YES**

#### New package
- This new package conforms to the [package requirements](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#package-requirements): **YES**

<!-- Note: If the build is likely to take more than 2 hours, please add ci skip tag as described in
https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->

#### Local build testing
- I built this PR locally for my native architecture, (x86_64-glibc)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - x86_64-musl

#### OpenSSL
> UxPlay's GPLv3 license does not have an added "GPL exception" explicitly allowing it to be distributed in compiled form when linked to OpenSSL versions prior to v. 3.0.0 (older versions of OpenSSL have a license clause incompatible with the GPL unless OpenSSL can be regarded as a "System Library", which it is in *BSD). Many Linux distributions treat OpenSSL as a "System Library", but some (e.g. Debian) do not: in this case, the issue is solved by linking with OpenSSL-3.0.0 or later.

~~How does Void handle this? Can OpenSSL be considered a "System Library"? Once #37681 lands, this won't be a concern anymore, of course. Until then, I've made the package `restricted=yes` for now.~~

**Update**: Since OpenSSL is now on version 3, I have removed the restriction.

A patch file from https://github.com/void-linux/void-packages/pull/44875.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-uxplay-44875.patch --]
[-- Type: text/x-diff, Size: 2201 bytes --]

From 001b1ab085b3bfdba52e42a2e43a2856d68710c4 Mon Sep 17 00:00:00 2001
From: T0mstone <realt0mstone@gmail.com>
Date: Wed, 5 Jul 2023 18:08:11 +0200
Subject: [PATCH] New package: UxPlay-1.68.3

---
 srcpkgs/UxPlay/files/README.voidlinux |  5 +++++
 srcpkgs/UxPlay/template               | 23 +++++++++++++++++++++++
 2 files changed, 28 insertions(+)
 create mode 100644 srcpkgs/UxPlay/files/README.voidlinux
 create mode 100644 srcpkgs/UxPlay/template

diff --git a/srcpkgs/UxPlay/files/README.voidlinux b/srcpkgs/UxPlay/files/README.voidlinux
new file mode 100644
index 00000000000000..f67a85659e506c
--- /dev/null
+++ b/srcpkgs/UxPlay/files/README.voidlinux
@@ -0,0 +1,5 @@
+Additional GStreamer plugins you may need to install:
+- `gstreamer-vaapi` is needed for hardware-accelerated h264 video decoding by Intel or AMD graphics (but not for use with NVIDIA using proprietary drivers)
+- `gstreamer1-pipewire` may be needed for audio sharing when your system is set up to use pipewire
+
+Additionally, UxPlay requires a running DNS-SD server (for example `avahi`).
diff --git a/srcpkgs/UxPlay/template b/srcpkgs/UxPlay/template
new file mode 100644
index 00000000000000..ab619777ad92fe
--- /dev/null
+++ b/srcpkgs/UxPlay/template
@@ -0,0 +1,23 @@
+# Template file for 'UxPlay'
+pkgname=UxPlay
+version=1.68.2
+revision=1
+build_style=cmake
+configure_args="$(vopt_if native_build '' '-DNO_MARCH_NATIVE=ON') $(vopt_if x11 '' '-DNO_X11_DEPS=ON')"
+hostmakedepends="pkg-config"
+makedepends="openssl-devel libplist-devel avahi-compat-libs-devel gstreamer1-devel gst-plugins-base1-devel $(vopt_if x11 libX11-devel)"
+depends="gst-plugins-base1 gst-libav gst-plugins-good1 gst-plugins-bad1"
+short_desc="AirPlay Unix mirroring server"
+maintainer="T0mstone <realt0mstone@gmail.com>"
+license="GPL-3.0-or-later"
+homepage="https://github.com/FDH2/UxPlay"
+changelog="https://github.com/FDH2/UxPlay/releases/tag/v${version}"
+distfiles="https://github.com/FDH2/UxPlay/archive/refs/tags/v${version}.tar.gz"
+checksum=7016d8800b89d3dec2139cc21b779cd61fd49b0d1456311ca3c5182c086ec8ed
+
+build_options="x11 native_build"
+build_options_default="x11"
+
+post_install() {
+	vdoc ${FILESDIR}/README.voidlinux
+}

^ permalink raw reply	[flat|nested] 16+ messages in thread

* Re: [PR PATCH] [Updated] New package: UxPlay-1.68.2
  2023-07-06 11:59 [PR PATCH] New package: UxPlay-1.65 T0mstone
                   ` (11 preceding siblings ...)
  2024-04-24  9:25 ` T0mstone
@ 2024-04-24  9:25 ` T0mstone
  2024-04-24  9:42 ` [PR PATCH] [Updated] New package: UxPlay-1.68.3 T0mstone
  2024-07-10  0:02 ` T0mstone
  14 siblings, 0 replies; 16+ messages in thread
From: T0mstone @ 2024-04-24  9:25 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 2012 bytes --]

There is an updated pull request by T0mstone against master on the void-packages repository

https://github.com/T0mstone/void-packages uxplay
https://github.com/void-linux/void-packages/pull/44875

New package: UxPlay-1.68.2
<!-- Uncomment relevant sections and delete options which are not applicable -->
Spiritual successor to #33191.

#### Testing the changes
- I tested the changes in this PR: **YES**

#### New package
- This new package conforms to the [package requirements](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#package-requirements): **YES**

<!-- Note: If the build is likely to take more than 2 hours, please add ci skip tag as described in
https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->

#### Local build testing
- I built this PR locally for my native architecture, (x86_64-glibc)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - x86_64-musl

#### OpenSSL
> UxPlay's GPLv3 license does not have an added "GPL exception" explicitly allowing it to be distributed in compiled form when linked to OpenSSL versions prior to v. 3.0.0 (older versions of OpenSSL have a license clause incompatible with the GPL unless OpenSSL can be regarded as a "System Library", which it is in *BSD). Many Linux distributions treat OpenSSL as a "System Library", but some (e.g. Debian) do not: in this case, the issue is solved by linking with OpenSSL-3.0.0 or later.

~~How does Void handle this? Can OpenSSL be considered a "System Library"? Once #37681 lands, this won't be a concern anymore, of course. Until then, I've made the package `restricted=yes` for now.~~

**Update**: Since OpenSSL is now on version 3, I have removed the restriction.

A patch file from https://github.com/void-linux/void-packages/pull/44875.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-uxplay-44875.patch --]
[-- Type: text/x-diff, Size: 2201 bytes --]

From 6ae70e418b08d73ab9e758b8105c0708058186ee Mon Sep 17 00:00:00 2001
From: T0mstone <realt0mstone@gmail.com>
Date: Wed, 5 Jul 2023 18:08:11 +0200
Subject: [PATCH] New package: UxPlay-1.68.3

---
 srcpkgs/UxPlay/files/README.voidlinux |  5 +++++
 srcpkgs/UxPlay/template               | 23 +++++++++++++++++++++++
 2 files changed, 28 insertions(+)
 create mode 100644 srcpkgs/UxPlay/files/README.voidlinux
 create mode 100644 srcpkgs/UxPlay/template

diff --git a/srcpkgs/UxPlay/files/README.voidlinux b/srcpkgs/UxPlay/files/README.voidlinux
new file mode 100644
index 00000000000000..f67a85659e506c
--- /dev/null
+++ b/srcpkgs/UxPlay/files/README.voidlinux
@@ -0,0 +1,5 @@
+Additional GStreamer plugins you may need to install:
+- `gstreamer-vaapi` is needed for hardware-accelerated h264 video decoding by Intel or AMD graphics (but not for use with NVIDIA using proprietary drivers)
+- `gstreamer1-pipewire` may be needed for audio sharing when your system is set up to use pipewire
+
+Additionally, UxPlay requires a running DNS-SD server (for example `avahi`).
diff --git a/srcpkgs/UxPlay/template b/srcpkgs/UxPlay/template
new file mode 100644
index 00000000000000..37bdc744e2ddad
--- /dev/null
+++ b/srcpkgs/UxPlay/template
@@ -0,0 +1,23 @@
+# Template file for 'UxPlay'
+pkgname=UxPlay
+version=1.68.3
+revision=1
+build_style=cmake
+configure_args="$(vopt_if native_build '' '-DNO_MARCH_NATIVE=ON') $(vopt_if x11 '' '-DNO_X11_DEPS=ON')"
+hostmakedepends="pkg-config"
+makedepends="openssl-devel libplist-devel avahi-compat-libs-devel gstreamer1-devel gst-plugins-base1-devel $(vopt_if x11 libX11-devel)"
+depends="gst-plugins-base1 gst-libav gst-plugins-good1 gst-plugins-bad1"
+short_desc="AirPlay Unix mirroring server"
+maintainer="T0mstone <realt0mstone@gmail.com>"
+license="GPL-3.0-or-later"
+homepage="https://github.com/FDH2/UxPlay"
+changelog="https://github.com/FDH2/UxPlay/releases/tag/v${version}"
+distfiles="https://github.com/FDH2/UxPlay/archive/refs/tags/v${version}.tar.gz"
+checksum=aa3f15e6a8568fdc3ad1f0a02956178964ca122e9bcdbff544e25a59a61127ae
+
+build_options="x11 native_build"
+build_options_default="x11"
+
+post_install() {
+	vdoc ${FILESDIR}/README.voidlinux
+}

^ permalink raw reply	[flat|nested] 16+ messages in thread

* Re: [PR PATCH] [Updated] New package: UxPlay-1.68.3
  2023-07-06 11:59 [PR PATCH] New package: UxPlay-1.65 T0mstone
                   ` (12 preceding siblings ...)
  2024-04-24  9:25 ` T0mstone
@ 2024-04-24  9:42 ` T0mstone
  2024-07-10  0:02 ` T0mstone
  14 siblings, 0 replies; 16+ messages in thread
From: T0mstone @ 2024-04-24  9:42 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 2012 bytes --]

There is an updated pull request by T0mstone against master on the void-packages repository

https://github.com/T0mstone/void-packages uxplay
https://github.com/void-linux/void-packages/pull/44875

New package: UxPlay-1.68.3
<!-- Uncomment relevant sections and delete options which are not applicable -->
Spiritual successor to #33191.

#### Testing the changes
- I tested the changes in this PR: **YES**

#### New package
- This new package conforms to the [package requirements](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#package-requirements): **YES**

<!-- Note: If the build is likely to take more than 2 hours, please add ci skip tag as described in
https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->

#### Local build testing
- I built this PR locally for my native architecture, (x86_64-glibc)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - x86_64-musl

#### OpenSSL
> UxPlay's GPLv3 license does not have an added "GPL exception" explicitly allowing it to be distributed in compiled form when linked to OpenSSL versions prior to v. 3.0.0 (older versions of OpenSSL have a license clause incompatible with the GPL unless OpenSSL can be regarded as a "System Library", which it is in *BSD). Many Linux distributions treat OpenSSL as a "System Library", but some (e.g. Debian) do not: in this case, the issue is solved by linking with OpenSSL-3.0.0 or later.

~~How does Void handle this? Can OpenSSL be considered a "System Library"? Once #37681 lands, this won't be a concern anymore, of course. Until then, I've made the package `restricted=yes` for now.~~

**Update**: Since OpenSSL is now on version 3, I have removed the restriction.

A patch file from https://github.com/void-linux/void-packages/pull/44875.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-uxplay-44875.patch --]
[-- Type: text/x-diff, Size: 2216 bytes --]

From 07531821171db9f2229cab0c4b212d2acc32b778 Mon Sep 17 00:00:00 2001
From: T0mstone <realt0mstone@gmail.com>
Date: Wed, 5 Jul 2023 18:08:11 +0200
Subject: [PATCH] New package: UxPlay-1.68.3

---
 srcpkgs/UxPlay/files/README.voidlinux |  5 +++++
 srcpkgs/UxPlay/template               | 23 +++++++++++++++++++++++
 2 files changed, 28 insertions(+)
 create mode 100644 srcpkgs/UxPlay/files/README.voidlinux
 create mode 100644 srcpkgs/UxPlay/template

diff --git a/srcpkgs/UxPlay/files/README.voidlinux b/srcpkgs/UxPlay/files/README.voidlinux
new file mode 100644
index 00000000000000..f67a85659e506c
--- /dev/null
+++ b/srcpkgs/UxPlay/files/README.voidlinux
@@ -0,0 +1,5 @@
+Additional GStreamer plugins you may need to install:
+- `gstreamer-vaapi` is needed for hardware-accelerated h264 video decoding by Intel or AMD graphics (but not for use with NVIDIA using proprietary drivers)
+- `gstreamer1-pipewire` may be needed for audio sharing when your system is set up to use pipewire
+
+Additionally, UxPlay requires a running DNS-SD server (for example `avahi`).
diff --git a/srcpkgs/UxPlay/template b/srcpkgs/UxPlay/template
new file mode 100644
index 00000000000000..5a66e50fdadc3e
--- /dev/null
+++ b/srcpkgs/UxPlay/template
@@ -0,0 +1,23 @@
+# Template file for 'UxPlay'
+pkgname=UxPlay
+version=1.68.3
+revision=1
+build_style=cmake
+configure_args="$(vopt_if native_build '' '-DNO_MARCH_NATIVE=ON') $(vopt_if x11 '' '-DNO_X11_DEPS=ON')"
+hostmakedepends="pkg-config"
+makedepends="openssl-devel libplist-devel avahi-compat-libs-devel gstreamer1-devel gst-plugins-base1-devel $(vopt_if x11 libX11-devel)"
+depends="openssl>=3.0.0 gst-plugins-base1 gst-libav gst-plugins-good1 gst-plugins-bad1"
+short_desc="AirPlay Unix mirroring server"
+maintainer="T0mstone <realt0mstone@gmail.com>"
+license="GPL-3.0-or-later"
+homepage="https://github.com/FDH2/UxPlay"
+changelog="https://github.com/FDH2/UxPlay/releases/tag/v${version}"
+distfiles="https://github.com/FDH2/UxPlay/archive/refs/tags/v${version}.tar.gz"
+checksum=aa3f15e6a8568fdc3ad1f0a02956178964ca122e9bcdbff544e25a59a61127ae
+
+build_options="x11 native_build"
+build_options_default="x11"
+
+post_install() {
+	vdoc ${FILESDIR}/README.voidlinux
+}

^ permalink raw reply	[flat|nested] 16+ messages in thread

* Re: [PR PATCH] [Updated] New package: UxPlay-1.68.3
  2023-07-06 11:59 [PR PATCH] New package: UxPlay-1.65 T0mstone
                   ` (13 preceding siblings ...)
  2024-04-24  9:42 ` [PR PATCH] [Updated] New package: UxPlay-1.68.3 T0mstone
@ 2024-07-10  0:02 ` T0mstone
  14 siblings, 0 replies; 16+ messages in thread
From: T0mstone @ 2024-07-10  0:02 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 2012 bytes --]

There is an updated pull request by T0mstone against master on the void-packages repository

https://github.com/T0mstone/void-packages uxplay
https://github.com/void-linux/void-packages/pull/44875

New package: UxPlay-1.68.3
<!-- Uncomment relevant sections and delete options which are not applicable -->
Spiritual successor to #33191.

#### Testing the changes
- I tested the changes in this PR: **YES**

#### New package
- This new package conforms to the [package requirements](https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#package-requirements): **YES**

<!-- Note: If the build is likely to take more than 2 hours, please add ci skip tag as described in
https://github.com/void-linux/void-packages/blob/master/CONTRIBUTING.md#continuous-integration
and test at least one native build and, if supported, at least one cross build.
Ignore this section if this PR is not skipping CI.
-->

#### Local build testing
- I built this PR locally for my native architecture, (x86_64-glibc)
- I built this PR locally for these architectures (if supported. mark crossbuilds):
  - x86_64-musl

#### OpenSSL
> UxPlay's GPLv3 license does not have an added "GPL exception" explicitly allowing it to be distributed in compiled form when linked to OpenSSL versions prior to v. 3.0.0 (older versions of OpenSSL have a license clause incompatible with the GPL unless OpenSSL can be regarded as a "System Library", which it is in *BSD). Many Linux distributions treat OpenSSL as a "System Library", but some (e.g. Debian) do not: in this case, the issue is solved by linking with OpenSSL-3.0.0 or later.

~~How does Void handle this? Can OpenSSL be considered a "System Library"? Once #37681 lands, this won't be a concern anymore, of course. Until then, I've made the package `restricted=yes` for now.~~

**Update**: Since OpenSSL is now on version 3, I have removed the restriction.

A patch file from https://github.com/void-linux/void-packages/pull/44875.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-uxplay-44875.patch --]
[-- Type: text/x-diff, Size: 2285 bytes --]

From 782ac5b47e66f2b6ba3ed97b2e8e8b96992d337a Mon Sep 17 00:00:00 2001
From: T0mstone <realt0mstone@gmail.com>
Date: Wed, 5 Jul 2023 18:08:11 +0200
Subject: [PATCH] New package: UxPlay-1.68.3

---
 srcpkgs/UxPlay/files/README.voidlinux |  5 +++++
 srcpkgs/UxPlay/template               | 24 ++++++++++++++++++++++++
 2 files changed, 29 insertions(+)
 create mode 100644 srcpkgs/UxPlay/files/README.voidlinux
 create mode 100644 srcpkgs/UxPlay/template

diff --git a/srcpkgs/UxPlay/files/README.voidlinux b/srcpkgs/UxPlay/files/README.voidlinux
new file mode 100644
index 00000000000000..f67a85659e506c
--- /dev/null
+++ b/srcpkgs/UxPlay/files/README.voidlinux
@@ -0,0 +1,5 @@
+Additional GStreamer plugins you may need to install:
+- `gstreamer-vaapi` is needed for hardware-accelerated h264 video decoding by Intel or AMD graphics (but not for use with NVIDIA using proprietary drivers)
+- `gstreamer1-pipewire` may be needed for audio sharing when your system is set up to use pipewire
+
+Additionally, UxPlay requires a running DNS-SD server (for example `avahi`).
diff --git a/srcpkgs/UxPlay/template b/srcpkgs/UxPlay/template
new file mode 100644
index 00000000000000..fe78080ade7c7f
--- /dev/null
+++ b/srcpkgs/UxPlay/template
@@ -0,0 +1,24 @@
+# Template file for 'UxPlay'
+pkgname=UxPlay
+version=1.68.3
+revision=1
+build_style=cmake
+configure_args="$(vopt_if native_build '' '-DNO_MARCH_NATIVE=ON') $(vopt_if x11 '' '-DNO_X11_DEPS=ON')"
+hostmakedepends="pkg-config"
+makedepends="openssl-devel libplist-devel avahi-compat-libs-devel gstreamer1-devel gst-plugins-base1-devel $(vopt_if x11 libX11-devel)"
+depends="openssl>=3.0.0 gst-plugins-base1 gst-libav gst-plugins-good1 gst-plugins-bad1"
+short_desc="AirPlay Unix mirroring server"
+maintainer="T0mstone <realt0mstone@gmail.com>"
+license="GPL-3.0-or-later"
+homepage="https://github.com/FDH2/UxPlay"
+changelog="https://github.com/FDH2/UxPlay/releases/tag/v${version}"
+distfiles="https://github.com/FDH2/UxPlay/archive/refs/tags/v${version}.tar.gz"
+checksum=aa3f15e6a8568fdc3ad1f0a02956178964ca122e9bcdbff544e25a59a61127ae
+
+build_options="x11 native_build"
+build_options_default="x11"
+
+post_install() {
+	vdoc ${FILESDIR}/README.voidlinux
+	mv $DESTDIR/usr/share/doc/uxplay/* $DESTDIR/usr/share/doc/UxPlay/
+}

^ permalink raw reply	[flat|nested] 16+ messages in thread

end of thread, other threads:[~2024-07-10  0:02 UTC | newest]

Thread overview: 16+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2023-07-06 11:59 [PR PATCH] New package: UxPlay-1.65 T0mstone
2023-07-06 20:52 ` [PR REVIEW] " classabbyamp
2023-07-07 16:33 ` [PR PATCH] [Updated] " T0mstone
2023-09-11 20:17 ` T0mstone
2023-09-11 20:19 ` [PR PATCH] [Updated] New package: UxPlay-1.66 T0mstone
2023-09-11 20:44 ` T0mstone
2023-12-09  4:54 ` T0mstone
2024-01-01 20:22 ` [PR PATCH] [Updated] New package: UxPlay-1.67 T0mstone
2024-01-08 18:45 ` [PR PATCH] [Updated] New package: UxPlay-1.68.1 T0mstone
2024-04-08  1:45 ` New package: UxPlay-1.68.2 github-actions
2024-04-09 17:46 ` T0mstone
2024-04-09 17:47 ` [PR PATCH] [Updated] " T0mstone
2024-04-24  9:25 ` T0mstone
2024-04-24  9:25 ` T0mstone
2024-04-24  9:42 ` [PR PATCH] [Updated] New package: UxPlay-1.68.3 T0mstone
2024-07-10  0:02 ` T0mstone

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).