Void Linux discussion
 help / Atom feed
* Building poppler/poppler-qt5
@ 2019-01-01  2:24 Jonathan Schultz
  0 siblings, 0 replies; 1+ messages in thread
From: Jonathan Schultz @ 2019-01-01  2:24 UTC (permalink / raw)
  To: voidlinux

Hello again,

I'm looking for some help building poppler and poppler-qt5. I see a comment at the top of the two template files saying that they need to be synchronized, but it's not clear what this means, or whether it is the reason why my builds (or more precisely installs) are failing.

For info, I'm running voidlinux-musl/x86-64 inside a Docker container. I can build plenty of other packages, but when I try './xbps-src pkg -j4 poppler' I get messages ending with

> => libpoppler83-0.72.0_1: running pkg_install ...
> mv: cannot move '/destdir//poppler-0.72.0/usr/lib/libpoppler.so.83' to '/destdir//libpoppler83-0.72.0/usr/lib/libpoppler.so.83': No such file or directory
> mv: cannot move '/destdir//poppler-0.72.0/usr/lib/libpoppler.so.83.0.0' to '/destdir//libpoppler83-0.72.0/usr/lib/libpoppler.so.83.0.0': No such file or directory
> => ERROR: libpoppler83-0.72.0_1: pkg_install: 'mv ${_destdir}/$files ${_pkgdestdir}/${_targetdir}' exited with 1
> => ERROR:   in _vmove() at common/environment/setup/install.sh:231
> => ERROR:   in _noglob_helper() at common/environment/setup/install.sh:12
> => ERROR:   in pkg_install() at srcpkgs/libpoppler83/template:36

and similarly './xbps-src pkg -j4 poppler-qt5' gives me

> => poppler-qt5-devel-0.72.0_1: running pkg_install ...
> mv: cannot move '/destdir//poppler-qt5-0.72.0/usr/include/poppler/qt5' to '/destdir//poppler-qt5-devel-0.72.0/usr/include/poppler/qt5': No such file or directory
> => ERROR: poppler-qt5-devel-0.72.0_1: pkg_install: 'mv ${_destdir}/$files ${_pkgdestdir}/${_targetdir}' exited with 1
> => ERROR:   in _vmove() at common/environment/setup/install.sh:231
> => ERROR:   in _noglob_helper() at common/environment/setup/install.sh:12
> => ERROR:   in pkg_install() at srcpkgs/poppler-qt5-devel/template:38
Many thanks,
Jonathan

-- 
You received this message because you are subscribed to the Google Groups "voidlinux" group.
To unsubscribe from this group and stop receiving emails from it, send an email to voidlinux+unsubscribe@googlegroups.com.
To post to this group, send email to voidlinux@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/voidlinux/63a36458-3fde-69a0-a139-a412247ede17%40schultz.la.
For more options, visit https://groups.google.com/d/optout.

^ permalink raw reply	[flat|nested] 1+ messages in thread

only message in thread, back to index

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-01-01  2:24 Building poppler/poppler-qt5 Jonathan Schultz

Void Linux discussion

Archives are clonable: git clone --mirror http://inbox.vuxu.org/voidlinux

Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.archive.voidlinux


AGPL code for this site: git clone https://public-inbox.org/ public-inbox