Void Linux discussion
 help / Atom feed
* webkitgtk-2.4.11_6: broken, unresolvable shlib `libicudata.so.62'
@ 2018-11-01  9:21 Steve Litt
  2018-11-01 19:34 ` Leah Neukirchen
                   ` (2 more replies)
  0 siblings, 3 replies; 4+ messages in thread
From: Steve Litt @ 2018-11-01  9:21 UTC (permalink / raw)
  To: voidlinux

[-- Attachment #1.1: Type: text/plain, Size: 1430 bytes --]

Tonight, when I tried xbps-install Su , I got the following errors:

[root@mydesk ~]# xbps-install -u
webkitgtk-2.4.11_6: broken, unresolvable shlib `libicudata.so.62'
webkitgtk2-2.4.11_6: broken, unresolvable shlib `libicudata.so.62'
webkitgtk-2.4.11_6: broken, unresolvable shlib `libicui18n.so.62'
webkitgtk2-2.4.11_6: broken, unresolvable shlib `libicui18n.so.62'
webkitgtk-2.4.11_6: broken, unresolvable shlib `libicuuc.so.62'
webkitgtk2-2.4.11_6: broken, unresolvable shlib `libicuuc.so.62'
Transaction aborted due to unresolved shlibs.
[root@mydesk ~]#

https://build.voidlinux.eu/waterfall shows no problem.

[root@mydesk ~]# uname -a
Linux mydesk 4.18.16_1 #1 SMP PREEMPT Sun Oct 21 03:00:36 UTC 2018 x86_64 
GNU/Linux
[root@mydesk ~]#

What can I do to get past this. De-installing webkitgtk and webkitgtk2 
would require removal of 10 or more often used apps. I tried changing my 
repos, but got the same symptom.

Thanks,

SteveT

-- 
You received this message because you are subscribed to the Google Groups "voidlinux" group.
To unsubscribe from this group and stop receiving emails from it, send an email to voidlinux+unsubscribe@googlegroups.com.
To post to this group, send email to voidlinux@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/voidlinux/818cf8a2-e2ce-4efd-ac28-3fe1dd219e5d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

[-- Attachment #1.2: Type: text/html, Size: 2128 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: webkitgtk-2.4.11_6: broken, unresolvable shlib `libicudata.so.62'
  2018-11-01  9:21 webkitgtk-2.4.11_6: broken, unresolvable shlib `libicudata.so.62' Steve Litt
@ 2018-11-01 19:34 ` Leah Neukirchen
  2018-11-02 17:59 ` MJ
  2018-11-25  3:00 ` Nashat Samir
  2 siblings, 0 replies; 4+ messages in thread
From: Leah Neukirchen @ 2018-11-01 19:34 UTC (permalink / raw)
  To: voidlinux

Steve Litt <littdom@gmail.com> writes:

> Tonight, when I tried xbps-install Su , I got the following errors:
>
> [root@mydesk ~]# xbps-install -u
> webkitgtk-2.4.11_6: broken, unresolvable shlib `libicudata.so.62'
> webkitgtk2-2.4.11_6: broken, unresolvable shlib `libicudata.so.62'
> webkitgtk-2.4.11_6: broken, unresolvable shlib `libicui18n.so.62'
> webkitgtk2-2.4.11_6: broken, unresolvable shlib `libicui18n.so.62'
> webkitgtk-2.4.11_6: broken, unresolvable shlib `libicuuc.so.62'
> webkitgtk2-2.4.11_6: broken, unresolvable shlib `libicuuc.so.62'
> Transaction aborted due to unresolved shlibs.
> [root@mydesk ~]#
>
> https://build.voidlinux.eu/waterfall shows no problem.
>
> [root@mydesk ~]# uname -a
> Linux mydesk 4.18.16_1 #1 SMP PREEMPT Sun Oct 21 03:00:36 UTC 2018 x86_64 
> GNU/Linux
> [root@mydesk ~]#
>
> What can I do to get past this. De-installing webkitgtk and webkitgtk2 
> would require removal of 10 or more often used apps. I tried changing my 
> repos, but got the same symptom.

Both packages have been removed.  Sync your repos first, and you
should be able to remove the packages

2018-10-25 977f88d9e0 webkitgtk: remove.

> Thanks,
>
> SteveT

-- 
Leah Neukirchen  <leah@vuxu.org>  http://leah.zone

-- 
You received this message because you are subscribed to the Google Groups "voidlinux" group.
To unsubscribe from this group and stop receiving emails from it, send an email to voidlinux+unsubscribe@googlegroups.com.
To post to this group, send email to voidlinux@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/voidlinux/874ld0twvb.fsf%40vuxu.org.
For more options, visit https://groups.google.com/d/optout.

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: webkitgtk-2.4.11_6: broken, unresolvable shlib `libicudata.so.62'
  2018-11-01  9:21 webkitgtk-2.4.11_6: broken, unresolvable shlib `libicudata.so.62' Steve Litt
  2018-11-01 19:34 ` Leah Neukirchen
@ 2018-11-02 17:59 ` MJ
  2018-11-25  3:00 ` Nashat Samir
  2 siblings, 0 replies; 4+ messages in thread
From: MJ @ 2018-11-02 17:59 UTC (permalink / raw)
  To: voidlinux

[-- Attachment #1.1: Type: text/plain, Size: 2555 bytes --]

On Thursday, November 1, 2018 at 4:21:53 AM UTC-5, Steve Litt wrote:
>
> Tonight, when I tried xbps-install Su , I got the following errors:
>
> [root@mydesk ~]# xbps-install -u
> webkitgtk-2.4.11_6: broken, unresolvable shlib `libicudata.so.62'
> webkitgtk2-2.4.11_6: broken, unresolvable shlib `libicudata.so.62'
> webkitgtk-2.4.11_6: broken, unresolvable shlib `libicui18n.so.62'
> webkitgtk2-2.4.11_6: broken, unresolvable shlib `libicui18n.so.62'
> webkitgtk-2.4.11_6: broken, unresolvable shlib `libicuuc.so.62'
> webkitgtk2-2.4.11_6: broken, unresolvable shlib `libicuuc.so.62'
> Transaction aborted due to unresolved shlibs.
> [root@mydesk ~]#
>
> https://build.voidlinux.eu/waterfall shows no problem.
>
> [root@mydesk ~]# uname -a
> Linux mydesk 4.18.16_1 #1 SMP PREEMPT Sun Oct 21 03:00:36 UTC 2018 x86_64 
> GNU/Linux
> [root@mydesk ~]#
>
> What can I do to get past this. De-installing webkitgtk and webkitgtk2 
> would require removal of 10 or more often used apps. I tried changing my 
> repos, but got the same symptom.
>
> Thanks,
>
> SteveT
>
> I had the same issue except I only had one utility that depended on 
webkitgtk2. I removed that package (yad) in order to uninstall gtkwebkit2 
so as to be able to do my system updates. Note that webkit2gtk is present 
on my system: I'm not sure what is the relationship between webkit2gtk and 
webkitgtk2, but for purposes of the package I removed, it is apparently not 
a drop-in replacement. The system now refuses to reinstall yad: "MISSING: 
webkitgtk2>=2.4.8_2 Transaction aborted due to unresolved dependencies."

Seems kind of strange that a package that cannot be installed due to 
dependency on a recently-removed package would even remain in the 
repository. So what do I have to do to get yad back? Compile from source 
and see whether I can stipulate that it use webkit2gtk instead of 
webkitgtk2?

Btw, what became of https://forum.voidlinux.org/? It's been unreachable for 
me for a couple days now. I know there had been some talk about shutting it 
down: did that finally happen? Thanks

-- 
You received this message because you are subscribed to the Google Groups "voidlinux" group.
To unsubscribe from this group and stop receiving emails from it, send an email to voidlinux+unsubscribe@googlegroups.com.
To post to this group, send email to voidlinux@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/voidlinux/6413a611-2330-426a-977c-9c2e643d5b4a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

[-- Attachment #1.2: Type: text/html, Size: 3854 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: webkitgtk-2.4.11_6: broken, unresolvable shlib `libicudata.so.62'
  2018-11-01  9:21 webkitgtk-2.4.11_6: broken, unresolvable shlib `libicudata.so.62' Steve Litt
  2018-11-01 19:34 ` Leah Neukirchen
  2018-11-02 17:59 ` MJ
@ 2018-11-25  3:00 ` Nashat Samir
  2 siblings, 0 replies; 4+ messages in thread
From: Nashat Samir @ 2018-11-25  3:00 UTC (permalink / raw)
  To: voidlinux

[-- Attachment #1.1: Type: text/plain, Size: 2258 bytes --]

After I remove the below packages to be able to update the system, I get a 
new error:

[*] Running transaction tasks oracle-jre-8u181_1: updating to 8u192_1 ... 
/tmp/.xbps-script-FoeTL2: 45: .: Can't open usr/lib/jvm/oracle-jre-vars.sh 
ERROR: oracle-jre-8u192_1: [remove] REMOVE script failed to execute pre 
ACTION: Key has expired ERROR: oracle-jre-8u192_1: failed to remove 
package: Key has expired ERROR: oracle-jre-8u192_1: [trans] failed to 
update package Key has expired'

this has been reported on 
https://github.com/void-linux/void-packages/issues/4209 but has not been 
resolved yet.  I cannot log in normally and have to resort to command line 
in a different TTY.  Any ideas?

Regards

Nashat

On Thursday, 1 November 2018 20:21:53 UTC+11, Steve Litt wrote:
>
> Tonight, when I tried xbps-install Su , I got the following errors:
>
> [root@mydesk ~]# xbps-install -u
> webkitgtk-2.4.11_6: broken, unresolvable shlib `libicudata.so.62'
> webkitgtk2-2.4.11_6: broken, unresolvable shlib `libicudata.so.62'
> webkitgtk-2.4.11_6: broken, unresolvable shlib `libicui18n.so.62'
> webkitgtk2-2.4.11_6: broken, unresolvable shlib `libicui18n.so.62'
> webkitgtk-2.4.11_6: broken, unresolvable shlib `libicuuc.so.62'
> webkitgtk2-2.4.11_6: broken, unresolvable shlib `libicuuc.so.62'
> Transaction aborted due to unresolved shlibs.
> [root@mydesk ~]#
>
> https://build.voidlinux.eu/waterfall shows no problem.
>
> [root@mydesk ~]# uname -a
> Linux mydesk 4.18.16_1 #1 SMP PREEMPT Sun Oct 21 03:00:36 UTC 2018 x86_64 
> GNU/Linux
> [root@mydesk ~]#
>
> What can I do to get past this. De-installing webkitgtk and webkitgtk2 
> would require removal of 10 or more often used apps. I tried changing my 
> repos, but got the same symptom.
>
> Thanks,
>
> SteveT
>
>

-- 
You received this message because you are subscribed to the Google Groups "voidlinux" group.
To unsubscribe from this group and stop receiving emails from it, send an email to voidlinux+unsubscribe@googlegroups.com.
To post to this group, send email to voidlinux@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/voidlinux/6c4bad04-fe82-4e54-93d6-d8e7a4c5c3cb%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

[-- Attachment #1.2: Type: text/html, Size: 3660 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, back to index

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-11-01  9:21 webkitgtk-2.4.11_6: broken, unresolvable shlib `libicudata.so.62' Steve Litt
2018-11-01 19:34 ` Leah Neukirchen
2018-11-02 17:59 ` MJ
2018-11-25  3:00 ` Nashat Samir

Void Linux discussion

Archives are clonable: git clone --mirror http://inbox.vuxu.org/voidlinux

Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.archive.voidlinux


AGPL code for this site: git clone https://public-inbox.org/ public-inbox