Void Linux discussion
 help / Atom feed
* how to enable pulseaudio/alsa
@ 2015-11-01 13:42 tuxracer
  2015-11-01 14:03 ` tuxracer
                   ` (3 more replies)
  0 siblings, 4 replies; 6+ messages in thread
From: tuxracer @ 2015-11-01 13:42 UTC (permalink / raw)
  To: voidlinux

[-- Attachment #1.1: Type: text/plain, Size: 259 bytes --]

So, I installed alsa and pulseaudio and alsa plugin then made simlink 
/etc/sv/alsa to /var/service and /etc/sv/pulseaudio to /var/service as well 
but system is not detecting any soundcard. alxamixer returns blank and 
nothing to configure. What went wrong?

[-- Attachment #1.2: Type: text/html, Size: 280 bytes --]

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: how to enable pulseaudio/alsa
  2015-11-01 13:42 how to enable pulseaudio/alsa tuxracer
@ 2015-11-01 14:03 ` tuxracer
  2015-11-01 14:06 ` tuxracer
                   ` (2 subsequent siblings)
  3 siblings, 0 replies; 6+ messages in thread
From: tuxracer @ 2015-11-01 14:03 UTC (permalink / raw)
  To: voidlinux

[-- Attachment #1.1: Type: text/plain, Size: 581 bytes --]

OK I added both alsa and pulseaudio sim link to /var/service and now 
"speaker-test -t wav -c 2" is making "front left," "front right" sound. 
However when I go into i3 and go to youtube, HTML5 player is completely 
silent. How could this be?


On Sunday, November 1, 2015 at 5:42:13 AM UTC-8, tuxracer wrote:
>
> So, I installed alsa and pulseaudio and alsa plugin then made simlink 
> /etc/sv/alsa to /var/service and /etc/sv/pulseaudio to /var/service as well 
> but system is not detecting any soundcard. alxamixer returns blank and 
> nothing to configure. What went wrong?
>

[-- Attachment #1.2: Type: text/html, Size: 775 bytes --]

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: how to enable pulseaudio/alsa
  2015-11-01 13:42 how to enable pulseaudio/alsa tuxracer
  2015-11-01 14:03 ` tuxracer
@ 2015-11-01 14:06 ` tuxracer
  2015-11-04 21:15 ` Muddmaker
  2015-11-07  5:26 ` Muddmaker
  3 siblings, 0 replies; 6+ messages in thread
From: tuxracer @ 2015-11-01 14:06 UTC (permalink / raw)
  To: voidlinux

[-- Attachment #1.1: Type: text/plain, Size: 1199 bytes --]

I tried speake test in i3 and it won't work:

$ speaker-test -t wav -c 2

speaker-test 1.0.29

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
ALSA lib confmisc.c:768:(parse_card) cannot find card 'PCH'
ALSA lib conf.c:4260:(_snd_config_evaluate) function snd_func_card_driver 
returned error: No such device
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4260:(_snd_config_evaluate) function snd_func_concat 
returned error: No such device
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:4260:(_snd_config_evaluate) function snd_func_refer 
returned error: No such device
ALSA lib conf.c:4739:(snd_config_expand) Evaluate error: No such device
ALSA lib pcm.c:2267:(snd_pcm_open_noupdate) Unknown PCM sysdefault
Playback open error: -19,No such device


On Sunday, November 1, 2015 at 5:42:13 AM UTC-8, tuxracer wrote:
>
> So, I installed alsa and pulseaudio and alsa plugin then made simlink 
> /etc/sv/alsa to /var/service and /etc/sv/pulseaudio to /var/service as well 
> but system is not detecting any soundcard. alxamixer returns blank and 
> nothing to configure. What went wrong?
>

[-- Attachment #1.2: Type: text/html, Size: 1426 bytes --]

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: how to enable pulseaudio/alsa
  2015-11-01 13:42 how to enable pulseaudio/alsa tuxracer
  2015-11-01 14:03 ` tuxracer
  2015-11-01 14:06 ` tuxracer
@ 2015-11-04 21:15 ` Muddmaker
  2015-11-05 12:02   ` Duncaen
  2015-11-07  5:26 ` Muddmaker
  3 siblings, 1 reply; 6+ messages in thread
From: Muddmaker @ 2015-11-04 21:15 UTC (permalink / raw)
  To: voidlinux

[-- Attachment #1.1: Type: text/plain, Size: 655 bytes --]

I want to bump this because I am having a very similar problem. However, it 
showed up once I switched my DE from MATE to Cinnamon. My audio was working 
just fine beforehand, and it has stopped working now. I have added 
pulseaudio as a service, and my problem is the same, as if there is no 
audio device connected.

On Sunday, November 1, 2015 at 5:42:13 AM UTC-8, tuxracer wrote:
>
> So, I installed alsa and pulseaudio and alsa plugin then made simlink 
> /etc/sv/alsa to /var/service and /etc/sv/pulseaudio to /var/service as well 
> but system is not detecting any soundcard. alxamixer returns blank and 
> nothing to configure. What went wrong?
>

[-- Attachment #1.2: Type: text/html, Size: 815 bytes --]

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: how to enable pulseaudio/alsa
  2015-11-04 21:15 ` Muddmaker
@ 2015-11-05 12:02   ` Duncaen
  0 siblings, 0 replies; 6+ messages in thread
From: Duncaen @ 2015-11-05 12:02 UTC (permalink / raw)
  To: voidlinux

[-- Attachment #1.1: Type: text/plain, Size: 1071 bytes --]

The pulseadio service is confusing and not needed, its used if you want a 
system wide pulseadio daemon and that is definitely not the preferred way 
of running pulse.
Normally pulse should start automatically in your desktop session if its 
required, if that doesn't work, maybe `start-pulseaudio-x11 &` in your 
xinitrc helps.

Am Mittwoch, 4. November 2015 22:15:24 UTC+1 schrieb Muddmaker:
>
> I want to bump this because I am having a very similar problem. However, 
> it showed up once I switched my DE from MATE to Cinnamon. My audio was 
> working just fine beforehand, and it has stopped working now. I have added 
> pulseaudio as a service, and my problem is the same, as if there is no 
> audio device connected.
>
> On Sunday, November 1, 2015 at 5:42:13 AM UTC-8, tuxracer wrote:
>>
>> So, I installed alsa and pulseaudio and alsa plugin then made simlink 
>> /etc/sv/alsa to /var/service and /etc/sv/pulseaudio to /var/service as well 
>> but system is not detecting any soundcard. alxamixer returns blank and 
>> nothing to configure. What went wrong?
>>
>
[-- Attachment #1.2: Type: text/html, Size: 1366 bytes --]

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: how to enable pulseaudio/alsa
  2015-11-01 13:42 how to enable pulseaudio/alsa tuxracer
                   ` (2 preceding siblings ...)
  2015-11-04 21:15 ` Muddmaker
@ 2015-11-07  5:26 ` Muddmaker
  3 siblings, 0 replies; 6+ messages in thread
From: Muddmaker @ 2015-11-07  5:26 UTC (permalink / raw)
  To: voidlinux

[-- Attachment #1.1: Type: text/plain, Size: 501 bytes --]

The solution to my problem was that I was missing  alsa-plugins-pulseaudio. 
It sounds like you already have that installed, so I'm not sure what your 
problem is.

On Sunday, November 1, 2015 at 5:42:13 AM UTC-8, tuxracer wrote:
>
> So, I installed alsa and pulseaudio and alsa plugin then made simlink 
> /etc/sv/alsa to /var/service and /etc/sv/pulseaudio to /var/service as well 
> but system is not detecting any soundcard. alxamixer returns blank and 
> nothing to configure. What went wrong?
>

[-- Attachment #1.2: Type: text/html, Size: 668 bytes --]

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, back to index

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-11-01 13:42 how to enable pulseaudio/alsa tuxracer
2015-11-01 14:03 ` tuxracer
2015-11-01 14:06 ` tuxracer
2015-11-04 21:15 ` Muddmaker
2015-11-05 12:02   ` Duncaen
2015-11-07  5:26 ` Muddmaker

Void Linux discussion

Archives are clonable: git clone --mirror http://inbox.vuxu.org/voidlinux

Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.archive.voidlinux


AGPL code for this site: git clone https://public-inbox.org/ public-inbox