Void Linux discussion
 help / Atom feed
* LXDM black screen
@ 2015-11-23 18:47 Cassie B
  2015-11-24  3:14 ` JD Robinson
  0 siblings, 1 reply; 2+ messages in thread
From: Cassie B @ 2015-11-23 18:47 UTC (permalink / raw)
  To: voidlinux

[-- Attachment #1.1: Type: text/plain, Size: 1566 bytes --]

After an update LXDM gives me a black screen and I have to reboot several 
times for it to work.

Here is my LXDM log:

** Message: 1447857384: add xserver watch


X.Org X Server 1.18.0
Release Date: 2015-11-09
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.2.6_1 x86_64
Current Operating System: Linux masters 4.2.6_1 #1 SMP PREEMPT Tue Nov 10 
07:19:29 UTC 2015 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.2.6_1 
root=UUID=a50727de-d384-4a4b-991a-92e83aff0ffb ro loglevel=4
Build Date: 12 November 2015  06:40:40AM

Current version of pixman: 0.32.8
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Nov 18 06:36:25 2015
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
** Message: 1447857388: start xserver in 23 retry
** Message: find greeter (nil)

** Message: find idle 0x564d86e34c90

** Message: add 0x564d86e34c90

** Message: prepare greeter on /var/run/lxdm/lxdm-:0.auth

** Message: start greeter on /var/run/lxdm/lxdm-:0.auth

No protocol specified

(lxdm-greeter-gtk:794): Gtk-WARNING **: cannot open display: :0
(II) AIGLX: Suspending AIGLX clients for VT switch

** (process:703): CRITICAL **: QUIT BY SIGNAL 15

** Message: quit code 0

** Message: exit cb


Any help would be appreciated.

[-- Attachment #1.2: Type: text/html, Size: 2155 bytes --]

^ permalink raw reply	[flat|nested] 2+ messages in thread

* LXDM black screen
  2015-11-23 18:47 LXDM black screen Cassie B
@ 2015-11-24  3:14 ` JD Robinson
  0 siblings, 0 replies; 2+ messages in thread
From: JD Robinson @ 2015-11-24  3:14 UTC (permalink / raw)
  To: voidlinux

[-- Attachment #1: Type: text/plain, Size: 546 bytes --]

I had some similar problems with an nvidia dkms module not loading properly at boot. Lxdm would cut on and off, interrupting my command line until I sv stop lxdm the service and rebuilt the kernel module. This was gone over in the thread titled "Nvidia problem?".

This may not be your issue, though, it would help to see the other logs from Xorg/X11 and possibly check dmesg or syslog files.

Sorry if that's not very specific, log file names have changed since I took classes 10 years ago.

It kind of sounds like X isn't up for lxdm to run in.

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, back to index

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-11-23 18:47 LXDM black screen Cassie B
2015-11-24  3:14 ` JD Robinson

Void Linux discussion

Archives are clonable: git clone --mirror http://inbox.vuxu.org/voidlinux

Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.archive.voidlinux


AGPL code for this site: git clone https://public-inbox.org/ public-inbox