zsh-users
 help / color / mirror / code / Atom feed
* a little alternative syntax improvement?
@ 2015-10-20  9:22 Marc Chantreux
  0 siblings, 0 replies; only message in thread
From: Marc Chantreux @ 2015-10-20  9:22 UTC (permalink / raw)
  To: Zsh hackers list

hello,

this message is just a proposal but i don't know how naive it is.
i just give it a try.

alternative syntax for for control statements are really pleasant
because the lhs uses the good context

      # lhs           # rhs
while ((count-- > 0)) { do_something }
while [[ -e $file ]]  { do_something }

and could be a bit more if the rhs would be context sensitive also:

for the moment, you need to write

    while {next_file} {((
        older = last < older ? last : older,
        count++
    ))}

when it would be more readable and consistent to write

    while {next_file} ((
        older = last < older ? last : older,
        count++
    )) 

my two cents.

regards
-- 
Marc Chantreux (eiro on github and freenode)
http://eiro.github.com/
http://eiro.github.com/atom.xml
"Don't believe everything you read on the Internet"
    -- Abraham Lincoln


^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2015-10-20  9:28 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-10-20  9:22 a little alternative syntax improvement? Marc Chantreux

Code repositories for project(s) associated with this public inbox

	https://git.vuxu.org/mirror/zsh/

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).