zsh-workers
 help / Atom feed
* */ globs and non-searchable directories
@ 2019-06-28  9:36 Stephane Chazelas
  0 siblings, 0 replies; 1+ messages in thread
From: Stephane Chazelas @ 2019-06-28  9:36 UTC (permalink / raw)
  To: Zsh hackers list

Not really a bug as such but a difference from other shells:

$ mkdir -m a=x searchable
$ mkdir -m a=r readable

$ echo *(/)
readable searchable
$ echo */
searchable/

All the other shells I tried output:

$ echo */
readable/ searchable/

In any case, all the shells I tried agree with zsh on:

$ echo */.
searchable/.

(though note the bug in current versions of bash5 as discussed
on the POSIX ML:

$ bash5 -c 'echo */.'
searchable/.
$ bash5 -c 'echo */"."'
readable/.
)

-- 
Stephane

^ permalink raw reply	[flat|nested] 1+ messages in thread

only message in thread, back to index

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-06-28  9:36 */ globs and non-searchable directories Stephane Chazelas

zsh-workers

Archives are clonable: git clone --mirror http://inbox.vuxu.org/zsh-workers

Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.archive.zsh.workers


AGPL code for this site: git clone https://public-inbox.org/ public-inbox