Github messages for voidlinux
 help / color / mirror / Atom feed
* [PR PATCH] update few python3 packages
@ 2022-02-03 13:22 dkwo
  2022-02-03 13:23 ` ahesford
                   ` (50 more replies)
  0 siblings, 51 replies; 52+ messages in thread
From: dkwo @ 2022-02-03 13:22 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 392 bytes --]

There is a new pull request by dkwo against master on the void-packages repository

https://github.com/dkwo/void-packages pytupd
https://github.com/void-linux/void-packages/pull/35376

update few python3 packages
@ahesford Could you check whather the new jupyter client solves the issue with console?

A patch file from https://github.com/void-linux/void-packages/pull/35376.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-pytupd-35376.patch --]
[-- Type: text/x-diff, Size: 14547 bytes --]

From b7c70361175ff73bc671a1edec5b2d07256e7b71 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:50:20 +0100
Subject: [PATCH 01/12] python3-bleach: update to 4.1.0

---
 srcpkgs/python3-bleach/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-bleach/template b/srcpkgs/python3-bleach/template
index 21fec4f4b37c..2b8af3b8fbba 100644
--- a/srcpkgs/python3-bleach/template
+++ b/srcpkgs/python3-bleach/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-bleach'
 pkgname=python3-bleach
-version=3.3.0
-revision=2
+version=4.1.0
+revision=1
 wrksrc="bleach-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -13,4 +13,4 @@ license="Apache-2.0"
 homepage="https://github.com/mozilla/bleach"
 changelog="https://raw.githubusercontent.com/mozilla/bleach/master/CHANGES"
 distfiles="${PYPI_SITE}/b/bleach/bleach-${version}.tar.gz"
-checksum=98b3170739e5e83dd9dc19633f074727ad848cbedb6026708c8ac2d3b697a433
+checksum=0900d8b37eba61a802ee40ac0061f8c2b5dee29c1927dd1d233e075ebf5a71da

From 8057bd1cb6ade173af7a8665d9884ade1404f883 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:51:55 +0100
Subject: [PATCH 02/12] python3-defusedxml: update to 0.7.1

---
 srcpkgs/python3-defusedxml/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-defusedxml/template b/srcpkgs/python3-defusedxml/template
index 06bdd57a3526..90dc454d120d 100644
--- a/srcpkgs/python3-defusedxml/template
+++ b/srcpkgs/python3-defusedxml/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-defusedxml'
 pkgname=python3-defusedxml
-version=0.6.0
-revision=5
+version=0.7.1
+revision=1
 wrksrc="defusedxml-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Python-2.0"
 homepage="https://github.com/tiran/defusedxml"
 distfiles="${PYPI_SITE}/d/defusedxml/defusedxml-${version}.tar.gz"
-checksum=f684034d135af4c6cbb949b8a4d2ed61634515257a67299e5f940fbaa34377f5
+checksum=1bb3032db185915b62d7c6209c5a8792be6a32ab2fedacc84e01b52c51aa3e69
 
 post_install() {
 	vlicense LICENSE

From 026b1219fef5f567c682baed41278c30ea16c387 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:54:30 +0100
Subject: [PATCH 03/12] python3-httplib2: update to 0.20.4

---
 srcpkgs/python3-httplib2/template | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-httplib2/template b/srcpkgs/python3-httplib2/template
index d0c39a478622..ac898ef2327f 100644
--- a/srcpkgs/python3-httplib2/template
+++ b/srcpkgs/python3-httplib2/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-httplib2'
 pkgname=python3-httplib2
-version=0.18.1
-revision=3
+version=0.20.4
+revision=1
 create_wrksrc=yes
 build_wrksrc="httplib2-${version}"
 build_style=python3-module
@@ -14,8 +14,10 @@ homepage="https://github.com/httplib2/httplib2"
 changelog="https://raw.githubusercontent.com/httplib2/httplib2/master/CHANGELOG"
 distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz
  https://raw.githubusercontent.com/httplib2/httplib2/master/LICENSE>LICENSE.txt"
-checksum="8af66c1c52c7ffe1aa5dc4bcd7c769885254b0756e6e69f953c7f0ab49a70ba3
+checksum="58a98e45b4b1a48273073f905d2961666ecf0fbac4250ea5b47aef259eb5c585
  589eec38f72df2be203711d3b8cbece9b908c5e7ff00bc3cab7f63bae9e366b4"
+# Testing via this command is deprecated
+make_check=no
 
 post_install() {
 	# use system ca certificates

From 300613c6aef5bbb6c9df4989690ff8af0845a7b5 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:55:53 +0100
Subject: [PATCH 04/12] python3-ipython_ipykernel: update to 6.7.0

---
 srcpkgs/python3-ipython_ipykernel/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-ipython_ipykernel/template b/srcpkgs/python3-ipython_ipykernel/template
index f00e0a3f1a0c..9b15e7c8a080 100644
--- a/srcpkgs/python3-ipython_ipykernel/template
+++ b/srcpkgs/python3-ipython_ipykernel/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-ipython_ipykernel'
 pkgname=python3-ipython_ipykernel
-version=5.5.4
-revision=2
+version=6.7.0
+revision=1
 wrksrc="ipykernel-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools python3-ipython
@@ -12,7 +12,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/ipykernel"
 distfiles="${PYPI_SITE}/i/ipykernel/ipykernel-${version}.tar.gz"
-checksum=1ce0e83672cc3bfdc1ffb5603e1d77ab125f24b41abc4612e22bfb3e994c0db2
+checksum=d82b904fdc2fd8c7b1fbe0fa481c68a11b4cd4c8ef07e6517da1f10cc3114d24
 # checks create a cycle with python3-jupyter_core and python3-jupyter_client
 make_check=no
 

From 8dfdc66c8f07182c422e15be39f98b426fa2c65f Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:57:38 +0100
Subject: [PATCH 05/12] python3-jsonschema: update to 4.4.0

---
 srcpkgs/python3-jsonschema/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-jsonschema/template b/srcpkgs/python3-jsonschema/template
index 82f45e037865..120392ad1be3 100644
--- a/srcpkgs/python3-jsonschema/template
+++ b/srcpkgs/python3-jsonschema/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-jsonschema'
 pkgname=python3-jsonschema
-version=4.2.1
+version=4.4.0
 revision=1
 wrksrc="jsonschema-${version}"
 build_style=python3-pep517
@@ -14,7 +14,7 @@ license="MIT"
 homepage="https://github.com/Julian/jsonschema"
 changelog="https://raw.githubusercontent.com/Julian/jsonschema/master/CHANGELOG.rst"
 distfiles="${PYPI_SITE}/j/jsonschema/jsonschema-${version}.tar.gz"
-checksum=390713469ae64b8a58698bb3cbc3859abe6925b565a973f87323ef21b09a27a8
+checksum=636694eb41b3535ed608fe04129f26542b59ed99808b4f688aa32dcf55317a83
 
 post_install() {
 	vlicense COPYING LICENSE

From 3a7b757ae573af78599f3350fd2a857e80b236a3 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:04:52 +0100
Subject: [PATCH 06/12] python3-jupyter_client: update to 7.1.2

---
 srcpkgs/python3-jupyter_client/template | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-jupyter_client/template b/srcpkgs/python3-jupyter_client/template
index be6aa5594095..b6ca0b980239 100644
--- a/srcpkgs/python3-jupyter_client/template
+++ b/srcpkgs/python3-jupyter_client/template
@@ -1,8 +1,7 @@
 # Template file for 'python3-jupyter_client'
 pkgname=python3-jupyter_client
-# delay 6.2 until jupyter/jupyter_console#241 is fixed
-version=6.1.12
-revision=2
+version=7.1.1
+revision=1
 wrksrc="jupyter_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -13,7 +12,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_client"
 distfiles="${PYPI_SITE}/j/jupyter_client/jupyter_client-${version}.tar.gz"
-checksum=c4bca1d0846186ca8be97f4d2fa6d2bae889cce4892a167ffa1ba6bd1f73e782
+checksum=540ca35e57e83c5ece81abd9b781a57cba39a37c60a2a30c8c1b2f6663544343
 conflicts="python-jupyter_client<=5.2.4_2"
 # checks create a cycle with python3-jupyter_core and python3-ipython_ipykernel
 make_check=no

From 633e715821a3e8dc8ffa6013de476af17473dc3c Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:06:12 +0100
Subject: [PATCH 07/12] python3-jupyter_core: update to 4.9.1

---
 srcpkgs/python3-jupyter_core/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_core/template b/srcpkgs/python3-jupyter_core/template
index d0fa364a6751..5f450d293d4f 100644
--- a/srcpkgs/python3-jupyter_core/template
+++ b/srcpkgs/python3-jupyter_core/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_core'
 pkgname=python3-jupyter_core
-version=4.7.1
-revision=2
+version=4.9.1
+revision=1
 wrksrc="jupyter_core-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter_core/jupyter_core-${version}.tar.gz"
-checksum=79025cb3225efcd36847d0840f3fc672c0abd7afd0de83ba8a1d3837619122b4
+checksum=dce8a7499da5a53ae3afd5a9f4b02e5df1d57250cf48f3ad79da23b4778cd6fa
 conflicts="python-jupyter_core<=4.4.0_3"
 # checks create a cycle with python3-jypter_client and python3-ipython_ipykernel
 make_check=no

From 2d781bbb7deaaf3f2b75171ff7862370fd2e82c6 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:07:34 +0100
Subject: [PATCH 08/12] python3-jupyter_notebook: update to 6.4.8

---
 srcpkgs/python3-jupyter_notebook/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_notebook/template b/srcpkgs/python3-jupyter_notebook/template
index ca9e1d43df21..f1ec68546fd9 100644
--- a/srcpkgs/python3-jupyter_notebook/template
+++ b/srcpkgs/python3-jupyter_notebook/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_notebook'
 pkgname=python3-jupyter_notebook
-version=6.3.0
-revision=2
+version=6.4.8
+revision=1
 wrksrc="notebook-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -15,7 +15,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org/"
 distfiles="${PYPI_SITE}/n/notebook/notebook-${version}.tar.gz"
-checksum=cbc9398d6c81473e9cdb891d2cae9c0d3718fca289dda6d26df5cb660fcadc7d
+checksum=1e985c9dc6f678bdfffb9dc657306b5469bfa62d73e03f74e8defbf76d284312
 conflicts="python-jupyter_notebook<=5.7.0_2"
 # Tests require unpackaged selenium
 make_check=no

From 7dd8f6c76bbf55dd9698e5787ccd3badf8463714 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:14:36 +0100
Subject: [PATCH 09/12] python3-paramiko: update to 2.9.2

---
 srcpkgs/python3-paramiko/template | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-paramiko/template b/srcpkgs/python3-paramiko/template
index cff1b3a2fb59..a11808886b73 100644
--- a/srcpkgs/python3-paramiko/template
+++ b/srcpkgs/python3-paramiko/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-paramiko'
 pkgname=python3-paramiko
-version=2.7.2
-revision=2
+version=2.9.2
+revision=1
 wrksrc="${pkgname#*-}-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,4 +11,6 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="LGPL-2.1-or-later"
 homepage="http://www.paramiko.org/"
 distfiles="${PYPI_SITE}/p/paramiko/paramiko-${version}.tar.gz"
-checksum=7f36f4ba2c0d81d219f4595e35f70d56cc94f9ac40a6acdf51d6ca210ce65035
+checksum=944a9e5dbdd413ab6c7951ea46b0ab40713235a9c4c5ca81cfe45c6f14fa677b
+# Testing via this command is deprecated
+make_check=no

From d3a31bb5bc56ea38e3b89f9b3faf10402111579c Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:16:02 +0100
Subject: [PATCH 10/12] python3-prometheus_client: update to 0.13.1

---
 srcpkgs/python3-prometheus_client/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-prometheus_client/template b/srcpkgs/python3-prometheus_client/template
index 82e4da1f3edd..739013270799 100644
--- a/srcpkgs/python3-prometheus_client/template
+++ b/srcpkgs/python3-prometheus_client/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-prometheus_client'
 pkgname=python3-prometheus_client
-version=0.9.0
-revision=2
+version=0.13.1
+revision=1
 wrksrc="prometheus_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,4 +12,4 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Apache-2.0"
 homepage="https://github.com/prometheus/client_python"
 distfiles="${PYPI_SITE}/p/prometheus_client/prometheus_client-${version}.tar.gz"
-checksum=9da7b32f02439d8c04f7777021c304ed51d9ec180604700c1ba72a4d44dceb03
+checksum=ada41b891b79fca5638bd5cfe149efa86512eaa55987893becd2c6d8d0a5dfc5

From b3b67f9982ae6e09bed0be5b04c6a4ce7d591e38 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:17:21 +0100
Subject: [PATCH 11/12] python3-soupsieve: update to 2.3.1

---
 srcpkgs/python3-soupsieve/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-soupsieve/template b/srcpkgs/python3-soupsieve/template
index 14449f20c47f..06eb2b8b8895 100644
--- a/srcpkgs/python3-soupsieve/template
+++ b/srcpkgs/python3-soupsieve/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-soupsieve'
 pkgname=python3-soupsieve
-version=1.9.5
-revision=6
+version=2.3.1
+revision=1
 wrksrc="soupsieve-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,7 +12,7 @@ maintainer="Aluísio Augusto Silva Gonçalves <aluisio@aasg.name>"
 license="MIT"
 homepage="https://facelessuser.github.io/soupsieve/"
 distfiles="${PYPI_SITE}/s/soupsieve/soupsieve-${version}.tar.gz"
-checksum=e2c1c5dee4a1c36bcb790e0fabd5492d874b8ebd4617622c4f6a731701060dda
+checksum=b8d49b1cd4f037c7082a9683dfa1801aa2597fb11c3a1155b7a5b94829b4f1f9
 
 post_install() {
 	vlicense LICENSE.md

From 6fad35e2edf9bd08ff020b6866f227112685447b Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:20:35 +0100
Subject: [PATCH 12/12] python3-terminado: update to 0.13.0

---
 srcpkgs/python3-terminado/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-terminado/template b/srcpkgs/python3-terminado/template
index 28c65c82ba99..a640dbeab9c4 100644
--- a/srcpkgs/python3-terminado/template
+++ b/srcpkgs/python3-terminado/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-terminado'
 pkgname=python3-terminado
-version=0.9.4
-revision=2
+version=0.13.0
+revision=1
 wrksrc="terminado-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,7 +12,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/takluyver/terminado"
 distfiles="${PYPI_SITE}/t/terminado/terminado-${version}.tar.gz"
-checksum=9a7dbcfbc2778830eeb70261bf7aa9d98a3eac8631a3afe3febeb57c12f798be
+checksum=713531ccb5db7d4f544651f14050da79809030f00d1afa21462088cf32fb143a
 
 post_install() {
 	vlicense LICENSE

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
@ 2022-02-03 13:23 ` ahesford
  2022-02-03 13:30 ` dkwo
                   ` (49 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: ahesford @ 2022-02-03 13:23 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 234 bytes --]

New comment by ahesford on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#issuecomment-1028987126

Comment:
I don't use jupyter; I wouldn't know how to test whether the console works properly or not.

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
  2022-02-03 13:23 ` ahesford
@ 2022-02-03 13:30 ` dkwo
  2022-02-03 13:32 ` [PR PATCH] [Updated] " dkwo
                   ` (48 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-02-03 13:30 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 284 bytes --]

New comment by dkwo on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#issuecomment-1028993223

Comment:
There was this comment in `jupyter_client`
` # delay 6.2 until jupyter/jupyter_console#241 is fixed`
I thought you were affected by this issue.

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR PATCH] [Updated] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
  2022-02-03 13:23 ` ahesford
  2022-02-03 13:30 ` dkwo
@ 2022-02-03 13:32 ` dkwo
  2022-02-03 13:46 ` dkwo
                   ` (47 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-02-03 13:32 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 397 bytes --]

There is an updated pull request by dkwo against master on the void-packages repository

https://github.com/dkwo/void-packages pytupd
https://github.com/void-linux/void-packages/pull/35376

update few python3 packages
@ahesford Could you check whether the new jupyter client solves the issue with console?

A patch file from https://github.com/void-linux/void-packages/pull/35376.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-pytupd-35376.patch --]
[-- Type: text/x-diff, Size: 14836 bytes --]

From b7c70361175ff73bc671a1edec5b2d07256e7b71 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:50:20 +0100
Subject: [PATCH 01/12] python3-bleach: update to 4.1.0

---
 srcpkgs/python3-bleach/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-bleach/template b/srcpkgs/python3-bleach/template
index 21fec4f4b37c..2b8af3b8fbba 100644
--- a/srcpkgs/python3-bleach/template
+++ b/srcpkgs/python3-bleach/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-bleach'
 pkgname=python3-bleach
-version=3.3.0
-revision=2
+version=4.1.0
+revision=1
 wrksrc="bleach-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -13,4 +13,4 @@ license="Apache-2.0"
 homepage="https://github.com/mozilla/bleach"
 changelog="https://raw.githubusercontent.com/mozilla/bleach/master/CHANGES"
 distfiles="${PYPI_SITE}/b/bleach/bleach-${version}.tar.gz"
-checksum=98b3170739e5e83dd9dc19633f074727ad848cbedb6026708c8ac2d3b697a433
+checksum=0900d8b37eba61a802ee40ac0061f8c2b5dee29c1927dd1d233e075ebf5a71da

From 8057bd1cb6ade173af7a8665d9884ade1404f883 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:51:55 +0100
Subject: [PATCH 02/12] python3-defusedxml: update to 0.7.1

---
 srcpkgs/python3-defusedxml/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-defusedxml/template b/srcpkgs/python3-defusedxml/template
index 06bdd57a3526..90dc454d120d 100644
--- a/srcpkgs/python3-defusedxml/template
+++ b/srcpkgs/python3-defusedxml/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-defusedxml'
 pkgname=python3-defusedxml
-version=0.6.0
-revision=5
+version=0.7.1
+revision=1
 wrksrc="defusedxml-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Python-2.0"
 homepage="https://github.com/tiran/defusedxml"
 distfiles="${PYPI_SITE}/d/defusedxml/defusedxml-${version}.tar.gz"
-checksum=f684034d135af4c6cbb949b8a4d2ed61634515257a67299e5f940fbaa34377f5
+checksum=1bb3032db185915b62d7c6209c5a8792be6a32ab2fedacc84e01b52c51aa3e69
 
 post_install() {
 	vlicense LICENSE

From 026b1219fef5f567c682baed41278c30ea16c387 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:54:30 +0100
Subject: [PATCH 03/12] python3-httplib2: update to 0.20.4

---
 srcpkgs/python3-httplib2/template | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-httplib2/template b/srcpkgs/python3-httplib2/template
index d0c39a478622..ac898ef2327f 100644
--- a/srcpkgs/python3-httplib2/template
+++ b/srcpkgs/python3-httplib2/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-httplib2'
 pkgname=python3-httplib2
-version=0.18.1
-revision=3
+version=0.20.4
+revision=1
 create_wrksrc=yes
 build_wrksrc="httplib2-${version}"
 build_style=python3-module
@@ -14,8 +14,10 @@ homepage="https://github.com/httplib2/httplib2"
 changelog="https://raw.githubusercontent.com/httplib2/httplib2/master/CHANGELOG"
 distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz
  https://raw.githubusercontent.com/httplib2/httplib2/master/LICENSE>LICENSE.txt"
-checksum="8af66c1c52c7ffe1aa5dc4bcd7c769885254b0756e6e69f953c7f0ab49a70ba3
+checksum="58a98e45b4b1a48273073f905d2961666ecf0fbac4250ea5b47aef259eb5c585
  589eec38f72df2be203711d3b8cbece9b908c5e7ff00bc3cab7f63bae9e366b4"
+# Testing via this command is deprecated
+make_check=no
 
 post_install() {
 	# use system ca certificates

From 7831bf1e84a1597c8f0fb883e3772c38f0211480 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:55:53 +0100
Subject: [PATCH 04/12] python3-ipython_ipykernel: update to 6.7.0

---
 srcpkgs/python3-ipython_ipykernel/template | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-ipython_ipykernel/template b/srcpkgs/python3-ipython_ipykernel/template
index f00e0a3f1a0c..e0392f2ed3b9 100644
--- a/srcpkgs/python3-ipython_ipykernel/template
+++ b/srcpkgs/python3-ipython_ipykernel/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-ipython_ipykernel'
 pkgname=python3-ipython_ipykernel
-version=5.5.4
-revision=2
+version=6.7.0
+revision=1
 wrksrc="ipykernel-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools python3-ipython
  python3-jupyter_client python3-traitlets python3-tornado"
-depends="python3-ipython python3-traitlets python3-jupyter_client python3-tornado"
+depends="python3-ipython python3-traitlets python3-jupyter_client
+ python3-tornado python3-entrypoints"
 short_desc="IPython kernel for Jupyter (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/ipykernel"
 distfiles="${PYPI_SITE}/i/ipykernel/ipykernel-${version}.tar.gz"
-checksum=1ce0e83672cc3bfdc1ffb5603e1d77ab125f24b41abc4612e22bfb3e994c0db2
+checksum=d82b904fdc2fd8c7b1fbe0fa481c68a11b4cd4c8ef07e6517da1f10cc3114d24
 # checks create a cycle with python3-jupyter_core and python3-jupyter_client
 make_check=no
 

From 20cc8c730d9c5deba9f089df10f66d2f3a0f3353 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:57:38 +0100
Subject: [PATCH 05/12] python3-jsonschema: update to 4.4.0

---
 srcpkgs/python3-jsonschema/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-jsonschema/template b/srcpkgs/python3-jsonschema/template
index 82f45e037865..120392ad1be3 100644
--- a/srcpkgs/python3-jsonschema/template
+++ b/srcpkgs/python3-jsonschema/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-jsonschema'
 pkgname=python3-jsonschema
-version=4.2.1
+version=4.4.0
 revision=1
 wrksrc="jsonschema-${version}"
 build_style=python3-pep517
@@ -14,7 +14,7 @@ license="MIT"
 homepage="https://github.com/Julian/jsonschema"
 changelog="https://raw.githubusercontent.com/Julian/jsonschema/master/CHANGELOG.rst"
 distfiles="${PYPI_SITE}/j/jsonschema/jsonschema-${version}.tar.gz"
-checksum=390713469ae64b8a58698bb3cbc3859abe6925b565a973f87323ef21b09a27a8
+checksum=636694eb41b3535ed608fe04129f26542b59ed99808b4f688aa32dcf55317a83
 
 post_install() {
 	vlicense COPYING LICENSE

From 7332949bd7e539724ca50c39497d7970233ffa99 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:04:52 +0100
Subject: [PATCH 06/12] python3-jupyter_client: update to 7.1.2

---
 srcpkgs/python3-jupyter_client/template | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-jupyter_client/template b/srcpkgs/python3-jupyter_client/template
index be6aa5594095..b6ca0b980239 100644
--- a/srcpkgs/python3-jupyter_client/template
+++ b/srcpkgs/python3-jupyter_client/template
@@ -1,8 +1,7 @@
 # Template file for 'python3-jupyter_client'
 pkgname=python3-jupyter_client
-# delay 6.2 until jupyter/jupyter_console#241 is fixed
-version=6.1.12
-revision=2
+version=7.1.1
+revision=1
 wrksrc="jupyter_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -13,7 +12,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_client"
 distfiles="${PYPI_SITE}/j/jupyter_client/jupyter_client-${version}.tar.gz"
-checksum=c4bca1d0846186ca8be97f4d2fa6d2bae889cce4892a167ffa1ba6bd1f73e782
+checksum=540ca35e57e83c5ece81abd9b781a57cba39a37c60a2a30c8c1b2f6663544343
 conflicts="python-jupyter_client<=5.2.4_2"
 # checks create a cycle with python3-jupyter_core and python3-ipython_ipykernel
 make_check=no

From d15ebb45c63922b91a3001ab232485320b57b3d6 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:06:12 +0100
Subject: [PATCH 07/12] python3-jupyter_core: update to 4.9.1

---
 srcpkgs/python3-jupyter_core/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_core/template b/srcpkgs/python3-jupyter_core/template
index d0fa364a6751..5f450d293d4f 100644
--- a/srcpkgs/python3-jupyter_core/template
+++ b/srcpkgs/python3-jupyter_core/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_core'
 pkgname=python3-jupyter_core
-version=4.7.1
-revision=2
+version=4.9.1
+revision=1
 wrksrc="jupyter_core-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter_core/jupyter_core-${version}.tar.gz"
-checksum=79025cb3225efcd36847d0840f3fc672c0abd7afd0de83ba8a1d3837619122b4
+checksum=dce8a7499da5a53ae3afd5a9f4b02e5df1d57250cf48f3ad79da23b4778cd6fa
 conflicts="python-jupyter_core<=4.4.0_3"
 # checks create a cycle with python3-jypter_client and python3-ipython_ipykernel
 make_check=no

From c5557467e1cbefa2ad181691f9cb87487baafde0 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:07:34 +0100
Subject: [PATCH 08/12] python3-jupyter_notebook: update to 6.4.8

---
 srcpkgs/python3-jupyter_notebook/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_notebook/template b/srcpkgs/python3-jupyter_notebook/template
index ca9e1d43df21..f1ec68546fd9 100644
--- a/srcpkgs/python3-jupyter_notebook/template
+++ b/srcpkgs/python3-jupyter_notebook/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_notebook'
 pkgname=python3-jupyter_notebook
-version=6.3.0
-revision=2
+version=6.4.8
+revision=1
 wrksrc="notebook-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -15,7 +15,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org/"
 distfiles="${PYPI_SITE}/n/notebook/notebook-${version}.tar.gz"
-checksum=cbc9398d6c81473e9cdb891d2cae9c0d3718fca289dda6d26df5cb660fcadc7d
+checksum=1e985c9dc6f678bdfffb9dc657306b5469bfa62d73e03f74e8defbf76d284312
 conflicts="python-jupyter_notebook<=5.7.0_2"
 # Tests require unpackaged selenium
 make_check=no

From aad75b2c2e0051536ffc609644d31bff5ab4312f Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:14:36 +0100
Subject: [PATCH 09/12] python3-paramiko: update to 2.9.2

---
 srcpkgs/python3-paramiko/template | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-paramiko/template b/srcpkgs/python3-paramiko/template
index cff1b3a2fb59..a11808886b73 100644
--- a/srcpkgs/python3-paramiko/template
+++ b/srcpkgs/python3-paramiko/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-paramiko'
 pkgname=python3-paramiko
-version=2.7.2
-revision=2
+version=2.9.2
+revision=1
 wrksrc="${pkgname#*-}-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,4 +11,6 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="LGPL-2.1-or-later"
 homepage="http://www.paramiko.org/"
 distfiles="${PYPI_SITE}/p/paramiko/paramiko-${version}.tar.gz"
-checksum=7f36f4ba2c0d81d219f4595e35f70d56cc94f9ac40a6acdf51d6ca210ce65035
+checksum=944a9e5dbdd413ab6c7951ea46b0ab40713235a9c4c5ca81cfe45c6f14fa677b
+# Testing via this command is deprecated
+make_check=no

From 694b78f219a66c62596e9653b33ebd2e9a65d44e Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:16:02 +0100
Subject: [PATCH 10/12] python3-prometheus_client: update to 0.13.1

---
 srcpkgs/python3-prometheus_client/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-prometheus_client/template b/srcpkgs/python3-prometheus_client/template
index 82e4da1f3edd..739013270799 100644
--- a/srcpkgs/python3-prometheus_client/template
+++ b/srcpkgs/python3-prometheus_client/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-prometheus_client'
 pkgname=python3-prometheus_client
-version=0.9.0
-revision=2
+version=0.13.1
+revision=1
 wrksrc="prometheus_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,4 +12,4 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Apache-2.0"
 homepage="https://github.com/prometheus/client_python"
 distfiles="${PYPI_SITE}/p/prometheus_client/prometheus_client-${version}.tar.gz"
-checksum=9da7b32f02439d8c04f7777021c304ed51d9ec180604700c1ba72a4d44dceb03
+checksum=ada41b891b79fca5638bd5cfe149efa86512eaa55987893becd2c6d8d0a5dfc5

From 2e701c4c5ec4b7ea57c2f400575168701ab4fcdb Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:17:21 +0100
Subject: [PATCH 11/12] python3-soupsieve: update to 2.3.1

---
 srcpkgs/python3-soupsieve/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-soupsieve/template b/srcpkgs/python3-soupsieve/template
index 14449f20c47f..06eb2b8b8895 100644
--- a/srcpkgs/python3-soupsieve/template
+++ b/srcpkgs/python3-soupsieve/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-soupsieve'
 pkgname=python3-soupsieve
-version=1.9.5
-revision=6
+version=2.3.1
+revision=1
 wrksrc="soupsieve-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,7 +12,7 @@ maintainer="Aluísio Augusto Silva Gonçalves <aluisio@aasg.name>"
 license="MIT"
 homepage="https://facelessuser.github.io/soupsieve/"
 distfiles="${PYPI_SITE}/s/soupsieve/soupsieve-${version}.tar.gz"
-checksum=e2c1c5dee4a1c36bcb790e0fabd5492d874b8ebd4617622c4f6a731701060dda
+checksum=b8d49b1cd4f037c7082a9683dfa1801aa2597fb11c3a1155b7a5b94829b4f1f9
 
 post_install() {
 	vlicense LICENSE.md

From 71615e0f8e8cb1526ba2a3cebb039602047f269d Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:20:35 +0100
Subject: [PATCH 12/12] python3-terminado: update to 0.13.0

---
 srcpkgs/python3-terminado/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-terminado/template b/srcpkgs/python3-terminado/template
index 28c65c82ba99..a640dbeab9c4 100644
--- a/srcpkgs/python3-terminado/template
+++ b/srcpkgs/python3-terminado/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-terminado'
 pkgname=python3-terminado
-version=0.9.4
-revision=2
+version=0.13.0
+revision=1
 wrksrc="terminado-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,7 +12,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/takluyver/terminado"
 distfiles="${PYPI_SITE}/t/terminado/terminado-${version}.tar.gz"
-checksum=9a7dbcfbc2778830eeb70261bf7aa9d98a3eac8631a3afe3febeb57c12f798be
+checksum=713531ccb5db7d4f544651f14050da79809030f00d1afa21462088cf32fb143a
 
 post_install() {
 	vlicense LICENSE

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR PATCH] [Updated] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (2 preceding siblings ...)
  2022-02-03 13:32 ` [PR PATCH] [Updated] " dkwo
@ 2022-02-03 13:46 ` dkwo
  2022-02-03 13:47 ` dkwo
                   ` (46 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-02-03 13:46 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 397 bytes --]

There is an updated pull request by dkwo against master on the void-packages repository

https://github.com/dkwo/void-packages pytupd
https://github.com/void-linux/void-packages/pull/35376

update few python3 packages
@ahesford Could you check whether the new jupyter client solves the issue with console?

A patch file from https://github.com/void-linux/void-packages/pull/35376.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-pytupd-35376.patch --]
[-- Type: text/x-diff, Size: 14940 bytes --]

From 34f06c1e64388da8db1c77ac0639f40aebe29f7c Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:50:20 +0100
Subject: [PATCH 01/12] python3-bleach: update to 4.1.0

---
 srcpkgs/python3-bleach/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-bleach/template b/srcpkgs/python3-bleach/template
index 21fec4f4b37c..2b8af3b8fbba 100644
--- a/srcpkgs/python3-bleach/template
+++ b/srcpkgs/python3-bleach/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-bleach'
 pkgname=python3-bleach
-version=3.3.0
-revision=2
+version=4.1.0
+revision=1
 wrksrc="bleach-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -13,4 +13,4 @@ license="Apache-2.0"
 homepage="https://github.com/mozilla/bleach"
 changelog="https://raw.githubusercontent.com/mozilla/bleach/master/CHANGES"
 distfiles="${PYPI_SITE}/b/bleach/bleach-${version}.tar.gz"
-checksum=98b3170739e5e83dd9dc19633f074727ad848cbedb6026708c8ac2d3b697a433
+checksum=0900d8b37eba61a802ee40ac0061f8c2b5dee29c1927dd1d233e075ebf5a71da

From 7e55938507f5c6a6434afe922c235c4f134ffed2 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:51:55 +0100
Subject: [PATCH 02/12] python3-defusedxml: update to 0.7.1

---
 srcpkgs/python3-defusedxml/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-defusedxml/template b/srcpkgs/python3-defusedxml/template
index 06bdd57a3526..90dc454d120d 100644
--- a/srcpkgs/python3-defusedxml/template
+++ b/srcpkgs/python3-defusedxml/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-defusedxml'
 pkgname=python3-defusedxml
-version=0.6.0
-revision=5
+version=0.7.1
+revision=1
 wrksrc="defusedxml-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Python-2.0"
 homepage="https://github.com/tiran/defusedxml"
 distfiles="${PYPI_SITE}/d/defusedxml/defusedxml-${version}.tar.gz"
-checksum=f684034d135af4c6cbb949b8a4d2ed61634515257a67299e5f940fbaa34377f5
+checksum=1bb3032db185915b62d7c6209c5a8792be6a32ab2fedacc84e01b52c51aa3e69
 
 post_install() {
 	vlicense LICENSE

From 0c1d6b7a93294ba7db8578e94de35586daf39288 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:54:30 +0100
Subject: [PATCH 03/12] python3-httplib2: update to 0.20.4

---
 srcpkgs/python3-httplib2/template | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-httplib2/template b/srcpkgs/python3-httplib2/template
index d0c39a478622..ac898ef2327f 100644
--- a/srcpkgs/python3-httplib2/template
+++ b/srcpkgs/python3-httplib2/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-httplib2'
 pkgname=python3-httplib2
-version=0.18.1
-revision=3
+version=0.20.4
+revision=1
 create_wrksrc=yes
 build_wrksrc="httplib2-${version}"
 build_style=python3-module
@@ -14,8 +14,10 @@ homepage="https://github.com/httplib2/httplib2"
 changelog="https://raw.githubusercontent.com/httplib2/httplib2/master/CHANGELOG"
 distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz
  https://raw.githubusercontent.com/httplib2/httplib2/master/LICENSE>LICENSE.txt"
-checksum="8af66c1c52c7ffe1aa5dc4bcd7c769885254b0756e6e69f953c7f0ab49a70ba3
+checksum="58a98e45b4b1a48273073f905d2961666ecf0fbac4250ea5b47aef259eb5c585
  589eec38f72df2be203711d3b8cbece9b908c5e7ff00bc3cab7f63bae9e366b4"
+# Testing via this command is deprecated
+make_check=no
 
 post_install() {
 	# use system ca certificates

From cce657e3942afed11e0650a3ada8dae75683bbed Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:55:53 +0100
Subject: [PATCH 04/12] python3-ipython_ipykernel: update to 6.8.0

---
 srcpkgs/python3-ipython_ipykernel/template | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-ipython_ipykernel/template b/srcpkgs/python3-ipython_ipykernel/template
index f00e0a3f1a0c..b75796ca0262 100644
--- a/srcpkgs/python3-ipython_ipykernel/template
+++ b/srcpkgs/python3-ipython_ipykernel/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-ipython_ipykernel'
 pkgname=python3-ipython_ipykernel
-version=5.5.4
-revision=2
+version=6.8.0
+revision=1
 wrksrc="ipykernel-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools python3-ipython
- python3-jupyter_client python3-traitlets python3-tornado"
-depends="python3-ipython python3-traitlets python3-jupyter_client python3-tornado"
+ python3-jupyter_client python3-traitlets python3-tornado python3-entrypoints"
+depends="python3-ipython python3-traitlets python3-jupyter_client
+ python3-tornado python3-entrypoints python3-nest_asyncio"
 short_desc="IPython kernel for Jupyter (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/ipykernel"
 distfiles="${PYPI_SITE}/i/ipykernel/ipykernel-${version}.tar.gz"
-checksum=1ce0e83672cc3bfdc1ffb5603e1d77ab125f24b41abc4612e22bfb3e994c0db2
+checksum=67d316d527eca24e3ded45a2b38689615bcda1aa520a11af0accdcea7152c18a
 # checks create a cycle with python3-jupyter_core and python3-jupyter_client
 make_check=no
 

From e3dd901cd5090300ccd37ef373dee63e61e15527 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:57:38 +0100
Subject: [PATCH 05/12] python3-jsonschema: update to 4.4.0

---
 srcpkgs/python3-jsonschema/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-jsonschema/template b/srcpkgs/python3-jsonschema/template
index 82f45e037865..120392ad1be3 100644
--- a/srcpkgs/python3-jsonschema/template
+++ b/srcpkgs/python3-jsonschema/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-jsonschema'
 pkgname=python3-jsonschema
-version=4.2.1
+version=4.4.0
 revision=1
 wrksrc="jsonschema-${version}"
 build_style=python3-pep517
@@ -14,7 +14,7 @@ license="MIT"
 homepage="https://github.com/Julian/jsonschema"
 changelog="https://raw.githubusercontent.com/Julian/jsonschema/master/CHANGELOG.rst"
 distfiles="${PYPI_SITE}/j/jsonschema/jsonschema-${version}.tar.gz"
-checksum=390713469ae64b8a58698bb3cbc3859abe6925b565a973f87323ef21b09a27a8
+checksum=636694eb41b3535ed608fe04129f26542b59ed99808b4f688aa32dcf55317a83
 
 post_install() {
 	vlicense COPYING LICENSE

From 84d0b869d7f3a15d160ba339f13f348321eb5d48 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:04:52 +0100
Subject: [PATCH 06/12] python3-jupyter_client: update to 7.1.2

---
 srcpkgs/python3-jupyter_client/template | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-jupyter_client/template b/srcpkgs/python3-jupyter_client/template
index be6aa5594095..b6ca0b980239 100644
--- a/srcpkgs/python3-jupyter_client/template
+++ b/srcpkgs/python3-jupyter_client/template
@@ -1,8 +1,7 @@
 # Template file for 'python3-jupyter_client'
 pkgname=python3-jupyter_client
-# delay 6.2 until jupyter/jupyter_console#241 is fixed
-version=6.1.12
-revision=2
+version=7.1.1
+revision=1
 wrksrc="jupyter_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -13,7 +12,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_client"
 distfiles="${PYPI_SITE}/j/jupyter_client/jupyter_client-${version}.tar.gz"
-checksum=c4bca1d0846186ca8be97f4d2fa6d2bae889cce4892a167ffa1ba6bd1f73e782
+checksum=540ca35e57e83c5ece81abd9b781a57cba39a37c60a2a30c8c1b2f6663544343
 conflicts="python-jupyter_client<=5.2.4_2"
 # checks create a cycle with python3-jupyter_core and python3-ipython_ipykernel
 make_check=no

From 4d6f10c84f70089971fe7bc9d56375f0d210c4d0 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:06:12 +0100
Subject: [PATCH 07/12] python3-jupyter_core: update to 4.9.1

---
 srcpkgs/python3-jupyter_core/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_core/template b/srcpkgs/python3-jupyter_core/template
index d0fa364a6751..5f450d293d4f 100644
--- a/srcpkgs/python3-jupyter_core/template
+++ b/srcpkgs/python3-jupyter_core/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_core'
 pkgname=python3-jupyter_core
-version=4.7.1
-revision=2
+version=4.9.1
+revision=1
 wrksrc="jupyter_core-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter_core/jupyter_core-${version}.tar.gz"
-checksum=79025cb3225efcd36847d0840f3fc672c0abd7afd0de83ba8a1d3837619122b4
+checksum=dce8a7499da5a53ae3afd5a9f4b02e5df1d57250cf48f3ad79da23b4778cd6fa
 conflicts="python-jupyter_core<=4.4.0_3"
 # checks create a cycle with python3-jypter_client and python3-ipython_ipykernel
 make_check=no

From 3e62f4d8fa6e71ac578bcbefb8233680f674538d Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:07:34 +0100
Subject: [PATCH 08/12] python3-jupyter_notebook: update to 6.4.8

---
 srcpkgs/python3-jupyter_notebook/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_notebook/template b/srcpkgs/python3-jupyter_notebook/template
index ca9e1d43df21..f1ec68546fd9 100644
--- a/srcpkgs/python3-jupyter_notebook/template
+++ b/srcpkgs/python3-jupyter_notebook/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_notebook'
 pkgname=python3-jupyter_notebook
-version=6.3.0
-revision=2
+version=6.4.8
+revision=1
 wrksrc="notebook-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -15,7 +15,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org/"
 distfiles="${PYPI_SITE}/n/notebook/notebook-${version}.tar.gz"
-checksum=cbc9398d6c81473e9cdb891d2cae9c0d3718fca289dda6d26df5cb660fcadc7d
+checksum=1e985c9dc6f678bdfffb9dc657306b5469bfa62d73e03f74e8defbf76d284312
 conflicts="python-jupyter_notebook<=5.7.0_2"
 # Tests require unpackaged selenium
 make_check=no

From 5e6458b989c19d01f042695e6c5c162150b3572a Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:14:36 +0100
Subject: [PATCH 09/12] python3-paramiko: update to 2.9.2

---
 srcpkgs/python3-paramiko/template | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-paramiko/template b/srcpkgs/python3-paramiko/template
index cff1b3a2fb59..a11808886b73 100644
--- a/srcpkgs/python3-paramiko/template
+++ b/srcpkgs/python3-paramiko/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-paramiko'
 pkgname=python3-paramiko
-version=2.7.2
-revision=2
+version=2.9.2
+revision=1
 wrksrc="${pkgname#*-}-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,4 +11,6 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="LGPL-2.1-or-later"
 homepage="http://www.paramiko.org/"
 distfiles="${PYPI_SITE}/p/paramiko/paramiko-${version}.tar.gz"
-checksum=7f36f4ba2c0d81d219f4595e35f70d56cc94f9ac40a6acdf51d6ca210ce65035
+checksum=944a9e5dbdd413ab6c7951ea46b0ab40713235a9c4c5ca81cfe45c6f14fa677b
+# Testing via this command is deprecated
+make_check=no

From 28bf96d9d3201cab37597820a1ddf329e8591d34 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:16:02 +0100
Subject: [PATCH 10/12] python3-prometheus_client: update to 0.13.1

---
 srcpkgs/python3-prometheus_client/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-prometheus_client/template b/srcpkgs/python3-prometheus_client/template
index 82e4da1f3edd..739013270799 100644
--- a/srcpkgs/python3-prometheus_client/template
+++ b/srcpkgs/python3-prometheus_client/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-prometheus_client'
 pkgname=python3-prometheus_client
-version=0.9.0
-revision=2
+version=0.13.1
+revision=1
 wrksrc="prometheus_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,4 +12,4 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Apache-2.0"
 homepage="https://github.com/prometheus/client_python"
 distfiles="${PYPI_SITE}/p/prometheus_client/prometheus_client-${version}.tar.gz"
-checksum=9da7b32f02439d8c04f7777021c304ed51d9ec180604700c1ba72a4d44dceb03
+checksum=ada41b891b79fca5638bd5cfe149efa86512eaa55987893becd2c6d8d0a5dfc5

From f10d9a535b00ebe97325cc488f9e3a6358bfb5a9 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:17:21 +0100
Subject: [PATCH 11/12] python3-soupsieve: update to 2.3.1

---
 srcpkgs/python3-soupsieve/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-soupsieve/template b/srcpkgs/python3-soupsieve/template
index 14449f20c47f..06eb2b8b8895 100644
--- a/srcpkgs/python3-soupsieve/template
+++ b/srcpkgs/python3-soupsieve/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-soupsieve'
 pkgname=python3-soupsieve
-version=1.9.5
-revision=6
+version=2.3.1
+revision=1
 wrksrc="soupsieve-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,7 +12,7 @@ maintainer="Aluísio Augusto Silva Gonçalves <aluisio@aasg.name>"
 license="MIT"
 homepage="https://facelessuser.github.io/soupsieve/"
 distfiles="${PYPI_SITE}/s/soupsieve/soupsieve-${version}.tar.gz"
-checksum=e2c1c5dee4a1c36bcb790e0fabd5492d874b8ebd4617622c4f6a731701060dda
+checksum=b8d49b1cd4f037c7082a9683dfa1801aa2597fb11c3a1155b7a5b94829b4f1f9
 
 post_install() {
 	vlicense LICENSE.md

From fd1c55be6f6be8d3a023b5a6a81046ca8527b6dd Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:20:35 +0100
Subject: [PATCH 12/12] python3-terminado: update to 0.13.0

---
 srcpkgs/python3-terminado/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-terminado/template b/srcpkgs/python3-terminado/template
index 28c65c82ba99..a640dbeab9c4 100644
--- a/srcpkgs/python3-terminado/template
+++ b/srcpkgs/python3-terminado/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-terminado'
 pkgname=python3-terminado
-version=0.9.4
-revision=2
+version=0.13.0
+revision=1
 wrksrc="terminado-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,7 +12,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/takluyver/terminado"
 distfiles="${PYPI_SITE}/t/terminado/terminado-${version}.tar.gz"
-checksum=9a7dbcfbc2778830eeb70261bf7aa9d98a3eac8631a3afe3febeb57c12f798be
+checksum=713531ccb5db7d4f544651f14050da79809030f00d1afa21462088cf32fb143a
 
 post_install() {
 	vlicense LICENSE

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (3 preceding siblings ...)
  2022-02-03 13:46 ` dkwo
@ 2022-02-03 13:47 ` dkwo
  2022-02-03 13:58 ` [PR PATCH] [Updated] " dkwo
                   ` (45 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-02-03 13:47 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 206 bytes --]

New comment by dkwo on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#issuecomment-1029008051

Comment:
Btw, all builds fine here, do not understand the entrypoints error.

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR PATCH] [Updated] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (4 preceding siblings ...)
  2022-02-03 13:47 ` dkwo
@ 2022-02-03 13:58 ` dkwo
  2022-02-03 14:07 ` dkwo
                   ` (44 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-02-03 13:58 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 397 bytes --]

There is an updated pull request by dkwo against master on the void-packages repository

https://github.com/dkwo/void-packages pytupd
https://github.com/void-linux/void-packages/pull/35376

update few python3 packages
@ahesford Could you check whether the new jupyter client solves the issue with console?

A patch file from https://github.com/void-linux/void-packages/pull/35376.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-pytupd-35376.patch --]
[-- Type: text/x-diff, Size: 15161 bytes --]

From 34f06c1e64388da8db1c77ac0639f40aebe29f7c Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:50:20 +0100
Subject: [PATCH 01/12] python3-bleach: update to 4.1.0

---
 srcpkgs/python3-bleach/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-bleach/template b/srcpkgs/python3-bleach/template
index 21fec4f4b37c..2b8af3b8fbba 100644
--- a/srcpkgs/python3-bleach/template
+++ b/srcpkgs/python3-bleach/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-bleach'
 pkgname=python3-bleach
-version=3.3.0
-revision=2
+version=4.1.0
+revision=1
 wrksrc="bleach-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -13,4 +13,4 @@ license="Apache-2.0"
 homepage="https://github.com/mozilla/bleach"
 changelog="https://raw.githubusercontent.com/mozilla/bleach/master/CHANGES"
 distfiles="${PYPI_SITE}/b/bleach/bleach-${version}.tar.gz"
-checksum=98b3170739e5e83dd9dc19633f074727ad848cbedb6026708c8ac2d3b697a433
+checksum=0900d8b37eba61a802ee40ac0061f8c2b5dee29c1927dd1d233e075ebf5a71da

From 7e55938507f5c6a6434afe922c235c4f134ffed2 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:51:55 +0100
Subject: [PATCH 02/12] python3-defusedxml: update to 0.7.1

---
 srcpkgs/python3-defusedxml/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-defusedxml/template b/srcpkgs/python3-defusedxml/template
index 06bdd57a3526..90dc454d120d 100644
--- a/srcpkgs/python3-defusedxml/template
+++ b/srcpkgs/python3-defusedxml/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-defusedxml'
 pkgname=python3-defusedxml
-version=0.6.0
-revision=5
+version=0.7.1
+revision=1
 wrksrc="defusedxml-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Python-2.0"
 homepage="https://github.com/tiran/defusedxml"
 distfiles="${PYPI_SITE}/d/defusedxml/defusedxml-${version}.tar.gz"
-checksum=f684034d135af4c6cbb949b8a4d2ed61634515257a67299e5f940fbaa34377f5
+checksum=1bb3032db185915b62d7c6209c5a8792be6a32ab2fedacc84e01b52c51aa3e69
 
 post_install() {
 	vlicense LICENSE

From 0c1d6b7a93294ba7db8578e94de35586daf39288 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:54:30 +0100
Subject: [PATCH 03/12] python3-httplib2: update to 0.20.4

---
 srcpkgs/python3-httplib2/template | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-httplib2/template b/srcpkgs/python3-httplib2/template
index d0c39a478622..ac898ef2327f 100644
--- a/srcpkgs/python3-httplib2/template
+++ b/srcpkgs/python3-httplib2/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-httplib2'
 pkgname=python3-httplib2
-version=0.18.1
-revision=3
+version=0.20.4
+revision=1
 create_wrksrc=yes
 build_wrksrc="httplib2-${version}"
 build_style=python3-module
@@ -14,8 +14,10 @@ homepage="https://github.com/httplib2/httplib2"
 changelog="https://raw.githubusercontent.com/httplib2/httplib2/master/CHANGELOG"
 distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz
  https://raw.githubusercontent.com/httplib2/httplib2/master/LICENSE>LICENSE.txt"
-checksum="8af66c1c52c7ffe1aa5dc4bcd7c769885254b0756e6e69f953c7f0ab49a70ba3
+checksum="58a98e45b4b1a48273073f905d2961666ecf0fbac4250ea5b47aef259eb5c585
  589eec38f72df2be203711d3b8cbece9b908c5e7ff00bc3cab7f63bae9e366b4"
+# Testing via this command is deprecated
+make_check=no
 
 post_install() {
 	# use system ca certificates

From cce657e3942afed11e0650a3ada8dae75683bbed Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:55:53 +0100
Subject: [PATCH 04/12] python3-ipython_ipykernel: update to 6.8.0

---
 srcpkgs/python3-ipython_ipykernel/template | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-ipython_ipykernel/template b/srcpkgs/python3-ipython_ipykernel/template
index f00e0a3f1a0c..b75796ca0262 100644
--- a/srcpkgs/python3-ipython_ipykernel/template
+++ b/srcpkgs/python3-ipython_ipykernel/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-ipython_ipykernel'
 pkgname=python3-ipython_ipykernel
-version=5.5.4
-revision=2
+version=6.8.0
+revision=1
 wrksrc="ipykernel-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools python3-ipython
- python3-jupyter_client python3-traitlets python3-tornado"
-depends="python3-ipython python3-traitlets python3-jupyter_client python3-tornado"
+ python3-jupyter_client python3-traitlets python3-tornado python3-entrypoints"
+depends="python3-ipython python3-traitlets python3-jupyter_client
+ python3-tornado python3-entrypoints python3-nest_asyncio"
 short_desc="IPython kernel for Jupyter (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/ipykernel"
 distfiles="${PYPI_SITE}/i/ipykernel/ipykernel-${version}.tar.gz"
-checksum=1ce0e83672cc3bfdc1ffb5603e1d77ab125f24b41abc4612e22bfb3e994c0db2
+checksum=67d316d527eca24e3ded45a2b38689615bcda1aa520a11af0accdcea7152c18a
 # checks create a cycle with python3-jupyter_core and python3-jupyter_client
 make_check=no
 

From e3dd901cd5090300ccd37ef373dee63e61e15527 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:57:38 +0100
Subject: [PATCH 05/12] python3-jsonschema: update to 4.4.0

---
 srcpkgs/python3-jsonschema/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-jsonschema/template b/srcpkgs/python3-jsonschema/template
index 82f45e037865..120392ad1be3 100644
--- a/srcpkgs/python3-jsonschema/template
+++ b/srcpkgs/python3-jsonschema/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-jsonschema'
 pkgname=python3-jsonschema
-version=4.2.1
+version=4.4.0
 revision=1
 wrksrc="jsonschema-${version}"
 build_style=python3-pep517
@@ -14,7 +14,7 @@ license="MIT"
 homepage="https://github.com/Julian/jsonschema"
 changelog="https://raw.githubusercontent.com/Julian/jsonschema/master/CHANGELOG.rst"
 distfiles="${PYPI_SITE}/j/jsonschema/jsonschema-${version}.tar.gz"
-checksum=390713469ae64b8a58698bb3cbc3859abe6925b565a973f87323ef21b09a27a8
+checksum=636694eb41b3535ed608fe04129f26542b59ed99808b4f688aa32dcf55317a83
 
 post_install() {
 	vlicense COPYING LICENSE

From 84d0b869d7f3a15d160ba339f13f348321eb5d48 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:04:52 +0100
Subject: [PATCH 06/12] python3-jupyter_client: update to 7.1.2

---
 srcpkgs/python3-jupyter_client/template | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-jupyter_client/template b/srcpkgs/python3-jupyter_client/template
index be6aa5594095..b6ca0b980239 100644
--- a/srcpkgs/python3-jupyter_client/template
+++ b/srcpkgs/python3-jupyter_client/template
@@ -1,8 +1,7 @@
 # Template file for 'python3-jupyter_client'
 pkgname=python3-jupyter_client
-# delay 6.2 until jupyter/jupyter_console#241 is fixed
-version=6.1.12
-revision=2
+version=7.1.1
+revision=1
 wrksrc="jupyter_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -13,7 +12,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_client"
 distfiles="${PYPI_SITE}/j/jupyter_client/jupyter_client-${version}.tar.gz"
-checksum=c4bca1d0846186ca8be97f4d2fa6d2bae889cce4892a167ffa1ba6bd1f73e782
+checksum=540ca35e57e83c5ece81abd9b781a57cba39a37c60a2a30c8c1b2f6663544343
 conflicts="python-jupyter_client<=5.2.4_2"
 # checks create a cycle with python3-jupyter_core and python3-ipython_ipykernel
 make_check=no

From 4d6f10c84f70089971fe7bc9d56375f0d210c4d0 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:06:12 +0100
Subject: [PATCH 07/12] python3-jupyter_core: update to 4.9.1

---
 srcpkgs/python3-jupyter_core/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_core/template b/srcpkgs/python3-jupyter_core/template
index d0fa364a6751..5f450d293d4f 100644
--- a/srcpkgs/python3-jupyter_core/template
+++ b/srcpkgs/python3-jupyter_core/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_core'
 pkgname=python3-jupyter_core
-version=4.7.1
-revision=2
+version=4.9.1
+revision=1
 wrksrc="jupyter_core-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter_core/jupyter_core-${version}.tar.gz"
-checksum=79025cb3225efcd36847d0840f3fc672c0abd7afd0de83ba8a1d3837619122b4
+checksum=dce8a7499da5a53ae3afd5a9f4b02e5df1d57250cf48f3ad79da23b4778cd6fa
 conflicts="python-jupyter_core<=4.4.0_3"
 # checks create a cycle with python3-jypter_client and python3-ipython_ipykernel
 make_check=no

From 3e62f4d8fa6e71ac578bcbefb8233680f674538d Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:07:34 +0100
Subject: [PATCH 08/12] python3-jupyter_notebook: update to 6.4.8

---
 srcpkgs/python3-jupyter_notebook/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_notebook/template b/srcpkgs/python3-jupyter_notebook/template
index ca9e1d43df21..f1ec68546fd9 100644
--- a/srcpkgs/python3-jupyter_notebook/template
+++ b/srcpkgs/python3-jupyter_notebook/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_notebook'
 pkgname=python3-jupyter_notebook
-version=6.3.0
-revision=2
+version=6.4.8
+revision=1
 wrksrc="notebook-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -15,7 +15,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org/"
 distfiles="${PYPI_SITE}/n/notebook/notebook-${version}.tar.gz"
-checksum=cbc9398d6c81473e9cdb891d2cae9c0d3718fca289dda6d26df5cb660fcadc7d
+checksum=1e985c9dc6f678bdfffb9dc657306b5469bfa62d73e03f74e8defbf76d284312
 conflicts="python-jupyter_notebook<=5.7.0_2"
 # Tests require unpackaged selenium
 make_check=no

From 5e6458b989c19d01f042695e6c5c162150b3572a Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:14:36 +0100
Subject: [PATCH 09/12] python3-paramiko: update to 2.9.2

---
 srcpkgs/python3-paramiko/template | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-paramiko/template b/srcpkgs/python3-paramiko/template
index cff1b3a2fb59..a11808886b73 100644
--- a/srcpkgs/python3-paramiko/template
+++ b/srcpkgs/python3-paramiko/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-paramiko'
 pkgname=python3-paramiko
-version=2.7.2
-revision=2
+version=2.9.2
+revision=1
 wrksrc="${pkgname#*-}-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,4 +11,6 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="LGPL-2.1-or-later"
 homepage="http://www.paramiko.org/"
 distfiles="${PYPI_SITE}/p/paramiko/paramiko-${version}.tar.gz"
-checksum=7f36f4ba2c0d81d219f4595e35f70d56cc94f9ac40a6acdf51d6ca210ce65035
+checksum=944a9e5dbdd413ab6c7951ea46b0ab40713235a9c4c5ca81cfe45c6f14fa677b
+# Testing via this command is deprecated
+make_check=no

From 28bf96d9d3201cab37597820a1ddf329e8591d34 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:16:02 +0100
Subject: [PATCH 10/12] python3-prometheus_client: update to 0.13.1

---
 srcpkgs/python3-prometheus_client/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-prometheus_client/template b/srcpkgs/python3-prometheus_client/template
index 82e4da1f3edd..739013270799 100644
--- a/srcpkgs/python3-prometheus_client/template
+++ b/srcpkgs/python3-prometheus_client/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-prometheus_client'
 pkgname=python3-prometheus_client
-version=0.9.0
-revision=2
+version=0.13.1
+revision=1
 wrksrc="prometheus_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,4 +12,4 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Apache-2.0"
 homepage="https://github.com/prometheus/client_python"
 distfiles="${PYPI_SITE}/p/prometheus_client/prometheus_client-${version}.tar.gz"
-checksum=9da7b32f02439d8c04f7777021c304ed51d9ec180604700c1ba72a4d44dceb03
+checksum=ada41b891b79fca5638bd5cfe149efa86512eaa55987893becd2c6d8d0a5dfc5

From f10d9a535b00ebe97325cc488f9e3a6358bfb5a9 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:17:21 +0100
Subject: [PATCH 11/12] python3-soupsieve: update to 2.3.1

---
 srcpkgs/python3-soupsieve/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-soupsieve/template b/srcpkgs/python3-soupsieve/template
index 14449f20c47f..06eb2b8b8895 100644
--- a/srcpkgs/python3-soupsieve/template
+++ b/srcpkgs/python3-soupsieve/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-soupsieve'
 pkgname=python3-soupsieve
-version=1.9.5
-revision=6
+version=2.3.1
+revision=1
 wrksrc="soupsieve-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,7 +12,7 @@ maintainer="Aluísio Augusto Silva Gonçalves <aluisio@aasg.name>"
 license="MIT"
 homepage="https://facelessuser.github.io/soupsieve/"
 distfiles="${PYPI_SITE}/s/soupsieve/soupsieve-${version}.tar.gz"
-checksum=e2c1c5dee4a1c36bcb790e0fabd5492d874b8ebd4617622c4f6a731701060dda
+checksum=b8d49b1cd4f037c7082a9683dfa1801aa2597fb11c3a1155b7a5b94829b4f1f9
 
 post_install() {
 	vlicense LICENSE.md

From 3d9915ef63777622a1df32e49fc094e9eb86e434 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:20:35 +0100
Subject: [PATCH 12/12] python3-terminado: update to 0.13.0

---
 srcpkgs/python3-terminado/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-terminado/template b/srcpkgs/python3-terminado/template
index 28c65c82ba99..e299a6ca8c4f 100644
--- a/srcpkgs/python3-terminado/template
+++ b/srcpkgs/python3-terminado/template
@@ -1,10 +1,10 @@
 # Template file for 'python3-terminado'
 pkgname=python3-terminado
-version=0.9.4
-revision=2
+version=0.13.0
+revision=1
 wrksrc="terminado-${version}"
 build_style=python3-module
-hostmakedepends="python3-setuptools"
+hostmakedepends="python3-setuptools python3-tornado"
 depends="python3-ptyprocess python3-tornado"
 checkdepends="python3-pytest $depends"
 short_desc="Terminals served to term.js using Tornado websockets (Python3)"
@@ -12,7 +12,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/takluyver/terminado"
 distfiles="${PYPI_SITE}/t/terminado/terminado-${version}.tar.gz"
-checksum=9a7dbcfbc2778830eeb70261bf7aa9d98a3eac8631a3afe3febeb57c12f798be
+checksum=713531ccb5db7d4f544651f14050da79809030f00d1afa21462088cf32fb143a
 
 post_install() {
 	vlicense LICENSE

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (5 preceding siblings ...)
  2022-02-03 13:58 ` [PR PATCH] [Updated] " dkwo
@ 2022-02-03 14:07 ` dkwo
  2022-02-03 14:30 ` ahesford
                   ` (43 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-02-03 14:07 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 181 bytes --]

New comment by dkwo on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#issuecomment-1029025367

Comment:
Ok, works fine after adding a few depends.

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (6 preceding siblings ...)
  2022-02-03 14:07 ` dkwo
@ 2022-02-03 14:30 ` ahesford
  2022-02-03 15:27 ` dkwo
                   ` (42 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: ahesford @ 2022-02-03 14:30 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 291 bytes --]

New comment by ahesford on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#issuecomment-1029047760

Comment:
Not me; I just undertook to update some of the jupyter packages one day and caught some failure when I installed and launched one of the components.

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (7 preceding siblings ...)
  2022-02-03 14:30 ` ahesford
@ 2022-02-03 15:27 ` dkwo
  2022-02-03 15:27 ` [PR PATCH] [Updated] " dkwo
                   ` (41 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-02-03 15:27 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 456 bytes --]

New comment by dkwo on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#issuecomment-1029105650

Comment:
It seems that `jupyter_console`, not directly touched here, is broken both before and after the updates proposed here.
I included a patch already merged upstream and one pr'd there that solve the basic use case. 
I think it's better to update the rest, and don't wait for an already broken package to fix its issue.

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR PATCH] [Updated] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (8 preceding siblings ...)
  2022-02-03 15:27 ` dkwo
@ 2022-02-03 15:27 ` dkwo
  2022-02-13 10:35 ` dkwo
                   ` (40 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-02-03 15:27 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 397 bytes --]

There is an updated pull request by dkwo against master on the void-packages repository

https://github.com/dkwo/void-packages pytupd
https://github.com/void-linux/void-packages/pull/35376

update few python3 packages
@ahesford Could you check whether the new jupyter client solves the issue with console?

A patch file from https://github.com/void-linux/void-packages/pull/35376.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-pytupd-35376.patch --]
[-- Type: text/x-diff, Size: 27784 bytes --]

From 34f06c1e64388da8db1c77ac0639f40aebe29f7c Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:50:20 +0100
Subject: [PATCH 01/13] python3-bleach: update to 4.1.0

---
 srcpkgs/python3-bleach/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-bleach/template b/srcpkgs/python3-bleach/template
index 21fec4f4b37c..2b8af3b8fbba 100644
--- a/srcpkgs/python3-bleach/template
+++ b/srcpkgs/python3-bleach/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-bleach'
 pkgname=python3-bleach
-version=3.3.0
-revision=2
+version=4.1.0
+revision=1
 wrksrc="bleach-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -13,4 +13,4 @@ license="Apache-2.0"
 homepage="https://github.com/mozilla/bleach"
 changelog="https://raw.githubusercontent.com/mozilla/bleach/master/CHANGES"
 distfiles="${PYPI_SITE}/b/bleach/bleach-${version}.tar.gz"
-checksum=98b3170739e5e83dd9dc19633f074727ad848cbedb6026708c8ac2d3b697a433
+checksum=0900d8b37eba61a802ee40ac0061f8c2b5dee29c1927dd1d233e075ebf5a71da

From 7e55938507f5c6a6434afe922c235c4f134ffed2 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:51:55 +0100
Subject: [PATCH 02/13] python3-defusedxml: update to 0.7.1

---
 srcpkgs/python3-defusedxml/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-defusedxml/template b/srcpkgs/python3-defusedxml/template
index 06bdd57a3526..90dc454d120d 100644
--- a/srcpkgs/python3-defusedxml/template
+++ b/srcpkgs/python3-defusedxml/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-defusedxml'
 pkgname=python3-defusedxml
-version=0.6.0
-revision=5
+version=0.7.1
+revision=1
 wrksrc="defusedxml-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Python-2.0"
 homepage="https://github.com/tiran/defusedxml"
 distfiles="${PYPI_SITE}/d/defusedxml/defusedxml-${version}.tar.gz"
-checksum=f684034d135af4c6cbb949b8a4d2ed61634515257a67299e5f940fbaa34377f5
+checksum=1bb3032db185915b62d7c6209c5a8792be6a32ab2fedacc84e01b52c51aa3e69
 
 post_install() {
 	vlicense LICENSE

From 0c1d6b7a93294ba7db8578e94de35586daf39288 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:54:30 +0100
Subject: [PATCH 03/13] python3-httplib2: update to 0.20.4

---
 srcpkgs/python3-httplib2/template | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-httplib2/template b/srcpkgs/python3-httplib2/template
index d0c39a478622..ac898ef2327f 100644
--- a/srcpkgs/python3-httplib2/template
+++ b/srcpkgs/python3-httplib2/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-httplib2'
 pkgname=python3-httplib2
-version=0.18.1
-revision=3
+version=0.20.4
+revision=1
 create_wrksrc=yes
 build_wrksrc="httplib2-${version}"
 build_style=python3-module
@@ -14,8 +14,10 @@ homepage="https://github.com/httplib2/httplib2"
 changelog="https://raw.githubusercontent.com/httplib2/httplib2/master/CHANGELOG"
 distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz
  https://raw.githubusercontent.com/httplib2/httplib2/master/LICENSE>LICENSE.txt"
-checksum="8af66c1c52c7ffe1aa5dc4bcd7c769885254b0756e6e69f953c7f0ab49a70ba3
+checksum="58a98e45b4b1a48273073f905d2961666ecf0fbac4250ea5b47aef259eb5c585
  589eec38f72df2be203711d3b8cbece9b908c5e7ff00bc3cab7f63bae9e366b4"
+# Testing via this command is deprecated
+make_check=no
 
 post_install() {
 	# use system ca certificates

From cce657e3942afed11e0650a3ada8dae75683bbed Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:55:53 +0100
Subject: [PATCH 04/13] python3-ipython_ipykernel: update to 6.8.0

---
 srcpkgs/python3-ipython_ipykernel/template | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-ipython_ipykernel/template b/srcpkgs/python3-ipython_ipykernel/template
index f00e0a3f1a0c..b75796ca0262 100644
--- a/srcpkgs/python3-ipython_ipykernel/template
+++ b/srcpkgs/python3-ipython_ipykernel/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-ipython_ipykernel'
 pkgname=python3-ipython_ipykernel
-version=5.5.4
-revision=2
+version=6.8.0
+revision=1
 wrksrc="ipykernel-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools python3-ipython
- python3-jupyter_client python3-traitlets python3-tornado"
-depends="python3-ipython python3-traitlets python3-jupyter_client python3-tornado"
+ python3-jupyter_client python3-traitlets python3-tornado python3-entrypoints"
+depends="python3-ipython python3-traitlets python3-jupyter_client
+ python3-tornado python3-entrypoints python3-nest_asyncio"
 short_desc="IPython kernel for Jupyter (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/ipykernel"
 distfiles="${PYPI_SITE}/i/ipykernel/ipykernel-${version}.tar.gz"
-checksum=1ce0e83672cc3bfdc1ffb5603e1d77ab125f24b41abc4612e22bfb3e994c0db2
+checksum=67d316d527eca24e3ded45a2b38689615bcda1aa520a11af0accdcea7152c18a
 # checks create a cycle with python3-jupyter_core and python3-jupyter_client
 make_check=no
 

From e3dd901cd5090300ccd37ef373dee63e61e15527 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:57:38 +0100
Subject: [PATCH 05/13] python3-jsonschema: update to 4.4.0

---
 srcpkgs/python3-jsonschema/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-jsonschema/template b/srcpkgs/python3-jsonschema/template
index 82f45e037865..120392ad1be3 100644
--- a/srcpkgs/python3-jsonschema/template
+++ b/srcpkgs/python3-jsonschema/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-jsonschema'
 pkgname=python3-jsonschema
-version=4.2.1
+version=4.4.0
 revision=1
 wrksrc="jsonschema-${version}"
 build_style=python3-pep517
@@ -14,7 +14,7 @@ license="MIT"
 homepage="https://github.com/Julian/jsonschema"
 changelog="https://raw.githubusercontent.com/Julian/jsonschema/master/CHANGELOG.rst"
 distfiles="${PYPI_SITE}/j/jsonschema/jsonschema-${version}.tar.gz"
-checksum=390713469ae64b8a58698bb3cbc3859abe6925b565a973f87323ef21b09a27a8
+checksum=636694eb41b3535ed608fe04129f26542b59ed99808b4f688aa32dcf55317a83
 
 post_install() {
 	vlicense COPYING LICENSE

From 84d0b869d7f3a15d160ba339f13f348321eb5d48 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:04:52 +0100
Subject: [PATCH 06/13] python3-jupyter_client: update to 7.1.2

---
 srcpkgs/python3-jupyter_client/template | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-jupyter_client/template b/srcpkgs/python3-jupyter_client/template
index be6aa5594095..b6ca0b980239 100644
--- a/srcpkgs/python3-jupyter_client/template
+++ b/srcpkgs/python3-jupyter_client/template
@@ -1,8 +1,7 @@
 # Template file for 'python3-jupyter_client'
 pkgname=python3-jupyter_client
-# delay 6.2 until jupyter/jupyter_console#241 is fixed
-version=6.1.12
-revision=2
+version=7.1.1
+revision=1
 wrksrc="jupyter_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -13,7 +12,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_client"
 distfiles="${PYPI_SITE}/j/jupyter_client/jupyter_client-${version}.tar.gz"
-checksum=c4bca1d0846186ca8be97f4d2fa6d2bae889cce4892a167ffa1ba6bd1f73e782
+checksum=540ca35e57e83c5ece81abd9b781a57cba39a37c60a2a30c8c1b2f6663544343
 conflicts="python-jupyter_client<=5.2.4_2"
 # checks create a cycle with python3-jupyter_core and python3-ipython_ipykernel
 make_check=no

From 4d6f10c84f70089971fe7bc9d56375f0d210c4d0 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:06:12 +0100
Subject: [PATCH 07/13] python3-jupyter_core: update to 4.9.1

---
 srcpkgs/python3-jupyter_core/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_core/template b/srcpkgs/python3-jupyter_core/template
index d0fa364a6751..5f450d293d4f 100644
--- a/srcpkgs/python3-jupyter_core/template
+++ b/srcpkgs/python3-jupyter_core/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_core'
 pkgname=python3-jupyter_core
-version=4.7.1
-revision=2
+version=4.9.1
+revision=1
 wrksrc="jupyter_core-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter_core/jupyter_core-${version}.tar.gz"
-checksum=79025cb3225efcd36847d0840f3fc672c0abd7afd0de83ba8a1d3837619122b4
+checksum=dce8a7499da5a53ae3afd5a9f4b02e5df1d57250cf48f3ad79da23b4778cd6fa
 conflicts="python-jupyter_core<=4.4.0_3"
 # checks create a cycle with python3-jypter_client and python3-ipython_ipykernel
 make_check=no

From 3e62f4d8fa6e71ac578bcbefb8233680f674538d Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:07:34 +0100
Subject: [PATCH 08/13] python3-jupyter_notebook: update to 6.4.8

---
 srcpkgs/python3-jupyter_notebook/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_notebook/template b/srcpkgs/python3-jupyter_notebook/template
index ca9e1d43df21..f1ec68546fd9 100644
--- a/srcpkgs/python3-jupyter_notebook/template
+++ b/srcpkgs/python3-jupyter_notebook/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_notebook'
 pkgname=python3-jupyter_notebook
-version=6.3.0
-revision=2
+version=6.4.8
+revision=1
 wrksrc="notebook-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -15,7 +15,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org/"
 distfiles="${PYPI_SITE}/n/notebook/notebook-${version}.tar.gz"
-checksum=cbc9398d6c81473e9cdb891d2cae9c0d3718fca289dda6d26df5cb660fcadc7d
+checksum=1e985c9dc6f678bdfffb9dc657306b5469bfa62d73e03f74e8defbf76d284312
 conflicts="python-jupyter_notebook<=5.7.0_2"
 # Tests require unpackaged selenium
 make_check=no

From 5e6458b989c19d01f042695e6c5c162150b3572a Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:14:36 +0100
Subject: [PATCH 09/13] python3-paramiko: update to 2.9.2

---
 srcpkgs/python3-paramiko/template | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-paramiko/template b/srcpkgs/python3-paramiko/template
index cff1b3a2fb59..a11808886b73 100644
--- a/srcpkgs/python3-paramiko/template
+++ b/srcpkgs/python3-paramiko/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-paramiko'
 pkgname=python3-paramiko
-version=2.7.2
-revision=2
+version=2.9.2
+revision=1
 wrksrc="${pkgname#*-}-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,4 +11,6 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="LGPL-2.1-or-later"
 homepage="http://www.paramiko.org/"
 distfiles="${PYPI_SITE}/p/paramiko/paramiko-${version}.tar.gz"
-checksum=7f36f4ba2c0d81d219f4595e35f70d56cc94f9ac40a6acdf51d6ca210ce65035
+checksum=944a9e5dbdd413ab6c7951ea46b0ab40713235a9c4c5ca81cfe45c6f14fa677b
+# Testing via this command is deprecated
+make_check=no

From 28bf96d9d3201cab37597820a1ddf329e8591d34 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:16:02 +0100
Subject: [PATCH 10/13] python3-prometheus_client: update to 0.13.1

---
 srcpkgs/python3-prometheus_client/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-prometheus_client/template b/srcpkgs/python3-prometheus_client/template
index 82e4da1f3edd..739013270799 100644
--- a/srcpkgs/python3-prometheus_client/template
+++ b/srcpkgs/python3-prometheus_client/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-prometheus_client'
 pkgname=python3-prometheus_client
-version=0.9.0
-revision=2
+version=0.13.1
+revision=1
 wrksrc="prometheus_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,4 +12,4 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Apache-2.0"
 homepage="https://github.com/prometheus/client_python"
 distfiles="${PYPI_SITE}/p/prometheus_client/prometheus_client-${version}.tar.gz"
-checksum=9da7b32f02439d8c04f7777021c304ed51d9ec180604700c1ba72a4d44dceb03
+checksum=ada41b891b79fca5638bd5cfe149efa86512eaa55987893becd2c6d8d0a5dfc5

From f10d9a535b00ebe97325cc488f9e3a6358bfb5a9 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:17:21 +0100
Subject: [PATCH 11/13] python3-soupsieve: update to 2.3.1

---
 srcpkgs/python3-soupsieve/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-soupsieve/template b/srcpkgs/python3-soupsieve/template
index 14449f20c47f..06eb2b8b8895 100644
--- a/srcpkgs/python3-soupsieve/template
+++ b/srcpkgs/python3-soupsieve/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-soupsieve'
 pkgname=python3-soupsieve
-version=1.9.5
-revision=6
+version=2.3.1
+revision=1
 wrksrc="soupsieve-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,7 +12,7 @@ maintainer="Aluísio Augusto Silva Gonçalves <aluisio@aasg.name>"
 license="MIT"
 homepage="https://facelessuser.github.io/soupsieve/"
 distfiles="${PYPI_SITE}/s/soupsieve/soupsieve-${version}.tar.gz"
-checksum=e2c1c5dee4a1c36bcb790e0fabd5492d874b8ebd4617622c4f6a731701060dda
+checksum=b8d49b1cd4f037c7082a9683dfa1801aa2597fb11c3a1155b7a5b94829b4f1f9
 
 post_install() {
 	vlicense LICENSE.md

From 3d9915ef63777622a1df32e49fc094e9eb86e434 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:20:35 +0100
Subject: [PATCH 12/13] python3-terminado: update to 0.13.0

---
 srcpkgs/python3-terminado/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-terminado/template b/srcpkgs/python3-terminado/template
index 28c65c82ba99..e299a6ca8c4f 100644
--- a/srcpkgs/python3-terminado/template
+++ b/srcpkgs/python3-terminado/template
@@ -1,10 +1,10 @@
 # Template file for 'python3-terminado'
 pkgname=python3-terminado
-version=0.9.4
-revision=2
+version=0.13.0
+revision=1
 wrksrc="terminado-${version}"
 build_style=python3-module
-hostmakedepends="python3-setuptools"
+hostmakedepends="python3-setuptools python3-tornado"
 depends="python3-ptyprocess python3-tornado"
 checkdepends="python3-pytest $depends"
 short_desc="Terminals served to term.js using Tornado websockets (Python3)"
@@ -12,7 +12,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/takluyver/terminado"
 distfiles="${PYPI_SITE}/t/terminado/terminado-${version}.tar.gz"
-checksum=9a7dbcfbc2778830eeb70261bf7aa9d98a3eac8631a3afe3febeb57c12f798be
+checksum=713531ccb5db7d4f544651f14050da79809030f00d1afa21462088cf32fb143a
 
 post_install() {
 	vlicense LICENSE

From 5c4dde5a4f207a74e6ec87b0371f9120eb1c435b Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 16:27:01 +0100
Subject: [PATCH 13/13] python3-jupyter_console: add patches

---
 .../patches/pr258.patch                       |  22 ++
 .../patches/upstream1.patch                   | 252 ++++++++++++++++++
 srcpkgs/python3-jupyter_console/template      |   2 +-
 3 files changed, 275 insertions(+), 1 deletion(-)
 create mode 100644 srcpkgs/python3-jupyter_console/patches/pr258.patch
 create mode 100644 srcpkgs/python3-jupyter_console/patches/upstream1.patch

diff --git a/srcpkgs/python3-jupyter_console/patches/pr258.patch b/srcpkgs/python3-jupyter_console/patches/pr258.patch
new file mode 100644
index 000000000000..7f3c6188c78e
--- /dev/null
+++ b/srcpkgs/python3-jupyter_console/patches/pr258.patch
@@ -0,0 +1,22 @@
+From 7a68e9f630c5484159fddce1bb5718e26d592f32 Mon Sep 17 00:00:00 2001
+From: Jade Lovelace <software@lfcode.ca>
+Date: Sat, 1 Jan 2022 19:11:57 -0800
+Subject: [PATCH] Remove loop=loop in asyncio.wait call. Fix #245
+
+---
+ jupyter_console/ptshell.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/jupyter_console/ptshell.py b/jupyter_console/ptshell.py
+index 31f424d..08f0342 100644
+--- a/jupyter_console/ptshell.py
++++ b/jupyter_console/ptshell.py
+@@ -673,7 +673,7 @@ def mainloop(self):
+                     # wish to include external content
+                     tasks.append(self.handle_external_iopub(loop=loop))
+ 
+-                main_task = asyncio.wait(tasks, loop=loop, return_when=asyncio.FIRST_COMPLETED)
++                main_task = asyncio.wait(tasks, return_when=asyncio.FIRST_COMPLETED)
+                 _, pending = loop.run_until_complete(main_task)
+ 
+                 for task in pending:
diff --git a/srcpkgs/python3-jupyter_console/patches/upstream1.patch b/srcpkgs/python3-jupyter_console/patches/upstream1.patch
new file mode 100644
index 000000000000..97cfb0ce3c8b
--- /dev/null
+++ b/srcpkgs/python3-jupyter_console/patches/upstream1.patch
@@ -0,0 +1,252 @@
+From 0c7aca07d45ff009327599f6985c6a8ebbd98987 Mon Sep 17 00:00:00 2001
+From: David Brochart <david.brochart@gmail.com>
+Date: Tue, 1 Jun 2021 09:41:11 +0200
+Subject: [PATCH 1/5] Wrap jupyter_client's async functions with run_sync
+
+---
+ .github/workflows/python-package.yml |  1 +
+ jupyter_console/ptshell.py           | 16 +++++++++-------
+ 2 files changed, 10 insertions(+), 7 deletions(-)
+
+diff --git a/.github/workflows/python-package.yml b/.github/workflows/python-package.yml
+index eb8048e..fd5fcd0 100644
+--- a/.github/workflows/python-package.yml
++++ b/.github/workflows/python-package.yml
+@@ -29,6 +29,7 @@ jobs:
+         pip install pytest pytest-cov
+         pip install .
+         python -m ipykernel.kernelspec --user
++        pip install https://github.com/jupyter/jupyter_client/archive/master.zip
+     - name: Test with pytest
+       run: |
+         pytest --cov jupyter_console
+diff --git a/jupyter_console/ptshell.py b/jupyter_console/ptshell.py
+index a9daeed..d6dc1e7 100644
+--- a/jupyter_console/ptshell.py
++++ b/jupyter_console/ptshell.py
+@@ -76,6 +76,8 @@
+ from pygments.util import ClassNotFound
+ from pygments.token import Token
+ 
++from jupyter_client.utils import run_sync
++
+ 
+ def ask_yes_no(prompt, default=None, interrupt=None):
+     """Asks a question and returns a boolean (y/n) answer.
+@@ -705,8 +707,8 @@ def run_cell(self, cell, store_history=True):
+             return
+ 
+         # flush stale replies, which could have been ignored, due to missed heartbeats
+-        while self.client.shell_channel.msg_ready():
+-            self.client.shell_channel.get_msg()
++        while run_sync(self.client.shell_channel.msg_ready)():
++            run_sync(self.client.shell_channel.get_msg)()
+         # execute takes 'hidden', which is the inverse of store_hist
+         msg_id = self.client.execute(cell, not store_history)
+ 
+@@ -739,7 +741,7 @@ def run_cell(self, cell, store_history=True):
+     #-----------------
+ 
+     def handle_execute_reply(self, msg_id, timeout=None):
+-        msg = self.client.shell_channel.get_msg(block=False, timeout=timeout)
++        msg = run_sync(self.client.shell_channel.get_msg)(block=False, timeout=timeout)
+         if msg["parent_header"].get("msg_id", None) == msg_id:
+ 
+             self.handle_iopub(msg_id)
+@@ -778,7 +780,7 @@ def handle_is_complete_reply(self, msg_id, timeout=None):
+         ## Get the is_complete response:
+         msg = None
+         try:
+-            msg = self.client.shell_channel.get_msg(block=True, timeout=timeout)
++            msg = run_sync(self.client.shell_channel.get_msg)(block=True, timeout=timeout)
+         except Empty:
+             warn('The kernel did not respond to an is_complete_request. '
+                  'Setting `use_kernel_is_complete` to False.')
+@@ -849,8 +851,8 @@ def handle_iopub(self, msg_id=''):
+ 
+            It only displays output that is caused by this session.
+         """
+-        while self.client.iopub_channel.msg_ready():
+-            sub_msg = self.client.iopub_channel.get_msg()
++        while run_sync(self.client.iopub_channel.msg_ready)():
++            sub_msg = run_sync(self.client.iopub_channel.get_msg)()
+             msg_type = sub_msg['header']['msg_type']
+ 
+             # Update execution_count in case it changed in another session
+@@ -1003,7 +1005,7 @@ def handle_image_callable(self, data, mime):
+     def handle_input_request(self, msg_id, timeout=0.1):
+         """ Method to capture raw_input
+         """
+-        req = self.client.stdin_channel.get_msg(timeout=timeout)
++        req = run_sync(self.client.stdin_channel.get_msg)(timeout=timeout)
+         # in case any iopub came while we were waiting:
+         self.handle_iopub(msg_id)
+         if msg_id == req["parent_header"].get("msg_id"):
+
+From 84a4c63f7c2b700357f5e5f730209dc4fc897c24 Mon Sep 17 00:00:00 2001
+From: David Brochart <david.brochart@gmail.com>
+Date: Wed, 2 Jun 2021 09:45:47 +0200
+Subject: [PATCH 2/5] Use run_sync only from jupyter_client 7.0+
+
+---
+ jupyter_console/completer.py | 12 +++++++++++-
+ jupyter_console/ptshell.py   | 13 ++++++++++---
+ 2 files changed, 21 insertions(+), 4 deletions(-)
+
+diff --git a/jupyter_console/completer.py b/jupyter_console/completer.py
+index d0b7b9a..4b845e3 100644
+--- a/jupyter_console/completer.py
++++ b/jupyter_console/completer.py
+@@ -7,6 +7,16 @@
+ from traitlets.config import Configurable
+ from traitlets import Float
+ 
++import jupyter_client
++
++
++# jupyter_client 7.0+ has async channel methods that we expect to be sync here
++if jupyter_client._version.version_info[0] >= 7:
++    from jupyter_client.utils import run_sync
++else:
++    run_sync = lambda x: x
++
++
+ class ZMQCompleter(Configurable):
+     """Client-side completion machinery.
+ 
+@@ -31,7 +41,7 @@ def complete_request(self, code, cursor_pos):
+             cursor_pos=cursor_pos,
+         )
+     
+-        msg = self.client.shell_channel.get_msg(timeout=self.timeout)
++        msg = run_sync(self.client.shell_channel.get_msg)(timeout=self.timeout)
+         if msg['parent_header']['msg_id'] == msg_id:
+             return msg['content']
+ 
+diff --git a/jupyter_console/ptshell.py b/jupyter_console/ptshell.py
+index d6dc1e7..4608992 100644
+--- a/jupyter_console/ptshell.py
++++ b/jupyter_console/ptshell.py
+@@ -76,7 +76,14 @@
+ from pygments.util import ClassNotFound
+ from pygments.token import Token
+ 
+-from jupyter_client.utils import run_sync
++import jupyter_client
++
++
++# jupyter_client 7.0+ has async channel methods that we expect to be sync here
++if jupyter_client._version.version_info[0] >= 7:
++    from jupyter_client.utils import run_sync
++else:
++    run_sync = lambda x: x
+ 
+ 
+ def ask_yes_no(prompt, default=None, interrupt=None):
+@@ -1034,6 +1041,6 @@ def double_int(sig, frame):
+ 
+             # only send stdin reply if there *was not* another request
+             # or execution finished while we were reading.
+-            if not (self.client.stdin_channel.msg_ready() or
+-                    self.client.shell_channel.msg_ready()):
++            if not (run_sync(self.client.stdin_channel.msg_ready)() or
++                    run_sync(self.client.shell_channel.msg_ready)()):
+                 self.client.input(raw_data)
+
+From 71bdcb5198ac7d79b246029965d945b5e726a6ed Mon Sep 17 00:00:00 2001
+From: David Brochart <david.brochart@gmail.com>
+Date: Wed, 2 Jun 2021 09:55:03 +0200
+Subject: [PATCH 3/5] Don't install jupyter_client master
+
+---
+ .github/workflows/python-package.yml | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/.github/workflows/python-package.yml b/.github/workflows/python-package.yml
+index fd5fcd0..eb8048e 100644
+--- a/.github/workflows/python-package.yml
++++ b/.github/workflows/python-package.yml
+@@ -29,7 +29,6 @@ jobs:
+         pip install pytest pytest-cov
+         pip install .
+         python -m ipykernel.kernelspec --user
+-        pip install https://github.com/jupyter/jupyter_client/archive/master.zip
+     - name: Test with pytest
+       run: |
+         pytest --cov jupyter_console
+
+From 6620bdbecd66196721f9765a13659bdc26e28740 Mon Sep 17 00:00:00 2001
+From: David Brochart <david.brochart@gmail.com>
+Date: Wed, 15 Sep 2021 08:40:06 +0200
+Subject: [PATCH 4/5] Update jupyter_console/completer.py
+
+Co-authored-by: Matthias Bussonnier <bussonniermatthias@gmail.com>
+---
+ jupyter_console/completer.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/jupyter_console/completer.py b/jupyter_console/completer.py
+index 4b845e3..6a38a6a 100644
+--- a/jupyter_console/completer.py
++++ b/jupyter_console/completer.py
+@@ -11,7 +11,7 @@
+ 
+ 
+ # jupyter_client 7.0+ has async channel methods that we expect to be sync here
+-if jupyter_client._version.version_info[0] >= 7:
++if jupyter_client.version_info >= (7,):
+     from jupyter_client.utils import run_sync
+ else:
+     run_sync = lambda x: x
+
+From 7f2dc911b41df9ed7f3cdc09a6832451cbe69d15 Mon Sep 17 00:00:00 2001
+From: David Brochart <david.brochart@gmail.com>
+Date: Tue, 9 Nov 2021 14:27:16 +0100
+Subject: [PATCH 5/5] Drop block kwarg from get_msg() for jupyter_client>=7.0
+
+---
+ jupyter_console/ptshell.py | 13 +++++++++++--
+ 1 file changed, 11 insertions(+), 2 deletions(-)
+
+diff --git a/jupyter_console/ptshell.py b/jupyter_console/ptshell.py
+index 4608992..31f424d 100644
+--- a/jupyter_console/ptshell.py
++++ b/jupyter_console/ptshell.py
+@@ -80,10 +80,13 @@
+ 
+ 
+ # jupyter_client 7.0+ has async channel methods that we expect to be sync here
++# also, `block` was removed from `get_msg()`
+ if jupyter_client._version.version_info[0] >= 7:
+     from jupyter_client.utils import run_sync
++    JUPYTER_CLIENT_7 = True
+ else:
+     run_sync = lambda x: x
++    JUPYTER_CLIENT_7 = False
+ 
+ 
+ def ask_yes_no(prompt, default=None, interrupt=None):
+@@ -748,7 +751,10 @@ def run_cell(self, cell, store_history=True):
+     #-----------------
+ 
+     def handle_execute_reply(self, msg_id, timeout=None):
+-        msg = run_sync(self.client.shell_channel.get_msg)(block=False, timeout=timeout)
++        kwargs = {"timeout": timeout}
++        if not JUPYTER_CLIENT_7:
++            kwargs["block"] = False
++        msg = run_sync(self.client.shell_channel.get_msg)(**kwargs)
+         if msg["parent_header"].get("msg_id", None) == msg_id:
+ 
+             self.handle_iopub(msg_id)
+@@ -787,7 +793,10 @@ def handle_is_complete_reply(self, msg_id, timeout=None):
+         ## Get the is_complete response:
+         msg = None
+         try:
+-            msg = run_sync(self.client.shell_channel.get_msg)(block=True, timeout=timeout)
++            kwargs = {"timeout": timeout}
++            if not JUPYTER_CLIENT_7:
++                kwargs["block"] = True
++            msg = run_sync(self.client.shell_channel.get_msg)(**kwargs)
+         except Empty:
+             warn('The kernel did not respond to an is_complete_request. '
+                  'Setting `use_kernel_is_complete` to False.')
diff --git a/srcpkgs/python3-jupyter_console/template b/srcpkgs/python3-jupyter_console/template
index 3124f3854a19..2971b9fe92c5 100644
--- a/srcpkgs/python3-jupyter_console/template
+++ b/srcpkgs/python3-jupyter_console/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_console'
 pkgname=python3-jupyter_console
 version=6.4.0
-revision=2
+revision=3
 wrksrc="jupyter_console-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR PATCH] [Updated] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (9 preceding siblings ...)
  2022-02-03 15:27 ` [PR PATCH] [Updated] " dkwo
@ 2022-02-13 10:35 ` dkwo
  2022-02-13 10:46 ` dkwo
                   ` (39 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-02-13 10:35 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 397 bytes --]

There is an updated pull request by dkwo against master on the void-packages repository

https://github.com/dkwo/void-packages pytupd
https://github.com/void-linux/void-packages/pull/35376

update few python3 packages
@ahesford Could you check whether the new jupyter client solves the issue with console?

A patch file from https://github.com/void-linux/void-packages/pull/35376.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-pytupd-35376.patch --]
[-- Type: text/x-diff, Size: 30056 bytes --]

From b6ad23b80972c287b53fd72055509ca7abc33bfb Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:50:20 +0100
Subject: [PATCH 01/15] python3-bleach: update to 4.1.0

---
 srcpkgs/python3-bleach/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-bleach/template b/srcpkgs/python3-bleach/template
index 21fec4f4b37c..2b8af3b8fbba 100644
--- a/srcpkgs/python3-bleach/template
+++ b/srcpkgs/python3-bleach/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-bleach'
 pkgname=python3-bleach
-version=3.3.0
-revision=2
+version=4.1.0
+revision=1
 wrksrc="bleach-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -13,4 +13,4 @@ license="Apache-2.0"
 homepage="https://github.com/mozilla/bleach"
 changelog="https://raw.githubusercontent.com/mozilla/bleach/master/CHANGES"
 distfiles="${PYPI_SITE}/b/bleach/bleach-${version}.tar.gz"
-checksum=98b3170739e5e83dd9dc19633f074727ad848cbedb6026708c8ac2d3b697a433
+checksum=0900d8b37eba61a802ee40ac0061f8c2b5dee29c1927dd1d233e075ebf5a71da

From a692f360b3e110c8c54ef89038738e6e4f611832 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:51:55 +0100
Subject: [PATCH 02/15] python3-defusedxml: update to 0.7.1

---
 srcpkgs/python3-defusedxml/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-defusedxml/template b/srcpkgs/python3-defusedxml/template
index 06bdd57a3526..90dc454d120d 100644
--- a/srcpkgs/python3-defusedxml/template
+++ b/srcpkgs/python3-defusedxml/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-defusedxml'
 pkgname=python3-defusedxml
-version=0.6.0
-revision=5
+version=0.7.1
+revision=1
 wrksrc="defusedxml-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Python-2.0"
 homepage="https://github.com/tiran/defusedxml"
 distfiles="${PYPI_SITE}/d/defusedxml/defusedxml-${version}.tar.gz"
-checksum=f684034d135af4c6cbb949b8a4d2ed61634515257a67299e5f940fbaa34377f5
+checksum=1bb3032db185915b62d7c6209c5a8792be6a32ab2fedacc84e01b52c51aa3e69
 
 post_install() {
 	vlicense LICENSE

From 46bdd26800c3fb95fcc0eadb6477e98ceac3e4ae Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:54:30 +0100
Subject: [PATCH 03/15] python3-httplib2: update to 0.20.4

---
 srcpkgs/python3-httplib2/template | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-httplib2/template b/srcpkgs/python3-httplib2/template
index d0c39a478622..ac898ef2327f 100644
--- a/srcpkgs/python3-httplib2/template
+++ b/srcpkgs/python3-httplib2/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-httplib2'
 pkgname=python3-httplib2
-version=0.18.1
-revision=3
+version=0.20.4
+revision=1
 create_wrksrc=yes
 build_wrksrc="httplib2-${version}"
 build_style=python3-module
@@ -14,8 +14,10 @@ homepage="https://github.com/httplib2/httplib2"
 changelog="https://raw.githubusercontent.com/httplib2/httplib2/master/CHANGELOG"
 distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz
  https://raw.githubusercontent.com/httplib2/httplib2/master/LICENSE>LICENSE.txt"
-checksum="8af66c1c52c7ffe1aa5dc4bcd7c769885254b0756e6e69f953c7f0ab49a70ba3
+checksum="58a98e45b4b1a48273073f905d2961666ecf0fbac4250ea5b47aef259eb5c585
  589eec38f72df2be203711d3b8cbece9b908c5e7ff00bc3cab7f63bae9e366b4"
+# Testing via this command is deprecated
+make_check=no
 
 post_install() {
 	# use system ca certificates

From 753897708a7a56ee1c66cc8a0033122d769ee480 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:55:53 +0100
Subject: [PATCH 04/15] python3-ipython_ipykernel: update to 6.8.0

---
 srcpkgs/python3-ipython_ipykernel/template | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-ipython_ipykernel/template b/srcpkgs/python3-ipython_ipykernel/template
index f00e0a3f1a0c..b75796ca0262 100644
--- a/srcpkgs/python3-ipython_ipykernel/template
+++ b/srcpkgs/python3-ipython_ipykernel/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-ipython_ipykernel'
 pkgname=python3-ipython_ipykernel
-version=5.5.4
-revision=2
+version=6.8.0
+revision=1
 wrksrc="ipykernel-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools python3-ipython
- python3-jupyter_client python3-traitlets python3-tornado"
-depends="python3-ipython python3-traitlets python3-jupyter_client python3-tornado"
+ python3-jupyter_client python3-traitlets python3-tornado python3-entrypoints"
+depends="python3-ipython python3-traitlets python3-jupyter_client
+ python3-tornado python3-entrypoints python3-nest_asyncio"
 short_desc="IPython kernel for Jupyter (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/ipykernel"
 distfiles="${PYPI_SITE}/i/ipykernel/ipykernel-${version}.tar.gz"
-checksum=1ce0e83672cc3bfdc1ffb5603e1d77ab125f24b41abc4612e22bfb3e994c0db2
+checksum=67d316d527eca24e3ded45a2b38689615bcda1aa520a11af0accdcea7152c18a
 # checks create a cycle with python3-jupyter_core and python3-jupyter_client
 make_check=no
 

From 8c847ac10588b4f65004911ae71d36cf6c2b3302 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:57:38 +0100
Subject: [PATCH 05/15] python3-jsonschema: update to 4.4.0

---
 srcpkgs/python3-jsonschema/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-jsonschema/template b/srcpkgs/python3-jsonschema/template
index 82f45e037865..120392ad1be3 100644
--- a/srcpkgs/python3-jsonschema/template
+++ b/srcpkgs/python3-jsonschema/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-jsonschema'
 pkgname=python3-jsonschema
-version=4.2.1
+version=4.4.0
 revision=1
 wrksrc="jsonschema-${version}"
 build_style=python3-pep517
@@ -14,7 +14,7 @@ license="MIT"
 homepage="https://github.com/Julian/jsonschema"
 changelog="https://raw.githubusercontent.com/Julian/jsonschema/master/CHANGELOG.rst"
 distfiles="${PYPI_SITE}/j/jsonschema/jsonschema-${version}.tar.gz"
-checksum=390713469ae64b8a58698bb3cbc3859abe6925b565a973f87323ef21b09a27a8
+checksum=636694eb41b3535ed608fe04129f26542b59ed99808b4f688aa32dcf55317a83
 
 post_install() {
 	vlicense COPYING LICENSE

From 0d984eea8c73d86b9b825e07635ae02da0c30e75 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:04:52 +0100
Subject: [PATCH 06/15] python3-jupyter_client: update to 7.1.2

---
 srcpkgs/python3-jupyter_client/template | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-jupyter_client/template b/srcpkgs/python3-jupyter_client/template
index be6aa5594095..b6ca0b980239 100644
--- a/srcpkgs/python3-jupyter_client/template
+++ b/srcpkgs/python3-jupyter_client/template
@@ -1,8 +1,7 @@
 # Template file for 'python3-jupyter_client'
 pkgname=python3-jupyter_client
-# delay 6.2 until jupyter/jupyter_console#241 is fixed
-version=6.1.12
-revision=2
+version=7.1.1
+revision=1
 wrksrc="jupyter_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -13,7 +12,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_client"
 distfiles="${PYPI_SITE}/j/jupyter_client/jupyter_client-${version}.tar.gz"
-checksum=c4bca1d0846186ca8be97f4d2fa6d2bae889cce4892a167ffa1ba6bd1f73e782
+checksum=540ca35e57e83c5ece81abd9b781a57cba39a37c60a2a30c8c1b2f6663544343
 conflicts="python-jupyter_client<=5.2.4_2"
 # checks create a cycle with python3-jupyter_core and python3-ipython_ipykernel
 make_check=no

From 80be48bfb340d7327bfe1c3f4e279391c4d1d3d5 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:06:12 +0100
Subject: [PATCH 07/15] python3-jupyter_core: update to 4.9.1

---
 srcpkgs/python3-jupyter_core/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_core/template b/srcpkgs/python3-jupyter_core/template
index d0fa364a6751..5f450d293d4f 100644
--- a/srcpkgs/python3-jupyter_core/template
+++ b/srcpkgs/python3-jupyter_core/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_core'
 pkgname=python3-jupyter_core
-version=4.7.1
-revision=2
+version=4.9.1
+revision=1
 wrksrc="jupyter_core-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter_core/jupyter_core-${version}.tar.gz"
-checksum=79025cb3225efcd36847d0840f3fc672c0abd7afd0de83ba8a1d3837619122b4
+checksum=dce8a7499da5a53ae3afd5a9f4b02e5df1d57250cf48f3ad79da23b4778cd6fa
 conflicts="python-jupyter_core<=4.4.0_3"
 # checks create a cycle with python3-jypter_client and python3-ipython_ipykernel
 make_check=no

From 65b272267916d74878041621de6edebcb83becb5 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:07:34 +0100
Subject: [PATCH 08/15] python3-jupyter_notebook: update to 6.4.8

---
 srcpkgs/python3-jupyter_notebook/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_notebook/template b/srcpkgs/python3-jupyter_notebook/template
index ca9e1d43df21..f1ec68546fd9 100644
--- a/srcpkgs/python3-jupyter_notebook/template
+++ b/srcpkgs/python3-jupyter_notebook/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_notebook'
 pkgname=python3-jupyter_notebook
-version=6.3.0
-revision=2
+version=6.4.8
+revision=1
 wrksrc="notebook-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -15,7 +15,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org/"
 distfiles="${PYPI_SITE}/n/notebook/notebook-${version}.tar.gz"
-checksum=cbc9398d6c81473e9cdb891d2cae9c0d3718fca289dda6d26df5cb660fcadc7d
+checksum=1e985c9dc6f678bdfffb9dc657306b5469bfa62d73e03f74e8defbf76d284312
 conflicts="python-jupyter_notebook<=5.7.0_2"
 # Tests require unpackaged selenium
 make_check=no

From fd0bd606a656b003473d262d25e7cc7ef3d414fc Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:14:36 +0100
Subject: [PATCH 09/15] python3-paramiko: update to 2.9.2

---
 srcpkgs/python3-paramiko/template | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-paramiko/template b/srcpkgs/python3-paramiko/template
index cff1b3a2fb59..a11808886b73 100644
--- a/srcpkgs/python3-paramiko/template
+++ b/srcpkgs/python3-paramiko/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-paramiko'
 pkgname=python3-paramiko
-version=2.7.2
-revision=2
+version=2.9.2
+revision=1
 wrksrc="${pkgname#*-}-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,4 +11,6 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="LGPL-2.1-or-later"
 homepage="http://www.paramiko.org/"
 distfiles="${PYPI_SITE}/p/paramiko/paramiko-${version}.tar.gz"
-checksum=7f36f4ba2c0d81d219f4595e35f70d56cc94f9ac40a6acdf51d6ca210ce65035
+checksum=944a9e5dbdd413ab6c7951ea46b0ab40713235a9c4c5ca81cfe45c6f14fa677b
+# Testing via this command is deprecated
+make_check=no

From 8f8119db01736aedf66355355dd4f56ee86dfa65 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:16:02 +0100
Subject: [PATCH 10/15] python3-prometheus_client: update to 0.13.1

---
 srcpkgs/python3-prometheus_client/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-prometheus_client/template b/srcpkgs/python3-prometheus_client/template
index 82e4da1f3edd..739013270799 100644
--- a/srcpkgs/python3-prometheus_client/template
+++ b/srcpkgs/python3-prometheus_client/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-prometheus_client'
 pkgname=python3-prometheus_client
-version=0.9.0
-revision=2
+version=0.13.1
+revision=1
 wrksrc="prometheus_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,4 +12,4 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Apache-2.0"
 homepage="https://github.com/prometheus/client_python"
 distfiles="${PYPI_SITE}/p/prometheus_client/prometheus_client-${version}.tar.gz"
-checksum=9da7b32f02439d8c04f7777021c304ed51d9ec180604700c1ba72a4d44dceb03
+checksum=ada41b891b79fca5638bd5cfe149efa86512eaa55987893becd2c6d8d0a5dfc5

From 77789f4c8488fb9064505b087f61c2a85558a853 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:17:21 +0100
Subject: [PATCH 11/15] python3-soupsieve: update to 2.3.1

---
 srcpkgs/python3-soupsieve/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-soupsieve/template b/srcpkgs/python3-soupsieve/template
index 14449f20c47f..06eb2b8b8895 100644
--- a/srcpkgs/python3-soupsieve/template
+++ b/srcpkgs/python3-soupsieve/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-soupsieve'
 pkgname=python3-soupsieve
-version=1.9.5
-revision=6
+version=2.3.1
+revision=1
 wrksrc="soupsieve-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,7 +12,7 @@ maintainer="Aluísio Augusto Silva Gonçalves <aluisio@aasg.name>"
 license="MIT"
 homepage="https://facelessuser.github.io/soupsieve/"
 distfiles="${PYPI_SITE}/s/soupsieve/soupsieve-${version}.tar.gz"
-checksum=e2c1c5dee4a1c36bcb790e0fabd5492d874b8ebd4617622c4f6a731701060dda
+checksum=b8d49b1cd4f037c7082a9683dfa1801aa2597fb11c3a1155b7a5b94829b4f1f9
 
 post_install() {
 	vlicense LICENSE.md

From 2d38f129dcc7c2b90b3153dbf22d3ab1b7a00dd8 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:20:35 +0100
Subject: [PATCH 12/15] python3-terminado: update to 0.13.0

---
 srcpkgs/python3-terminado/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-terminado/template b/srcpkgs/python3-terminado/template
index 28c65c82ba99..e299a6ca8c4f 100644
--- a/srcpkgs/python3-terminado/template
+++ b/srcpkgs/python3-terminado/template
@@ -1,10 +1,10 @@
 # Template file for 'python3-terminado'
 pkgname=python3-terminado
-version=0.9.4
-revision=2
+version=0.13.0
+revision=1
 wrksrc="terminado-${version}"
 build_style=python3-module
-hostmakedepends="python3-setuptools"
+hostmakedepends="python3-setuptools python3-tornado"
 depends="python3-ptyprocess python3-tornado"
 checkdepends="python3-pytest $depends"
 short_desc="Terminals served to term.js using Tornado websockets (Python3)"
@@ -12,7 +12,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/takluyver/terminado"
 distfiles="${PYPI_SITE}/t/terminado/terminado-${version}.tar.gz"
-checksum=9a7dbcfbc2778830eeb70261bf7aa9d98a3eac8631a3afe3febeb57c12f798be
+checksum=713531ccb5db7d4f544651f14050da79809030f00d1afa21462088cf32fb143a
 
 post_install() {
 	vlicense LICENSE

From 8c4e593dec59e7572a7cbb72d8e95f47d17132e4 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 16:27:01 +0100
Subject: [PATCH 13/15] python3-jupyter_console: add patches

---
 .../patches/pr258.patch                       |  22 ++
 .../patches/upstream1.patch                   | 252 ++++++++++++++++++
 srcpkgs/python3-jupyter_console/template      |   2 +-
 3 files changed, 275 insertions(+), 1 deletion(-)
 create mode 100644 srcpkgs/python3-jupyter_console/patches/pr258.patch
 create mode 100644 srcpkgs/python3-jupyter_console/patches/upstream1.patch

diff --git a/srcpkgs/python3-jupyter_console/patches/pr258.patch b/srcpkgs/python3-jupyter_console/patches/pr258.patch
new file mode 100644
index 000000000000..7f3c6188c78e
--- /dev/null
+++ b/srcpkgs/python3-jupyter_console/patches/pr258.patch
@@ -0,0 +1,22 @@
+From 7a68e9f630c5484159fddce1bb5718e26d592f32 Mon Sep 17 00:00:00 2001
+From: Jade Lovelace <software@lfcode.ca>
+Date: Sat, 1 Jan 2022 19:11:57 -0800
+Subject: [PATCH] Remove loop=loop in asyncio.wait call. Fix #245
+
+---
+ jupyter_console/ptshell.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/jupyter_console/ptshell.py b/jupyter_console/ptshell.py
+index 31f424d..08f0342 100644
+--- a/jupyter_console/ptshell.py
++++ b/jupyter_console/ptshell.py
+@@ -673,7 +673,7 @@ def mainloop(self):
+                     # wish to include external content
+                     tasks.append(self.handle_external_iopub(loop=loop))
+ 
+-                main_task = asyncio.wait(tasks, loop=loop, return_when=asyncio.FIRST_COMPLETED)
++                main_task = asyncio.wait(tasks, return_when=asyncio.FIRST_COMPLETED)
+                 _, pending = loop.run_until_complete(main_task)
+ 
+                 for task in pending:
diff --git a/srcpkgs/python3-jupyter_console/patches/upstream1.patch b/srcpkgs/python3-jupyter_console/patches/upstream1.patch
new file mode 100644
index 000000000000..97cfb0ce3c8b
--- /dev/null
+++ b/srcpkgs/python3-jupyter_console/patches/upstream1.patch
@@ -0,0 +1,252 @@
+From 0c7aca07d45ff009327599f6985c6a8ebbd98987 Mon Sep 17 00:00:00 2001
+From: David Brochart <david.brochart@gmail.com>
+Date: Tue, 1 Jun 2021 09:41:11 +0200
+Subject: [PATCH 1/5] Wrap jupyter_client's async functions with run_sync
+
+---
+ .github/workflows/python-package.yml |  1 +
+ jupyter_console/ptshell.py           | 16 +++++++++-------
+ 2 files changed, 10 insertions(+), 7 deletions(-)
+
+diff --git a/.github/workflows/python-package.yml b/.github/workflows/python-package.yml
+index eb8048e..fd5fcd0 100644
+--- a/.github/workflows/python-package.yml
++++ b/.github/workflows/python-package.yml
+@@ -29,6 +29,7 @@ jobs:
+         pip install pytest pytest-cov
+         pip install .
+         python -m ipykernel.kernelspec --user
++        pip install https://github.com/jupyter/jupyter_client/archive/master.zip
+     - name: Test with pytest
+       run: |
+         pytest --cov jupyter_console
+diff --git a/jupyter_console/ptshell.py b/jupyter_console/ptshell.py
+index a9daeed..d6dc1e7 100644
+--- a/jupyter_console/ptshell.py
++++ b/jupyter_console/ptshell.py
+@@ -76,6 +76,8 @@
+ from pygments.util import ClassNotFound
+ from pygments.token import Token
+ 
++from jupyter_client.utils import run_sync
++
+ 
+ def ask_yes_no(prompt, default=None, interrupt=None):
+     """Asks a question and returns a boolean (y/n) answer.
+@@ -705,8 +707,8 @@ def run_cell(self, cell, store_history=True):
+             return
+ 
+         # flush stale replies, which could have been ignored, due to missed heartbeats
+-        while self.client.shell_channel.msg_ready():
+-            self.client.shell_channel.get_msg()
++        while run_sync(self.client.shell_channel.msg_ready)():
++            run_sync(self.client.shell_channel.get_msg)()
+         # execute takes 'hidden', which is the inverse of store_hist
+         msg_id = self.client.execute(cell, not store_history)
+ 
+@@ -739,7 +741,7 @@ def run_cell(self, cell, store_history=True):
+     #-----------------
+ 
+     def handle_execute_reply(self, msg_id, timeout=None):
+-        msg = self.client.shell_channel.get_msg(block=False, timeout=timeout)
++        msg = run_sync(self.client.shell_channel.get_msg)(block=False, timeout=timeout)
+         if msg["parent_header"].get("msg_id", None) == msg_id:
+ 
+             self.handle_iopub(msg_id)
+@@ -778,7 +780,7 @@ def handle_is_complete_reply(self, msg_id, timeout=None):
+         ## Get the is_complete response:
+         msg = None
+         try:
+-            msg = self.client.shell_channel.get_msg(block=True, timeout=timeout)
++            msg = run_sync(self.client.shell_channel.get_msg)(block=True, timeout=timeout)
+         except Empty:
+             warn('The kernel did not respond to an is_complete_request. '
+                  'Setting `use_kernel_is_complete` to False.')
+@@ -849,8 +851,8 @@ def handle_iopub(self, msg_id=''):
+ 
+            It only displays output that is caused by this session.
+         """
+-        while self.client.iopub_channel.msg_ready():
+-            sub_msg = self.client.iopub_channel.get_msg()
++        while run_sync(self.client.iopub_channel.msg_ready)():
++            sub_msg = run_sync(self.client.iopub_channel.get_msg)()
+             msg_type = sub_msg['header']['msg_type']
+ 
+             # Update execution_count in case it changed in another session
+@@ -1003,7 +1005,7 @@ def handle_image_callable(self, data, mime):
+     def handle_input_request(self, msg_id, timeout=0.1):
+         """ Method to capture raw_input
+         """
+-        req = self.client.stdin_channel.get_msg(timeout=timeout)
++        req = run_sync(self.client.stdin_channel.get_msg)(timeout=timeout)
+         # in case any iopub came while we were waiting:
+         self.handle_iopub(msg_id)
+         if msg_id == req["parent_header"].get("msg_id"):
+
+From 84a4c63f7c2b700357f5e5f730209dc4fc897c24 Mon Sep 17 00:00:00 2001
+From: David Brochart <david.brochart@gmail.com>
+Date: Wed, 2 Jun 2021 09:45:47 +0200
+Subject: [PATCH 2/5] Use run_sync only from jupyter_client 7.0+
+
+---
+ jupyter_console/completer.py | 12 +++++++++++-
+ jupyter_console/ptshell.py   | 13 ++++++++++---
+ 2 files changed, 21 insertions(+), 4 deletions(-)
+
+diff --git a/jupyter_console/completer.py b/jupyter_console/completer.py
+index d0b7b9a..4b845e3 100644
+--- a/jupyter_console/completer.py
++++ b/jupyter_console/completer.py
+@@ -7,6 +7,16 @@
+ from traitlets.config import Configurable
+ from traitlets import Float
+ 
++import jupyter_client
++
++
++# jupyter_client 7.0+ has async channel methods that we expect to be sync here
++if jupyter_client._version.version_info[0] >= 7:
++    from jupyter_client.utils import run_sync
++else:
++    run_sync = lambda x: x
++
++
+ class ZMQCompleter(Configurable):
+     """Client-side completion machinery.
+ 
+@@ -31,7 +41,7 @@ def complete_request(self, code, cursor_pos):
+             cursor_pos=cursor_pos,
+         )
+     
+-        msg = self.client.shell_channel.get_msg(timeout=self.timeout)
++        msg = run_sync(self.client.shell_channel.get_msg)(timeout=self.timeout)
+         if msg['parent_header']['msg_id'] == msg_id:
+             return msg['content']
+ 
+diff --git a/jupyter_console/ptshell.py b/jupyter_console/ptshell.py
+index d6dc1e7..4608992 100644
+--- a/jupyter_console/ptshell.py
++++ b/jupyter_console/ptshell.py
+@@ -76,7 +76,14 @@
+ from pygments.util import ClassNotFound
+ from pygments.token import Token
+ 
+-from jupyter_client.utils import run_sync
++import jupyter_client
++
++
++# jupyter_client 7.0+ has async channel methods that we expect to be sync here
++if jupyter_client._version.version_info[0] >= 7:
++    from jupyter_client.utils import run_sync
++else:
++    run_sync = lambda x: x
+ 
+ 
+ def ask_yes_no(prompt, default=None, interrupt=None):
+@@ -1034,6 +1041,6 @@ def double_int(sig, frame):
+ 
+             # only send stdin reply if there *was not* another request
+             # or execution finished while we were reading.
+-            if not (self.client.stdin_channel.msg_ready() or
+-                    self.client.shell_channel.msg_ready()):
++            if not (run_sync(self.client.stdin_channel.msg_ready)() or
++                    run_sync(self.client.shell_channel.msg_ready)()):
+                 self.client.input(raw_data)
+
+From 71bdcb5198ac7d79b246029965d945b5e726a6ed Mon Sep 17 00:00:00 2001
+From: David Brochart <david.brochart@gmail.com>
+Date: Wed, 2 Jun 2021 09:55:03 +0200
+Subject: [PATCH 3/5] Don't install jupyter_client master
+
+---
+ .github/workflows/python-package.yml | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/.github/workflows/python-package.yml b/.github/workflows/python-package.yml
+index fd5fcd0..eb8048e 100644
+--- a/.github/workflows/python-package.yml
++++ b/.github/workflows/python-package.yml
+@@ -29,7 +29,6 @@ jobs:
+         pip install pytest pytest-cov
+         pip install .
+         python -m ipykernel.kernelspec --user
+-        pip install https://github.com/jupyter/jupyter_client/archive/master.zip
+     - name: Test with pytest
+       run: |
+         pytest --cov jupyter_console
+
+From 6620bdbecd66196721f9765a13659bdc26e28740 Mon Sep 17 00:00:00 2001
+From: David Brochart <david.brochart@gmail.com>
+Date: Wed, 15 Sep 2021 08:40:06 +0200
+Subject: [PATCH 4/5] Update jupyter_console/completer.py
+
+Co-authored-by: Matthias Bussonnier <bussonniermatthias@gmail.com>
+---
+ jupyter_console/completer.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/jupyter_console/completer.py b/jupyter_console/completer.py
+index 4b845e3..6a38a6a 100644
+--- a/jupyter_console/completer.py
++++ b/jupyter_console/completer.py
+@@ -11,7 +11,7 @@
+ 
+ 
+ # jupyter_client 7.0+ has async channel methods that we expect to be sync here
+-if jupyter_client._version.version_info[0] >= 7:
++if jupyter_client.version_info >= (7,):
+     from jupyter_client.utils import run_sync
+ else:
+     run_sync = lambda x: x
+
+From 7f2dc911b41df9ed7f3cdc09a6832451cbe69d15 Mon Sep 17 00:00:00 2001
+From: David Brochart <david.brochart@gmail.com>
+Date: Tue, 9 Nov 2021 14:27:16 +0100
+Subject: [PATCH 5/5] Drop block kwarg from get_msg() for jupyter_client>=7.0
+
+---
+ jupyter_console/ptshell.py | 13 +++++++++++--
+ 1 file changed, 11 insertions(+), 2 deletions(-)
+
+diff --git a/jupyter_console/ptshell.py b/jupyter_console/ptshell.py
+index 4608992..31f424d 100644
+--- a/jupyter_console/ptshell.py
++++ b/jupyter_console/ptshell.py
+@@ -80,10 +80,13 @@
+ 
+ 
+ # jupyter_client 7.0+ has async channel methods that we expect to be sync here
++# also, `block` was removed from `get_msg()`
+ if jupyter_client._version.version_info[0] >= 7:
+     from jupyter_client.utils import run_sync
++    JUPYTER_CLIENT_7 = True
+ else:
+     run_sync = lambda x: x
++    JUPYTER_CLIENT_7 = False
+ 
+ 
+ def ask_yes_no(prompt, default=None, interrupt=None):
+@@ -748,7 +751,10 @@ def run_cell(self, cell, store_history=True):
+     #-----------------
+ 
+     def handle_execute_reply(self, msg_id, timeout=None):
+-        msg = run_sync(self.client.shell_channel.get_msg)(block=False, timeout=timeout)
++        kwargs = {"timeout": timeout}
++        if not JUPYTER_CLIENT_7:
++            kwargs["block"] = False
++        msg = run_sync(self.client.shell_channel.get_msg)(**kwargs)
+         if msg["parent_header"].get("msg_id", None) == msg_id:
+ 
+             self.handle_iopub(msg_id)
+@@ -787,7 +793,10 @@ def handle_is_complete_reply(self, msg_id, timeout=None):
+         ## Get the is_complete response:
+         msg = None
+         try:
+-            msg = run_sync(self.client.shell_channel.get_msg)(block=True, timeout=timeout)
++            kwargs = {"timeout": timeout}
++            if not JUPYTER_CLIENT_7:
++                kwargs["block"] = True
++            msg = run_sync(self.client.shell_channel.get_msg)(**kwargs)
+         except Empty:
+             warn('The kernel did not respond to an is_complete_request. '
+                  'Setting `use_kernel_is_complete` to False.')
diff --git a/srcpkgs/python3-jupyter_console/template b/srcpkgs/python3-jupyter_console/template
index 3124f3854a19..2971b9fe92c5 100644
--- a/srcpkgs/python3-jupyter_console/template
+++ b/srcpkgs/python3-jupyter_console/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_console'
 pkgname=python3-jupyter_console
 version=6.4.0
-revision=2
+revision=3
 wrksrc="jupyter_console-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"

From b7f4b3214d8fa7f735bcd99368ab037c21645222 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:43 +0100
Subject: [PATCH 14/15] python3-jupyter_server: update to 1.13.5

---
 srcpkgs/python3-jupyter_server/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-jupyter_server/template b/srcpkgs/python3-jupyter_server/template
index 4e6d8a6fe52a..e872ca652d59 100644
--- a/srcpkgs/python3-jupyter_server/template
+++ b/srcpkgs/python3-jupyter_server/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-jupyter_server'
 pkgname=python3-jupyter_server
-version=1.13.4
+version=1.13.5
 revision=1
 wrksrc="jupyter_server-${version}"
 build_style=python3-module
@@ -14,7 +14,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter-server/jupyter_server-${version}.tar.gz"
-checksum=5fb5a219385338b1d13a013a68f54688b6a69ecff4e757fd230e27ecacdbf212
+checksum=9e3e9717eea3bffab8cfb2ff330011be6c8bbd9cdae5b71cef169fcece2f19d3
 # Tarball defines no tests
 make_check=no
 

From 9ebf1231f2090c545c8db2626069c2319c14f7bb Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:59 +0100
Subject: [PATCH 15/15] jupyterlab: update to 3.2.9

---
 srcpkgs/jupyterlab/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/jupyterlab/template b/srcpkgs/jupyterlab/template
index 330d959bc154..133fdab3b206 100644
--- a/srcpkgs/jupyterlab/template
+++ b/srcpkgs/jupyterlab/template
@@ -1,7 +1,7 @@
 # Template file for 'jupyterlab'
 pkgname=jupyterlab
-version=3.2.8
-revision=2
+version=3.2.9
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-jupyterlab_server nodejs python3-nbclassic
@@ -11,7 +11,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="custom:jupyterlab"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyterlab/jupyterlab-${version}.tar.gz"
-checksum=5e4e99868c4f385372686767781408acbb9004b690b198b45597ba869802334b
+checksum=65ddc34e5da1a764606e38c4f70cf9d4ac1c05182813cf0ab2dfea312c701124
 # Tests require unpackaged dependencies
 make_check=no
 

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (10 preceding siblings ...)
  2022-02-13 10:35 ` dkwo
@ 2022-02-13 10:46 ` dkwo
  2022-02-13 12:41 ` ahesford
                   ` (38 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-02-13 10:46 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 210 bytes --]

New comment by dkwo on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#issuecomment-1038006976

Comment:
I pushed a couple more simpe updates.
Any obstruction to merging this?

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (11 preceding siblings ...)
  2022-02-13 10:46 ` dkwo
@ 2022-02-13 12:41 ` ahesford
  2022-02-13 13:22 ` dkwo
                   ` (37 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: ahesford @ 2022-02-13 12:41 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 338 bytes --]

New comment by ahesford on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#issuecomment-1038084400

Comment:
What's the nature of the problem that the console patches solve? Has the PR from where you pulled the patches been accepted yet? We don't generally pull patches that haven't been merged upstream.

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (12 preceding siblings ...)
  2022-02-13 12:41 ` ahesford
@ 2022-02-13 13:22 ` dkwo
  2022-02-13 18:49 ` ahesford
                   ` (36 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-02-13 13:22 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 584 bytes --]

New comment by dkwo on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#issuecomment-1038113461

Comment:
Let me clarify: the upstream1.patch set has already been merged into master; the other patch just removes `loop=loop`, partially fixing the zeroMQ issue (at least in some cases, see issues 241 and 245 there).
Together, they make console at least usable, while now it is broken on Void, so I don't see any point in blocking the updates of other packages due to it. If you prefer I can remove the second patch, and leave it broken for the moment.

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (13 preceding siblings ...)
  2022-02-13 13:22 ` dkwo
@ 2022-02-13 18:49 ` ahesford
  2022-02-14  9:58 ` [PR PATCH] [Updated] " dkwo
                   ` (35 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: ahesford @ 2022-02-13 18:49 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 438 bytes --]

New comment by ahesford on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#issuecomment-1038337575

Comment:
The `loop=loop` removal eliminates an obvious API incompatibility, but I suspect that there are some much deeper issues with how they handle the event loop that are just hidden by this change. I'm tempted to just leave `jupyter_console` untouched for now while they shake out the right approach.

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR PATCH] [Updated] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (14 preceding siblings ...)
  2022-02-13 18:49 ` ahesford
@ 2022-02-14  9:58 ` dkwo
  2022-02-14 10:00 ` dkwo
                   ` (34 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-02-14  9:58 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 397 bytes --]

There is an updated pull request by dkwo against master on the void-packages repository

https://github.com/dkwo/void-packages pytupd
https://github.com/void-linux/void-packages/pull/35376

update few python3 packages
@ahesford Could you check whether the new jupyter client solves the issue with console?

A patch file from https://github.com/void-linux/void-packages/pull/35376.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-pytupd-35376.patch --]
[-- Type: text/x-diff, Size: 18110 bytes --]

From 12ead3a2ce25d0aa852a8bf2af44da58e71716c6 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:50:20 +0100
Subject: [PATCH 01/14] python3-bleach: update to 4.1.0

---
 srcpkgs/python3-bleach/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-bleach/template b/srcpkgs/python3-bleach/template
index 21fec4f4b37c..2b8af3b8fbba 100644
--- a/srcpkgs/python3-bleach/template
+++ b/srcpkgs/python3-bleach/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-bleach'
 pkgname=python3-bleach
-version=3.3.0
-revision=2
+version=4.1.0
+revision=1
 wrksrc="bleach-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -13,4 +13,4 @@ license="Apache-2.0"
 homepage="https://github.com/mozilla/bleach"
 changelog="https://raw.githubusercontent.com/mozilla/bleach/master/CHANGES"
 distfiles="${PYPI_SITE}/b/bleach/bleach-${version}.tar.gz"
-checksum=98b3170739e5e83dd9dc19633f074727ad848cbedb6026708c8ac2d3b697a433
+checksum=0900d8b37eba61a802ee40ac0061f8c2b5dee29c1927dd1d233e075ebf5a71da

From 4ba0d5ebac70de1289f3a73f61c01fde983d6112 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:51:55 +0100
Subject: [PATCH 02/14] python3-defusedxml: update to 0.7.1

---
 srcpkgs/python3-defusedxml/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-defusedxml/template b/srcpkgs/python3-defusedxml/template
index 06bdd57a3526..90dc454d120d 100644
--- a/srcpkgs/python3-defusedxml/template
+++ b/srcpkgs/python3-defusedxml/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-defusedxml'
 pkgname=python3-defusedxml
-version=0.6.0
-revision=5
+version=0.7.1
+revision=1
 wrksrc="defusedxml-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Python-2.0"
 homepage="https://github.com/tiran/defusedxml"
 distfiles="${PYPI_SITE}/d/defusedxml/defusedxml-${version}.tar.gz"
-checksum=f684034d135af4c6cbb949b8a4d2ed61634515257a67299e5f940fbaa34377f5
+checksum=1bb3032db185915b62d7c6209c5a8792be6a32ab2fedacc84e01b52c51aa3e69
 
 post_install() {
 	vlicense LICENSE

From c11aea159a953b85b8ad5c543893adba9888ecf1 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:54:30 +0100
Subject: [PATCH 03/14] python3-httplib2: update to 0.20.4

---
 srcpkgs/python3-httplib2/template | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-httplib2/template b/srcpkgs/python3-httplib2/template
index d0c39a478622..32fd1c87c2c1 100644
--- a/srcpkgs/python3-httplib2/template
+++ b/srcpkgs/python3-httplib2/template
@@ -1,12 +1,12 @@
 # Template file for 'python3-httplib2'
 pkgname=python3-httplib2
-version=0.18.1
-revision=3
+version=0.20.4
+revision=1
 create_wrksrc=yes
 build_wrksrc="httplib2-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="python3 ca-certificates"
+depends="python3 ca-certificates python3-parsing"
 short_desc="Comprehensive HTTP client library (Python3)"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
@@ -14,8 +14,10 @@ homepage="https://github.com/httplib2/httplib2"
 changelog="https://raw.githubusercontent.com/httplib2/httplib2/master/CHANGELOG"
 distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz
  https://raw.githubusercontent.com/httplib2/httplib2/master/LICENSE>LICENSE.txt"
-checksum="8af66c1c52c7ffe1aa5dc4bcd7c769885254b0756e6e69f953c7f0ab49a70ba3
+checksum="58a98e45b4b1a48273073f905d2961666ecf0fbac4250ea5b47aef259eb5c585
  589eec38f72df2be203711d3b8cbece9b908c5e7ff00bc3cab7f63bae9e366b4"
+# Testing via this command is deprecated
+make_check=no
 
 post_install() {
 	# use system ca certificates

From 1191fcd9f7e0f3dc86406d505be51cb3080cbfb3 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:55:53 +0100
Subject: [PATCH 04/14] python3-ipython_ipykernel: update to 6.8.0

---
 srcpkgs/python3-ipython_ipykernel/template | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-ipython_ipykernel/template b/srcpkgs/python3-ipython_ipykernel/template
index f00e0a3f1a0c..b75796ca0262 100644
--- a/srcpkgs/python3-ipython_ipykernel/template
+++ b/srcpkgs/python3-ipython_ipykernel/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-ipython_ipykernel'
 pkgname=python3-ipython_ipykernel
-version=5.5.4
-revision=2
+version=6.8.0
+revision=1
 wrksrc="ipykernel-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools python3-ipython
- python3-jupyter_client python3-traitlets python3-tornado"
-depends="python3-ipython python3-traitlets python3-jupyter_client python3-tornado"
+ python3-jupyter_client python3-traitlets python3-tornado python3-entrypoints"
+depends="python3-ipython python3-traitlets python3-jupyter_client
+ python3-tornado python3-entrypoints python3-nest_asyncio"
 short_desc="IPython kernel for Jupyter (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/ipykernel"
 distfiles="${PYPI_SITE}/i/ipykernel/ipykernel-${version}.tar.gz"
-checksum=1ce0e83672cc3bfdc1ffb5603e1d77ab125f24b41abc4612e22bfb3e994c0db2
+checksum=67d316d527eca24e3ded45a2b38689615bcda1aa520a11af0accdcea7152c18a
 # checks create a cycle with python3-jupyter_core and python3-jupyter_client
 make_check=no
 

From 52f256ce2722606693721306409980a97f6cab0c Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:57:38 +0100
Subject: [PATCH 05/14] python3-jsonschema: update to 4.4.0

---
 srcpkgs/python3-jsonschema/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-jsonschema/template b/srcpkgs/python3-jsonschema/template
index 82f45e037865..120392ad1be3 100644
--- a/srcpkgs/python3-jsonschema/template
+++ b/srcpkgs/python3-jsonschema/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-jsonschema'
 pkgname=python3-jsonschema
-version=4.2.1
+version=4.4.0
 revision=1
 wrksrc="jsonschema-${version}"
 build_style=python3-pep517
@@ -14,7 +14,7 @@ license="MIT"
 homepage="https://github.com/Julian/jsonschema"
 changelog="https://raw.githubusercontent.com/Julian/jsonschema/master/CHANGELOG.rst"
 distfiles="${PYPI_SITE}/j/jsonschema/jsonschema-${version}.tar.gz"
-checksum=390713469ae64b8a58698bb3cbc3859abe6925b565a973f87323ef21b09a27a8
+checksum=636694eb41b3535ed608fe04129f26542b59ed99808b4f688aa32dcf55317a83
 
 post_install() {
 	vlicense COPYING LICENSE

From aba52a8e5425e4e30319dfe3802c819f776bd311 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:04:52 +0100
Subject: [PATCH 06/14] python3-jupyter_client: update to 7.1.2

---
 srcpkgs/python3-jupyter_client/template | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-jupyter_client/template b/srcpkgs/python3-jupyter_client/template
index be6aa5594095..c3906f07e7b4 100644
--- a/srcpkgs/python3-jupyter_client/template
+++ b/srcpkgs/python3-jupyter_client/template
@@ -1,19 +1,18 @@
 # Template file for 'python3-jupyter_client'
 pkgname=python3-jupyter_client
-# delay 6.2 until jupyter/jupyter_console#241 is fixed
-version=6.1.12
-revision=2
+version=7.1.1
+revision=1
 wrksrc="jupyter_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-traitlets python3-jupyter_core python3-pyzmq
- python3-dateutil python3-tornado python3-nest_asyncio"
+ python3-dateutil python3-tornado python3-nest_asyncio python3-entrypoints"
 short_desc="Jupyter protocol client APIs"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_client"
 distfiles="${PYPI_SITE}/j/jupyter_client/jupyter_client-${version}.tar.gz"
-checksum=c4bca1d0846186ca8be97f4d2fa6d2bae889cce4892a167ffa1ba6bd1f73e782
+checksum=540ca35e57e83c5ece81abd9b781a57cba39a37c60a2a30c8c1b2f6663544343
 conflicts="python-jupyter_client<=5.2.4_2"
 # checks create a cycle with python3-jupyter_core and python3-ipython_ipykernel
 make_check=no

From 2c763675c70f05cf14973006348cd9a8edee59a5 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:06:12 +0100
Subject: [PATCH 07/14] python3-jupyter_core: update to 4.9.1

---
 srcpkgs/python3-jupyter_core/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_core/template b/srcpkgs/python3-jupyter_core/template
index d0fa364a6751..5f450d293d4f 100644
--- a/srcpkgs/python3-jupyter_core/template
+++ b/srcpkgs/python3-jupyter_core/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_core'
 pkgname=python3-jupyter_core
-version=4.7.1
-revision=2
+version=4.9.1
+revision=1
 wrksrc="jupyter_core-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter_core/jupyter_core-${version}.tar.gz"
-checksum=79025cb3225efcd36847d0840f3fc672c0abd7afd0de83ba8a1d3837619122b4
+checksum=dce8a7499da5a53ae3afd5a9f4b02e5df1d57250cf48f3ad79da23b4778cd6fa
 conflicts="python-jupyter_core<=4.4.0_3"
 # checks create a cycle with python3-jypter_client and python3-ipython_ipykernel
 make_check=no

From f65a7522c95565c1ce96d996c06822e4b6a66d84 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:07:34 +0100
Subject: [PATCH 08/14] python3-jupyter_notebook: update to 6.4.8

---
 srcpkgs/python3-jupyter_notebook/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_notebook/template b/srcpkgs/python3-jupyter_notebook/template
index ca9e1d43df21..f1ec68546fd9 100644
--- a/srcpkgs/python3-jupyter_notebook/template
+++ b/srcpkgs/python3-jupyter_notebook/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_notebook'
 pkgname=python3-jupyter_notebook
-version=6.3.0
-revision=2
+version=6.4.8
+revision=1
 wrksrc="notebook-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -15,7 +15,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org/"
 distfiles="${PYPI_SITE}/n/notebook/notebook-${version}.tar.gz"
-checksum=cbc9398d6c81473e9cdb891d2cae9c0d3718fca289dda6d26df5cb660fcadc7d
+checksum=1e985c9dc6f678bdfffb9dc657306b5469bfa62d73e03f74e8defbf76d284312
 conflicts="python-jupyter_notebook<=5.7.0_2"
 # Tests require unpackaged selenium
 make_check=no

From 2b760cb3bcc29be8ecf4e0eac7a29f838a0b46b0 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:14:36 +0100
Subject: [PATCH 09/14] python3-paramiko: update to 2.9.2

---
 srcpkgs/python3-paramiko/template | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-paramiko/template b/srcpkgs/python3-paramiko/template
index cff1b3a2fb59..a11808886b73 100644
--- a/srcpkgs/python3-paramiko/template
+++ b/srcpkgs/python3-paramiko/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-paramiko'
 pkgname=python3-paramiko
-version=2.7.2
-revision=2
+version=2.9.2
+revision=1
 wrksrc="${pkgname#*-}-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,4 +11,6 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="LGPL-2.1-or-later"
 homepage="http://www.paramiko.org/"
 distfiles="${PYPI_SITE}/p/paramiko/paramiko-${version}.tar.gz"
-checksum=7f36f4ba2c0d81d219f4595e35f70d56cc94f9ac40a6acdf51d6ca210ce65035
+checksum=944a9e5dbdd413ab6c7951ea46b0ab40713235a9c4c5ca81cfe45c6f14fa677b
+# Testing via this command is deprecated
+make_check=no

From 7d3f5513981e96b45c9f2905bc08379af8197968 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:16:02 +0100
Subject: [PATCH 10/14] python3-prometheus_client: update to 0.13.1

---
 srcpkgs/python3-prometheus_client/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-prometheus_client/template b/srcpkgs/python3-prometheus_client/template
index 82e4da1f3edd..739013270799 100644
--- a/srcpkgs/python3-prometheus_client/template
+++ b/srcpkgs/python3-prometheus_client/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-prometheus_client'
 pkgname=python3-prometheus_client
-version=0.9.0
-revision=2
+version=0.13.1
+revision=1
 wrksrc="prometheus_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,4 +12,4 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Apache-2.0"
 homepage="https://github.com/prometheus/client_python"
 distfiles="${PYPI_SITE}/p/prometheus_client/prometheus_client-${version}.tar.gz"
-checksum=9da7b32f02439d8c04f7777021c304ed51d9ec180604700c1ba72a4d44dceb03
+checksum=ada41b891b79fca5638bd5cfe149efa86512eaa55987893becd2c6d8d0a5dfc5

From 74815dca718135bfda0b4aebcf596984834448b3 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:17:21 +0100
Subject: [PATCH 11/14] python3-soupsieve: update to 2.3.1

---
 srcpkgs/python3-soupsieve/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-soupsieve/template b/srcpkgs/python3-soupsieve/template
index 14449f20c47f..bb63a5ec0952 100644
--- a/srcpkgs/python3-soupsieve/template
+++ b/srcpkgs/python3-soupsieve/template
@@ -1,18 +1,18 @@
 # Template file for 'python3-soupsieve'
 pkgname=python3-soupsieve
-version=1.9.5
-revision=6
+version=2.3.1
+revision=1
 wrksrc="soupsieve-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="python3"
+depends="python3 python3-BeautifulSoup4"
 checkdepends="python3-pytest python3-lxml python3-html5lib python3-BeautifulSoup4"
 short_desc="CSS4 selector implementation for Python3 Beautiful Soup"
 maintainer="Aluísio Augusto Silva Gonçalves <aluisio@aasg.name>"
 license="MIT"
 homepage="https://facelessuser.github.io/soupsieve/"
 distfiles="${PYPI_SITE}/s/soupsieve/soupsieve-${version}.tar.gz"
-checksum=e2c1c5dee4a1c36bcb790e0fabd5492d874b8ebd4617622c4f6a731701060dda
+checksum=b8d49b1cd4f037c7082a9683dfa1801aa2597fb11c3a1155b7a5b94829b4f1f9
 
 post_install() {
 	vlicense LICENSE.md

From 748d971a8d5d8456a63da1269e6d285c3c1da37c Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:20:35 +0100
Subject: [PATCH 12/14] python3-terminado: update to 0.13.0

---
 srcpkgs/python3-terminado/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-terminado/template b/srcpkgs/python3-terminado/template
index 28c65c82ba99..e299a6ca8c4f 100644
--- a/srcpkgs/python3-terminado/template
+++ b/srcpkgs/python3-terminado/template
@@ -1,10 +1,10 @@
 # Template file for 'python3-terminado'
 pkgname=python3-terminado
-version=0.9.4
-revision=2
+version=0.13.0
+revision=1
 wrksrc="terminado-${version}"
 build_style=python3-module
-hostmakedepends="python3-setuptools"
+hostmakedepends="python3-setuptools python3-tornado"
 depends="python3-ptyprocess python3-tornado"
 checkdepends="python3-pytest $depends"
 short_desc="Terminals served to term.js using Tornado websockets (Python3)"
@@ -12,7 +12,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/takluyver/terminado"
 distfiles="${PYPI_SITE}/t/terminado/terminado-${version}.tar.gz"
-checksum=9a7dbcfbc2778830eeb70261bf7aa9d98a3eac8631a3afe3febeb57c12f798be
+checksum=713531ccb5db7d4f544651f14050da79809030f00d1afa21462088cf32fb143a
 
 post_install() {
 	vlicense LICENSE

From 272c82f695f12c54dc562b410d609b19c22079ac Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:43 +0100
Subject: [PATCH 13/14] python3-jupyter_server: update to 1.13.5

---
 srcpkgs/python3-jupyter_server/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-jupyter_server/template b/srcpkgs/python3-jupyter_server/template
index 4e6d8a6fe52a..e872ca652d59 100644
--- a/srcpkgs/python3-jupyter_server/template
+++ b/srcpkgs/python3-jupyter_server/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-jupyter_server'
 pkgname=python3-jupyter_server
-version=1.13.4
+version=1.13.5
 revision=1
 wrksrc="jupyter_server-${version}"
 build_style=python3-module
@@ -14,7 +14,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter-server/jupyter_server-${version}.tar.gz"
-checksum=5fb5a219385338b1d13a013a68f54688b6a69ecff4e757fd230e27ecacdbf212
+checksum=9e3e9717eea3bffab8cfb2ff330011be6c8bbd9cdae5b71cef169fcece2f19d3
 # Tarball defines no tests
 make_check=no
 

From 1d621883a4f4b15f51971a1390d1649854212e72 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:59 +0100
Subject: [PATCH 14/14] jupyterlab: update to 3.2.9

---
 srcpkgs/jupyterlab/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/jupyterlab/template b/srcpkgs/jupyterlab/template
index 330d959bc154..133fdab3b206 100644
--- a/srcpkgs/jupyterlab/template
+++ b/srcpkgs/jupyterlab/template
@@ -1,7 +1,7 @@
 # Template file for 'jupyterlab'
 pkgname=jupyterlab
-version=3.2.8
-revision=2
+version=3.2.9
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-jupyterlab_server nodejs python3-nbclassic
@@ -11,7 +11,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="custom:jupyterlab"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyterlab/jupyterlab-${version}.tar.gz"
-checksum=5e4e99868c4f385372686767781408acbb9004b690b198b45597ba869802334b
+checksum=65ddc34e5da1a764606e38c4f70cf9d4ac1c05182813cf0ab2dfea312c701124
 # Tests require unpackaged dependencies
 make_check=no
 

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (15 preceding siblings ...)
  2022-02-14  9:58 ` [PR PATCH] [Updated] " dkwo
@ 2022-02-14 10:00 ` dkwo
  2022-02-14 10:08 ` dkwo
                   ` (33 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-02-14 10:00 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 302 bytes --]

New comment by dkwo on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#issuecomment-1038884694

Comment:
Thanks. I believe those are now fixed. I removed any change to `jupyter_console`. (I will open an issue just to document present status, and not forget about it :)

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (16 preceding siblings ...)
  2022-02-14 10:00 ` dkwo
@ 2022-02-14 10:08 ` dkwo
  2022-02-21  9:42 ` [PR PATCH] [Updated] " dkwo
                   ` (32 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-02-14 10:08 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 150 bytes --]

New comment by dkwo on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#issuecomment-1038893954

Comment:
see #35608 

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR PATCH] [Updated] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (17 preceding siblings ...)
  2022-02-14 10:08 ` dkwo
@ 2022-02-21  9:42 ` dkwo
  2022-02-28 12:49 ` dkwo
                   ` (31 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-02-21  9:42 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 397 bytes --]

There is an updated pull request by dkwo against master on the void-packages repository

https://github.com/dkwo/void-packages pytupd
https://github.com/void-linux/void-packages/pull/35376

update few python3 packages
@ahesford Could you check whether the new jupyter client solves the issue with console?

A patch file from https://github.com/void-linux/void-packages/pull/35376.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-pytupd-35376.patch --]
[-- Type: text/x-diff, Size: 19242 bytes --]

From d66167a63e022e3b3e3191652287c28c4bee972c Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:50:20 +0100
Subject: [PATCH 01/15] python3-bleach: update to 4.1.0

---
 srcpkgs/python3-bleach/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-bleach/template b/srcpkgs/python3-bleach/template
index 21fec4f4b37c..2b8af3b8fbba 100644
--- a/srcpkgs/python3-bleach/template
+++ b/srcpkgs/python3-bleach/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-bleach'
 pkgname=python3-bleach
-version=3.3.0
-revision=2
+version=4.1.0
+revision=1
 wrksrc="bleach-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -13,4 +13,4 @@ license="Apache-2.0"
 homepage="https://github.com/mozilla/bleach"
 changelog="https://raw.githubusercontent.com/mozilla/bleach/master/CHANGES"
 distfiles="${PYPI_SITE}/b/bleach/bleach-${version}.tar.gz"
-checksum=98b3170739e5e83dd9dc19633f074727ad848cbedb6026708c8ac2d3b697a433
+checksum=0900d8b37eba61a802ee40ac0061f8c2b5dee29c1927dd1d233e075ebf5a71da

From 0492da3b953452223b0667c5ba68d0e052988316 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:51:55 +0100
Subject: [PATCH 02/15] python3-defusedxml: update to 0.7.1

---
 srcpkgs/python3-defusedxml/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-defusedxml/template b/srcpkgs/python3-defusedxml/template
index 06bdd57a3526..90dc454d120d 100644
--- a/srcpkgs/python3-defusedxml/template
+++ b/srcpkgs/python3-defusedxml/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-defusedxml'
 pkgname=python3-defusedxml
-version=0.6.0
-revision=5
+version=0.7.1
+revision=1
 wrksrc="defusedxml-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Python-2.0"
 homepage="https://github.com/tiran/defusedxml"
 distfiles="${PYPI_SITE}/d/defusedxml/defusedxml-${version}.tar.gz"
-checksum=f684034d135af4c6cbb949b8a4d2ed61634515257a67299e5f940fbaa34377f5
+checksum=1bb3032db185915b62d7c6209c5a8792be6a32ab2fedacc84e01b52c51aa3e69
 
 post_install() {
 	vlicense LICENSE

From 76f154567f9d58132b3c3614022e0e4697fad2e6 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:54:30 +0100
Subject: [PATCH 03/15] python3-httplib2: update to 0.20.4

---
 srcpkgs/python3-httplib2/template | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-httplib2/template b/srcpkgs/python3-httplib2/template
index d0c39a478622..32fd1c87c2c1 100644
--- a/srcpkgs/python3-httplib2/template
+++ b/srcpkgs/python3-httplib2/template
@@ -1,12 +1,12 @@
 # Template file for 'python3-httplib2'
 pkgname=python3-httplib2
-version=0.18.1
-revision=3
+version=0.20.4
+revision=1
 create_wrksrc=yes
 build_wrksrc="httplib2-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="python3 ca-certificates"
+depends="python3 ca-certificates python3-parsing"
 short_desc="Comprehensive HTTP client library (Python3)"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
@@ -14,8 +14,10 @@ homepage="https://github.com/httplib2/httplib2"
 changelog="https://raw.githubusercontent.com/httplib2/httplib2/master/CHANGELOG"
 distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz
  https://raw.githubusercontent.com/httplib2/httplib2/master/LICENSE>LICENSE.txt"
-checksum="8af66c1c52c7ffe1aa5dc4bcd7c769885254b0756e6e69f953c7f0ab49a70ba3
+checksum="58a98e45b4b1a48273073f905d2961666ecf0fbac4250ea5b47aef259eb5c585
  589eec38f72df2be203711d3b8cbece9b908c5e7ff00bc3cab7f63bae9e366b4"
+# Testing via this command is deprecated
+make_check=no
 
 post_install() {
 	# use system ca certificates

From 07e7de87a197bbf84b5b225e066f2391ef68f71c Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:55:53 +0100
Subject: [PATCH 04/15] python3-ipython_ipykernel: update to 6.8.0

---
 srcpkgs/python3-ipython_ipykernel/template | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-ipython_ipykernel/template b/srcpkgs/python3-ipython_ipykernel/template
index f00e0a3f1a0c..b75796ca0262 100644
--- a/srcpkgs/python3-ipython_ipykernel/template
+++ b/srcpkgs/python3-ipython_ipykernel/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-ipython_ipykernel'
 pkgname=python3-ipython_ipykernel
-version=5.5.4
-revision=2
+version=6.8.0
+revision=1
 wrksrc="ipykernel-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools python3-ipython
- python3-jupyter_client python3-traitlets python3-tornado"
-depends="python3-ipython python3-traitlets python3-jupyter_client python3-tornado"
+ python3-jupyter_client python3-traitlets python3-tornado python3-entrypoints"
+depends="python3-ipython python3-traitlets python3-jupyter_client
+ python3-tornado python3-entrypoints python3-nest_asyncio"
 short_desc="IPython kernel for Jupyter (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/ipykernel"
 distfiles="${PYPI_SITE}/i/ipykernel/ipykernel-${version}.tar.gz"
-checksum=1ce0e83672cc3bfdc1ffb5603e1d77ab125f24b41abc4612e22bfb3e994c0db2
+checksum=67d316d527eca24e3ded45a2b38689615bcda1aa520a11af0accdcea7152c18a
 # checks create a cycle with python3-jupyter_core and python3-jupyter_client
 make_check=no
 

From 66baec384cbee2899ffd4353ab34ea2550621f6b Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:57:38 +0100
Subject: [PATCH 05/15] python3-jsonschema: update to 4.4.0

---
 srcpkgs/python3-jsonschema/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-jsonschema/template b/srcpkgs/python3-jsonschema/template
index 82f45e037865..120392ad1be3 100644
--- a/srcpkgs/python3-jsonschema/template
+++ b/srcpkgs/python3-jsonschema/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-jsonschema'
 pkgname=python3-jsonschema
-version=4.2.1
+version=4.4.0
 revision=1
 wrksrc="jsonschema-${version}"
 build_style=python3-pep517
@@ -14,7 +14,7 @@ license="MIT"
 homepage="https://github.com/Julian/jsonschema"
 changelog="https://raw.githubusercontent.com/Julian/jsonschema/master/CHANGELOG.rst"
 distfiles="${PYPI_SITE}/j/jsonschema/jsonschema-${version}.tar.gz"
-checksum=390713469ae64b8a58698bb3cbc3859abe6925b565a973f87323ef21b09a27a8
+checksum=636694eb41b3535ed608fe04129f26542b59ed99808b4f688aa32dcf55317a83
 
 post_install() {
 	vlicense COPYING LICENSE

From f7694dc7a8922fbc523c9fb8deac297ff44fe0a5 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:04:52 +0100
Subject: [PATCH 06/15] python3-jupyter_client: update to 7.1.2

---
 srcpkgs/python3-jupyter_client/template | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-jupyter_client/template b/srcpkgs/python3-jupyter_client/template
index be6aa5594095..c3906f07e7b4 100644
--- a/srcpkgs/python3-jupyter_client/template
+++ b/srcpkgs/python3-jupyter_client/template
@@ -1,19 +1,18 @@
 # Template file for 'python3-jupyter_client'
 pkgname=python3-jupyter_client
-# delay 6.2 until jupyter/jupyter_console#241 is fixed
-version=6.1.12
-revision=2
+version=7.1.1
+revision=1
 wrksrc="jupyter_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-traitlets python3-jupyter_core python3-pyzmq
- python3-dateutil python3-tornado python3-nest_asyncio"
+ python3-dateutil python3-tornado python3-nest_asyncio python3-entrypoints"
 short_desc="Jupyter protocol client APIs"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_client"
 distfiles="${PYPI_SITE}/j/jupyter_client/jupyter_client-${version}.tar.gz"
-checksum=c4bca1d0846186ca8be97f4d2fa6d2bae889cce4892a167ffa1ba6bd1f73e782
+checksum=540ca35e57e83c5ece81abd9b781a57cba39a37c60a2a30c8c1b2f6663544343
 conflicts="python-jupyter_client<=5.2.4_2"
 # checks create a cycle with python3-jupyter_core and python3-ipython_ipykernel
 make_check=no

From c9876f478ed13f1a0bcda7b7c937a570e2e38b6d Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:06:12 +0100
Subject: [PATCH 07/15] python3-jupyter_core: update to 4.9.1

---
 srcpkgs/python3-jupyter_core/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_core/template b/srcpkgs/python3-jupyter_core/template
index d0fa364a6751..5f450d293d4f 100644
--- a/srcpkgs/python3-jupyter_core/template
+++ b/srcpkgs/python3-jupyter_core/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_core'
 pkgname=python3-jupyter_core
-version=4.7.1
-revision=2
+version=4.9.1
+revision=1
 wrksrc="jupyter_core-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter_core/jupyter_core-${version}.tar.gz"
-checksum=79025cb3225efcd36847d0840f3fc672c0abd7afd0de83ba8a1d3837619122b4
+checksum=dce8a7499da5a53ae3afd5a9f4b02e5df1d57250cf48f3ad79da23b4778cd6fa
 conflicts="python-jupyter_core<=4.4.0_3"
 # checks create a cycle with python3-jypter_client and python3-ipython_ipykernel
 make_check=no

From 4d5a00915d39eff25e06492778ee9f731b10c926 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:07:34 +0100
Subject: [PATCH 08/15] python3-jupyter_notebook: update to 6.4.8

---
 srcpkgs/python3-jupyter_notebook/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_notebook/template b/srcpkgs/python3-jupyter_notebook/template
index ca9e1d43df21..f1ec68546fd9 100644
--- a/srcpkgs/python3-jupyter_notebook/template
+++ b/srcpkgs/python3-jupyter_notebook/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_notebook'
 pkgname=python3-jupyter_notebook
-version=6.3.0
-revision=2
+version=6.4.8
+revision=1
 wrksrc="notebook-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -15,7 +15,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org/"
 distfiles="${PYPI_SITE}/n/notebook/notebook-${version}.tar.gz"
-checksum=cbc9398d6c81473e9cdb891d2cae9c0d3718fca289dda6d26df5cb660fcadc7d
+checksum=1e985c9dc6f678bdfffb9dc657306b5469bfa62d73e03f74e8defbf76d284312
 conflicts="python-jupyter_notebook<=5.7.0_2"
 # Tests require unpackaged selenium
 make_check=no

From 3cc3a014b78b7d12733d2cbdc88b3400e0c623b0 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:14:36 +0100
Subject: [PATCH 09/15] python3-paramiko: update to 2.9.2

---
 srcpkgs/python3-paramiko/template | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-paramiko/template b/srcpkgs/python3-paramiko/template
index cff1b3a2fb59..a11808886b73 100644
--- a/srcpkgs/python3-paramiko/template
+++ b/srcpkgs/python3-paramiko/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-paramiko'
 pkgname=python3-paramiko
-version=2.7.2
-revision=2
+version=2.9.2
+revision=1
 wrksrc="${pkgname#*-}-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,4 +11,6 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="LGPL-2.1-or-later"
 homepage="http://www.paramiko.org/"
 distfiles="${PYPI_SITE}/p/paramiko/paramiko-${version}.tar.gz"
-checksum=7f36f4ba2c0d81d219f4595e35f70d56cc94f9ac40a6acdf51d6ca210ce65035
+checksum=944a9e5dbdd413ab6c7951ea46b0ab40713235a9c4c5ca81cfe45c6f14fa677b
+# Testing via this command is deprecated
+make_check=no

From eb91dfca817e74070fa621bdea4cd861786dd131 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:16:02 +0100
Subject: [PATCH 10/15] python3-prometheus_client: update to 0.13.1

---
 srcpkgs/python3-prometheus_client/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-prometheus_client/template b/srcpkgs/python3-prometheus_client/template
index 82e4da1f3edd..739013270799 100644
--- a/srcpkgs/python3-prometheus_client/template
+++ b/srcpkgs/python3-prometheus_client/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-prometheus_client'
 pkgname=python3-prometheus_client
-version=0.9.0
-revision=2
+version=0.13.1
+revision=1
 wrksrc="prometheus_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,4 +12,4 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Apache-2.0"
 homepage="https://github.com/prometheus/client_python"
 distfiles="${PYPI_SITE}/p/prometheus_client/prometheus_client-${version}.tar.gz"
-checksum=9da7b32f02439d8c04f7777021c304ed51d9ec180604700c1ba72a4d44dceb03
+checksum=ada41b891b79fca5638bd5cfe149efa86512eaa55987893becd2c6d8d0a5dfc5

From 156d5a142eef6700e22390f61f11099dafdd7ac9 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:17:21 +0100
Subject: [PATCH 11/15] python3-soupsieve: update to 2.3.1

---
 srcpkgs/python3-soupsieve/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-soupsieve/template b/srcpkgs/python3-soupsieve/template
index 14449f20c47f..bb63a5ec0952 100644
--- a/srcpkgs/python3-soupsieve/template
+++ b/srcpkgs/python3-soupsieve/template
@@ -1,18 +1,18 @@
 # Template file for 'python3-soupsieve'
 pkgname=python3-soupsieve
-version=1.9.5
-revision=6
+version=2.3.1
+revision=1
 wrksrc="soupsieve-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="python3"
+depends="python3 python3-BeautifulSoup4"
 checkdepends="python3-pytest python3-lxml python3-html5lib python3-BeautifulSoup4"
 short_desc="CSS4 selector implementation for Python3 Beautiful Soup"
 maintainer="Aluísio Augusto Silva Gonçalves <aluisio@aasg.name>"
 license="MIT"
 homepage="https://facelessuser.github.io/soupsieve/"
 distfiles="${PYPI_SITE}/s/soupsieve/soupsieve-${version}.tar.gz"
-checksum=e2c1c5dee4a1c36bcb790e0fabd5492d874b8ebd4617622c4f6a731701060dda
+checksum=b8d49b1cd4f037c7082a9683dfa1801aa2597fb11c3a1155b7a5b94829b4f1f9
 
 post_install() {
 	vlicense LICENSE.md

From 28ef3224467fee4f9b347a7eceafa33d9c4a6082 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:20:35 +0100
Subject: [PATCH 12/15] python3-terminado: update to 0.13.0

---
 srcpkgs/python3-terminado/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-terminado/template b/srcpkgs/python3-terminado/template
index 28c65c82ba99..e299a6ca8c4f 100644
--- a/srcpkgs/python3-terminado/template
+++ b/srcpkgs/python3-terminado/template
@@ -1,10 +1,10 @@
 # Template file for 'python3-terminado'
 pkgname=python3-terminado
-version=0.9.4
-revision=2
+version=0.13.0
+revision=1
 wrksrc="terminado-${version}"
 build_style=python3-module
-hostmakedepends="python3-setuptools"
+hostmakedepends="python3-setuptools python3-tornado"
 depends="python3-ptyprocess python3-tornado"
 checkdepends="python3-pytest $depends"
 short_desc="Terminals served to term.js using Tornado websockets (Python3)"
@@ -12,7 +12,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/takluyver/terminado"
 distfiles="${PYPI_SITE}/t/terminado/terminado-${version}.tar.gz"
-checksum=9a7dbcfbc2778830eeb70261bf7aa9d98a3eac8631a3afe3febeb57c12f798be
+checksum=713531ccb5db7d4f544651f14050da79809030f00d1afa21462088cf32fb143a
 
 post_install() {
 	vlicense LICENSE

From 18a46e8d09dd11b0984bf6e154315778f3995f9b Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:43 +0100
Subject: [PATCH 13/15] python3-jupyter_server: update to 1.13.5

---
 srcpkgs/python3-jupyter_server/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-jupyter_server/template b/srcpkgs/python3-jupyter_server/template
index 4e6d8a6fe52a..e872ca652d59 100644
--- a/srcpkgs/python3-jupyter_server/template
+++ b/srcpkgs/python3-jupyter_server/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-jupyter_server'
 pkgname=python3-jupyter_server
-version=1.13.4
+version=1.13.5
 revision=1
 wrksrc="jupyter_server-${version}"
 build_style=python3-module
@@ -14,7 +14,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter-server/jupyter_server-${version}.tar.gz"
-checksum=5fb5a219385338b1d13a013a68f54688b6a69ecff4e757fd230e27ecacdbf212
+checksum=9e3e9717eea3bffab8cfb2ff330011be6c8bbd9cdae5b71cef169fcece2f19d3
 # Tarball defines no tests
 make_check=no
 

From fe8898e37a89439104ec58325936312ef6dd7695 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:59 +0100
Subject: [PATCH 14/15] jupyterlab: update to 3.2.9

---
 srcpkgs/jupyterlab/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/jupyterlab/template b/srcpkgs/jupyterlab/template
index 330d959bc154..133fdab3b206 100644
--- a/srcpkgs/jupyterlab/template
+++ b/srcpkgs/jupyterlab/template
@@ -1,7 +1,7 @@
 # Template file for 'jupyterlab'
 pkgname=jupyterlab
-version=3.2.8
-revision=2
+version=3.2.9
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-jupyterlab_server nodejs python3-nbclassic
@@ -11,7 +11,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="custom:jupyterlab"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyterlab/jupyterlab-${version}.tar.gz"
-checksum=5e4e99868c4f385372686767781408acbb9004b690b198b45597ba869802334b
+checksum=65ddc34e5da1a764606e38c4f70cf9d4ac1c05182813cf0ab2dfea312c701124
 # Tests require unpackaged dependencies
 make_check=no
 

From 1d1943d7b15e2aae438b149eb6b280c6553ab0be Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Mon, 21 Feb 2022 10:41:56 +0100
Subject: [PATCH 15/15] python3-nbclient: update to 0.5.11

---
 srcpkgs/python3-nbclient/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-nbclient/template b/srcpkgs/python3-nbclient/template
index 24f9242016fb..db15eacda5ee 100644
--- a/srcpkgs/python3-nbclient/template
+++ b/srcpkgs/python3-nbclient/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-nbclient'
 pkgname=python3-nbclient
-version=0.5.10
+version=0.5.11
 revision=1
 wrksrc="${pkgname#python3-}-${version}"
 build_style=python3-module
@@ -12,7 +12,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://nbclient.readthedocs.io/en/latest/"
 distfiles="${PYPI_SITE}/n/nbclient/nbclient-${version}.tar.gz"
-checksum=b5fdea88d6fa52ca38de6c2361401cfe7aaa7cd24c74effc5e489cec04d79088
+checksum=751516992f34b58172bad54eef1e4bf7e4f4460d58e255ca1a4e5c9649476007
 # Package might need to be installed for testing
 make_check=no
 

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR PATCH] [Updated] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (18 preceding siblings ...)
  2022-02-21  9:42 ` [PR PATCH] [Updated] " dkwo
@ 2022-02-28 12:49 ` dkwo
  2022-03-11 17:38 ` dkwo
                   ` (30 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-02-28 12:49 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 397 bytes --]

There is an updated pull request by dkwo against master on the void-packages repository

https://github.com/dkwo/void-packages pytupd
https://github.com/void-linux/void-packages/pull/35376

update few python3 packages
@ahesford Could you check whether the new jupyter client solves the issue with console?

A patch file from https://github.com/void-linux/void-packages/pull/35376.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-pytupd-35376.patch --]
[-- Type: text/x-diff, Size: 15805 bytes --]

From cb3bc15937ae31f53851b9fdd96ca9b02b2af47c Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:51:55 +0100
Subject: [PATCH 01/12] python3-defusedxml: update to 0.7.1

---
 srcpkgs/python3-defusedxml/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-defusedxml/template b/srcpkgs/python3-defusedxml/template
index 06bdd57a3526..90dc454d120d 100644
--- a/srcpkgs/python3-defusedxml/template
+++ b/srcpkgs/python3-defusedxml/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-defusedxml'
 pkgname=python3-defusedxml
-version=0.6.0
-revision=5
+version=0.7.1
+revision=1
 wrksrc="defusedxml-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Python-2.0"
 homepage="https://github.com/tiran/defusedxml"
 distfiles="${PYPI_SITE}/d/defusedxml/defusedxml-${version}.tar.gz"
-checksum=f684034d135af4c6cbb949b8a4d2ed61634515257a67299e5f940fbaa34377f5
+checksum=1bb3032db185915b62d7c6209c5a8792be6a32ab2fedacc84e01b52c51aa3e69
 
 post_install() {
 	vlicense LICENSE

From aebc0cc458204a4db8ef129adddab335d8846e49 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:54:30 +0100
Subject: [PATCH 02/12] python3-httplib2: update to 0.20.4

---
 srcpkgs/python3-httplib2/template | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-httplib2/template b/srcpkgs/python3-httplib2/template
index d0c39a478622..32fd1c87c2c1 100644
--- a/srcpkgs/python3-httplib2/template
+++ b/srcpkgs/python3-httplib2/template
@@ -1,12 +1,12 @@
 # Template file for 'python3-httplib2'
 pkgname=python3-httplib2
-version=0.18.1
-revision=3
+version=0.20.4
+revision=1
 create_wrksrc=yes
 build_wrksrc="httplib2-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="python3 ca-certificates"
+depends="python3 ca-certificates python3-parsing"
 short_desc="Comprehensive HTTP client library (Python3)"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
@@ -14,8 +14,10 @@ homepage="https://github.com/httplib2/httplib2"
 changelog="https://raw.githubusercontent.com/httplib2/httplib2/master/CHANGELOG"
 distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz
  https://raw.githubusercontent.com/httplib2/httplib2/master/LICENSE>LICENSE.txt"
-checksum="8af66c1c52c7ffe1aa5dc4bcd7c769885254b0756e6e69f953c7f0ab49a70ba3
+checksum="58a98e45b4b1a48273073f905d2961666ecf0fbac4250ea5b47aef259eb5c585
  589eec38f72df2be203711d3b8cbece9b908c5e7ff00bc3cab7f63bae9e366b4"
+# Testing via this command is deprecated
+make_check=no
 
 post_install() {
 	# use system ca certificates

From 8e76da0289c893b52023a9fc526aee9327de5102 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:55:53 +0100
Subject: [PATCH 03/12] python3-ipython_ipykernel: update to 6.8.0

---
 srcpkgs/python3-ipython_ipykernel/template | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-ipython_ipykernel/template b/srcpkgs/python3-ipython_ipykernel/template
index f00e0a3f1a0c..b75796ca0262 100644
--- a/srcpkgs/python3-ipython_ipykernel/template
+++ b/srcpkgs/python3-ipython_ipykernel/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-ipython_ipykernel'
 pkgname=python3-ipython_ipykernel
-version=5.5.4
-revision=2
+version=6.8.0
+revision=1
 wrksrc="ipykernel-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools python3-ipython
- python3-jupyter_client python3-traitlets python3-tornado"
-depends="python3-ipython python3-traitlets python3-jupyter_client python3-tornado"
+ python3-jupyter_client python3-traitlets python3-tornado python3-entrypoints"
+depends="python3-ipython python3-traitlets python3-jupyter_client
+ python3-tornado python3-entrypoints python3-nest_asyncio"
 short_desc="IPython kernel for Jupyter (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/ipykernel"
 distfiles="${PYPI_SITE}/i/ipykernel/ipykernel-${version}.tar.gz"
-checksum=1ce0e83672cc3bfdc1ffb5603e1d77ab125f24b41abc4612e22bfb3e994c0db2
+checksum=67d316d527eca24e3ded45a2b38689615bcda1aa520a11af0accdcea7152c18a
 # checks create a cycle with python3-jupyter_core and python3-jupyter_client
 make_check=no
 

From 260482fa54fa956f3c56e624b605cd2ad020d845 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:04:52 +0100
Subject: [PATCH 04/12] python3-jupyter_client: update to 7.1.2

---
 srcpkgs/python3-jupyter_client/template | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-jupyter_client/template b/srcpkgs/python3-jupyter_client/template
index be6aa5594095..c3906f07e7b4 100644
--- a/srcpkgs/python3-jupyter_client/template
+++ b/srcpkgs/python3-jupyter_client/template
@@ -1,19 +1,18 @@
 # Template file for 'python3-jupyter_client'
 pkgname=python3-jupyter_client
-# delay 6.2 until jupyter/jupyter_console#241 is fixed
-version=6.1.12
-revision=2
+version=7.1.1
+revision=1
 wrksrc="jupyter_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-traitlets python3-jupyter_core python3-pyzmq
- python3-dateutil python3-tornado python3-nest_asyncio"
+ python3-dateutil python3-tornado python3-nest_asyncio python3-entrypoints"
 short_desc="Jupyter protocol client APIs"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_client"
 distfiles="${PYPI_SITE}/j/jupyter_client/jupyter_client-${version}.tar.gz"
-checksum=c4bca1d0846186ca8be97f4d2fa6d2bae889cce4892a167ffa1ba6bd1f73e782
+checksum=540ca35e57e83c5ece81abd9b781a57cba39a37c60a2a30c8c1b2f6663544343
 conflicts="python-jupyter_client<=5.2.4_2"
 # checks create a cycle with python3-jupyter_core and python3-ipython_ipykernel
 make_check=no

From c32d729c47767b7fa517946622371b87bec2ef0a Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:06:12 +0100
Subject: [PATCH 05/12] python3-jupyter_core: update to 4.9.1

---
 srcpkgs/python3-jupyter_core/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_core/template b/srcpkgs/python3-jupyter_core/template
index d0fa364a6751..5f450d293d4f 100644
--- a/srcpkgs/python3-jupyter_core/template
+++ b/srcpkgs/python3-jupyter_core/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_core'
 pkgname=python3-jupyter_core
-version=4.7.1
-revision=2
+version=4.9.1
+revision=1
 wrksrc="jupyter_core-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter_core/jupyter_core-${version}.tar.gz"
-checksum=79025cb3225efcd36847d0840f3fc672c0abd7afd0de83ba8a1d3837619122b4
+checksum=dce8a7499da5a53ae3afd5a9f4b02e5df1d57250cf48f3ad79da23b4778cd6fa
 conflicts="python-jupyter_core<=4.4.0_3"
 # checks create a cycle with python3-jypter_client and python3-ipython_ipykernel
 make_check=no

From 903dc8dd72a451f1171f5c24e9c40c1a9e62e14e Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:07:34 +0100
Subject: [PATCH 06/12] python3-jupyter_notebook: update to 6.4.8

---
 srcpkgs/python3-jupyter_notebook/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_notebook/template b/srcpkgs/python3-jupyter_notebook/template
index ca9e1d43df21..f1ec68546fd9 100644
--- a/srcpkgs/python3-jupyter_notebook/template
+++ b/srcpkgs/python3-jupyter_notebook/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_notebook'
 pkgname=python3-jupyter_notebook
-version=6.3.0
-revision=2
+version=6.4.8
+revision=1
 wrksrc="notebook-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -15,7 +15,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org/"
 distfiles="${PYPI_SITE}/n/notebook/notebook-${version}.tar.gz"
-checksum=cbc9398d6c81473e9cdb891d2cae9c0d3718fca289dda6d26df5cb660fcadc7d
+checksum=1e985c9dc6f678bdfffb9dc657306b5469bfa62d73e03f74e8defbf76d284312
 conflicts="python-jupyter_notebook<=5.7.0_2"
 # Tests require unpackaged selenium
 make_check=no

From 6b347e95a0595e413a420c1a0744256941a15549 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:14:36 +0100
Subject: [PATCH 07/12] python3-paramiko: update to 2.9.2

---
 srcpkgs/python3-paramiko/template | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-paramiko/template b/srcpkgs/python3-paramiko/template
index cff1b3a2fb59..a11808886b73 100644
--- a/srcpkgs/python3-paramiko/template
+++ b/srcpkgs/python3-paramiko/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-paramiko'
 pkgname=python3-paramiko
-version=2.7.2
-revision=2
+version=2.9.2
+revision=1
 wrksrc="${pkgname#*-}-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,4 +11,6 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="LGPL-2.1-or-later"
 homepage="http://www.paramiko.org/"
 distfiles="${PYPI_SITE}/p/paramiko/paramiko-${version}.tar.gz"
-checksum=7f36f4ba2c0d81d219f4595e35f70d56cc94f9ac40a6acdf51d6ca210ce65035
+checksum=944a9e5dbdd413ab6c7951ea46b0ab40713235a9c4c5ca81cfe45c6f14fa677b
+# Testing via this command is deprecated
+make_check=no

From 65a3b71b35ffde8b1f18993939236044d5d74149 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:17:21 +0100
Subject: [PATCH 08/12] python3-soupsieve: update to 2.3.1

---
 srcpkgs/python3-soupsieve/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-soupsieve/template b/srcpkgs/python3-soupsieve/template
index 14449f20c47f..bb63a5ec0952 100644
--- a/srcpkgs/python3-soupsieve/template
+++ b/srcpkgs/python3-soupsieve/template
@@ -1,18 +1,18 @@
 # Template file for 'python3-soupsieve'
 pkgname=python3-soupsieve
-version=1.9.5
-revision=6
+version=2.3.1
+revision=1
 wrksrc="soupsieve-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="python3"
+depends="python3 python3-BeautifulSoup4"
 checkdepends="python3-pytest python3-lxml python3-html5lib python3-BeautifulSoup4"
 short_desc="CSS4 selector implementation for Python3 Beautiful Soup"
 maintainer="Aluísio Augusto Silva Gonçalves <aluisio@aasg.name>"
 license="MIT"
 homepage="https://facelessuser.github.io/soupsieve/"
 distfiles="${PYPI_SITE}/s/soupsieve/soupsieve-${version}.tar.gz"
-checksum=e2c1c5dee4a1c36bcb790e0fabd5492d874b8ebd4617622c4f6a731701060dda
+checksum=b8d49b1cd4f037c7082a9683dfa1801aa2597fb11c3a1155b7a5b94829b4f1f9
 
 post_install() {
 	vlicense LICENSE.md

From 7e99b57a484a96f10ebdede6213d0c6aa51cd584 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:20:35 +0100
Subject: [PATCH 09/12] python3-terminado: update to 0.13.0

---
 srcpkgs/python3-terminado/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-terminado/template b/srcpkgs/python3-terminado/template
index 28c65c82ba99..e299a6ca8c4f 100644
--- a/srcpkgs/python3-terminado/template
+++ b/srcpkgs/python3-terminado/template
@@ -1,10 +1,10 @@
 # Template file for 'python3-terminado'
 pkgname=python3-terminado
-version=0.9.4
-revision=2
+version=0.13.0
+revision=1
 wrksrc="terminado-${version}"
 build_style=python3-module
-hostmakedepends="python3-setuptools"
+hostmakedepends="python3-setuptools python3-tornado"
 depends="python3-ptyprocess python3-tornado"
 checkdepends="python3-pytest $depends"
 short_desc="Terminals served to term.js using Tornado websockets (Python3)"
@@ -12,7 +12,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/takluyver/terminado"
 distfiles="${PYPI_SITE}/t/terminado/terminado-${version}.tar.gz"
-checksum=9a7dbcfbc2778830eeb70261bf7aa9d98a3eac8631a3afe3febeb57c12f798be
+checksum=713531ccb5db7d4f544651f14050da79809030f00d1afa21462088cf32fb143a
 
 post_install() {
 	vlicense LICENSE

From b82d3613c061d578645399383492372cd964c64c Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:43 +0100
Subject: [PATCH 10/12] python3-jupyter_server: update to 1.13.5

---
 srcpkgs/python3-jupyter_server/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-jupyter_server/template b/srcpkgs/python3-jupyter_server/template
index 4e6d8a6fe52a..e872ca652d59 100644
--- a/srcpkgs/python3-jupyter_server/template
+++ b/srcpkgs/python3-jupyter_server/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-jupyter_server'
 pkgname=python3-jupyter_server
-version=1.13.4
+version=1.13.5
 revision=1
 wrksrc="jupyter_server-${version}"
 build_style=python3-module
@@ -14,7 +14,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter-server/jupyter_server-${version}.tar.gz"
-checksum=5fb5a219385338b1d13a013a68f54688b6a69ecff4e757fd230e27ecacdbf212
+checksum=9e3e9717eea3bffab8cfb2ff330011be6c8bbd9cdae5b71cef169fcece2f19d3
 # Tarball defines no tests
 make_check=no
 

From 52717dd22a286f9d4a77b423f7e2366da9241f77 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:59 +0100
Subject: [PATCH 11/12] jupyterlab: update to 3.2.9

---
 srcpkgs/jupyterlab/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/jupyterlab/template b/srcpkgs/jupyterlab/template
index 330d959bc154..133fdab3b206 100644
--- a/srcpkgs/jupyterlab/template
+++ b/srcpkgs/jupyterlab/template
@@ -1,7 +1,7 @@
 # Template file for 'jupyterlab'
 pkgname=jupyterlab
-version=3.2.8
-revision=2
+version=3.2.9
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-jupyterlab_server nodejs python3-nbclassic
@@ -11,7 +11,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="custom:jupyterlab"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyterlab/jupyterlab-${version}.tar.gz"
-checksum=5e4e99868c4f385372686767781408acbb9004b690b198b45597ba869802334b
+checksum=65ddc34e5da1a764606e38c4f70cf9d4ac1c05182813cf0ab2dfea312c701124
 # Tests require unpackaged dependencies
 make_check=no
 

From 1115520f807a265668f23b7459eaffd89f734d07 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Mon, 21 Feb 2022 10:41:56 +0100
Subject: [PATCH 12/12] python3-nbclient: update to 0.5.11

---
 srcpkgs/python3-nbclient/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-nbclient/template b/srcpkgs/python3-nbclient/template
index 24f9242016fb..db15eacda5ee 100644
--- a/srcpkgs/python3-nbclient/template
+++ b/srcpkgs/python3-nbclient/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-nbclient'
 pkgname=python3-nbclient
-version=0.5.10
+version=0.5.11
 revision=1
 wrksrc="${pkgname#python3-}-${version}"
 build_style=python3-module
@@ -12,7 +12,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://nbclient.readthedocs.io/en/latest/"
 distfiles="${PYPI_SITE}/n/nbclient/nbclient-${version}.tar.gz"
-checksum=b5fdea88d6fa52ca38de6c2361401cfe7aaa7cd24c74effc5e489cec04d79088
+checksum=751516992f34b58172bad54eef1e4bf7e4f4460d58e255ca1a4e5c9649476007
 # Package might need to be installed for testing
 make_check=no
 

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR PATCH] [Updated] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (19 preceding siblings ...)
  2022-02-28 12:49 ` dkwo
@ 2022-03-11 17:38 ` dkwo
  2022-03-11 17:41 ` dkwo
                   ` (29 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-03-11 17:38 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 397 bytes --]

There is an updated pull request by dkwo against master on the void-packages repository

https://github.com/dkwo/void-packages pytupd
https://github.com/void-linux/void-packages/pull/35376

update few python3 packages
@ahesford Could you check whether the new jupyter client solves the issue with console?

A patch file from https://github.com/void-linux/void-packages/pull/35376.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-pytupd-35376.patch --]
[-- Type: text/x-diff, Size: 19658 bytes --]

From bbabe5bf6f2b120c047a64dc91ac2359e42c66d4 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:51:55 +0100
Subject: [PATCH 01/15] python3-defusedxml: update to 0.7.1

---
 srcpkgs/python3-defusedxml/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-defusedxml/template b/srcpkgs/python3-defusedxml/template
index 06bdd57a3526..90dc454d120d 100644
--- a/srcpkgs/python3-defusedxml/template
+++ b/srcpkgs/python3-defusedxml/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-defusedxml'
 pkgname=python3-defusedxml
-version=0.6.0
-revision=5
+version=0.7.1
+revision=1
 wrksrc="defusedxml-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Python-2.0"
 homepage="https://github.com/tiran/defusedxml"
 distfiles="${PYPI_SITE}/d/defusedxml/defusedxml-${version}.tar.gz"
-checksum=f684034d135af4c6cbb949b8a4d2ed61634515257a67299e5f940fbaa34377f5
+checksum=1bb3032db185915b62d7c6209c5a8792be6a32ab2fedacc84e01b52c51aa3e69
 
 post_install() {
 	vlicense LICENSE

From 762dec664c53bb0cef466d1040850422e46aa2de Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:54:30 +0100
Subject: [PATCH 02/15] python3-httplib2: update to 0.20.4

---
 srcpkgs/python3-httplib2/template | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-httplib2/template b/srcpkgs/python3-httplib2/template
index d0c39a478622..32fd1c87c2c1 100644
--- a/srcpkgs/python3-httplib2/template
+++ b/srcpkgs/python3-httplib2/template
@@ -1,12 +1,12 @@
 # Template file for 'python3-httplib2'
 pkgname=python3-httplib2
-version=0.18.1
-revision=3
+version=0.20.4
+revision=1
 create_wrksrc=yes
 build_wrksrc="httplib2-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="python3 ca-certificates"
+depends="python3 ca-certificates python3-parsing"
 short_desc="Comprehensive HTTP client library (Python3)"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
@@ -14,8 +14,10 @@ homepage="https://github.com/httplib2/httplib2"
 changelog="https://raw.githubusercontent.com/httplib2/httplib2/master/CHANGELOG"
 distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz
  https://raw.githubusercontent.com/httplib2/httplib2/master/LICENSE>LICENSE.txt"
-checksum="8af66c1c52c7ffe1aa5dc4bcd7c769885254b0756e6e69f953c7f0ab49a70ba3
+checksum="58a98e45b4b1a48273073f905d2961666ecf0fbac4250ea5b47aef259eb5c585
  589eec38f72df2be203711d3b8cbece9b908c5e7ff00bc3cab7f63bae9e366b4"
+# Testing via this command is deprecated
+make_check=no
 
 post_install() {
 	# use system ca certificates

From 1bc9bfb61e60c93b5ab43b81a0a57f33c63fe556 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:55:53 +0100
Subject: [PATCH 03/15] python3-ipython_ipykernel: update to 6.8.0

---
 srcpkgs/python3-ipython_ipykernel/template | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-ipython_ipykernel/template b/srcpkgs/python3-ipython_ipykernel/template
index f00e0a3f1a0c..b75796ca0262 100644
--- a/srcpkgs/python3-ipython_ipykernel/template
+++ b/srcpkgs/python3-ipython_ipykernel/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-ipython_ipykernel'
 pkgname=python3-ipython_ipykernel
-version=5.5.4
-revision=2
+version=6.8.0
+revision=1
 wrksrc="ipykernel-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools python3-ipython
- python3-jupyter_client python3-traitlets python3-tornado"
-depends="python3-ipython python3-traitlets python3-jupyter_client python3-tornado"
+ python3-jupyter_client python3-traitlets python3-tornado python3-entrypoints"
+depends="python3-ipython python3-traitlets python3-jupyter_client
+ python3-tornado python3-entrypoints python3-nest_asyncio"
 short_desc="IPython kernel for Jupyter (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/ipykernel"
 distfiles="${PYPI_SITE}/i/ipykernel/ipykernel-${version}.tar.gz"
-checksum=1ce0e83672cc3bfdc1ffb5603e1d77ab125f24b41abc4612e22bfb3e994c0db2
+checksum=67d316d527eca24e3ded45a2b38689615bcda1aa520a11af0accdcea7152c18a
 # checks create a cycle with python3-jupyter_core and python3-jupyter_client
 make_check=no
 

From 3bcd559dd55e17c8d69186fddd083cfdba304996 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:04:52 +0100
Subject: [PATCH 04/15] python3-jupyter_client: update to 7.1.2

---
 srcpkgs/python3-jupyter_client/template | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-jupyter_client/template b/srcpkgs/python3-jupyter_client/template
index be6aa5594095..c3906f07e7b4 100644
--- a/srcpkgs/python3-jupyter_client/template
+++ b/srcpkgs/python3-jupyter_client/template
@@ -1,19 +1,18 @@
 # Template file for 'python3-jupyter_client'
 pkgname=python3-jupyter_client
-# delay 6.2 until jupyter/jupyter_console#241 is fixed
-version=6.1.12
-revision=2
+version=7.1.1
+revision=1
 wrksrc="jupyter_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-traitlets python3-jupyter_core python3-pyzmq
- python3-dateutil python3-tornado python3-nest_asyncio"
+ python3-dateutil python3-tornado python3-nest_asyncio python3-entrypoints"
 short_desc="Jupyter protocol client APIs"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_client"
 distfiles="${PYPI_SITE}/j/jupyter_client/jupyter_client-${version}.tar.gz"
-checksum=c4bca1d0846186ca8be97f4d2fa6d2bae889cce4892a167ffa1ba6bd1f73e782
+checksum=540ca35e57e83c5ece81abd9b781a57cba39a37c60a2a30c8c1b2f6663544343
 conflicts="python-jupyter_client<=5.2.4_2"
 # checks create a cycle with python3-jupyter_core and python3-ipython_ipykernel
 make_check=no

From d58af0537e597fd806af599bc8af104932dbff64 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:06:12 +0100
Subject: [PATCH 05/15] python3-jupyter_core: update to 4.9.1

---
 srcpkgs/python3-jupyter_core/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_core/template b/srcpkgs/python3-jupyter_core/template
index d0fa364a6751..5f450d293d4f 100644
--- a/srcpkgs/python3-jupyter_core/template
+++ b/srcpkgs/python3-jupyter_core/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_core'
 pkgname=python3-jupyter_core
-version=4.7.1
-revision=2
+version=4.9.1
+revision=1
 wrksrc="jupyter_core-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter_core/jupyter_core-${version}.tar.gz"
-checksum=79025cb3225efcd36847d0840f3fc672c0abd7afd0de83ba8a1d3837619122b4
+checksum=dce8a7499da5a53ae3afd5a9f4b02e5df1d57250cf48f3ad79da23b4778cd6fa
 conflicts="python-jupyter_core<=4.4.0_3"
 # checks create a cycle with python3-jypter_client and python3-ipython_ipykernel
 make_check=no

From ed92cf14abb4de39771f93a917285941dfd19b38 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:07:34 +0100
Subject: [PATCH 06/15] python3-jupyter_notebook: update to 6.4.8

---
 srcpkgs/python3-jupyter_notebook/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_notebook/template b/srcpkgs/python3-jupyter_notebook/template
index ca9e1d43df21..f1ec68546fd9 100644
--- a/srcpkgs/python3-jupyter_notebook/template
+++ b/srcpkgs/python3-jupyter_notebook/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_notebook'
 pkgname=python3-jupyter_notebook
-version=6.3.0
-revision=2
+version=6.4.8
+revision=1
 wrksrc="notebook-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -15,7 +15,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org/"
 distfiles="${PYPI_SITE}/n/notebook/notebook-${version}.tar.gz"
-checksum=cbc9398d6c81473e9cdb891d2cae9c0d3718fca289dda6d26df5cb660fcadc7d
+checksum=1e985c9dc6f678bdfffb9dc657306b5469bfa62d73e03f74e8defbf76d284312
 conflicts="python-jupyter_notebook<=5.7.0_2"
 # Tests require unpackaged selenium
 make_check=no

From 781ef67faf5da8dbe7f3acc119e71167a9ded301 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:14:36 +0100
Subject: [PATCH 07/15] python3-paramiko: update to 2.9.2

---
 srcpkgs/python3-paramiko/template | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-paramiko/template b/srcpkgs/python3-paramiko/template
index cff1b3a2fb59..a11808886b73 100644
--- a/srcpkgs/python3-paramiko/template
+++ b/srcpkgs/python3-paramiko/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-paramiko'
 pkgname=python3-paramiko
-version=2.7.2
-revision=2
+version=2.9.2
+revision=1
 wrksrc="${pkgname#*-}-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,4 +11,6 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="LGPL-2.1-or-later"
 homepage="http://www.paramiko.org/"
 distfiles="${PYPI_SITE}/p/paramiko/paramiko-${version}.tar.gz"
-checksum=7f36f4ba2c0d81d219f4595e35f70d56cc94f9ac40a6acdf51d6ca210ce65035
+checksum=944a9e5dbdd413ab6c7951ea46b0ab40713235a9c4c5ca81cfe45c6f14fa677b
+# Testing via this command is deprecated
+make_check=no

From 0f8e1a7d9d811d3a1652f253002f007f68e500ed Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:17:21 +0100
Subject: [PATCH 08/15] python3-soupsieve: update to 2.3.1

---
 srcpkgs/python3-soupsieve/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-soupsieve/template b/srcpkgs/python3-soupsieve/template
index 14449f20c47f..bb63a5ec0952 100644
--- a/srcpkgs/python3-soupsieve/template
+++ b/srcpkgs/python3-soupsieve/template
@@ -1,18 +1,18 @@
 # Template file for 'python3-soupsieve'
 pkgname=python3-soupsieve
-version=1.9.5
-revision=6
+version=2.3.1
+revision=1
 wrksrc="soupsieve-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="python3"
+depends="python3 python3-BeautifulSoup4"
 checkdepends="python3-pytest python3-lxml python3-html5lib python3-BeautifulSoup4"
 short_desc="CSS4 selector implementation for Python3 Beautiful Soup"
 maintainer="Aluísio Augusto Silva Gonçalves <aluisio@aasg.name>"
 license="MIT"
 homepage="https://facelessuser.github.io/soupsieve/"
 distfiles="${PYPI_SITE}/s/soupsieve/soupsieve-${version}.tar.gz"
-checksum=e2c1c5dee4a1c36bcb790e0fabd5492d874b8ebd4617622c4f6a731701060dda
+checksum=b8d49b1cd4f037c7082a9683dfa1801aa2597fb11c3a1155b7a5b94829b4f1f9
 
 post_install() {
 	vlicense LICENSE.md

From 2b6ea51638aa56b9a2b27bf0ce27ca2fc4aa4301 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:20:35 +0100
Subject: [PATCH 09/15] python3-terminado: update to 0.13.0

---
 srcpkgs/python3-terminado/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-terminado/template b/srcpkgs/python3-terminado/template
index 28c65c82ba99..e299a6ca8c4f 100644
--- a/srcpkgs/python3-terminado/template
+++ b/srcpkgs/python3-terminado/template
@@ -1,10 +1,10 @@
 # Template file for 'python3-terminado'
 pkgname=python3-terminado
-version=0.9.4
-revision=2
+version=0.13.0
+revision=1
 wrksrc="terminado-${version}"
 build_style=python3-module
-hostmakedepends="python3-setuptools"
+hostmakedepends="python3-setuptools python3-tornado"
 depends="python3-ptyprocess python3-tornado"
 checkdepends="python3-pytest $depends"
 short_desc="Terminals served to term.js using Tornado websockets (Python3)"
@@ -12,7 +12,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/takluyver/terminado"
 distfiles="${PYPI_SITE}/t/terminado/terminado-${version}.tar.gz"
-checksum=9a7dbcfbc2778830eeb70261bf7aa9d98a3eac8631a3afe3febeb57c12f798be
+checksum=713531ccb5db7d4f544651f14050da79809030f00d1afa21462088cf32fb143a
 
 post_install() {
 	vlicense LICENSE

From de8a76cb2567f6e57c2010bf2de9c25ae409df51 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:43 +0100
Subject: [PATCH 10/15] python3-jupyter_server: update to 1.13.5

---
 srcpkgs/python3-jupyter_server/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-jupyter_server/template b/srcpkgs/python3-jupyter_server/template
index 4e6d8a6fe52a..e872ca652d59 100644
--- a/srcpkgs/python3-jupyter_server/template
+++ b/srcpkgs/python3-jupyter_server/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-jupyter_server'
 pkgname=python3-jupyter_server
-version=1.13.4
+version=1.13.5
 revision=1
 wrksrc="jupyter_server-${version}"
 build_style=python3-module
@@ -14,7 +14,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter-server/jupyter_server-${version}.tar.gz"
-checksum=5fb5a219385338b1d13a013a68f54688b6a69ecff4e757fd230e27ecacdbf212
+checksum=9e3e9717eea3bffab8cfb2ff330011be6c8bbd9cdae5b71cef169fcece2f19d3
 # Tarball defines no tests
 make_check=no
 

From f45c7a7bd2720617ae4c6cd619fc7771a8ae2280 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:59 +0100
Subject: [PATCH 11/15] jupyterlab: update to 3.3.1

---
 srcpkgs/jupyterlab/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/jupyterlab/template b/srcpkgs/jupyterlab/template
index 330d959bc154..ea12f6d4a946 100644
--- a/srcpkgs/jupyterlab/template
+++ b/srcpkgs/jupyterlab/template
@@ -1,7 +1,7 @@
 # Template file for 'jupyterlab'
 pkgname=jupyterlab
-version=3.2.8
-revision=2
+version=3.3.1
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-jupyterlab_server nodejs python3-nbclassic
@@ -11,7 +11,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="custom:jupyterlab"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyterlab/jupyterlab-${version}.tar.gz"
-checksum=5e4e99868c4f385372686767781408acbb9004b690b198b45597ba869802334b
+checksum=ce482799379c70aa87e63b59e2c5379779ce18658b92460cd20bb44154865973
 # Tests require unpackaged dependencies
 make_check=no
 

From 7a145ad077eaacd424826f97f0c547281dd60f7d Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Mon, 21 Feb 2022 10:41:56 +0100
Subject: [PATCH 12/15] python3-nbclient: update to 0.5.12

---
 srcpkgs/python3-nbclient/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-nbclient/template b/srcpkgs/python3-nbclient/template
index 24f9242016fb..50909329ed35 100644
--- a/srcpkgs/python3-nbclient/template
+++ b/srcpkgs/python3-nbclient/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-nbclient'
 pkgname=python3-nbclient
-version=0.5.10
+version=0.5.12
 revision=1
 wrksrc="${pkgname#python3-}-${version}"
 build_style=python3-module
@@ -12,7 +12,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://nbclient.readthedocs.io/en/latest/"
 distfiles="${PYPI_SITE}/n/nbclient/nbclient-${version}.tar.gz"
-checksum=b5fdea88d6fa52ca38de6c2361401cfe7aaa7cd24c74effc5e489cec04d79088
+checksum=0dd7ee6db59753563035f606421c3b558bd8c28b116d7e3ab8a0b4026cb44e38
 # Package might need to be installed for testing
 make_check=no
 

From 392cc1e08b69a34fb984e321b50b0ce16b9ba5d4 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:30:18 +0100
Subject: [PATCH 13/15] python3-traitlets: update to 5.1.1

---
 srcpkgs/python3-traitlets/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-traitlets/template b/srcpkgs/python3-traitlets/template
index f9b5819f9177..1cf7e4688617 100644
--- a/srcpkgs/python3-traitlets/template
+++ b/srcpkgs/python3-traitlets/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-traitlets'
 pkgname=python3-traitlets
-version=5.0.5
-revision=2
+version=5.1.1
+revision=1
 wrksrc="traitlets-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,7 +12,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/traitlets"
 distfiles="${PYPI_SITE}/t/traitlets/traitlets-${version}.tar.gz"
-checksum=178f4ce988f69189f7e523337a3e11d91c786ded9360174a3d9ca83e79bc5396
+checksum=059f456c5a7c1c82b98c2e8c799f39c9b8128f6d0d46941ee118daace9eb70c7
 
 do_check() {
 	pytest

From 9787f67eb5b499c5254f99501f05f0308dbc2ffd Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:30:45 +0100
Subject: [PATCH 14/15] python3-jupyter_console: update to 6.4.3

---
 srcpkgs/python3-jupyter_console/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-jupyter_console/template b/srcpkgs/python3-jupyter_console/template
index 3124f3854a19..c431d39ed7a6 100644
--- a/srcpkgs/python3-jupyter_console/template
+++ b/srcpkgs/python3-jupyter_console/template
@@ -1,24 +1,24 @@
 # Template file for 'python3-jupyter_console'
 pkgname=python3-jupyter_console
-version=6.4.0
-revision=2
+version=6.4.3
+revision=1
 wrksrc="jupyter_console-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-ipython python3-ipython_ipykernel python3-jupyter_client
- python3-prompt_toolkit python3-Pygments"
+ python3-prompt_toolkit python3-Pygments python3-traitlets"
 checkdepends="$depends python3-pytest"
 short_desc="Jupyter terminal console (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_console"
 distfiles="${PYPI_SITE}/j/jupyter_console/jupyter_console-${version}.tar.gz"
-checksum=242248e1685039cd8bff2c2ecb7ce6c1546eb50ee3b08519729e6e881aec19c7
+checksum=55f32626b0be647a85e3217ddcdb22db69efc79e8b403b9771eb9ecc696019b5
 # alternatives will be a conflict
 conflicts="python-jupyter_console<=6.0.0_2"
 # Tests fail because stdin is not a terminal
 make_check=no
 
 post_install() {
-	vlicense COPYING.md LICENSE
+	vlicense LICENSE
 }

From a29023d74cf081c467e8134edb822d7f1e6c8dc5 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:35:22 +0100
Subject: [PATCH 15/15]  python3-nbclassic-0.3.6

---
 srcpkgs/python3-nbclassic/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-nbclassic/template b/srcpkgs/python3-nbclassic/template
index 066ce4adc96b..ccd5d416ef75 100644
--- a/srcpkgs/python3-nbclassic/template
+++ b/srcpkgs/python3-nbclassic/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-nbclassic'
 pkgname=python3-nbclassic
-version=0.3.5
+version=0.3.6
 revision=1
 wrksrc=nbclassic-${version}
 build_style=python3-module
@@ -11,7 +11,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/n/nbclassic/nbclassic-${version}.tar.gz"
-checksum=99444dd63103af23c788d9b5172992f12caf8c3098dd5a35c787f0df31490c29
+checksum=7dbac0a6cb71bbe3afa1fe89369e6e3174d89f42aa08216a327046de45aa9a4f
 # Tarball includes no tests
 make_check=no
 

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (20 preceding siblings ...)
  2022-03-11 17:38 ` dkwo
@ 2022-03-11 17:41 ` dkwo
  2022-03-14 19:24 ` [PR PATCH] [Updated] " dkwo
                   ` (28 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-03-11 17:41 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 204 bytes --]

New comment by dkwo on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#issuecomment-1065337085

Comment:
It seems they unbroke console, fixing #35608
Can this be merged?

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR PATCH] [Updated] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (21 preceding siblings ...)
  2022-03-11 17:41 ` dkwo
@ 2022-03-14 19:24 ` dkwo
  2022-03-14 20:22 ` [PR REVIEW] " paper42
                   ` (27 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-03-14 19:24 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 397 bytes --]

There is an updated pull request by dkwo against master on the void-packages repository

https://github.com/dkwo/void-packages pytupd
https://github.com/void-linux/void-packages/pull/35376

update few python3 packages
@ahesford Could you check whether the new jupyter client solves the issue with console?

A patch file from https://github.com/void-linux/void-packages/pull/35376.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-pytupd-35376.patch --]
[-- Type: text/x-diff, Size: 19669 bytes --]

From 1c4fa6632d717ce328fc2dcd588b54bde27c7c37 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:51:55 +0100
Subject: [PATCH 01/15] python3-defusedxml: update to 0.7.1

---
 srcpkgs/python3-defusedxml/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-defusedxml/template b/srcpkgs/python3-defusedxml/template
index 06bdd57a3526..90dc454d120d 100644
--- a/srcpkgs/python3-defusedxml/template
+++ b/srcpkgs/python3-defusedxml/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-defusedxml'
 pkgname=python3-defusedxml
-version=0.6.0
-revision=5
+version=0.7.1
+revision=1
 wrksrc="defusedxml-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Python-2.0"
 homepage="https://github.com/tiran/defusedxml"
 distfiles="${PYPI_SITE}/d/defusedxml/defusedxml-${version}.tar.gz"
-checksum=f684034d135af4c6cbb949b8a4d2ed61634515257a67299e5f940fbaa34377f5
+checksum=1bb3032db185915b62d7c6209c5a8792be6a32ab2fedacc84e01b52c51aa3e69
 
 post_install() {
 	vlicense LICENSE

From 14489a454238a191916e825a43871c8a02eb2ecf Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:54:30 +0100
Subject: [PATCH 02/15] python3-httplib2: update to 0.20.4

---
 srcpkgs/python3-httplib2/template | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-httplib2/template b/srcpkgs/python3-httplib2/template
index d0c39a478622..32fd1c87c2c1 100644
--- a/srcpkgs/python3-httplib2/template
+++ b/srcpkgs/python3-httplib2/template
@@ -1,12 +1,12 @@
 # Template file for 'python3-httplib2'
 pkgname=python3-httplib2
-version=0.18.1
-revision=3
+version=0.20.4
+revision=1
 create_wrksrc=yes
 build_wrksrc="httplib2-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="python3 ca-certificates"
+depends="python3 ca-certificates python3-parsing"
 short_desc="Comprehensive HTTP client library (Python3)"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
@@ -14,8 +14,10 @@ homepage="https://github.com/httplib2/httplib2"
 changelog="https://raw.githubusercontent.com/httplib2/httplib2/master/CHANGELOG"
 distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz
  https://raw.githubusercontent.com/httplib2/httplib2/master/LICENSE>LICENSE.txt"
-checksum="8af66c1c52c7ffe1aa5dc4bcd7c769885254b0756e6e69f953c7f0ab49a70ba3
+checksum="58a98e45b4b1a48273073f905d2961666ecf0fbac4250ea5b47aef259eb5c585
  589eec38f72df2be203711d3b8cbece9b908c5e7ff00bc3cab7f63bae9e366b4"
+# Testing via this command is deprecated
+make_check=no
 
 post_install() {
 	# use system ca certificates

From 475238dbc0ba4630fa3ef7172db0525e10160471 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:55:53 +0100
Subject: [PATCH 03/15] python3-ipython_ipykernel: update to 6.8.0

---
 srcpkgs/python3-ipython_ipykernel/template | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-ipython_ipykernel/template b/srcpkgs/python3-ipython_ipykernel/template
index f00e0a3f1a0c..b75796ca0262 100644
--- a/srcpkgs/python3-ipython_ipykernel/template
+++ b/srcpkgs/python3-ipython_ipykernel/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-ipython_ipykernel'
 pkgname=python3-ipython_ipykernel
-version=5.5.4
-revision=2
+version=6.8.0
+revision=1
 wrksrc="ipykernel-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools python3-ipython
- python3-jupyter_client python3-traitlets python3-tornado"
-depends="python3-ipython python3-traitlets python3-jupyter_client python3-tornado"
+ python3-jupyter_client python3-traitlets python3-tornado python3-entrypoints"
+depends="python3-ipython python3-traitlets python3-jupyter_client
+ python3-tornado python3-entrypoints python3-nest_asyncio"
 short_desc="IPython kernel for Jupyter (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/ipykernel"
 distfiles="${PYPI_SITE}/i/ipykernel/ipykernel-${version}.tar.gz"
-checksum=1ce0e83672cc3bfdc1ffb5603e1d77ab125f24b41abc4612e22bfb3e994c0db2
+checksum=67d316d527eca24e3ded45a2b38689615bcda1aa520a11af0accdcea7152c18a
 # checks create a cycle with python3-jupyter_core and python3-jupyter_client
 make_check=no
 

From 8f155d8885393eacc5397cd8d6ffd8ec655daf0a Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:04:52 +0100
Subject: [PATCH 04/15] python3-jupyter_client: update to 7.1.2

---
 srcpkgs/python3-jupyter_client/template | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-jupyter_client/template b/srcpkgs/python3-jupyter_client/template
index be6aa5594095..c3906f07e7b4 100644
--- a/srcpkgs/python3-jupyter_client/template
+++ b/srcpkgs/python3-jupyter_client/template
@@ -1,19 +1,18 @@
 # Template file for 'python3-jupyter_client'
 pkgname=python3-jupyter_client
-# delay 6.2 until jupyter/jupyter_console#241 is fixed
-version=6.1.12
-revision=2
+version=7.1.1
+revision=1
 wrksrc="jupyter_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-traitlets python3-jupyter_core python3-pyzmq
- python3-dateutil python3-tornado python3-nest_asyncio"
+ python3-dateutil python3-tornado python3-nest_asyncio python3-entrypoints"
 short_desc="Jupyter protocol client APIs"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_client"
 distfiles="${PYPI_SITE}/j/jupyter_client/jupyter_client-${version}.tar.gz"
-checksum=c4bca1d0846186ca8be97f4d2fa6d2bae889cce4892a167ffa1ba6bd1f73e782
+checksum=540ca35e57e83c5ece81abd9b781a57cba39a37c60a2a30c8c1b2f6663544343
 conflicts="python-jupyter_client<=5.2.4_2"
 # checks create a cycle with python3-jupyter_core and python3-ipython_ipykernel
 make_check=no

From 29266555158c64db0037d44c2c168bf3f07e1be2 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:06:12 +0100
Subject: [PATCH 05/15] python3-jupyter_core: update to 4.9.1

---
 srcpkgs/python3-jupyter_core/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_core/template b/srcpkgs/python3-jupyter_core/template
index d0fa364a6751..5f450d293d4f 100644
--- a/srcpkgs/python3-jupyter_core/template
+++ b/srcpkgs/python3-jupyter_core/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_core'
 pkgname=python3-jupyter_core
-version=4.7.1
-revision=2
+version=4.9.1
+revision=1
 wrksrc="jupyter_core-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter_core/jupyter_core-${version}.tar.gz"
-checksum=79025cb3225efcd36847d0840f3fc672c0abd7afd0de83ba8a1d3837619122b4
+checksum=dce8a7499da5a53ae3afd5a9f4b02e5df1d57250cf48f3ad79da23b4778cd6fa
 conflicts="python-jupyter_core<=4.4.0_3"
 # checks create a cycle with python3-jypter_client and python3-ipython_ipykernel
 make_check=no

From 065b2c8be9b92a9a8f7a27247f4aa869fba97f5d Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:07:34 +0100
Subject: [PATCH 06/15] python3-jupyter_notebook: update to 6.4.8

---
 srcpkgs/python3-jupyter_notebook/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_notebook/template b/srcpkgs/python3-jupyter_notebook/template
index ca9e1d43df21..f1ec68546fd9 100644
--- a/srcpkgs/python3-jupyter_notebook/template
+++ b/srcpkgs/python3-jupyter_notebook/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_notebook'
 pkgname=python3-jupyter_notebook
-version=6.3.0
-revision=2
+version=6.4.8
+revision=1
 wrksrc="notebook-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -15,7 +15,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org/"
 distfiles="${PYPI_SITE}/n/notebook/notebook-${version}.tar.gz"
-checksum=cbc9398d6c81473e9cdb891d2cae9c0d3718fca289dda6d26df5cb660fcadc7d
+checksum=1e985c9dc6f678bdfffb9dc657306b5469bfa62d73e03f74e8defbf76d284312
 conflicts="python-jupyter_notebook<=5.7.0_2"
 # Tests require unpackaged selenium
 make_check=no

From 5b4ede77487b5a2d590f3c4726314db07917c9df Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:14:36 +0100
Subject: [PATCH 07/15] python3-paramiko: update to 2.9.2

---
 srcpkgs/python3-paramiko/template | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-paramiko/template b/srcpkgs/python3-paramiko/template
index cff1b3a2fb59..a11808886b73 100644
--- a/srcpkgs/python3-paramiko/template
+++ b/srcpkgs/python3-paramiko/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-paramiko'
 pkgname=python3-paramiko
-version=2.7.2
-revision=2
+version=2.9.2
+revision=1
 wrksrc="${pkgname#*-}-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,4 +11,6 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="LGPL-2.1-or-later"
 homepage="http://www.paramiko.org/"
 distfiles="${PYPI_SITE}/p/paramiko/paramiko-${version}.tar.gz"
-checksum=7f36f4ba2c0d81d219f4595e35f70d56cc94f9ac40a6acdf51d6ca210ce65035
+checksum=944a9e5dbdd413ab6c7951ea46b0ab40713235a9c4c5ca81cfe45c6f14fa677b
+# Testing via this command is deprecated
+make_check=no

From cff28834585f86787f61a0cec7ebb0e7bb59ebaf Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:17:21 +0100
Subject: [PATCH 08/15] python3-soupsieve: update to 2.3.1

---
 srcpkgs/python3-soupsieve/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-soupsieve/template b/srcpkgs/python3-soupsieve/template
index 14449f20c47f..bb63a5ec0952 100644
--- a/srcpkgs/python3-soupsieve/template
+++ b/srcpkgs/python3-soupsieve/template
@@ -1,18 +1,18 @@
 # Template file for 'python3-soupsieve'
 pkgname=python3-soupsieve
-version=1.9.5
-revision=6
+version=2.3.1
+revision=1
 wrksrc="soupsieve-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="python3"
+depends="python3 python3-BeautifulSoup4"
 checkdepends="python3-pytest python3-lxml python3-html5lib python3-BeautifulSoup4"
 short_desc="CSS4 selector implementation for Python3 Beautiful Soup"
 maintainer="Aluísio Augusto Silva Gonçalves <aluisio@aasg.name>"
 license="MIT"
 homepage="https://facelessuser.github.io/soupsieve/"
 distfiles="${PYPI_SITE}/s/soupsieve/soupsieve-${version}.tar.gz"
-checksum=e2c1c5dee4a1c36bcb790e0fabd5492d874b8ebd4617622c4f6a731701060dda
+checksum=b8d49b1cd4f037c7082a9683dfa1801aa2597fb11c3a1155b7a5b94829b4f1f9
 
 post_install() {
 	vlicense LICENSE.md

From 1b232f1f4eb2b419bed99d5b2760574bb14b0435 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:20:35 +0100
Subject: [PATCH 09/15] python3-terminado: update to 0.13.0

---
 srcpkgs/python3-terminado/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-terminado/template b/srcpkgs/python3-terminado/template
index 28c65c82ba99..e299a6ca8c4f 100644
--- a/srcpkgs/python3-terminado/template
+++ b/srcpkgs/python3-terminado/template
@@ -1,10 +1,10 @@
 # Template file for 'python3-terminado'
 pkgname=python3-terminado
-version=0.9.4
-revision=2
+version=0.13.0
+revision=1
 wrksrc="terminado-${version}"
 build_style=python3-module
-hostmakedepends="python3-setuptools"
+hostmakedepends="python3-setuptools python3-tornado"
 depends="python3-ptyprocess python3-tornado"
 checkdepends="python3-pytest $depends"
 short_desc="Terminals served to term.js using Tornado websockets (Python3)"
@@ -12,7 +12,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/takluyver/terminado"
 distfiles="${PYPI_SITE}/t/terminado/terminado-${version}.tar.gz"
-checksum=9a7dbcfbc2778830eeb70261bf7aa9d98a3eac8631a3afe3febeb57c12f798be
+checksum=713531ccb5db7d4f544651f14050da79809030f00d1afa21462088cf32fb143a
 
 post_install() {
 	vlicense LICENSE

From ea7e5f64809506bf3b740b8eeca98eecb736cde0 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:43 +0100
Subject: [PATCH 10/15] python3-jupyter_server: update to 1.13.5

---
 srcpkgs/python3-jupyter_server/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-jupyter_server/template b/srcpkgs/python3-jupyter_server/template
index 4e6d8a6fe52a..e872ca652d59 100644
--- a/srcpkgs/python3-jupyter_server/template
+++ b/srcpkgs/python3-jupyter_server/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-jupyter_server'
 pkgname=python3-jupyter_server
-version=1.13.4
+version=1.13.5
 revision=1
 wrksrc="jupyter_server-${version}"
 build_style=python3-module
@@ -14,7 +14,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter-server/jupyter_server-${version}.tar.gz"
-checksum=5fb5a219385338b1d13a013a68f54688b6a69ecff4e757fd230e27ecacdbf212
+checksum=9e3e9717eea3bffab8cfb2ff330011be6c8bbd9cdae5b71cef169fcece2f19d3
 # Tarball defines no tests
 make_check=no
 

From 3f00f725acea956ff67968bf90c6cf843e845bb4 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:59 +0100
Subject: [PATCH 11/15] jupyterlab: update to 3.3.1

---
 srcpkgs/jupyterlab/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/jupyterlab/template b/srcpkgs/jupyterlab/template
index 330d959bc154..ea12f6d4a946 100644
--- a/srcpkgs/jupyterlab/template
+++ b/srcpkgs/jupyterlab/template
@@ -1,7 +1,7 @@
 # Template file for 'jupyterlab'
 pkgname=jupyterlab
-version=3.2.8
-revision=2
+version=3.3.1
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-jupyterlab_server nodejs python3-nbclassic
@@ -11,7 +11,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="custom:jupyterlab"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyterlab/jupyterlab-${version}.tar.gz"
-checksum=5e4e99868c4f385372686767781408acbb9004b690b198b45597ba869802334b
+checksum=ce482799379c70aa87e63b59e2c5379779ce18658b92460cd20bb44154865973
 # Tests require unpackaged dependencies
 make_check=no
 

From 621208ee04f5b1ed417d517817861fdd847f6aa5 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Mon, 21 Feb 2022 10:41:56 +0100
Subject: [PATCH 12/15] python3-nbclient: update to 0.5.12

---
 srcpkgs/python3-nbclient/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-nbclient/template b/srcpkgs/python3-nbclient/template
index 24f9242016fb..50909329ed35 100644
--- a/srcpkgs/python3-nbclient/template
+++ b/srcpkgs/python3-nbclient/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-nbclient'
 pkgname=python3-nbclient
-version=0.5.10
+version=0.5.12
 revision=1
 wrksrc="${pkgname#python3-}-${version}"
 build_style=python3-module
@@ -12,7 +12,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://nbclient.readthedocs.io/en/latest/"
 distfiles="${PYPI_SITE}/n/nbclient/nbclient-${version}.tar.gz"
-checksum=b5fdea88d6fa52ca38de6c2361401cfe7aaa7cd24c74effc5e489cec04d79088
+checksum=0dd7ee6db59753563035f606421c3b558bd8c28b116d7e3ab8a0b4026cb44e38
 # Package might need to be installed for testing
 make_check=no
 

From ec039f9c34e8375613baf9204a97af82c6914dd3 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:30:18 +0100
Subject: [PATCH 13/15] python3-traitlets: update to 5.1.1

---
 srcpkgs/python3-traitlets/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-traitlets/template b/srcpkgs/python3-traitlets/template
index f9b5819f9177..1cf7e4688617 100644
--- a/srcpkgs/python3-traitlets/template
+++ b/srcpkgs/python3-traitlets/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-traitlets'
 pkgname=python3-traitlets
-version=5.0.5
-revision=2
+version=5.1.1
+revision=1
 wrksrc="traitlets-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,7 +12,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/traitlets"
 distfiles="${PYPI_SITE}/t/traitlets/traitlets-${version}.tar.gz"
-checksum=178f4ce988f69189f7e523337a3e11d91c786ded9360174a3d9ca83e79bc5396
+checksum=059f456c5a7c1c82b98c2e8c799f39c9b8128f6d0d46941ee118daace9eb70c7
 
 do_check() {
 	pytest

From 1b2481d5a65b11069768fedfa356a504025e005a Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:30:45 +0100
Subject: [PATCH 14/15] python3-jupyter_console: update to 6.4.3

---
 srcpkgs/python3-jupyter_console/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-jupyter_console/template b/srcpkgs/python3-jupyter_console/template
index 3124f3854a19..c431d39ed7a6 100644
--- a/srcpkgs/python3-jupyter_console/template
+++ b/srcpkgs/python3-jupyter_console/template
@@ -1,24 +1,24 @@
 # Template file for 'python3-jupyter_console'
 pkgname=python3-jupyter_console
-version=6.4.0
-revision=2
+version=6.4.3
+revision=1
 wrksrc="jupyter_console-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-ipython python3-ipython_ipykernel python3-jupyter_client
- python3-prompt_toolkit python3-Pygments"
+ python3-prompt_toolkit python3-Pygments python3-traitlets"
 checkdepends="$depends python3-pytest"
 short_desc="Jupyter terminal console (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_console"
 distfiles="${PYPI_SITE}/j/jupyter_console/jupyter_console-${version}.tar.gz"
-checksum=242248e1685039cd8bff2c2ecb7ce6c1546eb50ee3b08519729e6e881aec19c7
+checksum=55f32626b0be647a85e3217ddcdb22db69efc79e8b403b9771eb9ecc696019b5
 # alternatives will be a conflict
 conflicts="python-jupyter_console<=6.0.0_2"
 # Tests fail because stdin is not a terminal
 make_check=no
 
 post_install() {
-	vlicense COPYING.md LICENSE
+	vlicense LICENSE
 }

From 3d41bc36bfbd26a263dfa42973ff932a3901d06b Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:35:22 +0100
Subject: [PATCH 15/15]  python3-nbclassic: update to 0.3.6

---
 srcpkgs/python3-nbclassic/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-nbclassic/template b/srcpkgs/python3-nbclassic/template
index 066ce4adc96b..ccd5d416ef75 100644
--- a/srcpkgs/python3-nbclassic/template
+++ b/srcpkgs/python3-nbclassic/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-nbclassic'
 pkgname=python3-nbclassic
-version=0.3.5
+version=0.3.6
 revision=1
 wrksrc=nbclassic-${version}
 build_style=python3-module
@@ -11,7 +11,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/n/nbclassic/nbclassic-${version}.tar.gz"
-checksum=99444dd63103af23c788d9b5172992f12caf8c3098dd5a35c787f0df31490c29
+checksum=7dbac0a6cb71bbe3afa1fe89369e6e3174d89f42aa08216a327046de45aa9a4f
 # Tarball includes no tests
 make_check=no
 

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR REVIEW] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (25 preceding siblings ...)
  2022-03-14 20:22 ` paper42
@ 2022-03-14 20:22 ` paper42
  2022-03-14 20:23 ` paper42
                   ` (23 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: paper42 @ 2022-03-14 20:22 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 293 bytes --]

New review comment by paper42 on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#discussion_r826307172

Comment:
```suggestion
 https://raw.githubusercontent.com/httplib2/httplib2/v$version/LICENSE>LICENSE.txt"
```
And I don't think we need `> LICENSE.txt`

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR REVIEW] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (22 preceding siblings ...)
  2022-03-14 19:24 ` [PR PATCH] [Updated] " dkwo
@ 2022-03-14 20:22 ` paper42
  2022-03-14 20:22 ` paper42
                   ` (26 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: paper42 @ 2022-03-14 20:22 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 160 bytes --]

New review comment by paper42 on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#discussion_r826314589

Comment:
same as above

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR REVIEW] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (24 preceding siblings ...)
  2022-03-14 20:22 ` paper42
@ 2022-03-14 20:22 ` paper42
  2022-03-14 20:22 ` paper42
                   ` (24 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: paper42 @ 2022-03-14 20:22 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 273 bytes --]

New review comment by paper42 on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#discussion_r826314452

Comment:
If we remove this and add checkdepends="$depends", we should be able to at least test if we have all the runtime dependencies.

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR REVIEW] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (23 preceding siblings ...)
  2022-03-14 20:22 ` [PR REVIEW] " paper42
@ 2022-03-14 20:22 ` paper42
  2022-03-14 20:22 ` paper42
                   ` (25 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: paper42 @ 2022-03-14 20:22 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 265 bytes --]

New review comment by paper42 on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#discussion_r826306489

Comment:
This is just a warning and we can use a newer, not deprecated testing method by adding python3-pytest to checkdepends.

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR REVIEW] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (26 preceding siblings ...)
  2022-03-14 20:22 ` paper42
@ 2022-03-14 20:23 ` paper42
  2022-03-15 13:40 ` dkwo
                   ` (22 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: paper42 @ 2022-03-14 20:23 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 160 bytes --]

New review comment by paper42 on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#discussion_r826346100

Comment:
same as above

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR REVIEW] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (27 preceding siblings ...)
  2022-03-14 20:23 ` paper42
@ 2022-03-15 13:40 ` dkwo
  2022-03-15 13:41 ` dkwo
                   ` (21 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-03-15 13:40 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1112 bytes --]

New review comment by dkwo on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#discussion_r826984429

Comment:
in which case, I get:
```
=> python3-jupyter_server-1.13.5_1: running do_check ...
running test
WARNING: Testing via this command is deprecated and will be removed in a future version. Users looking for a generic test entry point independent of test runner are encouraged to use tox.
/usr/lib/python3.10/site-packages/setuptools/installer.py:27: SetuptoolsDeprecationWarning: setuptools.installer is deprecated. Requirements should be satisfied by a PEP 517 installer.
  warnings.warn(
WARNING: The wheel package is not available.
/usr/bin/python3: No module named pip
error: Command '['/usr/bin/python3', '-m', 'pip', '--disable-pip-version-check', 'wheel', '--no-deps', '-w', '/tmp/tmprp9eg75u', '--quiet', 'argon2-cffi']' returned non-zero exit status 1.
=> ERROR: python3-jupyter_server-1.13.5_1: do_check: 'python3 setup.py ${make_check_target} ${make_check_args}' exited with 1
=> ERROR:   in do_check() at common/build-style/python3-module.sh:40
```

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR REVIEW] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (28 preceding siblings ...)
  2022-03-15 13:40 ` dkwo
@ 2022-03-15 13:41 ` dkwo
  2022-03-15 13:45 ` dkwo
                   ` (20 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-03-15 13:41 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 251 bytes --]

New review comment by dkwo on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#discussion_r826986226

Comment:
I've added several to checks, but it still fails one. It seems we are missing some checkdepends. Any ideas?

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR REVIEW] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (29 preceding siblings ...)
  2022-03-15 13:41 ` dkwo
@ 2022-03-15 13:45 ` dkwo
  2022-03-15 13:46 ` dkwo
                   ` (19 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-03-15 13:45 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 165 bytes --]

New review comment by dkwo on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#discussion_r826990002

Comment:
indeed, same as above

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR REVIEW] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (30 preceding siblings ...)
  2022-03-15 13:45 ` dkwo
@ 2022-03-15 13:46 ` dkwo
  2022-03-15 13:48 ` [PR PATCH] [Updated] " dkwo
                   ` (18 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-03-15 13:46 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 3019 bytes --]

New review comment by dkwo on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#discussion_r826991610

Comment:
This one I get
```
=> python3-paramiko-2.9.2_1: running do_check ...
running test
WARNING: Testing via this command is deprecated and will be removed in a future version. Users looking for a generic test entry point independent of test runner are encouraged to use tox.
running egg_info
writing manifest file 'paramiko.egg-info/SOURCES.txt'
running build_ext
Traceback (most recent call last):
  File "/builddir/paramiko-2.9.2/setup.py", line 51, in <module>
    setup(
  File "/usr/lib/python3.10/site-packages/setuptools/__init__.py", line 155, in setup
    return distutils.core.setup(**attrs)
  File "/usr/lib/python3.10/site-packages/setuptools/_distutils/core.py", line 148, in setup
    return run_commands(dist)
  File "/usr/lib/python3.10/site-packages/setuptools/_distutils/core.py", line 163, in run_commands
    dist.run_commands()
  File "/usr/lib/python3.10/site-packages/setuptools/_distutils/dist.py", line 967, in run_commands
    self.run_command(cmd)
  File "/usr/lib/python3.10/site-packages/setuptools/_distutils/dist.py", line 986, in run_command
    cmd_obj.run()
  File "/usr/lib/python3.10/site-packages/setuptools/command/test.py", line 223, in run
    self.run_tests()
  File "/usr/lib/python3.10/site-packages/setuptools/command/test.py", line 226, in run_tests
    test = unittest.main(
  File "/usr/lib/python3.10/unittest/main.py", line 100, in __init__
    self.parseArgs(argv)
  File "/usr/lib/python3.10/unittest/main.py", line 124, in parseArgs
    self._do_discovery(argv[2:])
  File "/usr/lib/python3.10/unittest/main.py", line 244, in _do_discovery
    self.createTests(from_discovery=True, Loader=Loader)
  File "/usr/lib/python3.10/unittest/main.py", line 154, in createTests
    self.test = loader.discover(self.start, self.pattern, self.top)
  File "/usr/lib/python3.10/unittest/loader.py", line 349, in discover
    tests = list(self._find_tests(start_dir, pattern))
  File "/usr/lib/python3.10/unittest/loader.py", line 405, in _find_tests
    tests, should_recurse = self._find_test_path(
  File "/usr/lib/python3.10/unittest/loader.py", line 483, in _find_test_path
    tests = self.loadTestsFromModule(package, pattern=pattern)
  File "/usr/lib/python3.10/site-packages/setuptools/command/test.py", line 56, in loadTestsFromModule
    tests.append(self.loadTestsFromName(submodule))
  File "/usr/lib/python3.10/unittest/loader.py", line 154, in loadTestsFromName
    module = __import__(module_name)
  File "/builddir/paramiko-2.9.2/paramiko/_winapi.py", line 55, in <module>
    class WindowsError(builtins.WindowsError):
AttributeError: module 'builtins' has no attribute 'WindowsError'
=> ERROR: python3-paramiko-2.9.2_1: do_check: 'python3 setup.py ${make_check_target} ${make_check_args}' exited with 1
=> ERROR:   in do_check() at common/build-style/python3-module.sh:40
```

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR PATCH] [Updated] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (31 preceding siblings ...)
  2022-03-15 13:46 ` dkwo
@ 2022-03-15 13:48 ` dkwo
  2022-03-20 22:51 ` [PR REVIEW] " paper42
                   ` (17 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-03-15 13:48 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 397 bytes --]

There is an updated pull request by dkwo against master on the void-packages repository

https://github.com/dkwo/void-packages pytupd
https://github.com/void-linux/void-packages/pull/35376

update few python3 packages
@ahesford Could you check whether the new jupyter client solves the issue with console?

A patch file from https://github.com/void-linux/void-packages/pull/35376.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-pytupd-35376.patch --]
[-- Type: text/x-diff, Size: 19983 bytes --]

From e91d7fb2816d818a3bc0b0c9dd831416e88b7045 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:51:55 +0100
Subject: [PATCH 01/15] python3-defusedxml: update to 0.7.1

---
 srcpkgs/python3-defusedxml/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-defusedxml/template b/srcpkgs/python3-defusedxml/template
index 06bdd57a3526..90dc454d120d 100644
--- a/srcpkgs/python3-defusedxml/template
+++ b/srcpkgs/python3-defusedxml/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-defusedxml'
 pkgname=python3-defusedxml
-version=0.6.0
-revision=5
+version=0.7.1
+revision=1
 wrksrc="defusedxml-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Python-2.0"
 homepage="https://github.com/tiran/defusedxml"
 distfiles="${PYPI_SITE}/d/defusedxml/defusedxml-${version}.tar.gz"
-checksum=f684034d135af4c6cbb949b8a4d2ed61634515257a67299e5f940fbaa34377f5
+checksum=1bb3032db185915b62d7c6209c5a8792be6a32ab2fedacc84e01b52c51aa3e69
 
 post_install() {
 	vlicense LICENSE

From 12b230af9053d6bf29701871c6c4bee433d519fb Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:54:30 +0100
Subject: [PATCH 02/15] python3-httplib2: update to 0.20.4

---
 srcpkgs/python3-httplib2/template | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/python3-httplib2/template b/srcpkgs/python3-httplib2/template
index d0c39a478622..0ee43a375770 100644
--- a/srcpkgs/python3-httplib2/template
+++ b/srcpkgs/python3-httplib2/template
@@ -1,26 +1,26 @@
 # Template file for 'python3-httplib2'
 pkgname=python3-httplib2
-version=0.18.1
-revision=3
+version=0.20.4
+revision=1
 create_wrksrc=yes
 build_wrksrc="httplib2-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="python3 ca-certificates"
+depends="python3 ca-certificates python3-parsing"
+checkdepends="python3-pytest python3-pytest-cov python3-pytest-timeout
+ python3-cryptography python3-flake8 python3-six python3-future"
 short_desc="Comprehensive HTTP client library (Python3)"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/httplib2/httplib2"
 changelog="https://raw.githubusercontent.com/httplib2/httplib2/master/CHANGELOG"
-distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz
- https://raw.githubusercontent.com/httplib2/httplib2/master/LICENSE>LICENSE.txt"
-checksum="8af66c1c52c7ffe1aa5dc4bcd7c769885254b0756e6e69f953c7f0ab49a70ba3
- 589eec38f72df2be203711d3b8cbece9b908c5e7ff00bc3cab7f63bae9e366b4"
+distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz"
+checksum="58a98e45b4b1a48273073f905d2961666ecf0fbac4250ea5b47aef259eb5c585"
 
 post_install() {
 	# use system ca certificates
 	rm -rf ${DESTDIR}/${py3_sitelib}/httplib2/cacerts.txt
 	ln -sf /etc/ssl/cert.pem ${DESTDIR}/${py3_sitelib}/httplib2/cacerts.txt
 
-	vlicense ../LICENSE.txt
+	vlicense LICENSE
 }

From 619b6a431eb4a777212cc7e24adec3ea5b276e54 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:55:53 +0100
Subject: [PATCH 03/15] python3-ipython_ipykernel: update to 6.8.0

---
 srcpkgs/python3-ipython_ipykernel/template | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-ipython_ipykernel/template b/srcpkgs/python3-ipython_ipykernel/template
index f00e0a3f1a0c..b75796ca0262 100644
--- a/srcpkgs/python3-ipython_ipykernel/template
+++ b/srcpkgs/python3-ipython_ipykernel/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-ipython_ipykernel'
 pkgname=python3-ipython_ipykernel
-version=5.5.4
-revision=2
+version=6.8.0
+revision=1
 wrksrc="ipykernel-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools python3-ipython
- python3-jupyter_client python3-traitlets python3-tornado"
-depends="python3-ipython python3-traitlets python3-jupyter_client python3-tornado"
+ python3-jupyter_client python3-traitlets python3-tornado python3-entrypoints"
+depends="python3-ipython python3-traitlets python3-jupyter_client
+ python3-tornado python3-entrypoints python3-nest_asyncio"
 short_desc="IPython kernel for Jupyter (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/ipykernel"
 distfiles="${PYPI_SITE}/i/ipykernel/ipykernel-${version}.tar.gz"
-checksum=1ce0e83672cc3bfdc1ffb5603e1d77ab125f24b41abc4612e22bfb3e994c0db2
+checksum=67d316d527eca24e3ded45a2b38689615bcda1aa520a11af0accdcea7152c18a
 # checks create a cycle with python3-jupyter_core and python3-jupyter_client
 make_check=no
 

From a1aec16bd953cab095914002b44691e8e9f9a1a3 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:04:52 +0100
Subject: [PATCH 04/15] python3-jupyter_client: update to 7.1.2

---
 srcpkgs/python3-jupyter_client/template | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-jupyter_client/template b/srcpkgs/python3-jupyter_client/template
index be6aa5594095..c3906f07e7b4 100644
--- a/srcpkgs/python3-jupyter_client/template
+++ b/srcpkgs/python3-jupyter_client/template
@@ -1,19 +1,18 @@
 # Template file for 'python3-jupyter_client'
 pkgname=python3-jupyter_client
-# delay 6.2 until jupyter/jupyter_console#241 is fixed
-version=6.1.12
-revision=2
+version=7.1.1
+revision=1
 wrksrc="jupyter_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-traitlets python3-jupyter_core python3-pyzmq
- python3-dateutil python3-tornado python3-nest_asyncio"
+ python3-dateutil python3-tornado python3-nest_asyncio python3-entrypoints"
 short_desc="Jupyter protocol client APIs"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_client"
 distfiles="${PYPI_SITE}/j/jupyter_client/jupyter_client-${version}.tar.gz"
-checksum=c4bca1d0846186ca8be97f4d2fa6d2bae889cce4892a167ffa1ba6bd1f73e782
+checksum=540ca35e57e83c5ece81abd9b781a57cba39a37c60a2a30c8c1b2f6663544343
 conflicts="python-jupyter_client<=5.2.4_2"
 # checks create a cycle with python3-jupyter_core and python3-ipython_ipykernel
 make_check=no

From 9aa233c68b9a527bee6d9edb1cdc1fffd7074aba Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:06:12 +0100
Subject: [PATCH 05/15] python3-jupyter_core: update to 4.9.1

---
 srcpkgs/python3-jupyter_core/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_core/template b/srcpkgs/python3-jupyter_core/template
index d0fa364a6751..5f450d293d4f 100644
--- a/srcpkgs/python3-jupyter_core/template
+++ b/srcpkgs/python3-jupyter_core/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_core'
 pkgname=python3-jupyter_core
-version=4.7.1
-revision=2
+version=4.9.1
+revision=1
 wrksrc="jupyter_core-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter_core/jupyter_core-${version}.tar.gz"
-checksum=79025cb3225efcd36847d0840f3fc672c0abd7afd0de83ba8a1d3837619122b4
+checksum=dce8a7499da5a53ae3afd5a9f4b02e5df1d57250cf48f3ad79da23b4778cd6fa
 conflicts="python-jupyter_core<=4.4.0_3"
 # checks create a cycle with python3-jypter_client and python3-ipython_ipykernel
 make_check=no

From 79639c7dbcdfc39f8b96c565d1196d13dd5bddc1 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:07:34 +0100
Subject: [PATCH 06/15] python3-jupyter_notebook: update to 6.4.8

---
 srcpkgs/python3-jupyter_notebook/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_notebook/template b/srcpkgs/python3-jupyter_notebook/template
index ca9e1d43df21..f1ec68546fd9 100644
--- a/srcpkgs/python3-jupyter_notebook/template
+++ b/srcpkgs/python3-jupyter_notebook/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_notebook'
 pkgname=python3-jupyter_notebook
-version=6.3.0
-revision=2
+version=6.4.8
+revision=1
 wrksrc="notebook-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -15,7 +15,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org/"
 distfiles="${PYPI_SITE}/n/notebook/notebook-${version}.tar.gz"
-checksum=cbc9398d6c81473e9cdb891d2cae9c0d3718fca289dda6d26df5cb660fcadc7d
+checksum=1e985c9dc6f678bdfffb9dc657306b5469bfa62d73e03f74e8defbf76d284312
 conflicts="python-jupyter_notebook<=5.7.0_2"
 # Tests require unpackaged selenium
 make_check=no

From 9b412da8740d50abe03bd2302ae6f68e4dbe9590 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:14:36 +0100
Subject: [PATCH 07/15] python3-paramiko: update to 2.9.2

---
 srcpkgs/python3-paramiko/template | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-paramiko/template b/srcpkgs/python3-paramiko/template
index cff1b3a2fb59..a11808886b73 100644
--- a/srcpkgs/python3-paramiko/template
+++ b/srcpkgs/python3-paramiko/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-paramiko'
 pkgname=python3-paramiko
-version=2.7.2
-revision=2
+version=2.9.2
+revision=1
 wrksrc="${pkgname#*-}-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,4 +11,6 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="LGPL-2.1-or-later"
 homepage="http://www.paramiko.org/"
 distfiles="${PYPI_SITE}/p/paramiko/paramiko-${version}.tar.gz"
-checksum=7f36f4ba2c0d81d219f4595e35f70d56cc94f9ac40a6acdf51d6ca210ce65035
+checksum=944a9e5dbdd413ab6c7951ea46b0ab40713235a9c4c5ca81cfe45c6f14fa677b
+# Testing via this command is deprecated
+make_check=no

From d3f55f08f31ada093c65b02d8d5a83499809f150 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:17:21 +0100
Subject: [PATCH 08/15] python3-soupsieve: update to 2.3.1

---
 srcpkgs/python3-soupsieve/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-soupsieve/template b/srcpkgs/python3-soupsieve/template
index 14449f20c47f..bb63a5ec0952 100644
--- a/srcpkgs/python3-soupsieve/template
+++ b/srcpkgs/python3-soupsieve/template
@@ -1,18 +1,18 @@
 # Template file for 'python3-soupsieve'
 pkgname=python3-soupsieve
-version=1.9.5
-revision=6
+version=2.3.1
+revision=1
 wrksrc="soupsieve-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="python3"
+depends="python3 python3-BeautifulSoup4"
 checkdepends="python3-pytest python3-lxml python3-html5lib python3-BeautifulSoup4"
 short_desc="CSS4 selector implementation for Python3 Beautiful Soup"
 maintainer="Aluísio Augusto Silva Gonçalves <aluisio@aasg.name>"
 license="MIT"
 homepage="https://facelessuser.github.io/soupsieve/"
 distfiles="${PYPI_SITE}/s/soupsieve/soupsieve-${version}.tar.gz"
-checksum=e2c1c5dee4a1c36bcb790e0fabd5492d874b8ebd4617622c4f6a731701060dda
+checksum=b8d49b1cd4f037c7082a9683dfa1801aa2597fb11c3a1155b7a5b94829b4f1f9
 
 post_install() {
 	vlicense LICENSE.md

From f4fe6c8f55a5014ad6a6fe5d0a1e595ae923015b Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:20:35 +0100
Subject: [PATCH 09/15] python3-terminado: update to 0.13.0

---
 srcpkgs/python3-terminado/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-terminado/template b/srcpkgs/python3-terminado/template
index 28c65c82ba99..e299a6ca8c4f 100644
--- a/srcpkgs/python3-terminado/template
+++ b/srcpkgs/python3-terminado/template
@@ -1,10 +1,10 @@
 # Template file for 'python3-terminado'
 pkgname=python3-terminado
-version=0.9.4
-revision=2
+version=0.13.0
+revision=1
 wrksrc="terminado-${version}"
 build_style=python3-module
-hostmakedepends="python3-setuptools"
+hostmakedepends="python3-setuptools python3-tornado"
 depends="python3-ptyprocess python3-tornado"
 checkdepends="python3-pytest $depends"
 short_desc="Terminals served to term.js using Tornado websockets (Python3)"
@@ -12,7 +12,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/takluyver/terminado"
 distfiles="${PYPI_SITE}/t/terminado/terminado-${version}.tar.gz"
-checksum=9a7dbcfbc2778830eeb70261bf7aa9d98a3eac8631a3afe3febeb57c12f798be
+checksum=713531ccb5db7d4f544651f14050da79809030f00d1afa21462088cf32fb143a
 
 post_install() {
 	vlicense LICENSE

From 1b64609b2b61ba8ca4eae84995bf290515cbf158 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:43 +0100
Subject: [PATCH 10/15] python3-jupyter_server: update to 1.13.5

---
 srcpkgs/python3-jupyter_server/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-jupyter_server/template b/srcpkgs/python3-jupyter_server/template
index 4e6d8a6fe52a..e872ca652d59 100644
--- a/srcpkgs/python3-jupyter_server/template
+++ b/srcpkgs/python3-jupyter_server/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-jupyter_server'
 pkgname=python3-jupyter_server
-version=1.13.4
+version=1.13.5
 revision=1
 wrksrc="jupyter_server-${version}"
 build_style=python3-module
@@ -14,7 +14,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter-server/jupyter_server-${version}.tar.gz"
-checksum=5fb5a219385338b1d13a013a68f54688b6a69ecff4e757fd230e27ecacdbf212
+checksum=9e3e9717eea3bffab8cfb2ff330011be6c8bbd9cdae5b71cef169fcece2f19d3
 # Tarball defines no tests
 make_check=no
 

From 59e58c3a2dcd93a9eb4dd4f69ec64abdd7c466ad Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:59 +0100
Subject: [PATCH 11/15] jupyterlab: update to 3.3.1

---
 srcpkgs/jupyterlab/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/jupyterlab/template b/srcpkgs/jupyterlab/template
index 330d959bc154..ea12f6d4a946 100644
--- a/srcpkgs/jupyterlab/template
+++ b/srcpkgs/jupyterlab/template
@@ -1,7 +1,7 @@
 # Template file for 'jupyterlab'
 pkgname=jupyterlab
-version=3.2.8
-revision=2
+version=3.3.1
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-jupyterlab_server nodejs python3-nbclassic
@@ -11,7 +11,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="custom:jupyterlab"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyterlab/jupyterlab-${version}.tar.gz"
-checksum=5e4e99868c4f385372686767781408acbb9004b690b198b45597ba869802334b
+checksum=ce482799379c70aa87e63b59e2c5379779ce18658b92460cd20bb44154865973
 # Tests require unpackaged dependencies
 make_check=no
 

From 41528f2b436b6a2ad5517131aa2d6975e5d3a840 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Mon, 21 Feb 2022 10:41:56 +0100
Subject: [PATCH 12/15] python3-nbclient: update to 0.5.12

---
 srcpkgs/python3-nbclient/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-nbclient/template b/srcpkgs/python3-nbclient/template
index 24f9242016fb..50909329ed35 100644
--- a/srcpkgs/python3-nbclient/template
+++ b/srcpkgs/python3-nbclient/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-nbclient'
 pkgname=python3-nbclient
-version=0.5.10
+version=0.5.12
 revision=1
 wrksrc="${pkgname#python3-}-${version}"
 build_style=python3-module
@@ -12,7 +12,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://nbclient.readthedocs.io/en/latest/"
 distfiles="${PYPI_SITE}/n/nbclient/nbclient-${version}.tar.gz"
-checksum=b5fdea88d6fa52ca38de6c2361401cfe7aaa7cd24c74effc5e489cec04d79088
+checksum=0dd7ee6db59753563035f606421c3b558bd8c28b116d7e3ab8a0b4026cb44e38
 # Package might need to be installed for testing
 make_check=no
 

From 7f944b626be53c3d4ba5dbd7eaf54d64f8d0b3de Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:30:18 +0100
Subject: [PATCH 13/15] python3-traitlets: update to 5.1.1

---
 srcpkgs/python3-traitlets/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-traitlets/template b/srcpkgs/python3-traitlets/template
index f9b5819f9177..1cf7e4688617 100644
--- a/srcpkgs/python3-traitlets/template
+++ b/srcpkgs/python3-traitlets/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-traitlets'
 pkgname=python3-traitlets
-version=5.0.5
-revision=2
+version=5.1.1
+revision=1
 wrksrc="traitlets-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,7 +12,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/traitlets"
 distfiles="${PYPI_SITE}/t/traitlets/traitlets-${version}.tar.gz"
-checksum=178f4ce988f69189f7e523337a3e11d91c786ded9360174a3d9ca83e79bc5396
+checksum=059f456c5a7c1c82b98c2e8c799f39c9b8128f6d0d46941ee118daace9eb70c7
 
 do_check() {
 	pytest

From 67490642280f9aefb4b5dcdd762dc0e8aef021f1 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:30:45 +0100
Subject: [PATCH 14/15] python3-jupyter_console: update to 6.4.3

---
 srcpkgs/python3-jupyter_console/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-jupyter_console/template b/srcpkgs/python3-jupyter_console/template
index 3124f3854a19..c431d39ed7a6 100644
--- a/srcpkgs/python3-jupyter_console/template
+++ b/srcpkgs/python3-jupyter_console/template
@@ -1,24 +1,24 @@
 # Template file for 'python3-jupyter_console'
 pkgname=python3-jupyter_console
-version=6.4.0
-revision=2
+version=6.4.3
+revision=1
 wrksrc="jupyter_console-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-ipython python3-ipython_ipykernel python3-jupyter_client
- python3-prompt_toolkit python3-Pygments"
+ python3-prompt_toolkit python3-Pygments python3-traitlets"
 checkdepends="$depends python3-pytest"
 short_desc="Jupyter terminal console (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_console"
 distfiles="${PYPI_SITE}/j/jupyter_console/jupyter_console-${version}.tar.gz"
-checksum=242248e1685039cd8bff2c2ecb7ce6c1546eb50ee3b08519729e6e881aec19c7
+checksum=55f32626b0be647a85e3217ddcdb22db69efc79e8b403b9771eb9ecc696019b5
 # alternatives will be a conflict
 conflicts="python-jupyter_console<=6.0.0_2"
 # Tests fail because stdin is not a terminal
 make_check=no
 
 post_install() {
-	vlicense COPYING.md LICENSE
+	vlicense LICENSE
 }

From 209e8495de22f9b5210e9ffda5584ac750af6ad2 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:35:22 +0100
Subject: [PATCH 15/15]  python3-nbclassic: update to 0.3.6

---
 srcpkgs/python3-nbclassic/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-nbclassic/template b/srcpkgs/python3-nbclassic/template
index 066ce4adc96b..ccd5d416ef75 100644
--- a/srcpkgs/python3-nbclassic/template
+++ b/srcpkgs/python3-nbclassic/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-nbclassic'
 pkgname=python3-nbclassic
-version=0.3.5
+version=0.3.6
 revision=1
 wrksrc=nbclassic-${version}
 build_style=python3-module
@@ -11,7 +11,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/n/nbclassic/nbclassic-${version}.tar.gz"
-checksum=99444dd63103af23c788d9b5172992f12caf8c3098dd5a35c787f0df31490c29
+checksum=7dbac0a6cb71bbe3afa1fe89369e6e3174d89f42aa08216a327046de45aa9a4f
 # Tarball includes no tests
 make_check=no
 

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR REVIEW] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (32 preceding siblings ...)
  2022-03-15 13:48 ` [PR PATCH] [Updated] " dkwo
@ 2022-03-20 22:51 ` paper42
  2022-03-20 22:51 ` paper42
                   ` (16 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: paper42 @ 2022-03-20 22:51 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 382 bytes --]

New review comment by paper42 on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#discussion_r830685794

Comment:
That's because argon2-cffi is in install_requires, but it's actually an optional dependency. We can either package it and add it to checkdepends or use make_check=no and add a comment `# needs python3-argon2-cffi which is not packaged`

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR REVIEW] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (33 preceding siblings ...)
  2022-03-20 22:51 ` [PR REVIEW] " paper42
@ 2022-03-20 22:51 ` paper42
  2022-03-20 22:52 ` paper42
                   ` (15 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: paper42 @ 2022-03-20 22:51 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 292 bytes --]

New review comment by paper42 on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#discussion_r830685807

Comment:
```suggestion
homepage="https://jupyter.org"
changelog="https://raw.githubusercontent.com/jupyter-server/jupyter_server/main/CHANGELOG.md"
```

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR REVIEW] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (34 preceding siblings ...)
  2022-03-20 22:51 ` paper42
@ 2022-03-20 22:52 ` paper42
  2022-03-21  7:46 ` dkwo
                   ` (14 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: paper42 @ 2022-03-20 22:52 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 201 bytes --]

New review comment by paper42 on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#discussion_r830686008

Comment:
interesting, did you try removing the _winapi.py file?

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR REVIEW] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (35 preceding siblings ...)
  2022-03-20 22:52 ` paper42
@ 2022-03-21  7:46 ` dkwo
  2022-03-21  7:51 ` dkwo
                   ` (13 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-03-21  7:46 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 1799 bytes --]

New review comment by dkwo on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#discussion_r830827380

Comment:
after adding `python3-argon2`, as well as a ton of other `checkdepends`, it still fails with
```
=> python3-jupyter_server-1.13.5_1: running do_check ...
============================= test session starts ==============================
platform linux -- Python 3.10.3, pytest-6.2.5, py-1.10.0, pluggy-0.13.1
rootdir: /builddir/jupyter_server-1.13.5, configfile: pyproject.toml, testpaths: jupyter_server/
plugins: mock-3.5.1, anyio-3.5.0, asyncio-0.14.0, timeout-1.4.2
timeout: 300.0s
timeout method: thread
timeout func_only: False
collected 0 items / 1 error

==================================== ERRORS ====================================
________________________ ERROR collecting test session _________________________
Defining 'pytest_plugins' in a non-top-level conftest is no longer supported:
It affects the entire test suite instead of just below the conftest as expected.
  /builddir/jupyter_server-1.13.5/jupyter_server/conftest.py
Please move it to a top level conftest file at the rootdir:
  /builddir/jupyter_server-1.13.5
For more information, visit:
  https://docs.pytest.org/en/stable/deprecations.html#pytest-plugins-in-non-top-level-conftest-files
=========================== short test summary info ============================
ERROR 
!!!!!!!!!!!!!!!!!!!! Interrupted: 1 error during collection !!!!!!!!!!!!!!!!!!!!
=============================== 1 error in 0.10s ===============================
```
What they actually require:
```
test =
    coverage
    pytest>=6.0
    pytest-cov
    pytest-mock
    pytest-timeout
    requests
    pytest-tornasync
    pytest-console-scripts
    ipykernel
```

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR REVIEW] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (36 preceding siblings ...)
  2022-03-21  7:46 ` dkwo
@ 2022-03-21  7:51 ` dkwo
  2022-03-21  7:54 ` dkwo
                   ` (12 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-03-21  7:51 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 149 bytes --]

New review comment by dkwo on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#discussion_r830829814

Comment:
Done.

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR REVIEW] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (37 preceding siblings ...)
  2022-03-21  7:51 ` dkwo
@ 2022-03-21  7:54 ` dkwo
  2022-03-21  8:07 ` dkwo
                   ` (11 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-03-21  7:54 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 219 bytes --]

New review comment by dkwo on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#discussion_r830831718

Comment:
ok, after updating, error message is clear: we are missing pytest_tornasync

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR REVIEW] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (38 preceding siblings ...)
  2022-03-21  7:54 ` dkwo
@ 2022-03-21  8:07 ` dkwo
  2022-03-21  8:11 ` dkwo
                   ` (10 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-03-21  8:07 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 179 bytes --]

New review comment by dkwo on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#discussion_r830839097

Comment:
now it wants pytest-relaxed, invoke

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR REVIEW] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (39 preceding siblings ...)
  2022-03-21  8:07 ` dkwo
@ 2022-03-21  8:11 ` dkwo
  2022-03-21  8:19 ` dkwo
                   ` (9 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-03-21  8:11 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 2523 bytes --]

New review comment by dkwo on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#discussion_r830841445

Comment:
This only fails one test
```
FAILED tests/test_https.py::test_client_cert_password_verified - ValueError: ...
=================================== FAILURES ===================================
______________________ test_client_cert_password_verified ______________________
tests/test_https.py:151: in test_client_cert_password_verified
    expect_serial = tests.x509_serial(tests.CLIENT_ENCRYPTED_PEM) if tests.x509 else 16332984194609126128
        cert_log   = [{'issuer': ((('countryName', 'ZZ'),), (('stateOrProvinceName', '.'),), (('localityName', '.'),), (('organizationName'...tAfter': 'Oct  1 23:57:26 2031 GMT', 'notBefore': 'Oct  3 23:57:26 2021 GMT', 'serialNumber': 'E2AA6A96D1BF1AF0', ...}]
        handler    = <function test_client_cert_password_verified.<locals>.handler at 0x7f03cdb52440>
        http       = <httplib2.Http object at 0x7f03cdd9b670>
        setup_tls  = <function test_client_cert_password_verified.<locals>.setup_tls at 0x7f03cdb51d80>
        uri        = 'https://localhost:37437/'
        uri_parsed = ParseResult(scheme='https', netloc='localhost:37437', path='/', params='', query='', fragment='')
tests/__init__.py:786: in x509_serial
    cert = x509.load_pem_x509_certificate(pem)
        f          = <_io.BufferedReader name='/builddir/python3-httplib2-0.20.4/httplib2-0.20.4/tests/tls/client_encrypted.pem'>
        path       = '/builddir/python3-httplib2-0.20.4/httplib2-0.20.4/tests/tls/client_encrypted.pem'
        pem        = b'serial=E2AA6A96D1BF1AF0\nSHA1 Fingerprint=FB:42:16:53:02:8D:EA:F9:66:DB:BD:88:37:E1:93:7E:97:21:29:23\n-----BEGIN CE...LOQ4D+jK8/fcV9bhBuH\nLzBJ4gtPwUnvYqsaiIAeGi2EVllW0Ka+aTTzM1Yascl2q9WROvutAT0zz0M6smpO\n-----END RSA PRIVATE KEY-----\n'
/usr/lib/python3.10/site-packages/cryptography/x509/base.py:531: in load_pem_x509_certificate
    return rust_x509.load_pem_x509_certificate(data)
E   ValueError: Unable to load PEM file. See https://cryptography.io/en/latest/faq.html#why-can-t-i-import-my-pem-file for more details. InvalidData(InvalidByte(4, 45))
        backend    = None
        data       = b'serial=E2AA6A96D1BF1AF0\nSHA1 Fingerprint=FB:42:16:53:02:8D:EA:F9:66:DB:BD:88:37:E1:93:7E:97:21:29:23\n-----BEGIN CE...LOQ4D+jK8/fcV9bhBuH\nLzBJ4gtPwUnvYqsaiIAeGi2EVllW0Ka+aTTzM1Yascl2q9WROvutAT0zz0M6smpO\n-----END RSA PRIVATE KEY-----\n'
```
could you help me with this?

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR REVIEW] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (40 preceding siblings ...)
  2022-03-21  8:11 ` dkwo
@ 2022-03-21  8:19 ` dkwo
  2022-03-21  8:23 ` [PR PATCH] [Updated] " dkwo
                   ` (8 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-03-21  8:19 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 3755 bytes --]

New review comment by dkwo on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#discussion_r830846377

Comment:
similarly, missing fixtures:
```
==================================== ERRORS ====================================
_____________________ ERROR at setup of test_tree_handler ______________________
file /builddir/nbclassic-0.3.6/nbclassic/tests/test_notebookapp.py, line 19
  async def test_tree_handler(notebooks, jp_fetch):
      r = await jp_fetch('tree', 'nbclassic_test_notebooks')
      assert r.code == 200

      # Check that the tree template is loaded
      html = r.body.decode()
      assert "Files" in html
      assert "Running" in html
      assert "Clusters" in html
file /builddir/nbclassic-0.3.6/nbclassic/tests/test_notebookapp.py, line 7
  @pytest.fixture
  def notebooks(jp_create_notebook):
E       fixture 'jp_create_notebook' not found
>       available fixtures: anyio_backend, anyio_backend_name, anyio_backend_options, cache, capfd, capfdbinary, caplog, capsys, capsysbinary, doctest_namespace, monkeypatch, notebooks, pytestconfig, record_property, record_testsuite_property, record_xml_attribute, recwarn, subtests, tmp_path, tmp_path_factory, tmpdir, tmpdir_factory
>       use 'pytest --fixtures [testpath]' for help on them.

/builddir/nbclassic-0.3.6/nbclassic/tests/test_notebookapp.py:7
___________________ ERROR at setup of test_notebook_handler ____________________
file /builddir/nbclassic-0.3.6/nbclassic/tests/test_notebookapp.py, line 30
  async def test_notebook_handler(notebooks, jp_fetch):
      for nbpath in notebooks:
          r = await jp_fetch('notebooks', nbpath)
          assert r.code == 200
          # Check that the notebook template is loaded
          html = r.body.decode()
          assert "Menu" in html
          assert "Kernel" in html
          assert nbpath in html
file /builddir/nbclassic-0.3.6/nbclassic/tests/test_notebookapp.py, line 7
  @pytest.fixture
  def notebooks(jp_create_notebook):
E       fixture 'jp_create_notebook' not found
>       available fixtures: anyio_backend, anyio_backend_name, anyio_backend_options, cache, capfd, capfdbinary, caplog, capsys, capsysbinary, doctest_namespace, monkeypatch, notebooks, pytestconfig, record_property, record_testsuite_property, record_xml_attribute, recwarn, subtests, tmp_path, tmp_path_factory, tmpdir, tmpdir_factory
>       use 'pytest --fixtures [testpath]' for help on them.

/builddir/nbclassic-0.3.6/nbclassic/tests/test_notebookapp.py:7
___________________ ERROR at setup of test_terminal_handler ____________________
file /builddir/nbclassic-0.3.6/nbclassic/tests/test_notebookapp.py, line 41
  async def test_terminal_handler(jp_fetch):
          r = await jp_fetch('terminals', "1")
          assert r.code == 200
          # Check that the terminals template is loaded
          html = r.body.decode()
          assert "terminal-app" in html
E       fixture 'jp_fetch' not found
>       available fixtures: anyio_backend, anyio_backend_name, anyio_backend_options, cache, capfd, capfdbinary, caplog, capsys, capsysbinary, doctest_namespace, monkeypatch, notebooks, pytestconfig, record_property, record_testsuite_property, record_xml_attribute, recwarn, subtests, tmp_path, tmp_path_factory, tmpdir, tmpdir_factory
>       use 'pytest --fixtures [testpath]' for help on them.

/builddir/nbclassic-0.3.6/nbclassic/tests/test_notebookapp.py:41
=========================== short test summary info ============================
ERROR nbclassic/tests/test_notebookapp.py::test_tree_handler
ERROR nbclassic/tests/test_notebookapp.py::test_notebook_handler
ERROR nbclassic/tests/test_notebookapp.py::test_terminal_handler
```

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR PATCH] [Updated] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (41 preceding siblings ...)
  2022-03-21  8:19 ` dkwo
@ 2022-03-21  8:23 ` dkwo
  2022-03-21  8:23 ` dkwo
                   ` (7 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-03-21  8:23 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 397 bytes --]

There is an updated pull request by dkwo against master on the void-packages repository

https://github.com/dkwo/void-packages pytupd
https://github.com/void-linux/void-packages/pull/35376

update few python3 packages
@ahesford Could you check whether the new jupyter client solves the issue with console?

A patch file from https://github.com/void-linux/void-packages/pull/35376.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-pytupd-35376.patch --]
[-- Type: text/x-diff, Size: 21142 bytes --]

From 28c117015d320604eeb0c367b378c24709f75170 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:51:55 +0100
Subject: [PATCH 01/15] python3-defusedxml: update to 0.7.1

---
 srcpkgs/python3-defusedxml/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-defusedxml/template b/srcpkgs/python3-defusedxml/template
index 06bdd57a3526..90dc454d120d 100644
--- a/srcpkgs/python3-defusedxml/template
+++ b/srcpkgs/python3-defusedxml/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-defusedxml'
 pkgname=python3-defusedxml
-version=0.6.0
-revision=5
+version=0.7.1
+revision=1
 wrksrc="defusedxml-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Python-2.0"
 homepage="https://github.com/tiran/defusedxml"
 distfiles="${PYPI_SITE}/d/defusedxml/defusedxml-${version}.tar.gz"
-checksum=f684034d135af4c6cbb949b8a4d2ed61634515257a67299e5f940fbaa34377f5
+checksum=1bb3032db185915b62d7c6209c5a8792be6a32ab2fedacc84e01b52c51aa3e69
 
 post_install() {
 	vlicense LICENSE

From 4b200974e905bc808e26fe0eb130a8fbf0e687ca Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:54:30 +0100
Subject: [PATCH 02/15] python3-httplib2: update to 0.20.4

---
 srcpkgs/python3-httplib2/template | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/python3-httplib2/template b/srcpkgs/python3-httplib2/template
index d0c39a478622..3bea13357a87 100644
--- a/srcpkgs/python3-httplib2/template
+++ b/srcpkgs/python3-httplib2/template
@@ -1,26 +1,26 @@
 # Template file for 'python3-httplib2'
 pkgname=python3-httplib2
-version=0.18.1
-revision=3
+version=0.20.4
+revision=1
 create_wrksrc=yes
 build_wrksrc="httplib2-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="python3 ca-certificates"
+depends="python3 ca-certificates python3-parsing"
+checkdepends="python3-pytest python3-pytest-cov python3-pytest-timeout
+ python3-cryptography python3-flake8 python3-six python3-future"
 short_desc="Comprehensive HTTP client library (Python3)"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/httplib2/httplib2"
 changelog="https://raw.githubusercontent.com/httplib2/httplib2/master/CHANGELOG"
-distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz
- https://raw.githubusercontent.com/httplib2/httplib2/master/LICENSE>LICENSE.txt"
-checksum="8af66c1c52c7ffe1aa5dc4bcd7c769885254b0756e6e69f953c7f0ab49a70ba3
- 589eec38f72df2be203711d3b8cbece9b908c5e7ff00bc3cab7f63bae9e366b4"
+distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz"
+checksum=58a98e45b4b1a48273073f905d2961666ecf0fbac4250ea5b47aef259eb5c585
 
 post_install() {
 	# use system ca certificates
 	rm -rf ${DESTDIR}/${py3_sitelib}/httplib2/cacerts.txt
 	ln -sf /etc/ssl/cert.pem ${DESTDIR}/${py3_sitelib}/httplib2/cacerts.txt
 
-	vlicense ../LICENSE.txt
+	vlicense LICENSE
 }

From d61d1b6a739b5577e272e4523f82c133b0b22c7f Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:55:53 +0100
Subject: [PATCH 03/15] python3-ipython_ipykernel: update to 6.8.0

---
 srcpkgs/python3-ipython_ipykernel/template | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-ipython_ipykernel/template b/srcpkgs/python3-ipython_ipykernel/template
index f00e0a3f1a0c..b75796ca0262 100644
--- a/srcpkgs/python3-ipython_ipykernel/template
+++ b/srcpkgs/python3-ipython_ipykernel/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-ipython_ipykernel'
 pkgname=python3-ipython_ipykernel
-version=5.5.4
-revision=2
+version=6.8.0
+revision=1
 wrksrc="ipykernel-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools python3-ipython
- python3-jupyter_client python3-traitlets python3-tornado"
-depends="python3-ipython python3-traitlets python3-jupyter_client python3-tornado"
+ python3-jupyter_client python3-traitlets python3-tornado python3-entrypoints"
+depends="python3-ipython python3-traitlets python3-jupyter_client
+ python3-tornado python3-entrypoints python3-nest_asyncio"
 short_desc="IPython kernel for Jupyter (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/ipykernel"
 distfiles="${PYPI_SITE}/i/ipykernel/ipykernel-${version}.tar.gz"
-checksum=1ce0e83672cc3bfdc1ffb5603e1d77ab125f24b41abc4612e22bfb3e994c0db2
+checksum=67d316d527eca24e3ded45a2b38689615bcda1aa520a11af0accdcea7152c18a
 # checks create a cycle with python3-jupyter_core and python3-jupyter_client
 make_check=no
 

From 28fef5dbe89826b0fb046542bdffe2235294b002 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:04:52 +0100
Subject: [PATCH 04/15] python3-jupyter_client: update to 7.1.2

---
 srcpkgs/python3-jupyter_client/template | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-jupyter_client/template b/srcpkgs/python3-jupyter_client/template
index be6aa5594095..c3906f07e7b4 100644
--- a/srcpkgs/python3-jupyter_client/template
+++ b/srcpkgs/python3-jupyter_client/template
@@ -1,19 +1,18 @@
 # Template file for 'python3-jupyter_client'
 pkgname=python3-jupyter_client
-# delay 6.2 until jupyter/jupyter_console#241 is fixed
-version=6.1.12
-revision=2
+version=7.1.1
+revision=1
 wrksrc="jupyter_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-traitlets python3-jupyter_core python3-pyzmq
- python3-dateutil python3-tornado python3-nest_asyncio"
+ python3-dateutil python3-tornado python3-nest_asyncio python3-entrypoints"
 short_desc="Jupyter protocol client APIs"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_client"
 distfiles="${PYPI_SITE}/j/jupyter_client/jupyter_client-${version}.tar.gz"
-checksum=c4bca1d0846186ca8be97f4d2fa6d2bae889cce4892a167ffa1ba6bd1f73e782
+checksum=540ca35e57e83c5ece81abd9b781a57cba39a37c60a2a30c8c1b2f6663544343
 conflicts="python-jupyter_client<=5.2.4_2"
 # checks create a cycle with python3-jupyter_core and python3-ipython_ipykernel
 make_check=no

From d3e03373024f857014f193659710b364b5cd40f9 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:06:12 +0100
Subject: [PATCH 05/15] python3-jupyter_core: update to 4.9.1

---
 srcpkgs/python3-jupyter_core/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_core/template b/srcpkgs/python3-jupyter_core/template
index d0fa364a6751..5f450d293d4f 100644
--- a/srcpkgs/python3-jupyter_core/template
+++ b/srcpkgs/python3-jupyter_core/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_core'
 pkgname=python3-jupyter_core
-version=4.7.1
-revision=2
+version=4.9.1
+revision=1
 wrksrc="jupyter_core-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter_core/jupyter_core-${version}.tar.gz"
-checksum=79025cb3225efcd36847d0840f3fc672c0abd7afd0de83ba8a1d3837619122b4
+checksum=dce8a7499da5a53ae3afd5a9f4b02e5df1d57250cf48f3ad79da23b4778cd6fa
 conflicts="python-jupyter_core<=4.4.0_3"
 # checks create a cycle with python3-jypter_client and python3-ipython_ipykernel
 make_check=no

From 7515ac8beeb6075ce84193fc043bfb24b822eef3 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:07:34 +0100
Subject: [PATCH 06/15] python3-jupyter_notebook: update to 6.4.8

---
 srcpkgs/python3-jupyter_notebook/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_notebook/template b/srcpkgs/python3-jupyter_notebook/template
index ca9e1d43df21..f1ec68546fd9 100644
--- a/srcpkgs/python3-jupyter_notebook/template
+++ b/srcpkgs/python3-jupyter_notebook/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_notebook'
 pkgname=python3-jupyter_notebook
-version=6.3.0
-revision=2
+version=6.4.8
+revision=1
 wrksrc="notebook-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -15,7 +15,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org/"
 distfiles="${PYPI_SITE}/n/notebook/notebook-${version}.tar.gz"
-checksum=cbc9398d6c81473e9cdb891d2cae9c0d3718fca289dda6d26df5cb660fcadc7d
+checksum=1e985c9dc6f678bdfffb9dc657306b5469bfa62d73e03f74e8defbf76d284312
 conflicts="python-jupyter_notebook<=5.7.0_2"
 # Tests require unpackaged selenium
 make_check=no

From 2971d52dba21e7c2597a7da216494a2aa7e5b2c6 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:14:36 +0100
Subject: [PATCH 07/15] python3-paramiko: update to 2.9.2

---
 srcpkgs/python3-paramiko/template | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-paramiko/template b/srcpkgs/python3-paramiko/template
index cff1b3a2fb59..585a01085bd6 100644
--- a/srcpkgs/python3-paramiko/template
+++ b/srcpkgs/python3-paramiko/template
@@ -1,14 +1,17 @@
 # Template file for 'python3-paramiko'
 pkgname=python3-paramiko
-version=2.7.2
-revision=2
+version=2.9.2
+revision=1
 wrksrc="${pkgname#*-}-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-cryptography python3-pyasn1 python3-bcrypt python3-pynacl"
+checkdepends="${depends} python3-pynacl python3-pytest python3-mock"
 short_desc="Python3 SSH2 protocol library"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="LGPL-2.1-or-later"
 homepage="http://www.paramiko.org/"
 distfiles="${PYPI_SITE}/p/paramiko/paramiko-${version}.tar.gz"
-checksum=7f36f4ba2c0d81d219f4595e35f70d56cc94f9ac40a6acdf51d6ca210ce65035
+checksum=944a9e5dbdd413ab6c7951ea46b0ab40713235a9c4c5ca81cfe45c6f14fa677b
+# requires pytest-relaxed invoke
+make_check=no

From 8d4e4a1ecd78aafcc741af85f06bbd37eb046bd8 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:17:21 +0100
Subject: [PATCH 08/15] python3-soupsieve: update to 2.3.1

---
 srcpkgs/python3-soupsieve/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-soupsieve/template b/srcpkgs/python3-soupsieve/template
index 14449f20c47f..bb63a5ec0952 100644
--- a/srcpkgs/python3-soupsieve/template
+++ b/srcpkgs/python3-soupsieve/template
@@ -1,18 +1,18 @@
 # Template file for 'python3-soupsieve'
 pkgname=python3-soupsieve
-version=1.9.5
-revision=6
+version=2.3.1
+revision=1
 wrksrc="soupsieve-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="python3"
+depends="python3 python3-BeautifulSoup4"
 checkdepends="python3-pytest python3-lxml python3-html5lib python3-BeautifulSoup4"
 short_desc="CSS4 selector implementation for Python3 Beautiful Soup"
 maintainer="Aluísio Augusto Silva Gonçalves <aluisio@aasg.name>"
 license="MIT"
 homepage="https://facelessuser.github.io/soupsieve/"
 distfiles="${PYPI_SITE}/s/soupsieve/soupsieve-${version}.tar.gz"
-checksum=e2c1c5dee4a1c36bcb790e0fabd5492d874b8ebd4617622c4f6a731701060dda
+checksum=b8d49b1cd4f037c7082a9683dfa1801aa2597fb11c3a1155b7a5b94829b4f1f9
 
 post_install() {
 	vlicense LICENSE.md

From 46bb73e92c4c9e49e3800af10cdd6f66d709f8a6 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:20:35 +0100
Subject: [PATCH 09/15] python3-terminado: update to 0.13.0

---
 srcpkgs/python3-terminado/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-terminado/template b/srcpkgs/python3-terminado/template
index 28c65c82ba99..e299a6ca8c4f 100644
--- a/srcpkgs/python3-terminado/template
+++ b/srcpkgs/python3-terminado/template
@@ -1,10 +1,10 @@
 # Template file for 'python3-terminado'
 pkgname=python3-terminado
-version=0.9.4
-revision=2
+version=0.13.0
+revision=1
 wrksrc="terminado-${version}"
 build_style=python3-module
-hostmakedepends="python3-setuptools"
+hostmakedepends="python3-setuptools python3-tornado"
 depends="python3-ptyprocess python3-tornado"
 checkdepends="python3-pytest $depends"
 short_desc="Terminals served to term.js using Tornado websockets (Python3)"
@@ -12,7 +12,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/takluyver/terminado"
 distfiles="${PYPI_SITE}/t/terminado/terminado-${version}.tar.gz"
-checksum=9a7dbcfbc2778830eeb70261bf7aa9d98a3eac8631a3afe3febeb57c12f798be
+checksum=713531ccb5db7d4f544651f14050da79809030f00d1afa21462088cf32fb143a
 
 post_install() {
 	vlicense LICENSE

From 28f5f452d6dd29ec669467b84aa87625bc0787ab Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:43 +0100
Subject: [PATCH 10/15] python3-jupyter_server: update to 1.15.2

---
 srcpkgs/python3-jupyter_server/template | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_server/template b/srcpkgs/python3-jupyter_server/template
index 4e6d8a6fe52a..e8c98c8f9367 100644
--- a/srcpkgs/python3-jupyter_server/template
+++ b/srcpkgs/python3-jupyter_server/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-jupyter_server'
 pkgname=python3-jupyter_server
-version=1.13.4
+version=1.15.6
 revision=1
 wrksrc="jupyter_server-${version}"
 build_style=python3-module
@@ -9,13 +9,17 @@ depends="python3-anyio python3-jupyter_client python3-jupyter_nbformat
  python3-jupyter_nbconvert python3-terminado
  python3-prometheus_client python3-traitlets python3-tornado
  python3-Jinja2 python3-send2trash python3-websocket-client"
+checkdepends="${depends} python3-argon2 python3-packaging
+ python3-coverage python3-pytest-mock python3-requests
+ python3-pytest python3-pytest-timeout python3-pytest-asyncio"
 short_desc="Backend to Jupyter web applications"
 maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
+changelog="https://raw.githubusercontent.com/jupyter-server/jupyter_server/main/CHANGELOG.md"
 distfiles="${PYPI_SITE}/j/jupyter-server/jupyter_server-${version}.tar.gz"
-checksum=5fb5a219385338b1d13a013a68f54688b6a69ecff4e757fd230e27ecacdbf212
-# Tarball defines no tests
+checksum=56bd6f580d1f46b62294990e8e78651025729f5d3fc798f10f2c03f0cdcbf28d
+# missing pytest-tornasync, pytest-console-scripts
 make_check=no
 
 post_install() {

From 990b9e473a6a2bc791ce67ed2b09b359d5d74e7b Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:59 +0100
Subject: [PATCH 11/15] jupyterlab: update to 3.3.1

---
 srcpkgs/jupyterlab/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/jupyterlab/template b/srcpkgs/jupyterlab/template
index 330d959bc154..ea12f6d4a946 100644
--- a/srcpkgs/jupyterlab/template
+++ b/srcpkgs/jupyterlab/template
@@ -1,7 +1,7 @@
 # Template file for 'jupyterlab'
 pkgname=jupyterlab
-version=3.2.8
-revision=2
+version=3.3.1
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-jupyterlab_server nodejs python3-nbclassic
@@ -11,7 +11,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="custom:jupyterlab"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyterlab/jupyterlab-${version}.tar.gz"
-checksum=5e4e99868c4f385372686767781408acbb9004b690b198b45597ba869802334b
+checksum=ce482799379c70aa87e63b59e2c5379779ce18658b92460cd20bb44154865973
 # Tests require unpackaged dependencies
 make_check=no
 

From 001f2666a3a4f61e82245089990680ca20bd62fb Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Mon, 21 Feb 2022 10:41:56 +0100
Subject: [PATCH 12/15] python3-nbclient: update to 0.5.12

---
 srcpkgs/python3-nbclient/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-nbclient/template b/srcpkgs/python3-nbclient/template
index 24f9242016fb..50909329ed35 100644
--- a/srcpkgs/python3-nbclient/template
+++ b/srcpkgs/python3-nbclient/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-nbclient'
 pkgname=python3-nbclient
-version=0.5.10
+version=0.5.12
 revision=1
 wrksrc="${pkgname#python3-}-${version}"
 build_style=python3-module
@@ -12,7 +12,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://nbclient.readthedocs.io/en/latest/"
 distfiles="${PYPI_SITE}/n/nbclient/nbclient-${version}.tar.gz"
-checksum=b5fdea88d6fa52ca38de6c2361401cfe7aaa7cd24c74effc5e489cec04d79088
+checksum=0dd7ee6db59753563035f606421c3b558bd8c28b116d7e3ab8a0b4026cb44e38
 # Package might need to be installed for testing
 make_check=no
 

From f0b27a5fa2c628e3e1d30a85b193d6c2b447b646 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:30:18 +0100
Subject: [PATCH 13/15] python3-traitlets: update to 5.1.1

---
 srcpkgs/python3-traitlets/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-traitlets/template b/srcpkgs/python3-traitlets/template
index f9b5819f9177..1cf7e4688617 100644
--- a/srcpkgs/python3-traitlets/template
+++ b/srcpkgs/python3-traitlets/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-traitlets'
 pkgname=python3-traitlets
-version=5.0.5
-revision=2
+version=5.1.1
+revision=1
 wrksrc="traitlets-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,7 +12,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/traitlets"
 distfiles="${PYPI_SITE}/t/traitlets/traitlets-${version}.tar.gz"
-checksum=178f4ce988f69189f7e523337a3e11d91c786ded9360174a3d9ca83e79bc5396
+checksum=059f456c5a7c1c82b98c2e8c799f39c9b8128f6d0d46941ee118daace9eb70c7
 
 do_check() {
 	pytest

From 29dccd2d6d86aa8ef33de66c1239b6ddb7eafc48 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:30:45 +0100
Subject: [PATCH 14/15] python3-jupyter_console: update to 6.4.3

---
 srcpkgs/python3-jupyter_console/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-jupyter_console/template b/srcpkgs/python3-jupyter_console/template
index 3124f3854a19..c431d39ed7a6 100644
--- a/srcpkgs/python3-jupyter_console/template
+++ b/srcpkgs/python3-jupyter_console/template
@@ -1,24 +1,24 @@
 # Template file for 'python3-jupyter_console'
 pkgname=python3-jupyter_console
-version=6.4.0
-revision=2
+version=6.4.3
+revision=1
 wrksrc="jupyter_console-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-ipython python3-ipython_ipykernel python3-jupyter_client
- python3-prompt_toolkit python3-Pygments"
+ python3-prompt_toolkit python3-Pygments python3-traitlets"
 checkdepends="$depends python3-pytest"
 short_desc="Jupyter terminal console (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_console"
 distfiles="${PYPI_SITE}/j/jupyter_console/jupyter_console-${version}.tar.gz"
-checksum=242248e1685039cd8bff2c2ecb7ce6c1546eb50ee3b08519729e6e881aec19c7
+checksum=55f32626b0be647a85e3217ddcdb22db69efc79e8b403b9771eb9ecc696019b5
 # alternatives will be a conflict
 conflicts="python-jupyter_console<=6.0.0_2"
 # Tests fail because stdin is not a terminal
 make_check=no
 
 post_install() {
-	vlicense COPYING.md LICENSE
+	vlicense LICENSE
 }

From 9f7d7e6848cddf0c152b3bfb2e495bbe159151a2 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:35:22 +0100
Subject: [PATCH 15/15]  python3-nbclassic: update to 0.3.6

---
 srcpkgs/python3-nbclassic/template | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-nbclassic/template b/srcpkgs/python3-nbclassic/template
index 066ce4adc96b..6d122531347e 100644
--- a/srcpkgs/python3-nbclassic/template
+++ b/srcpkgs/python3-nbclassic/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-nbclassic'
 pkgname=python3-nbclassic
-version=0.3.5
+version=0.3.6
 revision=1
 wrksrc=nbclassic-${version}
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-jupyter_notebook python3-jupyter_server"
+checkdepends="${depends} python3-pytest python3-pytest-fixture-config python3-pytest-subtests"
 short_desc="Jupyter Notebook as a Jupyter Server Extension"
 maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/n/nbclassic/nbclassic-${version}.tar.gz"
-checksum=99444dd63103af23c788d9b5172992f12caf8c3098dd5a35c787f0df31490c29
-# Tarball includes no tests
+checksum=7dbac0a6cb71bbe3afa1fe89369e6e3174d89f42aa08216a327046de45aa9a4f
+# missing fixtures: jp_create_notebook jp_fetch
 make_check=no
 
 conf_files="/etc/jupyter/jupyter_server_config.d/*.json"

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (42 preceding siblings ...)
  2022-03-21  8:23 ` [PR PATCH] [Updated] " dkwo
@ 2022-03-21  8:23 ` dkwo
  2022-03-21 10:10 ` [PR PATCH] [Updated] " dkwo
                   ` (6 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-03-21  8:23 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 277 bytes --]

New comment by dkwo on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#issuecomment-1073611609

Comment:
I've added comments as to what is missing.
I feel httplib2 is close to passing tests, but I do not understand the only failure remaining.

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR PATCH] [Updated] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (43 preceding siblings ...)
  2022-03-21  8:23 ` dkwo
@ 2022-03-21 10:10 ` dkwo
  2022-04-11 17:08 ` dkwo
                   ` (5 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-03-21 10:10 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 397 bytes --]

There is an updated pull request by dkwo against master on the void-packages repository

https://github.com/dkwo/void-packages pytupd
https://github.com/void-linux/void-packages/pull/35376

update few python3 packages
@ahesford Could you check whether the new jupyter client solves the issue with console?

A patch file from https://github.com/void-linux/void-packages/pull/35376.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-pytupd-35376.patch --]
[-- Type: text/x-diff, Size: 21142 bytes --]

From 027e2dc41c28818266c6a18ed6b026607ab00896 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:51:55 +0100
Subject: [PATCH 01/15] python3-defusedxml: update to 0.7.1

---
 srcpkgs/python3-defusedxml/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-defusedxml/template b/srcpkgs/python3-defusedxml/template
index 06bdd57a3526..90dc454d120d 100644
--- a/srcpkgs/python3-defusedxml/template
+++ b/srcpkgs/python3-defusedxml/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-defusedxml'
 pkgname=python3-defusedxml
-version=0.6.0
-revision=5
+version=0.7.1
+revision=1
 wrksrc="defusedxml-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Python-2.0"
 homepage="https://github.com/tiran/defusedxml"
 distfiles="${PYPI_SITE}/d/defusedxml/defusedxml-${version}.tar.gz"
-checksum=f684034d135af4c6cbb949b8a4d2ed61634515257a67299e5f940fbaa34377f5
+checksum=1bb3032db185915b62d7c6209c5a8792be6a32ab2fedacc84e01b52c51aa3e69
 
 post_install() {
 	vlicense LICENSE

From 0835a7a533a1d32b0560051f0aff83f40fafb3f2 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:54:30 +0100
Subject: [PATCH 02/15] python3-httplib2: update to 0.20.4

---
 srcpkgs/python3-httplib2/template | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)

diff --git a/srcpkgs/python3-httplib2/template b/srcpkgs/python3-httplib2/template
index d0c39a478622..3bea13357a87 100644
--- a/srcpkgs/python3-httplib2/template
+++ b/srcpkgs/python3-httplib2/template
@@ -1,26 +1,26 @@
 # Template file for 'python3-httplib2'
 pkgname=python3-httplib2
-version=0.18.1
-revision=3
+version=0.20.4
+revision=1
 create_wrksrc=yes
 build_wrksrc="httplib2-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="python3 ca-certificates"
+depends="python3 ca-certificates python3-parsing"
+checkdepends="python3-pytest python3-pytest-cov python3-pytest-timeout
+ python3-cryptography python3-flake8 python3-six python3-future"
 short_desc="Comprehensive HTTP client library (Python3)"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/httplib2/httplib2"
 changelog="https://raw.githubusercontent.com/httplib2/httplib2/master/CHANGELOG"
-distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz
- https://raw.githubusercontent.com/httplib2/httplib2/master/LICENSE>LICENSE.txt"
-checksum="8af66c1c52c7ffe1aa5dc4bcd7c769885254b0756e6e69f953c7f0ab49a70ba3
- 589eec38f72df2be203711d3b8cbece9b908c5e7ff00bc3cab7f63bae9e366b4"
+distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz"
+checksum=58a98e45b4b1a48273073f905d2961666ecf0fbac4250ea5b47aef259eb5c585
 
 post_install() {
 	# use system ca certificates
 	rm -rf ${DESTDIR}/${py3_sitelib}/httplib2/cacerts.txt
 	ln -sf /etc/ssl/cert.pem ${DESTDIR}/${py3_sitelib}/httplib2/cacerts.txt
 
-	vlicense ../LICENSE.txt
+	vlicense LICENSE
 }

From 8c9014564f0ddc0164e4b4452a960aa7615250d3 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:55:53 +0100
Subject: [PATCH 03/15] python3-ipython_ipykernel: update to 6.8.0

---
 srcpkgs/python3-ipython_ipykernel/template | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-ipython_ipykernel/template b/srcpkgs/python3-ipython_ipykernel/template
index f00e0a3f1a0c..b75796ca0262 100644
--- a/srcpkgs/python3-ipython_ipykernel/template
+++ b/srcpkgs/python3-ipython_ipykernel/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-ipython_ipykernel'
 pkgname=python3-ipython_ipykernel
-version=5.5.4
-revision=2
+version=6.8.0
+revision=1
 wrksrc="ipykernel-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools python3-ipython
- python3-jupyter_client python3-traitlets python3-tornado"
-depends="python3-ipython python3-traitlets python3-jupyter_client python3-tornado"
+ python3-jupyter_client python3-traitlets python3-tornado python3-entrypoints"
+depends="python3-ipython python3-traitlets python3-jupyter_client
+ python3-tornado python3-entrypoints python3-nest_asyncio"
 short_desc="IPython kernel for Jupyter (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/ipykernel"
 distfiles="${PYPI_SITE}/i/ipykernel/ipykernel-${version}.tar.gz"
-checksum=1ce0e83672cc3bfdc1ffb5603e1d77ab125f24b41abc4612e22bfb3e994c0db2
+checksum=67d316d527eca24e3ded45a2b38689615bcda1aa520a11af0accdcea7152c18a
 # checks create a cycle with python3-jupyter_core and python3-jupyter_client
 make_check=no
 

From e0cef742a94d55aee13e026ca295204bd7132e55 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:04:52 +0100
Subject: [PATCH 04/15] python3-jupyter_client: update to 7.1.2

---
 srcpkgs/python3-jupyter_client/template | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-jupyter_client/template b/srcpkgs/python3-jupyter_client/template
index be6aa5594095..c3906f07e7b4 100644
--- a/srcpkgs/python3-jupyter_client/template
+++ b/srcpkgs/python3-jupyter_client/template
@@ -1,19 +1,18 @@
 # Template file for 'python3-jupyter_client'
 pkgname=python3-jupyter_client
-# delay 6.2 until jupyter/jupyter_console#241 is fixed
-version=6.1.12
-revision=2
+version=7.1.1
+revision=1
 wrksrc="jupyter_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-traitlets python3-jupyter_core python3-pyzmq
- python3-dateutil python3-tornado python3-nest_asyncio"
+ python3-dateutil python3-tornado python3-nest_asyncio python3-entrypoints"
 short_desc="Jupyter protocol client APIs"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_client"
 distfiles="${PYPI_SITE}/j/jupyter_client/jupyter_client-${version}.tar.gz"
-checksum=c4bca1d0846186ca8be97f4d2fa6d2bae889cce4892a167ffa1ba6bd1f73e782
+checksum=540ca35e57e83c5ece81abd9b781a57cba39a37c60a2a30c8c1b2f6663544343
 conflicts="python-jupyter_client<=5.2.4_2"
 # checks create a cycle with python3-jupyter_core and python3-ipython_ipykernel
 make_check=no

From a889772a77eb8cad43ecccc28c84bd6a4cd36ffa Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:06:12 +0100
Subject: [PATCH 05/15] python3-jupyter_core: update to 4.9.1

---
 srcpkgs/python3-jupyter_core/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_core/template b/srcpkgs/python3-jupyter_core/template
index d0fa364a6751..5f450d293d4f 100644
--- a/srcpkgs/python3-jupyter_core/template
+++ b/srcpkgs/python3-jupyter_core/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_core'
 pkgname=python3-jupyter_core
-version=4.7.1
-revision=2
+version=4.9.1
+revision=1
 wrksrc="jupyter_core-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter_core/jupyter_core-${version}.tar.gz"
-checksum=79025cb3225efcd36847d0840f3fc672c0abd7afd0de83ba8a1d3837619122b4
+checksum=dce8a7499da5a53ae3afd5a9f4b02e5df1d57250cf48f3ad79da23b4778cd6fa
 conflicts="python-jupyter_core<=4.4.0_3"
 # checks create a cycle with python3-jypter_client and python3-ipython_ipykernel
 make_check=no

From e046430c661996cd07e2cfd6393bbdc5c43094b7 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:07:34 +0100
Subject: [PATCH 06/15] python3-jupyter_notebook: update to 6.4.8

---
 srcpkgs/python3-jupyter_notebook/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_notebook/template b/srcpkgs/python3-jupyter_notebook/template
index ca9e1d43df21..f1ec68546fd9 100644
--- a/srcpkgs/python3-jupyter_notebook/template
+++ b/srcpkgs/python3-jupyter_notebook/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_notebook'
 pkgname=python3-jupyter_notebook
-version=6.3.0
-revision=2
+version=6.4.8
+revision=1
 wrksrc="notebook-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -15,7 +15,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org/"
 distfiles="${PYPI_SITE}/n/notebook/notebook-${version}.tar.gz"
-checksum=cbc9398d6c81473e9cdb891d2cae9c0d3718fca289dda6d26df5cb660fcadc7d
+checksum=1e985c9dc6f678bdfffb9dc657306b5469bfa62d73e03f74e8defbf76d284312
 conflicts="python-jupyter_notebook<=5.7.0_2"
 # Tests require unpackaged selenium
 make_check=no

From eb4794bfb24221ce7247b95fca599d7110789943 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:14:36 +0100
Subject: [PATCH 07/15] python3-paramiko: update to 2.9.2

---
 srcpkgs/python3-paramiko/template | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-paramiko/template b/srcpkgs/python3-paramiko/template
index cff1b3a2fb59..585a01085bd6 100644
--- a/srcpkgs/python3-paramiko/template
+++ b/srcpkgs/python3-paramiko/template
@@ -1,14 +1,17 @@
 # Template file for 'python3-paramiko'
 pkgname=python3-paramiko
-version=2.7.2
-revision=2
+version=2.9.2
+revision=1
 wrksrc="${pkgname#*-}-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-cryptography python3-pyasn1 python3-bcrypt python3-pynacl"
+checkdepends="${depends} python3-pynacl python3-pytest python3-mock"
 short_desc="Python3 SSH2 protocol library"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="LGPL-2.1-or-later"
 homepage="http://www.paramiko.org/"
 distfiles="${PYPI_SITE}/p/paramiko/paramiko-${version}.tar.gz"
-checksum=7f36f4ba2c0d81d219f4595e35f70d56cc94f9ac40a6acdf51d6ca210ce65035
+checksum=944a9e5dbdd413ab6c7951ea46b0ab40713235a9c4c5ca81cfe45c6f14fa677b
+# requires pytest-relaxed invoke
+make_check=no

From 9fece76e85530c2f26a671da39ad735455a69c73 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:17:21 +0100
Subject: [PATCH 08/15] python3-soupsieve: update to 2.3.1

---
 srcpkgs/python3-soupsieve/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-soupsieve/template b/srcpkgs/python3-soupsieve/template
index 14449f20c47f..bb63a5ec0952 100644
--- a/srcpkgs/python3-soupsieve/template
+++ b/srcpkgs/python3-soupsieve/template
@@ -1,18 +1,18 @@
 # Template file for 'python3-soupsieve'
 pkgname=python3-soupsieve
-version=1.9.5
-revision=6
+version=2.3.1
+revision=1
 wrksrc="soupsieve-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="python3"
+depends="python3 python3-BeautifulSoup4"
 checkdepends="python3-pytest python3-lxml python3-html5lib python3-BeautifulSoup4"
 short_desc="CSS4 selector implementation for Python3 Beautiful Soup"
 maintainer="Aluísio Augusto Silva Gonçalves <aluisio@aasg.name>"
 license="MIT"
 homepage="https://facelessuser.github.io/soupsieve/"
 distfiles="${PYPI_SITE}/s/soupsieve/soupsieve-${version}.tar.gz"
-checksum=e2c1c5dee4a1c36bcb790e0fabd5492d874b8ebd4617622c4f6a731701060dda
+checksum=b8d49b1cd4f037c7082a9683dfa1801aa2597fb11c3a1155b7a5b94829b4f1f9
 
 post_install() {
 	vlicense LICENSE.md

From dfa0d48a5957bf2c9c664799a4a70318c05f20bc Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:20:35 +0100
Subject: [PATCH 09/15] python3-terminado: update to 0.13.0

---
 srcpkgs/python3-terminado/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-terminado/template b/srcpkgs/python3-terminado/template
index 28c65c82ba99..e299a6ca8c4f 100644
--- a/srcpkgs/python3-terminado/template
+++ b/srcpkgs/python3-terminado/template
@@ -1,10 +1,10 @@
 # Template file for 'python3-terminado'
 pkgname=python3-terminado
-version=0.9.4
-revision=2
+version=0.13.0
+revision=1
 wrksrc="terminado-${version}"
 build_style=python3-module
-hostmakedepends="python3-setuptools"
+hostmakedepends="python3-setuptools python3-tornado"
 depends="python3-ptyprocess python3-tornado"
 checkdepends="python3-pytest $depends"
 short_desc="Terminals served to term.js using Tornado websockets (Python3)"
@@ -12,7 +12,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/takluyver/terminado"
 distfiles="${PYPI_SITE}/t/terminado/terminado-${version}.tar.gz"
-checksum=9a7dbcfbc2778830eeb70261bf7aa9d98a3eac8631a3afe3febeb57c12f798be
+checksum=713531ccb5db7d4f544651f14050da79809030f00d1afa21462088cf32fb143a
 
 post_install() {
 	vlicense LICENSE

From b8fb09946847c9edcc20f1e048414e95776fa0fe Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:43 +0100
Subject: [PATCH 10/15] python3-jupyter_server: update to 1.15.2

---
 srcpkgs/python3-jupyter_server/template | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_server/template b/srcpkgs/python3-jupyter_server/template
index 4e6d8a6fe52a..e8c98c8f9367 100644
--- a/srcpkgs/python3-jupyter_server/template
+++ b/srcpkgs/python3-jupyter_server/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-jupyter_server'
 pkgname=python3-jupyter_server
-version=1.13.4
+version=1.15.6
 revision=1
 wrksrc="jupyter_server-${version}"
 build_style=python3-module
@@ -9,13 +9,17 @@ depends="python3-anyio python3-jupyter_client python3-jupyter_nbformat
  python3-jupyter_nbconvert python3-terminado
  python3-prometheus_client python3-traitlets python3-tornado
  python3-Jinja2 python3-send2trash python3-websocket-client"
+checkdepends="${depends} python3-argon2 python3-packaging
+ python3-coverage python3-pytest-mock python3-requests
+ python3-pytest python3-pytest-timeout python3-pytest-asyncio"
 short_desc="Backend to Jupyter web applications"
 maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
+changelog="https://raw.githubusercontent.com/jupyter-server/jupyter_server/main/CHANGELOG.md"
 distfiles="${PYPI_SITE}/j/jupyter-server/jupyter_server-${version}.tar.gz"
-checksum=5fb5a219385338b1d13a013a68f54688b6a69ecff4e757fd230e27ecacdbf212
-# Tarball defines no tests
+checksum=56bd6f580d1f46b62294990e8e78651025729f5d3fc798f10f2c03f0cdcbf28d
+# missing pytest-tornasync, pytest-console-scripts
 make_check=no
 
 post_install() {

From 61184b2ab78d16aca5874728cbb01234426b364c Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:59 +0100
Subject: [PATCH 11/15] jupyterlab: update to 3.3.1

---
 srcpkgs/jupyterlab/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/jupyterlab/template b/srcpkgs/jupyterlab/template
index 330d959bc154..ea12f6d4a946 100644
--- a/srcpkgs/jupyterlab/template
+++ b/srcpkgs/jupyterlab/template
@@ -1,7 +1,7 @@
 # Template file for 'jupyterlab'
 pkgname=jupyterlab
-version=3.2.8
-revision=2
+version=3.3.1
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-jupyterlab_server nodejs python3-nbclassic
@@ -11,7 +11,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="custom:jupyterlab"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyterlab/jupyterlab-${version}.tar.gz"
-checksum=5e4e99868c4f385372686767781408acbb9004b690b198b45597ba869802334b
+checksum=ce482799379c70aa87e63b59e2c5379779ce18658b92460cd20bb44154865973
 # Tests require unpackaged dependencies
 make_check=no
 

From f1604adac5a7f91c6a457582ed97827962fee9bf Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Mon, 21 Feb 2022 10:41:56 +0100
Subject: [PATCH 12/15] python3-nbclient: update to 0.5.12

---
 srcpkgs/python3-nbclient/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-nbclient/template b/srcpkgs/python3-nbclient/template
index 24f9242016fb..50909329ed35 100644
--- a/srcpkgs/python3-nbclient/template
+++ b/srcpkgs/python3-nbclient/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-nbclient'
 pkgname=python3-nbclient
-version=0.5.10
+version=0.5.12
 revision=1
 wrksrc="${pkgname#python3-}-${version}"
 build_style=python3-module
@@ -12,7 +12,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://nbclient.readthedocs.io/en/latest/"
 distfiles="${PYPI_SITE}/n/nbclient/nbclient-${version}.tar.gz"
-checksum=b5fdea88d6fa52ca38de6c2361401cfe7aaa7cd24c74effc5e489cec04d79088
+checksum=0dd7ee6db59753563035f606421c3b558bd8c28b116d7e3ab8a0b4026cb44e38
 # Package might need to be installed for testing
 make_check=no
 

From 9b233e8ab9b0bd210ef557ce5b8927efd0ea732f Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:30:18 +0100
Subject: [PATCH 13/15] python3-traitlets: update to 5.1.1

---
 srcpkgs/python3-traitlets/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-traitlets/template b/srcpkgs/python3-traitlets/template
index f9b5819f9177..1cf7e4688617 100644
--- a/srcpkgs/python3-traitlets/template
+++ b/srcpkgs/python3-traitlets/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-traitlets'
 pkgname=python3-traitlets
-version=5.0.5
-revision=2
+version=5.1.1
+revision=1
 wrksrc="traitlets-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,7 +12,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/traitlets"
 distfiles="${PYPI_SITE}/t/traitlets/traitlets-${version}.tar.gz"
-checksum=178f4ce988f69189f7e523337a3e11d91c786ded9360174a3d9ca83e79bc5396
+checksum=059f456c5a7c1c82b98c2e8c799f39c9b8128f6d0d46941ee118daace9eb70c7
 
 do_check() {
 	pytest

From d92bfa58a37fd15fe89b6f1c062f8971818b50d2 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:30:45 +0100
Subject: [PATCH 14/15] python3-jupyter_console: update to 6.4.3

---
 srcpkgs/python3-jupyter_console/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-jupyter_console/template b/srcpkgs/python3-jupyter_console/template
index 3124f3854a19..c431d39ed7a6 100644
--- a/srcpkgs/python3-jupyter_console/template
+++ b/srcpkgs/python3-jupyter_console/template
@@ -1,24 +1,24 @@
 # Template file for 'python3-jupyter_console'
 pkgname=python3-jupyter_console
-version=6.4.0
-revision=2
+version=6.4.3
+revision=1
 wrksrc="jupyter_console-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-ipython python3-ipython_ipykernel python3-jupyter_client
- python3-prompt_toolkit python3-Pygments"
+ python3-prompt_toolkit python3-Pygments python3-traitlets"
 checkdepends="$depends python3-pytest"
 short_desc="Jupyter terminal console (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_console"
 distfiles="${PYPI_SITE}/j/jupyter_console/jupyter_console-${version}.tar.gz"
-checksum=242248e1685039cd8bff2c2ecb7ce6c1546eb50ee3b08519729e6e881aec19c7
+checksum=55f32626b0be647a85e3217ddcdb22db69efc79e8b403b9771eb9ecc696019b5
 # alternatives will be a conflict
 conflicts="python-jupyter_console<=6.0.0_2"
 # Tests fail because stdin is not a terminal
 make_check=no
 
 post_install() {
-	vlicense COPYING.md LICENSE
+	vlicense LICENSE
 }

From 01f21bc05ce90ff315c77fbd996ddf3617b0211c Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:35:22 +0100
Subject: [PATCH 15/15]  python3-nbclassic: update to 0.3.6

---
 srcpkgs/python3-nbclassic/template | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-nbclassic/template b/srcpkgs/python3-nbclassic/template
index 066ce4adc96b..6d122531347e 100644
--- a/srcpkgs/python3-nbclassic/template
+++ b/srcpkgs/python3-nbclassic/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-nbclassic'
 pkgname=python3-nbclassic
-version=0.3.5
+version=0.3.6
 revision=1
 wrksrc=nbclassic-${version}
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-jupyter_notebook python3-jupyter_server"
+checkdepends="${depends} python3-pytest python3-pytest-fixture-config python3-pytest-subtests"
 short_desc="Jupyter Notebook as a Jupyter Server Extension"
 maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/n/nbclassic/nbclassic-${version}.tar.gz"
-checksum=99444dd63103af23c788d9b5172992f12caf8c3098dd5a35c787f0df31490c29
-# Tarball includes no tests
+checksum=7dbac0a6cb71bbe3afa1fe89369e6e3174d89f42aa08216a327046de45aa9a4f
+# missing fixtures: jp_create_notebook jp_fetch
 make_check=no
 
 conf_files="/etc/jupyter/jupyter_server_config.d/*.json"

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR PATCH] [Updated] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (44 preceding siblings ...)
  2022-03-21 10:10 ` [PR PATCH] [Updated] " dkwo
@ 2022-04-11 17:08 ` dkwo
  2022-04-11 17:09 ` dkwo
                   ` (4 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-04-11 17:08 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 397 bytes --]

There is an updated pull request by dkwo against master on the void-packages repository

https://github.com/dkwo/void-packages pytupd
https://github.com/void-linux/void-packages/pull/35376

update few python3 packages
@ahesford Could you check whether the new jupyter client solves the issue with console?

A patch file from https://github.com/void-linux/void-packages/pull/35376.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-pytupd-35376.patch --]
[-- Type: text/x-diff, Size: 20010 bytes --]

From de2f09c5e36109e2aaf5077793e70485535c9f52 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:51:55 +0100
Subject: [PATCH 01/14] python3-defusedxml: update to 0.7.1

---
 srcpkgs/python3-defusedxml/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-defusedxml/template b/srcpkgs/python3-defusedxml/template
index 06bdd57a3526..90dc454d120d 100644
--- a/srcpkgs/python3-defusedxml/template
+++ b/srcpkgs/python3-defusedxml/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-defusedxml'
 pkgname=python3-defusedxml
-version=0.6.0
-revision=5
+version=0.7.1
+revision=1
 wrksrc="defusedxml-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Python-2.0"
 homepage="https://github.com/tiran/defusedxml"
 distfiles="${PYPI_SITE}/d/defusedxml/defusedxml-${version}.tar.gz"
-checksum=f684034d135af4c6cbb949b8a4d2ed61634515257a67299e5f940fbaa34377f5
+checksum=1bb3032db185915b62d7c6209c5a8792be6a32ab2fedacc84e01b52c51aa3e69
 
 post_install() {
 	vlicense LICENSE

From 0b0b44eb7c14ce9ac3e6cab3e3788ca706d7f99a Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:54:30 +0100
Subject: [PATCH 02/14] python3-httplib2: update to 0.20.4

---
 srcpkgs/python3-httplib2/template | 20 ++++++++++----------
 1 file changed, 10 insertions(+), 10 deletions(-)

diff --git a/srcpkgs/python3-httplib2/template b/srcpkgs/python3-httplib2/template
index d0c39a478622..e274fbec2145 100644
--- a/srcpkgs/python3-httplib2/template
+++ b/srcpkgs/python3-httplib2/template
@@ -1,26 +1,26 @@
 # Template file for 'python3-httplib2'
 pkgname=python3-httplib2
-version=0.18.1
-revision=3
-create_wrksrc=yes
-build_wrksrc="httplib2-${version}"
+version=0.20.4
+revision=1
+wrksrc="httplib2-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="python3 ca-certificates"
+depends="python3 ca-certificates python3-parsing"
+checkdepends="python3-pytest python3-pytest-cov python3-pytest-timeout
+ python3-cryptography python3-flake8 python3-six python3-future"
 short_desc="Comprehensive HTTP client library (Python3)"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/httplib2/httplib2"
 changelog="https://raw.githubusercontent.com/httplib2/httplib2/master/CHANGELOG"
-distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz
- https://raw.githubusercontent.com/httplib2/httplib2/master/LICENSE>LICENSE.txt"
-checksum="8af66c1c52c7ffe1aa5dc4bcd7c769885254b0756e6e69f953c7f0ab49a70ba3
- 589eec38f72df2be203711d3b8cbece9b908c5e7ff00bc3cab7f63bae9e366b4"
+distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz"
+checksum=58a98e45b4b1a48273073f905d2961666ecf0fbac4250ea5b47aef259eb5c585
+make_check=no # our cryptography package is too recent, one test fails
 
 post_install() {
 	# use system ca certificates
 	rm -rf ${DESTDIR}/${py3_sitelib}/httplib2/cacerts.txt
 	ln -sf /etc/ssl/cert.pem ${DESTDIR}/${py3_sitelib}/httplib2/cacerts.txt
 
-	vlicense ../LICENSE.txt
+	vlicense LICENSE
 }

From 1f9ff74045d88022f0c7d32868021e2533c21283 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:55:53 +0100
Subject: [PATCH 03/14] python3-ipython_ipykernel: update to 6.8.0

---
 srcpkgs/python3-ipython_ipykernel/template | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-ipython_ipykernel/template b/srcpkgs/python3-ipython_ipykernel/template
index f00e0a3f1a0c..b75796ca0262 100644
--- a/srcpkgs/python3-ipython_ipykernel/template
+++ b/srcpkgs/python3-ipython_ipykernel/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-ipython_ipykernel'
 pkgname=python3-ipython_ipykernel
-version=5.5.4
-revision=2
+version=6.8.0
+revision=1
 wrksrc="ipykernel-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools python3-ipython
- python3-jupyter_client python3-traitlets python3-tornado"
-depends="python3-ipython python3-traitlets python3-jupyter_client python3-tornado"
+ python3-jupyter_client python3-traitlets python3-tornado python3-entrypoints"
+depends="python3-ipython python3-traitlets python3-jupyter_client
+ python3-tornado python3-entrypoints python3-nest_asyncio"
 short_desc="IPython kernel for Jupyter (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/ipykernel"
 distfiles="${PYPI_SITE}/i/ipykernel/ipykernel-${version}.tar.gz"
-checksum=1ce0e83672cc3bfdc1ffb5603e1d77ab125f24b41abc4612e22bfb3e994c0db2
+checksum=67d316d527eca24e3ded45a2b38689615bcda1aa520a11af0accdcea7152c18a
 # checks create a cycle with python3-jupyter_core and python3-jupyter_client
 make_check=no
 

From 9a5341c0360e8486a58f716e837271c18b9ca0d5 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:04:52 +0100
Subject: [PATCH 04/14] python3-jupyter_client: update to 7.1.2

---
 srcpkgs/python3-jupyter_client/template | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-jupyter_client/template b/srcpkgs/python3-jupyter_client/template
index be6aa5594095..c3906f07e7b4 100644
--- a/srcpkgs/python3-jupyter_client/template
+++ b/srcpkgs/python3-jupyter_client/template
@@ -1,19 +1,18 @@
 # Template file for 'python3-jupyter_client'
 pkgname=python3-jupyter_client
-# delay 6.2 until jupyter/jupyter_console#241 is fixed
-version=6.1.12
-revision=2
+version=7.1.1
+revision=1
 wrksrc="jupyter_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-traitlets python3-jupyter_core python3-pyzmq
- python3-dateutil python3-tornado python3-nest_asyncio"
+ python3-dateutil python3-tornado python3-nest_asyncio python3-entrypoints"
 short_desc="Jupyter protocol client APIs"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_client"
 distfiles="${PYPI_SITE}/j/jupyter_client/jupyter_client-${version}.tar.gz"
-checksum=c4bca1d0846186ca8be97f4d2fa6d2bae889cce4892a167ffa1ba6bd1f73e782
+checksum=540ca35e57e83c5ece81abd9b781a57cba39a37c60a2a30c8c1b2f6663544343
 conflicts="python-jupyter_client<=5.2.4_2"
 # checks create a cycle with python3-jupyter_core and python3-ipython_ipykernel
 make_check=no

From 7ddcb1e135093e61e3e94ec2a3df9b73aacd6116 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:06:12 +0100
Subject: [PATCH 05/14] python3-jupyter_core: update to 4.9.1

---
 srcpkgs/python3-jupyter_core/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_core/template b/srcpkgs/python3-jupyter_core/template
index d0fa364a6751..5f450d293d4f 100644
--- a/srcpkgs/python3-jupyter_core/template
+++ b/srcpkgs/python3-jupyter_core/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_core'
 pkgname=python3-jupyter_core
-version=4.7.1
-revision=2
+version=4.9.1
+revision=1
 wrksrc="jupyter_core-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter_core/jupyter_core-${version}.tar.gz"
-checksum=79025cb3225efcd36847d0840f3fc672c0abd7afd0de83ba8a1d3837619122b4
+checksum=dce8a7499da5a53ae3afd5a9f4b02e5df1d57250cf48f3ad79da23b4778cd6fa
 conflicts="python-jupyter_core<=4.4.0_3"
 # checks create a cycle with python3-jypter_client and python3-ipython_ipykernel
 make_check=no

From 6413ebab7db47bdf0e763c09453780f0afb1cf5f Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:14:36 +0100
Subject: [PATCH 06/14] python3-paramiko: update to 2.9.2

---
 srcpkgs/python3-paramiko/template | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-paramiko/template b/srcpkgs/python3-paramiko/template
index cff1b3a2fb59..585a01085bd6 100644
--- a/srcpkgs/python3-paramiko/template
+++ b/srcpkgs/python3-paramiko/template
@@ -1,14 +1,17 @@
 # Template file for 'python3-paramiko'
 pkgname=python3-paramiko
-version=2.7.2
-revision=2
+version=2.9.2
+revision=1
 wrksrc="${pkgname#*-}-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-cryptography python3-pyasn1 python3-bcrypt python3-pynacl"
+checkdepends="${depends} python3-pynacl python3-pytest python3-mock"
 short_desc="Python3 SSH2 protocol library"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="LGPL-2.1-or-later"
 homepage="http://www.paramiko.org/"
 distfiles="${PYPI_SITE}/p/paramiko/paramiko-${version}.tar.gz"
-checksum=7f36f4ba2c0d81d219f4595e35f70d56cc94f9ac40a6acdf51d6ca210ce65035
+checksum=944a9e5dbdd413ab6c7951ea46b0ab40713235a9c4c5ca81cfe45c6f14fa677b
+# requires pytest-relaxed invoke
+make_check=no

From 2858a549f7455dc9e9c0607d959ba8119012bebe Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:17:21 +0100
Subject: [PATCH 07/14] python3-soupsieve: update to 2.3.1

---
 srcpkgs/python3-soupsieve/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-soupsieve/template b/srcpkgs/python3-soupsieve/template
index 14449f20c47f..bb63a5ec0952 100644
--- a/srcpkgs/python3-soupsieve/template
+++ b/srcpkgs/python3-soupsieve/template
@@ -1,18 +1,18 @@
 # Template file for 'python3-soupsieve'
 pkgname=python3-soupsieve
-version=1.9.5
-revision=6
+version=2.3.1
+revision=1
 wrksrc="soupsieve-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="python3"
+depends="python3 python3-BeautifulSoup4"
 checkdepends="python3-pytest python3-lxml python3-html5lib python3-BeautifulSoup4"
 short_desc="CSS4 selector implementation for Python3 Beautiful Soup"
 maintainer="Aluísio Augusto Silva Gonçalves <aluisio@aasg.name>"
 license="MIT"
 homepage="https://facelessuser.github.io/soupsieve/"
 distfiles="${PYPI_SITE}/s/soupsieve/soupsieve-${version}.tar.gz"
-checksum=e2c1c5dee4a1c36bcb790e0fabd5492d874b8ebd4617622c4f6a731701060dda
+checksum=b8d49b1cd4f037c7082a9683dfa1801aa2597fb11c3a1155b7a5b94829b4f1f9
 
 post_install() {
 	vlicense LICENSE.md

From d66690517d9af39fa065a093d329cc2f3d6f6efe Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:20:35 +0100
Subject: [PATCH 08/14] python3-terminado: update to 0.13.0

---
 srcpkgs/python3-terminado/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-terminado/template b/srcpkgs/python3-terminado/template
index 28c65c82ba99..e299a6ca8c4f 100644
--- a/srcpkgs/python3-terminado/template
+++ b/srcpkgs/python3-terminado/template
@@ -1,10 +1,10 @@
 # Template file for 'python3-terminado'
 pkgname=python3-terminado
-version=0.9.4
-revision=2
+version=0.13.0
+revision=1
 wrksrc="terminado-${version}"
 build_style=python3-module
-hostmakedepends="python3-setuptools"
+hostmakedepends="python3-setuptools python3-tornado"
 depends="python3-ptyprocess python3-tornado"
 checkdepends="python3-pytest $depends"
 short_desc="Terminals served to term.js using Tornado websockets (Python3)"
@@ -12,7 +12,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/takluyver/terminado"
 distfiles="${PYPI_SITE}/t/terminado/terminado-${version}.tar.gz"
-checksum=9a7dbcfbc2778830eeb70261bf7aa9d98a3eac8631a3afe3febeb57c12f798be
+checksum=713531ccb5db7d4f544651f14050da79809030f00d1afa21462088cf32fb143a
 
 post_install() {
 	vlicense LICENSE

From dc0795f8b9cd92d1346c405d8abadbf84fdc93c0 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:43 +0100
Subject: [PATCH 09/14] python3-jupyter_server: update to 1.15.2

---
 srcpkgs/python3-jupyter_server/template | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_server/template b/srcpkgs/python3-jupyter_server/template
index 4e6d8a6fe52a..e8c98c8f9367 100644
--- a/srcpkgs/python3-jupyter_server/template
+++ b/srcpkgs/python3-jupyter_server/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-jupyter_server'
 pkgname=python3-jupyter_server
-version=1.13.4
+version=1.15.6
 revision=1
 wrksrc="jupyter_server-${version}"
 build_style=python3-module
@@ -9,13 +9,17 @@ depends="python3-anyio python3-jupyter_client python3-jupyter_nbformat
  python3-jupyter_nbconvert python3-terminado
  python3-prometheus_client python3-traitlets python3-tornado
  python3-Jinja2 python3-send2trash python3-websocket-client"
+checkdepends="${depends} python3-argon2 python3-packaging
+ python3-coverage python3-pytest-mock python3-requests
+ python3-pytest python3-pytest-timeout python3-pytest-asyncio"
 short_desc="Backend to Jupyter web applications"
 maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
+changelog="https://raw.githubusercontent.com/jupyter-server/jupyter_server/main/CHANGELOG.md"
 distfiles="${PYPI_SITE}/j/jupyter-server/jupyter_server-${version}.tar.gz"
-checksum=5fb5a219385338b1d13a013a68f54688b6a69ecff4e757fd230e27ecacdbf212
-# Tarball defines no tests
+checksum=56bd6f580d1f46b62294990e8e78651025729f5d3fc798f10f2c03f0cdcbf28d
+# missing pytest-tornasync, pytest-console-scripts
 make_check=no
 
 post_install() {

From ca640a62736d9a5624abc30d54adbb704129eb32 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:59 +0100
Subject: [PATCH 10/14] jupyterlab: update to 3.3.1

---
 srcpkgs/jupyterlab/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/jupyterlab/template b/srcpkgs/jupyterlab/template
index 330d959bc154..ea12f6d4a946 100644
--- a/srcpkgs/jupyterlab/template
+++ b/srcpkgs/jupyterlab/template
@@ -1,7 +1,7 @@
 # Template file for 'jupyterlab'
 pkgname=jupyterlab
-version=3.2.8
-revision=2
+version=3.3.1
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-jupyterlab_server nodejs python3-nbclassic
@@ -11,7 +11,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="custom:jupyterlab"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyterlab/jupyterlab-${version}.tar.gz"
-checksum=5e4e99868c4f385372686767781408acbb9004b690b198b45597ba869802334b
+checksum=ce482799379c70aa87e63b59e2c5379779ce18658b92460cd20bb44154865973
 # Tests require unpackaged dependencies
 make_check=no
 

From 623829afee6474d0129c0e36c45254b4295349e4 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Mon, 21 Feb 2022 10:41:56 +0100
Subject: [PATCH 11/14] python3-nbclient: update to 0.5.12

---
 srcpkgs/python3-nbclient/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-nbclient/template b/srcpkgs/python3-nbclient/template
index 24f9242016fb..50909329ed35 100644
--- a/srcpkgs/python3-nbclient/template
+++ b/srcpkgs/python3-nbclient/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-nbclient'
 pkgname=python3-nbclient
-version=0.5.10
+version=0.5.12
 revision=1
 wrksrc="${pkgname#python3-}-${version}"
 build_style=python3-module
@@ -12,7 +12,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://nbclient.readthedocs.io/en/latest/"
 distfiles="${PYPI_SITE}/n/nbclient/nbclient-${version}.tar.gz"
-checksum=b5fdea88d6fa52ca38de6c2361401cfe7aaa7cd24c74effc5e489cec04d79088
+checksum=0dd7ee6db59753563035f606421c3b558bd8c28b116d7e3ab8a0b4026cb44e38
 # Package might need to be installed for testing
 make_check=no
 

From a50648ae27e0d93ac96c7052a3cc2f55beacebbb Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:30:18 +0100
Subject: [PATCH 12/14] python3-traitlets: update to 5.1.1

---
 srcpkgs/python3-traitlets/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-traitlets/template b/srcpkgs/python3-traitlets/template
index f9b5819f9177..1cf7e4688617 100644
--- a/srcpkgs/python3-traitlets/template
+++ b/srcpkgs/python3-traitlets/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-traitlets'
 pkgname=python3-traitlets
-version=5.0.5
-revision=2
+version=5.1.1
+revision=1
 wrksrc="traitlets-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,7 +12,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/traitlets"
 distfiles="${PYPI_SITE}/t/traitlets/traitlets-${version}.tar.gz"
-checksum=178f4ce988f69189f7e523337a3e11d91c786ded9360174a3d9ca83e79bc5396
+checksum=059f456c5a7c1c82b98c2e8c799f39c9b8128f6d0d46941ee118daace9eb70c7
 
 do_check() {
 	pytest

From db9e8f8bc58477aa7ff05ee74feaef4c375a3a7c Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:30:45 +0100
Subject: [PATCH 13/14] python3-jupyter_console: update to 6.4.3

---
 srcpkgs/python3-jupyter_console/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-jupyter_console/template b/srcpkgs/python3-jupyter_console/template
index 3124f3854a19..c431d39ed7a6 100644
--- a/srcpkgs/python3-jupyter_console/template
+++ b/srcpkgs/python3-jupyter_console/template
@@ -1,24 +1,24 @@
 # Template file for 'python3-jupyter_console'
 pkgname=python3-jupyter_console
-version=6.4.0
-revision=2
+version=6.4.3
+revision=1
 wrksrc="jupyter_console-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-ipython python3-ipython_ipykernel python3-jupyter_client
- python3-prompt_toolkit python3-Pygments"
+ python3-prompt_toolkit python3-Pygments python3-traitlets"
 checkdepends="$depends python3-pytest"
 short_desc="Jupyter terminal console (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_console"
 distfiles="${PYPI_SITE}/j/jupyter_console/jupyter_console-${version}.tar.gz"
-checksum=242248e1685039cd8bff2c2ecb7ce6c1546eb50ee3b08519729e6e881aec19c7
+checksum=55f32626b0be647a85e3217ddcdb22db69efc79e8b403b9771eb9ecc696019b5
 # alternatives will be a conflict
 conflicts="python-jupyter_console<=6.0.0_2"
 # Tests fail because stdin is not a terminal
 make_check=no
 
 post_install() {
-	vlicense COPYING.md LICENSE
+	vlicense LICENSE
 }

From ad91a55c699542cb6bdd6767d03f2d5592e6cc9e Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:35:22 +0100
Subject: [PATCH 14/14]  python3-nbclassic: update to 0.3.6

---
 srcpkgs/python3-nbclassic/template | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-nbclassic/template b/srcpkgs/python3-nbclassic/template
index 066ce4adc96b..6d122531347e 100644
--- a/srcpkgs/python3-nbclassic/template
+++ b/srcpkgs/python3-nbclassic/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-nbclassic'
 pkgname=python3-nbclassic
-version=0.3.5
+version=0.3.6
 revision=1
 wrksrc=nbclassic-${version}
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-jupyter_notebook python3-jupyter_server"
+checkdepends="${depends} python3-pytest python3-pytest-fixture-config python3-pytest-subtests"
 short_desc="Jupyter Notebook as a Jupyter Server Extension"
 maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/n/nbclassic/nbclassic-${version}.tar.gz"
-checksum=99444dd63103af23c788d9b5172992f12caf8c3098dd5a35c787f0df31490c29
-# Tarball includes no tests
+checksum=7dbac0a6cb71bbe3afa1fe89369e6e3174d89f42aa08216a327046de45aa9a4f
+# missing fixtures: jp_create_notebook jp_fetch
 make_check=no
 
 conf_files="/etc/jupyter/jupyter_server_config.d/*.json"

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (45 preceding siblings ...)
  2022-04-11 17:08 ` dkwo
@ 2022-04-11 17:09 ` dkwo
  2022-04-23 19:14 ` [PR PATCH] [Updated] " dkwo
                   ` (3 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-04-11 17:09 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 319 bytes --]

New comment by dkwo on void-packages repository

https://github.com/void-linux/void-packages/pull/35376#issuecomment-1095314835

Comment:
I think the last test failure left with httplib2 is due to our cryptography being too recent (they require 35.0.0).
I opened an issue upstream, and left a comment in our template.

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR PATCH] [Updated] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (46 preceding siblings ...)
  2022-04-11 17:09 ` dkwo
@ 2022-04-23 19:14 ` dkwo
  2022-06-11 14:11 ` dkwo
                   ` (2 subsequent siblings)
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-04-23 19:14 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 397 bytes --]

There is an updated pull request by dkwo against master on the void-packages repository

https://github.com/dkwo/void-packages pytupd
https://github.com/void-linux/void-packages/pull/35376

update few python3 packages
@ahesford Could you check whether the new jupyter client solves the issue with console?

A patch file from https://github.com/void-linux/void-packages/pull/35376.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-pytupd-35376.patch --]
[-- Type: text/x-diff, Size: 19808 bytes --]

From 33a3674e3059123a1641ef4dc1e8c8b2bd11c982 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:51:55 +0100
Subject: [PATCH 01/14] python3-defusedxml: update to 0.7.1

---
 srcpkgs/python3-defusedxml/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-defusedxml/template b/srcpkgs/python3-defusedxml/template
index 06bdd57a3526..90dc454d120d 100644
--- a/srcpkgs/python3-defusedxml/template
+++ b/srcpkgs/python3-defusedxml/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-defusedxml'
 pkgname=python3-defusedxml
-version=0.6.0
-revision=5
+version=0.7.1
+revision=1
 wrksrc="defusedxml-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Python-2.0"
 homepage="https://github.com/tiran/defusedxml"
 distfiles="${PYPI_SITE}/d/defusedxml/defusedxml-${version}.tar.gz"
-checksum=f684034d135af4c6cbb949b8a4d2ed61634515257a67299e5f940fbaa34377f5
+checksum=1bb3032db185915b62d7c6209c5a8792be6a32ab2fedacc84e01b52c51aa3e69
 
 post_install() {
 	vlicense LICENSE

From 4166f2348b32cd47b454518c77611dc92a559c38 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:54:30 +0100
Subject: [PATCH 02/14] python3-httplib2: update to 0.20.4

---
 srcpkgs/python3-httplib2/template | 20 ++++++++++----------
 1 file changed, 10 insertions(+), 10 deletions(-)

diff --git a/srcpkgs/python3-httplib2/template b/srcpkgs/python3-httplib2/template
index d0c39a478622..e274fbec2145 100644
--- a/srcpkgs/python3-httplib2/template
+++ b/srcpkgs/python3-httplib2/template
@@ -1,26 +1,26 @@
 # Template file for 'python3-httplib2'
 pkgname=python3-httplib2
-version=0.18.1
-revision=3
-create_wrksrc=yes
-build_wrksrc="httplib2-${version}"
+version=0.20.4
+revision=1
+wrksrc="httplib2-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="python3 ca-certificates"
+depends="python3 ca-certificates python3-parsing"
+checkdepends="python3-pytest python3-pytest-cov python3-pytest-timeout
+ python3-cryptography python3-flake8 python3-six python3-future"
 short_desc="Comprehensive HTTP client library (Python3)"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/httplib2/httplib2"
 changelog="https://raw.githubusercontent.com/httplib2/httplib2/master/CHANGELOG"
-distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz
- https://raw.githubusercontent.com/httplib2/httplib2/master/LICENSE>LICENSE.txt"
-checksum="8af66c1c52c7ffe1aa5dc4bcd7c769885254b0756e6e69f953c7f0ab49a70ba3
- 589eec38f72df2be203711d3b8cbece9b908c5e7ff00bc3cab7f63bae9e366b4"
+distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz"
+checksum=58a98e45b4b1a48273073f905d2961666ecf0fbac4250ea5b47aef259eb5c585
+make_check=no # our cryptography package is too recent, one test fails
 
 post_install() {
 	# use system ca certificates
 	rm -rf ${DESTDIR}/${py3_sitelib}/httplib2/cacerts.txt
 	ln -sf /etc/ssl/cert.pem ${DESTDIR}/${py3_sitelib}/httplib2/cacerts.txt
 
-	vlicense ../LICENSE.txt
+	vlicense LICENSE
 }

From 38b1e90f85af5cc1d6a30489f1269989f98db94b Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:55:53 +0100
Subject: [PATCH 03/14] python3-ipython_ipykernel: update to 6.8.0

---
 srcpkgs/python3-ipython_ipykernel/template | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-ipython_ipykernel/template b/srcpkgs/python3-ipython_ipykernel/template
index f00e0a3f1a0c..b75796ca0262 100644
--- a/srcpkgs/python3-ipython_ipykernel/template
+++ b/srcpkgs/python3-ipython_ipykernel/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-ipython_ipykernel'
 pkgname=python3-ipython_ipykernel
-version=5.5.4
-revision=2
+version=6.8.0
+revision=1
 wrksrc="ipykernel-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools python3-ipython
- python3-jupyter_client python3-traitlets python3-tornado"
-depends="python3-ipython python3-traitlets python3-jupyter_client python3-tornado"
+ python3-jupyter_client python3-traitlets python3-tornado python3-entrypoints"
+depends="python3-ipython python3-traitlets python3-jupyter_client
+ python3-tornado python3-entrypoints python3-nest_asyncio"
 short_desc="IPython kernel for Jupyter (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/ipykernel"
 distfiles="${PYPI_SITE}/i/ipykernel/ipykernel-${version}.tar.gz"
-checksum=1ce0e83672cc3bfdc1ffb5603e1d77ab125f24b41abc4612e22bfb3e994c0db2
+checksum=67d316d527eca24e3ded45a2b38689615bcda1aa520a11af0accdcea7152c18a
 # checks create a cycle with python3-jupyter_core and python3-jupyter_client
 make_check=no
 

From 88d08fe92fb628d89c5a6dff687590957bfbc5fb Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:04:52 +0100
Subject: [PATCH 04/14] python3-jupyter_client: update to 7.1.2

---
 srcpkgs/python3-jupyter_client/template | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-jupyter_client/template b/srcpkgs/python3-jupyter_client/template
index be6aa5594095..c3906f07e7b4 100644
--- a/srcpkgs/python3-jupyter_client/template
+++ b/srcpkgs/python3-jupyter_client/template
@@ -1,19 +1,18 @@
 # Template file for 'python3-jupyter_client'
 pkgname=python3-jupyter_client
-# delay 6.2 until jupyter/jupyter_console#241 is fixed
-version=6.1.12
-revision=2
+version=7.1.1
+revision=1
 wrksrc="jupyter_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-traitlets python3-jupyter_core python3-pyzmq
- python3-dateutil python3-tornado python3-nest_asyncio"
+ python3-dateutil python3-tornado python3-nest_asyncio python3-entrypoints"
 short_desc="Jupyter protocol client APIs"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_client"
 distfiles="${PYPI_SITE}/j/jupyter_client/jupyter_client-${version}.tar.gz"
-checksum=c4bca1d0846186ca8be97f4d2fa6d2bae889cce4892a167ffa1ba6bd1f73e782
+checksum=540ca35e57e83c5ece81abd9b781a57cba39a37c60a2a30c8c1b2f6663544343
 conflicts="python-jupyter_client<=5.2.4_2"
 # checks create a cycle with python3-jupyter_core and python3-ipython_ipykernel
 make_check=no

From b30fa48c3be4904aa82b26b3ea15f7f1753246fb Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:06:12 +0100
Subject: [PATCH 05/14] python3-jupyter_core: update to 4.9.1

---
 srcpkgs/python3-jupyter_core/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_core/template b/srcpkgs/python3-jupyter_core/template
index d0fa364a6751..5f450d293d4f 100644
--- a/srcpkgs/python3-jupyter_core/template
+++ b/srcpkgs/python3-jupyter_core/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_core'
 pkgname=python3-jupyter_core
-version=4.7.1
-revision=2
+version=4.9.1
+revision=1
 wrksrc="jupyter_core-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter_core/jupyter_core-${version}.tar.gz"
-checksum=79025cb3225efcd36847d0840f3fc672c0abd7afd0de83ba8a1d3837619122b4
+checksum=dce8a7499da5a53ae3afd5a9f4b02e5df1d57250cf48f3ad79da23b4778cd6fa
 conflicts="python-jupyter_core<=4.4.0_3"
 # checks create a cycle with python3-jypter_client and python3-ipython_ipykernel
 make_check=no

From fef1c0ee92802f8c8436dbedb1afedbad1737d3e Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:14:36 +0100
Subject: [PATCH 06/14] python3-paramiko: update to 2.9.2

---
 srcpkgs/python3-paramiko/template | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-paramiko/template b/srcpkgs/python3-paramiko/template
index cff1b3a2fb59..585a01085bd6 100644
--- a/srcpkgs/python3-paramiko/template
+++ b/srcpkgs/python3-paramiko/template
@@ -1,14 +1,17 @@
 # Template file for 'python3-paramiko'
 pkgname=python3-paramiko
-version=2.7.2
-revision=2
+version=2.9.2
+revision=1
 wrksrc="${pkgname#*-}-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-cryptography python3-pyasn1 python3-bcrypt python3-pynacl"
+checkdepends="${depends} python3-pynacl python3-pytest python3-mock"
 short_desc="Python3 SSH2 protocol library"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="LGPL-2.1-or-later"
 homepage="http://www.paramiko.org/"
 distfiles="${PYPI_SITE}/p/paramiko/paramiko-${version}.tar.gz"
-checksum=7f36f4ba2c0d81d219f4595e35f70d56cc94f9ac40a6acdf51d6ca210ce65035
+checksum=944a9e5dbdd413ab6c7951ea46b0ab40713235a9c4c5ca81cfe45c6f14fa677b
+# requires pytest-relaxed invoke
+make_check=no

From e732d56ac8f3f83b63f2a497f97a920be8aeb7a1 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:17:21 +0100
Subject: [PATCH 07/14] python3-soupsieve: update to 2.3.1

---
 srcpkgs/python3-soupsieve/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-soupsieve/template b/srcpkgs/python3-soupsieve/template
index aa8f81af5a6e..1c781df83298 100644
--- a/srcpkgs/python3-soupsieve/template
+++ b/srcpkgs/python3-soupsieve/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-soupsieve'
 pkgname=python3-soupsieve
-version=1.9.5
-revision=8
+version=2.3.1
+revision=1
 wrksrc="soupsieve-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -13,7 +13,7 @@ maintainer="Aluísio Augusto Silva Gonçalves <aluisio@aasg.name>"
 license="MIT"
 homepage="https://facelessuser.github.io/soupsieve/"
 distfiles="${PYPI_SITE}/s/soupsieve/soupsieve-${version}.tar.gz"
-checksum=e2c1c5dee4a1c36bcb790e0fabd5492d874b8ebd4617622c4f6a731701060dda
+checksum=b8d49b1cd4f037c7082a9683dfa1801aa2597fb11c3a1155b7a5b94829b4f1f9
 
 post_install() {
 	vlicense LICENSE.md

From 46ca3b5b3634842b732e70e62f308ec16f6b830e Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:20:35 +0100
Subject: [PATCH 08/14] python3-terminado: update to 0.13.0

---
 srcpkgs/python3-terminado/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-terminado/template b/srcpkgs/python3-terminado/template
index 28c65c82ba99..e299a6ca8c4f 100644
--- a/srcpkgs/python3-terminado/template
+++ b/srcpkgs/python3-terminado/template
@@ -1,10 +1,10 @@
 # Template file for 'python3-terminado'
 pkgname=python3-terminado
-version=0.9.4
-revision=2
+version=0.13.0
+revision=1
 wrksrc="terminado-${version}"
 build_style=python3-module
-hostmakedepends="python3-setuptools"
+hostmakedepends="python3-setuptools python3-tornado"
 depends="python3-ptyprocess python3-tornado"
 checkdepends="python3-pytest $depends"
 short_desc="Terminals served to term.js using Tornado websockets (Python3)"
@@ -12,7 +12,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/takluyver/terminado"
 distfiles="${PYPI_SITE}/t/terminado/terminado-${version}.tar.gz"
-checksum=9a7dbcfbc2778830eeb70261bf7aa9d98a3eac8631a3afe3febeb57c12f798be
+checksum=713531ccb5db7d4f544651f14050da79809030f00d1afa21462088cf32fb143a
 
 post_install() {
 	vlicense LICENSE

From 8814760f2430e33e4e81689bbc3571e6dceaa18c Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:43 +0100
Subject: [PATCH 09/14] python3-jupyter_server: update to 1.15.2

---
 srcpkgs/python3-jupyter_server/template | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_server/template b/srcpkgs/python3-jupyter_server/template
index 4e6d8a6fe52a..e8c98c8f9367 100644
--- a/srcpkgs/python3-jupyter_server/template
+++ b/srcpkgs/python3-jupyter_server/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-jupyter_server'
 pkgname=python3-jupyter_server
-version=1.13.4
+version=1.15.6
 revision=1
 wrksrc="jupyter_server-${version}"
 build_style=python3-module
@@ -9,13 +9,17 @@ depends="python3-anyio python3-jupyter_client python3-jupyter_nbformat
  python3-jupyter_nbconvert python3-terminado
  python3-prometheus_client python3-traitlets python3-tornado
  python3-Jinja2 python3-send2trash python3-websocket-client"
+checkdepends="${depends} python3-argon2 python3-packaging
+ python3-coverage python3-pytest-mock python3-requests
+ python3-pytest python3-pytest-timeout python3-pytest-asyncio"
 short_desc="Backend to Jupyter web applications"
 maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
+changelog="https://raw.githubusercontent.com/jupyter-server/jupyter_server/main/CHANGELOG.md"
 distfiles="${PYPI_SITE}/j/jupyter-server/jupyter_server-${version}.tar.gz"
-checksum=5fb5a219385338b1d13a013a68f54688b6a69ecff4e757fd230e27ecacdbf212
-# Tarball defines no tests
+checksum=56bd6f580d1f46b62294990e8e78651025729f5d3fc798f10f2c03f0cdcbf28d
+# missing pytest-tornasync, pytest-console-scripts
 make_check=no
 
 post_install() {

From 6e428624517885466566d1130d3ea782db7b9a94 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:59 +0100
Subject: [PATCH 10/14] jupyterlab: update to 3.3.1

---
 srcpkgs/jupyterlab/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/jupyterlab/template b/srcpkgs/jupyterlab/template
index 330d959bc154..ea12f6d4a946 100644
--- a/srcpkgs/jupyterlab/template
+++ b/srcpkgs/jupyterlab/template
@@ -1,7 +1,7 @@
 # Template file for 'jupyterlab'
 pkgname=jupyterlab
-version=3.2.8
-revision=2
+version=3.3.1
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-jupyterlab_server nodejs python3-nbclassic
@@ -11,7 +11,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="custom:jupyterlab"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyterlab/jupyterlab-${version}.tar.gz"
-checksum=5e4e99868c4f385372686767781408acbb9004b690b198b45597ba869802334b
+checksum=ce482799379c70aa87e63b59e2c5379779ce18658b92460cd20bb44154865973
 # Tests require unpackaged dependencies
 make_check=no
 

From 32276869c1816cad48d2e4eb7f26425cda1f4c1b Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Mon, 21 Feb 2022 10:41:56 +0100
Subject: [PATCH 11/14] python3-nbclient: update to 0.5.12

---
 srcpkgs/python3-nbclient/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-nbclient/template b/srcpkgs/python3-nbclient/template
index 24f9242016fb..50909329ed35 100644
--- a/srcpkgs/python3-nbclient/template
+++ b/srcpkgs/python3-nbclient/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-nbclient'
 pkgname=python3-nbclient
-version=0.5.10
+version=0.5.12
 revision=1
 wrksrc="${pkgname#python3-}-${version}"
 build_style=python3-module
@@ -12,7 +12,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://nbclient.readthedocs.io/en/latest/"
 distfiles="${PYPI_SITE}/n/nbclient/nbclient-${version}.tar.gz"
-checksum=b5fdea88d6fa52ca38de6c2361401cfe7aaa7cd24c74effc5e489cec04d79088
+checksum=0dd7ee6db59753563035f606421c3b558bd8c28b116d7e3ab8a0b4026cb44e38
 # Package might need to be installed for testing
 make_check=no
 

From 7ecbacb7c1a34ae377ffb9da1cf735a07d469b97 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:30:18 +0100
Subject: [PATCH 12/14] python3-traitlets: update to 5.1.1

---
 srcpkgs/python3-traitlets/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-traitlets/template b/srcpkgs/python3-traitlets/template
index f9b5819f9177..1cf7e4688617 100644
--- a/srcpkgs/python3-traitlets/template
+++ b/srcpkgs/python3-traitlets/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-traitlets'
 pkgname=python3-traitlets
-version=5.0.5
-revision=2
+version=5.1.1
+revision=1
 wrksrc="traitlets-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,7 +12,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/traitlets"
 distfiles="${PYPI_SITE}/t/traitlets/traitlets-${version}.tar.gz"
-checksum=178f4ce988f69189f7e523337a3e11d91c786ded9360174a3d9ca83e79bc5396
+checksum=059f456c5a7c1c82b98c2e8c799f39c9b8128f6d0d46941ee118daace9eb70c7
 
 do_check() {
 	pytest

From 91442a9eaac4a1a1194ef1e52fc36a46cfe2ed06 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:30:45 +0100
Subject: [PATCH 13/14] python3-jupyter_console: update to 6.4.3

---
 srcpkgs/python3-jupyter_console/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-jupyter_console/template b/srcpkgs/python3-jupyter_console/template
index 3124f3854a19..c431d39ed7a6 100644
--- a/srcpkgs/python3-jupyter_console/template
+++ b/srcpkgs/python3-jupyter_console/template
@@ -1,24 +1,24 @@
 # Template file for 'python3-jupyter_console'
 pkgname=python3-jupyter_console
-version=6.4.0
-revision=2
+version=6.4.3
+revision=1
 wrksrc="jupyter_console-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-ipython python3-ipython_ipykernel python3-jupyter_client
- python3-prompt_toolkit python3-Pygments"
+ python3-prompt_toolkit python3-Pygments python3-traitlets"
 checkdepends="$depends python3-pytest"
 short_desc="Jupyter terminal console (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_console"
 distfiles="${PYPI_SITE}/j/jupyter_console/jupyter_console-${version}.tar.gz"
-checksum=242248e1685039cd8bff2c2ecb7ce6c1546eb50ee3b08519729e6e881aec19c7
+checksum=55f32626b0be647a85e3217ddcdb22db69efc79e8b403b9771eb9ecc696019b5
 # alternatives will be a conflict
 conflicts="python-jupyter_console<=6.0.0_2"
 # Tests fail because stdin is not a terminal
 make_check=no
 
 post_install() {
-	vlicense COPYING.md LICENSE
+	vlicense LICENSE
 }

From 55097d93e32ffe140307edfc408ab64bb5617cf8 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:35:22 +0100
Subject: [PATCH 14/14]  python3-nbclassic: update to 0.3.6

---
 srcpkgs/python3-nbclassic/template | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-nbclassic/template b/srcpkgs/python3-nbclassic/template
index 066ce4adc96b..6d122531347e 100644
--- a/srcpkgs/python3-nbclassic/template
+++ b/srcpkgs/python3-nbclassic/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-nbclassic'
 pkgname=python3-nbclassic
-version=0.3.5
+version=0.3.6
 revision=1
 wrksrc=nbclassic-${version}
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-jupyter_notebook python3-jupyter_server"
+checkdepends="${depends} python3-pytest python3-pytest-fixture-config python3-pytest-subtests"
 short_desc="Jupyter Notebook as a Jupyter Server Extension"
 maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/n/nbclassic/nbclassic-${version}.tar.gz"
-checksum=99444dd63103af23c788d9b5172992f12caf8c3098dd5a35c787f0df31490c29
-# Tarball includes no tests
+checksum=7dbac0a6cb71bbe3afa1fe89369e6e3174d89f42aa08216a327046de45aa9a4f
+# missing fixtures: jp_create_notebook jp_fetch
 make_check=no
 
 conf_files="/etc/jupyter/jupyter_server_config.d/*.json"

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR PATCH] [Updated] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (47 preceding siblings ...)
  2022-04-23 19:14 ` [PR PATCH] [Updated] " dkwo
@ 2022-06-11 14:11 ` dkwo
  2022-08-22 16:17 ` dkwo
  2022-08-22 16:50 ` dkwo
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-06-11 14:11 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 397 bytes --]

There is an updated pull request by dkwo against master on the void-packages repository

https://github.com/dkwo/void-packages pytupd
https://github.com/void-linux/void-packages/pull/35376

update few python3 packages
@ahesford Could you check whether the new jupyter client solves the issue with console?

A patch file from https://github.com/void-linux/void-packages/pull/35376.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-pytupd-35376.patch --]
[-- Type: text/x-diff, Size: 18489 bytes --]

From 1c6d5a884c32eb8e162413c30064cadc82cdaa1a Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:51:55 +0100
Subject: [PATCH 01/13] python3-defusedxml: update to 0.7.1

---
 srcpkgs/python3-defusedxml/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-defusedxml/template b/srcpkgs/python3-defusedxml/template
index 06bdd57a3526..90dc454d120d 100644
--- a/srcpkgs/python3-defusedxml/template
+++ b/srcpkgs/python3-defusedxml/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-defusedxml'
 pkgname=python3-defusedxml
-version=0.6.0
-revision=5
+version=0.7.1
+revision=1
 wrksrc="defusedxml-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Python-2.0"
 homepage="https://github.com/tiran/defusedxml"
 distfiles="${PYPI_SITE}/d/defusedxml/defusedxml-${version}.tar.gz"
-checksum=f684034d135af4c6cbb949b8a4d2ed61634515257a67299e5f940fbaa34377f5
+checksum=1bb3032db185915b62d7c6209c5a8792be6a32ab2fedacc84e01b52c51aa3e69
 
 post_install() {
 	vlicense LICENSE

From 36087d27b77d6f6930b61bfb2355b4896e1126e6 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:54:30 +0100
Subject: [PATCH 02/13] python3-httplib2: update to 0.20.4

---
 srcpkgs/python3-httplib2/template | 20 ++++++++++----------
 1 file changed, 10 insertions(+), 10 deletions(-)

diff --git a/srcpkgs/python3-httplib2/template b/srcpkgs/python3-httplib2/template
index d0c39a478622..e274fbec2145 100644
--- a/srcpkgs/python3-httplib2/template
+++ b/srcpkgs/python3-httplib2/template
@@ -1,26 +1,26 @@
 # Template file for 'python3-httplib2'
 pkgname=python3-httplib2
-version=0.18.1
-revision=3
-create_wrksrc=yes
-build_wrksrc="httplib2-${version}"
+version=0.20.4
+revision=1
+wrksrc="httplib2-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="python3 ca-certificates"
+depends="python3 ca-certificates python3-parsing"
+checkdepends="python3-pytest python3-pytest-cov python3-pytest-timeout
+ python3-cryptography python3-flake8 python3-six python3-future"
 short_desc="Comprehensive HTTP client library (Python3)"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/httplib2/httplib2"
 changelog="https://raw.githubusercontent.com/httplib2/httplib2/master/CHANGELOG"
-distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz
- https://raw.githubusercontent.com/httplib2/httplib2/master/LICENSE>LICENSE.txt"
-checksum="8af66c1c52c7ffe1aa5dc4bcd7c769885254b0756e6e69f953c7f0ab49a70ba3
- 589eec38f72df2be203711d3b8cbece9b908c5e7ff00bc3cab7f63bae9e366b4"
+distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz"
+checksum=58a98e45b4b1a48273073f905d2961666ecf0fbac4250ea5b47aef259eb5c585
+make_check=no # our cryptography package is too recent, one test fails
 
 post_install() {
 	# use system ca certificates
 	rm -rf ${DESTDIR}/${py3_sitelib}/httplib2/cacerts.txt
 	ln -sf /etc/ssl/cert.pem ${DESTDIR}/${py3_sitelib}/httplib2/cacerts.txt
 
-	vlicense ../LICENSE.txt
+	vlicense LICENSE
 }

From 605936480540e18bb2ad83cdec6e9d5010ab63c4 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:55:53 +0100
Subject: [PATCH 03/13] python3-ipython_ipykernel: update to 6.8.0

---
 srcpkgs/python3-ipython_ipykernel/template | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-ipython_ipykernel/template b/srcpkgs/python3-ipython_ipykernel/template
index f00e0a3f1a0c..b75796ca0262 100644
--- a/srcpkgs/python3-ipython_ipykernel/template
+++ b/srcpkgs/python3-ipython_ipykernel/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-ipython_ipykernel'
 pkgname=python3-ipython_ipykernel
-version=5.5.4
-revision=2
+version=6.8.0
+revision=1
 wrksrc="ipykernel-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools python3-ipython
- python3-jupyter_client python3-traitlets python3-tornado"
-depends="python3-ipython python3-traitlets python3-jupyter_client python3-tornado"
+ python3-jupyter_client python3-traitlets python3-tornado python3-entrypoints"
+depends="python3-ipython python3-traitlets python3-jupyter_client
+ python3-tornado python3-entrypoints python3-nest_asyncio"
 short_desc="IPython kernel for Jupyter (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/ipykernel"
 distfiles="${PYPI_SITE}/i/ipykernel/ipykernel-${version}.tar.gz"
-checksum=1ce0e83672cc3bfdc1ffb5603e1d77ab125f24b41abc4612e22bfb3e994c0db2
+checksum=67d316d527eca24e3ded45a2b38689615bcda1aa520a11af0accdcea7152c18a
 # checks create a cycle with python3-jupyter_core and python3-jupyter_client
 make_check=no
 

From e325d3de3a75e00ceb8a3a5155f26b85c9e96ed6 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:04:52 +0100
Subject: [PATCH 04/13] python3-jupyter_client: update to 7.1.2

---
 srcpkgs/python3-jupyter_client/template | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-jupyter_client/template b/srcpkgs/python3-jupyter_client/template
index be6aa5594095..c3906f07e7b4 100644
--- a/srcpkgs/python3-jupyter_client/template
+++ b/srcpkgs/python3-jupyter_client/template
@@ -1,19 +1,18 @@
 # Template file for 'python3-jupyter_client'
 pkgname=python3-jupyter_client
-# delay 6.2 until jupyter/jupyter_console#241 is fixed
-version=6.1.12
-revision=2
+version=7.1.1
+revision=1
 wrksrc="jupyter_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-traitlets python3-jupyter_core python3-pyzmq
- python3-dateutil python3-tornado python3-nest_asyncio"
+ python3-dateutil python3-tornado python3-nest_asyncio python3-entrypoints"
 short_desc="Jupyter protocol client APIs"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_client"
 distfiles="${PYPI_SITE}/j/jupyter_client/jupyter_client-${version}.tar.gz"
-checksum=c4bca1d0846186ca8be97f4d2fa6d2bae889cce4892a167ffa1ba6bd1f73e782
+checksum=540ca35e57e83c5ece81abd9b781a57cba39a37c60a2a30c8c1b2f6663544343
 conflicts="python-jupyter_client<=5.2.4_2"
 # checks create a cycle with python3-jupyter_core and python3-ipython_ipykernel
 make_check=no

From 36035d1b95785336ac83376466f0721c6e51fa6a Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:06:12 +0100
Subject: [PATCH 05/13] python3-jupyter_core: update to 4.9.1

---
 srcpkgs/python3-jupyter_core/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_core/template b/srcpkgs/python3-jupyter_core/template
index d0fa364a6751..5f450d293d4f 100644
--- a/srcpkgs/python3-jupyter_core/template
+++ b/srcpkgs/python3-jupyter_core/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_core'
 pkgname=python3-jupyter_core
-version=4.7.1
-revision=2
+version=4.9.1
+revision=1
 wrksrc="jupyter_core-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter_core/jupyter_core-${version}.tar.gz"
-checksum=79025cb3225efcd36847d0840f3fc672c0abd7afd0de83ba8a1d3837619122b4
+checksum=dce8a7499da5a53ae3afd5a9f4b02e5df1d57250cf48f3ad79da23b4778cd6fa
 conflicts="python-jupyter_core<=4.4.0_3"
 # checks create a cycle with python3-jypter_client and python3-ipython_ipykernel
 make_check=no

From 2f7f0fb9194798b0a1c970400d2c040c5de303f0 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:17:21 +0100
Subject: [PATCH 06/13] python3-soupsieve: update to 2.3.1

---
 srcpkgs/python3-soupsieve/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-soupsieve/template b/srcpkgs/python3-soupsieve/template
index aa8f81af5a6e..1c781df83298 100644
--- a/srcpkgs/python3-soupsieve/template
+++ b/srcpkgs/python3-soupsieve/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-soupsieve'
 pkgname=python3-soupsieve
-version=1.9.5
-revision=8
+version=2.3.1
+revision=1
 wrksrc="soupsieve-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -13,7 +13,7 @@ maintainer="Aluísio Augusto Silva Gonçalves <aluisio@aasg.name>"
 license="MIT"
 homepage="https://facelessuser.github.io/soupsieve/"
 distfiles="${PYPI_SITE}/s/soupsieve/soupsieve-${version}.tar.gz"
-checksum=e2c1c5dee4a1c36bcb790e0fabd5492d874b8ebd4617622c4f6a731701060dda
+checksum=b8d49b1cd4f037c7082a9683dfa1801aa2597fb11c3a1155b7a5b94829b4f1f9
 
 post_install() {
 	vlicense LICENSE.md

From 024014f1504cda9f5a9c909b74ecc5f063523f6e Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:20:35 +0100
Subject: [PATCH 07/13] python3-terminado: update to 0.13.0

---
 srcpkgs/python3-terminado/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-terminado/template b/srcpkgs/python3-terminado/template
index 28c65c82ba99..e299a6ca8c4f 100644
--- a/srcpkgs/python3-terminado/template
+++ b/srcpkgs/python3-terminado/template
@@ -1,10 +1,10 @@
 # Template file for 'python3-terminado'
 pkgname=python3-terminado
-version=0.9.4
-revision=2
+version=0.13.0
+revision=1
 wrksrc="terminado-${version}"
 build_style=python3-module
-hostmakedepends="python3-setuptools"
+hostmakedepends="python3-setuptools python3-tornado"
 depends="python3-ptyprocess python3-tornado"
 checkdepends="python3-pytest $depends"
 short_desc="Terminals served to term.js using Tornado websockets (Python3)"
@@ -12,7 +12,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/takluyver/terminado"
 distfiles="${PYPI_SITE}/t/terminado/terminado-${version}.tar.gz"
-checksum=9a7dbcfbc2778830eeb70261bf7aa9d98a3eac8631a3afe3febeb57c12f798be
+checksum=713531ccb5db7d4f544651f14050da79809030f00d1afa21462088cf32fb143a
 
 post_install() {
 	vlicense LICENSE

From df5800a8beed61df5028cf81a56fb7eadf30c858 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:43 +0100
Subject: [PATCH 08/13] python3-jupyter_server: update to 1.15.2

---
 srcpkgs/python3-jupyter_server/template | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_server/template b/srcpkgs/python3-jupyter_server/template
index 4e6d8a6fe52a..e8c98c8f9367 100644
--- a/srcpkgs/python3-jupyter_server/template
+++ b/srcpkgs/python3-jupyter_server/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-jupyter_server'
 pkgname=python3-jupyter_server
-version=1.13.4
+version=1.15.6
 revision=1
 wrksrc="jupyter_server-${version}"
 build_style=python3-module
@@ -9,13 +9,17 @@ depends="python3-anyio python3-jupyter_client python3-jupyter_nbformat
  python3-jupyter_nbconvert python3-terminado
  python3-prometheus_client python3-traitlets python3-tornado
  python3-Jinja2 python3-send2trash python3-websocket-client"
+checkdepends="${depends} python3-argon2 python3-packaging
+ python3-coverage python3-pytest-mock python3-requests
+ python3-pytest python3-pytest-timeout python3-pytest-asyncio"
 short_desc="Backend to Jupyter web applications"
 maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
+changelog="https://raw.githubusercontent.com/jupyter-server/jupyter_server/main/CHANGELOG.md"
 distfiles="${PYPI_SITE}/j/jupyter-server/jupyter_server-${version}.tar.gz"
-checksum=5fb5a219385338b1d13a013a68f54688b6a69ecff4e757fd230e27ecacdbf212
-# Tarball defines no tests
+checksum=56bd6f580d1f46b62294990e8e78651025729f5d3fc798f10f2c03f0cdcbf28d
+# missing pytest-tornasync, pytest-console-scripts
 make_check=no
 
 post_install() {

From e1e8e2abd71b5925a7a10e920c3338604d73504c Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:59 +0100
Subject: [PATCH 09/13] jupyterlab: update to 3.3.1

---
 srcpkgs/jupyterlab/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/jupyterlab/template b/srcpkgs/jupyterlab/template
index 330d959bc154..ea12f6d4a946 100644
--- a/srcpkgs/jupyterlab/template
+++ b/srcpkgs/jupyterlab/template
@@ -1,7 +1,7 @@
 # Template file for 'jupyterlab'
 pkgname=jupyterlab
-version=3.2.8
-revision=2
+version=3.3.1
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-jupyterlab_server nodejs python3-nbclassic
@@ -11,7 +11,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="custom:jupyterlab"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyterlab/jupyterlab-${version}.tar.gz"
-checksum=5e4e99868c4f385372686767781408acbb9004b690b198b45597ba869802334b
+checksum=ce482799379c70aa87e63b59e2c5379779ce18658b92460cd20bb44154865973
 # Tests require unpackaged dependencies
 make_check=no
 

From 59ede7f132207bc4b93b7253fbebc96566fab2a4 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Mon, 21 Feb 2022 10:41:56 +0100
Subject: [PATCH 10/13] python3-nbclient: update to 0.5.12

---
 srcpkgs/python3-nbclient/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-nbclient/template b/srcpkgs/python3-nbclient/template
index 24f9242016fb..50909329ed35 100644
--- a/srcpkgs/python3-nbclient/template
+++ b/srcpkgs/python3-nbclient/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-nbclient'
 pkgname=python3-nbclient
-version=0.5.10
+version=0.5.12
 revision=1
 wrksrc="${pkgname#python3-}-${version}"
 build_style=python3-module
@@ -12,7 +12,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://nbclient.readthedocs.io/en/latest/"
 distfiles="${PYPI_SITE}/n/nbclient/nbclient-${version}.tar.gz"
-checksum=b5fdea88d6fa52ca38de6c2361401cfe7aaa7cd24c74effc5e489cec04d79088
+checksum=0dd7ee6db59753563035f606421c3b558bd8c28b116d7e3ab8a0b4026cb44e38
 # Package might need to be installed for testing
 make_check=no
 

From 85a40392b1100a334283ca7985e51b5a68608afb Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:30:18 +0100
Subject: [PATCH 11/13] python3-traitlets: update to 5.1.1

---
 srcpkgs/python3-traitlets/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-traitlets/template b/srcpkgs/python3-traitlets/template
index f9b5819f9177..1cf7e4688617 100644
--- a/srcpkgs/python3-traitlets/template
+++ b/srcpkgs/python3-traitlets/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-traitlets'
 pkgname=python3-traitlets
-version=5.0.5
-revision=2
+version=5.1.1
+revision=1
 wrksrc="traitlets-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,7 +12,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/traitlets"
 distfiles="${PYPI_SITE}/t/traitlets/traitlets-${version}.tar.gz"
-checksum=178f4ce988f69189f7e523337a3e11d91c786ded9360174a3d9ca83e79bc5396
+checksum=059f456c5a7c1c82b98c2e8c799f39c9b8128f6d0d46941ee118daace9eb70c7
 
 do_check() {
 	pytest

From f48c2c847a6e1c996b8f4124a9ff7767b545c7c9 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:30:45 +0100
Subject: [PATCH 12/13] python3-jupyter_console: update to 6.4.3

---
 srcpkgs/python3-jupyter_console/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-jupyter_console/template b/srcpkgs/python3-jupyter_console/template
index 3124f3854a19..c431d39ed7a6 100644
--- a/srcpkgs/python3-jupyter_console/template
+++ b/srcpkgs/python3-jupyter_console/template
@@ -1,24 +1,24 @@
 # Template file for 'python3-jupyter_console'
 pkgname=python3-jupyter_console
-version=6.4.0
-revision=2
+version=6.4.3
+revision=1
 wrksrc="jupyter_console-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-ipython python3-ipython_ipykernel python3-jupyter_client
- python3-prompt_toolkit python3-Pygments"
+ python3-prompt_toolkit python3-Pygments python3-traitlets"
 checkdepends="$depends python3-pytest"
 short_desc="Jupyter terminal console (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_console"
 distfiles="${PYPI_SITE}/j/jupyter_console/jupyter_console-${version}.tar.gz"
-checksum=242248e1685039cd8bff2c2ecb7ce6c1546eb50ee3b08519729e6e881aec19c7
+checksum=55f32626b0be647a85e3217ddcdb22db69efc79e8b403b9771eb9ecc696019b5
 # alternatives will be a conflict
 conflicts="python-jupyter_console<=6.0.0_2"
 # Tests fail because stdin is not a terminal
 make_check=no
 
 post_install() {
-	vlicense COPYING.md LICENSE
+	vlicense LICENSE
 }

From 66b620feb4b8f604923f9a7cbcb357e2ba83b939 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:35:22 +0100
Subject: [PATCH 13/13]  python3-nbclassic: update to 0.3.6

---
 srcpkgs/python3-nbclassic/template | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-nbclassic/template b/srcpkgs/python3-nbclassic/template
index 066ce4adc96b..6d122531347e 100644
--- a/srcpkgs/python3-nbclassic/template
+++ b/srcpkgs/python3-nbclassic/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-nbclassic'
 pkgname=python3-nbclassic
-version=0.3.5
+version=0.3.6
 revision=1
 wrksrc=nbclassic-${version}
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-jupyter_notebook python3-jupyter_server"
+checkdepends="${depends} python3-pytest python3-pytest-fixture-config python3-pytest-subtests"
 short_desc="Jupyter Notebook as a Jupyter Server Extension"
 maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/n/nbclassic/nbclassic-${version}.tar.gz"
-checksum=99444dd63103af23c788d9b5172992f12caf8c3098dd5a35c787f0df31490c29
-# Tarball includes no tests
+checksum=7dbac0a6cb71bbe3afa1fe89369e6e3174d89f42aa08216a327046de45aa9a4f
+# missing fixtures: jp_create_notebook jp_fetch
 make_check=no
 
 conf_files="/etc/jupyter/jupyter_server_config.d/*.json"

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR PATCH] [Updated] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (48 preceding siblings ...)
  2022-06-11 14:11 ` dkwo
@ 2022-08-22 16:17 ` dkwo
  2022-08-22 16:50 ` dkwo
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-08-22 16:17 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 397 bytes --]

There is an updated pull request by dkwo against master on the void-packages repository

https://github.com/dkwo/void-packages pytupd
https://github.com/void-linux/void-packages/pull/35376

update few python3 packages
@ahesford Could you check whether the new jupyter client solves the issue with console?

A patch file from https://github.com/void-linux/void-packages/pull/35376.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-pytupd-35376.patch --]
[-- Type: text/x-diff, Size: 18492 bytes --]

From 3e4f8fe156b4ac49140f8513c8606de71de4b883 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:51:55 +0100
Subject: [PATCH 01/13] python3-defusedxml: update to 0.7.1

---
 srcpkgs/python3-defusedxml/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-defusedxml/template b/srcpkgs/python3-defusedxml/template
index 06bdd57a3526..90dc454d120d 100644
--- a/srcpkgs/python3-defusedxml/template
+++ b/srcpkgs/python3-defusedxml/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-defusedxml'
 pkgname=python3-defusedxml
-version=0.6.0
-revision=5
+version=0.7.1
+revision=1
 wrksrc="defusedxml-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Python-2.0"
 homepage="https://github.com/tiran/defusedxml"
 distfiles="${PYPI_SITE}/d/defusedxml/defusedxml-${version}.tar.gz"
-checksum=f684034d135af4c6cbb949b8a4d2ed61634515257a67299e5f940fbaa34377f5
+checksum=1bb3032db185915b62d7c6209c5a8792be6a32ab2fedacc84e01b52c51aa3e69
 
 post_install() {
 	vlicense LICENSE

From c12d4d9bbba430b08011a5bfe548e440847cfb38 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:54:30 +0100
Subject: [PATCH 02/13] python3-httplib2: update to 0.20.4

---
 srcpkgs/python3-httplib2/template | 20 ++++++++++----------
 1 file changed, 10 insertions(+), 10 deletions(-)

diff --git a/srcpkgs/python3-httplib2/template b/srcpkgs/python3-httplib2/template
index 7e66bf376c67..a6e64fe65171 100644
--- a/srcpkgs/python3-httplib2/template
+++ b/srcpkgs/python3-httplib2/template
@@ -1,26 +1,26 @@
 # Template file for 'python3-httplib2'
 pkgname=python3-httplib2
-version=0.18.1
-revision=4
-create_wrksrc=yes
-build_wrksrc="httplib2-${version}"
+version=0.20.4
+revision=1
+wrksrc="httplib2-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="python3 ca-certificates"
+depends="python3 ca-certificates python3-parsing"
+checkdepends="python3-pytest python3-pytest-cov python3-pytest-timeout
+ python3-cryptography python3-flake8 python3-six python3-future"
 short_desc="Comprehensive HTTP client library (Python3)"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/httplib2/httplib2"
 changelog="https://raw.githubusercontent.com/httplib2/httplib2/master/CHANGELOG"
-distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz
- https://raw.githubusercontent.com/httplib2/httplib2/master/LICENSE>LICENSE.txt"
-checksum="8af66c1c52c7ffe1aa5dc4bcd7c769885254b0756e6e69f953c7f0ab49a70ba3
- 589eec38f72df2be203711d3b8cbece9b908c5e7ff00bc3cab7f63bae9e366b4"
+distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz"
+checksum=58a98e45b4b1a48273073f905d2961666ecf0fbac4250ea5b47aef259eb5c585
+# make_check=no # our cryptography package is too recent, one test fails
 
 post_install() {
 	# use system ca certificates
 	rm -rf ${DESTDIR}/${py3_sitelib}/httplib2/cacerts.txt
 	ln -sf /etc/ssl/certs.pem ${DESTDIR}/${py3_sitelib}/httplib2/cacerts.txt
 
-	vlicense ../LICENSE.txt
+	vlicense LICENSE
 }

From 53ac5ae9cb9d1e8829583191be5f89de8a584d7a Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:55:53 +0100
Subject: [PATCH 03/13] python3-ipython_ipykernel: update to 6.8.0

---
 srcpkgs/python3-ipython_ipykernel/template | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-ipython_ipykernel/template b/srcpkgs/python3-ipython_ipykernel/template
index f00e0a3f1a0c..b75796ca0262 100644
--- a/srcpkgs/python3-ipython_ipykernel/template
+++ b/srcpkgs/python3-ipython_ipykernel/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-ipython_ipykernel'
 pkgname=python3-ipython_ipykernel
-version=5.5.4
-revision=2
+version=6.8.0
+revision=1
 wrksrc="ipykernel-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools python3-ipython
- python3-jupyter_client python3-traitlets python3-tornado"
-depends="python3-ipython python3-traitlets python3-jupyter_client python3-tornado"
+ python3-jupyter_client python3-traitlets python3-tornado python3-entrypoints"
+depends="python3-ipython python3-traitlets python3-jupyter_client
+ python3-tornado python3-entrypoints python3-nest_asyncio"
 short_desc="IPython kernel for Jupyter (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/ipykernel"
 distfiles="${PYPI_SITE}/i/ipykernel/ipykernel-${version}.tar.gz"
-checksum=1ce0e83672cc3bfdc1ffb5603e1d77ab125f24b41abc4612e22bfb3e994c0db2
+checksum=67d316d527eca24e3ded45a2b38689615bcda1aa520a11af0accdcea7152c18a
 # checks create a cycle with python3-jupyter_core and python3-jupyter_client
 make_check=no
 

From c09483dad426703d5e15cdca22942ac72d48bb11 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:04:52 +0100
Subject: [PATCH 04/13] python3-jupyter_client: update to 7.1.2

---
 srcpkgs/python3-jupyter_client/template | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-jupyter_client/template b/srcpkgs/python3-jupyter_client/template
index be6aa5594095..c3906f07e7b4 100644
--- a/srcpkgs/python3-jupyter_client/template
+++ b/srcpkgs/python3-jupyter_client/template
@@ -1,19 +1,18 @@
 # Template file for 'python3-jupyter_client'
 pkgname=python3-jupyter_client
-# delay 6.2 until jupyter/jupyter_console#241 is fixed
-version=6.1.12
-revision=2
+version=7.1.1
+revision=1
 wrksrc="jupyter_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-traitlets python3-jupyter_core python3-pyzmq
- python3-dateutil python3-tornado python3-nest_asyncio"
+ python3-dateutil python3-tornado python3-nest_asyncio python3-entrypoints"
 short_desc="Jupyter protocol client APIs"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_client"
 distfiles="${PYPI_SITE}/j/jupyter_client/jupyter_client-${version}.tar.gz"
-checksum=c4bca1d0846186ca8be97f4d2fa6d2bae889cce4892a167ffa1ba6bd1f73e782
+checksum=540ca35e57e83c5ece81abd9b781a57cba39a37c60a2a30c8c1b2f6663544343
 conflicts="python-jupyter_client<=5.2.4_2"
 # checks create a cycle with python3-jupyter_core and python3-ipython_ipykernel
 make_check=no

From 6bc24b2a01e92a9c652038eec0cd47d2bac06500 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:06:12 +0100
Subject: [PATCH 05/13] python3-jupyter_core: update to 4.9.1

---
 srcpkgs/python3-jupyter_core/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_core/template b/srcpkgs/python3-jupyter_core/template
index d0fa364a6751..5f450d293d4f 100644
--- a/srcpkgs/python3-jupyter_core/template
+++ b/srcpkgs/python3-jupyter_core/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_core'
 pkgname=python3-jupyter_core
-version=4.7.1
-revision=2
+version=4.9.1
+revision=1
 wrksrc="jupyter_core-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter_core/jupyter_core-${version}.tar.gz"
-checksum=79025cb3225efcd36847d0840f3fc672c0abd7afd0de83ba8a1d3837619122b4
+checksum=dce8a7499da5a53ae3afd5a9f4b02e5df1d57250cf48f3ad79da23b4778cd6fa
 conflicts="python-jupyter_core<=4.4.0_3"
 # checks create a cycle with python3-jypter_client and python3-ipython_ipykernel
 make_check=no

From fa93e8d2d01f3ad3cb213c621fc178e48a1242e5 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:17:21 +0100
Subject: [PATCH 06/13] python3-soupsieve: update to 2.3.1

---
 srcpkgs/python3-soupsieve/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-soupsieve/template b/srcpkgs/python3-soupsieve/template
index aa8f81af5a6e..1c781df83298 100644
--- a/srcpkgs/python3-soupsieve/template
+++ b/srcpkgs/python3-soupsieve/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-soupsieve'
 pkgname=python3-soupsieve
-version=1.9.5
-revision=8
+version=2.3.1
+revision=1
 wrksrc="soupsieve-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -13,7 +13,7 @@ maintainer="Aluísio Augusto Silva Gonçalves <aluisio@aasg.name>"
 license="MIT"
 homepage="https://facelessuser.github.io/soupsieve/"
 distfiles="${PYPI_SITE}/s/soupsieve/soupsieve-${version}.tar.gz"
-checksum=e2c1c5dee4a1c36bcb790e0fabd5492d874b8ebd4617622c4f6a731701060dda
+checksum=b8d49b1cd4f037c7082a9683dfa1801aa2597fb11c3a1155b7a5b94829b4f1f9
 
 post_install() {
 	vlicense LICENSE.md

From 25cc32256d222d20424ac039087b494c37500e48 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:20:35 +0100
Subject: [PATCH 07/13] python3-terminado: update to 0.13.0

---
 srcpkgs/python3-terminado/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-terminado/template b/srcpkgs/python3-terminado/template
index 28c65c82ba99..e299a6ca8c4f 100644
--- a/srcpkgs/python3-terminado/template
+++ b/srcpkgs/python3-terminado/template
@@ -1,10 +1,10 @@
 # Template file for 'python3-terminado'
 pkgname=python3-terminado
-version=0.9.4
-revision=2
+version=0.13.0
+revision=1
 wrksrc="terminado-${version}"
 build_style=python3-module
-hostmakedepends="python3-setuptools"
+hostmakedepends="python3-setuptools python3-tornado"
 depends="python3-ptyprocess python3-tornado"
 checkdepends="python3-pytest $depends"
 short_desc="Terminals served to term.js using Tornado websockets (Python3)"
@@ -12,7 +12,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/takluyver/terminado"
 distfiles="${PYPI_SITE}/t/terminado/terminado-${version}.tar.gz"
-checksum=9a7dbcfbc2778830eeb70261bf7aa9d98a3eac8631a3afe3febeb57c12f798be
+checksum=713531ccb5db7d4f544651f14050da79809030f00d1afa21462088cf32fb143a
 
 post_install() {
 	vlicense LICENSE

From f0367be4111967c35e2bb621d7029be8fc154886 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:43 +0100
Subject: [PATCH 08/13] python3-jupyter_server: update to 1.15.2

---
 srcpkgs/python3-jupyter_server/template | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_server/template b/srcpkgs/python3-jupyter_server/template
index 4e6d8a6fe52a..e8c98c8f9367 100644
--- a/srcpkgs/python3-jupyter_server/template
+++ b/srcpkgs/python3-jupyter_server/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-jupyter_server'
 pkgname=python3-jupyter_server
-version=1.13.4
+version=1.15.6
 revision=1
 wrksrc="jupyter_server-${version}"
 build_style=python3-module
@@ -9,13 +9,17 @@ depends="python3-anyio python3-jupyter_client python3-jupyter_nbformat
  python3-jupyter_nbconvert python3-terminado
  python3-prometheus_client python3-traitlets python3-tornado
  python3-Jinja2 python3-send2trash python3-websocket-client"
+checkdepends="${depends} python3-argon2 python3-packaging
+ python3-coverage python3-pytest-mock python3-requests
+ python3-pytest python3-pytest-timeout python3-pytest-asyncio"
 short_desc="Backend to Jupyter web applications"
 maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
+changelog="https://raw.githubusercontent.com/jupyter-server/jupyter_server/main/CHANGELOG.md"
 distfiles="${PYPI_SITE}/j/jupyter-server/jupyter_server-${version}.tar.gz"
-checksum=5fb5a219385338b1d13a013a68f54688b6a69ecff4e757fd230e27ecacdbf212
-# Tarball defines no tests
+checksum=56bd6f580d1f46b62294990e8e78651025729f5d3fc798f10f2c03f0cdcbf28d
+# missing pytest-tornasync, pytest-console-scripts
 make_check=no
 
 post_install() {

From a84efb771fd6906805bfe640db4ef454b6bd366d Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:59 +0100
Subject: [PATCH 09/13] jupyterlab: update to 3.3.1

---
 srcpkgs/jupyterlab/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/jupyterlab/template b/srcpkgs/jupyterlab/template
index 330d959bc154..ea12f6d4a946 100644
--- a/srcpkgs/jupyterlab/template
+++ b/srcpkgs/jupyterlab/template
@@ -1,7 +1,7 @@
 # Template file for 'jupyterlab'
 pkgname=jupyterlab
-version=3.2.8
-revision=2
+version=3.3.1
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-jupyterlab_server nodejs python3-nbclassic
@@ -11,7 +11,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="custom:jupyterlab"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyterlab/jupyterlab-${version}.tar.gz"
-checksum=5e4e99868c4f385372686767781408acbb9004b690b198b45597ba869802334b
+checksum=ce482799379c70aa87e63b59e2c5379779ce18658b92460cd20bb44154865973
 # Tests require unpackaged dependencies
 make_check=no
 

From b9282668360b38e5cc8a9da491231006e3610650 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Mon, 21 Feb 2022 10:41:56 +0100
Subject: [PATCH 10/13] python3-nbclient: update to 0.5.12

---
 srcpkgs/python3-nbclient/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-nbclient/template b/srcpkgs/python3-nbclient/template
index 24f9242016fb..50909329ed35 100644
--- a/srcpkgs/python3-nbclient/template
+++ b/srcpkgs/python3-nbclient/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-nbclient'
 pkgname=python3-nbclient
-version=0.5.10
+version=0.5.12
 revision=1
 wrksrc="${pkgname#python3-}-${version}"
 build_style=python3-module
@@ -12,7 +12,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://nbclient.readthedocs.io/en/latest/"
 distfiles="${PYPI_SITE}/n/nbclient/nbclient-${version}.tar.gz"
-checksum=b5fdea88d6fa52ca38de6c2361401cfe7aaa7cd24c74effc5e489cec04d79088
+checksum=0dd7ee6db59753563035f606421c3b558bd8c28b116d7e3ab8a0b4026cb44e38
 # Package might need to be installed for testing
 make_check=no
 

From 953b39235c9ee46441ef006298bf62d033c9998b Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:30:18 +0100
Subject: [PATCH 11/13] python3-traitlets: update to 5.1.1

---
 srcpkgs/python3-traitlets/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-traitlets/template b/srcpkgs/python3-traitlets/template
index f9b5819f9177..1cf7e4688617 100644
--- a/srcpkgs/python3-traitlets/template
+++ b/srcpkgs/python3-traitlets/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-traitlets'
 pkgname=python3-traitlets
-version=5.0.5
-revision=2
+version=5.1.1
+revision=1
 wrksrc="traitlets-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,7 +12,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/traitlets"
 distfiles="${PYPI_SITE}/t/traitlets/traitlets-${version}.tar.gz"
-checksum=178f4ce988f69189f7e523337a3e11d91c786ded9360174a3d9ca83e79bc5396
+checksum=059f456c5a7c1c82b98c2e8c799f39c9b8128f6d0d46941ee118daace9eb70c7
 
 do_check() {
 	pytest

From 7a2eb9a5c86ac0b4168997899a428606fbb5fbba Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:30:45 +0100
Subject: [PATCH 12/13] python3-jupyter_console: update to 6.4.3

---
 srcpkgs/python3-jupyter_console/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-jupyter_console/template b/srcpkgs/python3-jupyter_console/template
index 3124f3854a19..c431d39ed7a6 100644
--- a/srcpkgs/python3-jupyter_console/template
+++ b/srcpkgs/python3-jupyter_console/template
@@ -1,24 +1,24 @@
 # Template file for 'python3-jupyter_console'
 pkgname=python3-jupyter_console
-version=6.4.0
-revision=2
+version=6.4.3
+revision=1
 wrksrc="jupyter_console-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-ipython python3-ipython_ipykernel python3-jupyter_client
- python3-prompt_toolkit python3-Pygments"
+ python3-prompt_toolkit python3-Pygments python3-traitlets"
 checkdepends="$depends python3-pytest"
 short_desc="Jupyter terminal console (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_console"
 distfiles="${PYPI_SITE}/j/jupyter_console/jupyter_console-${version}.tar.gz"
-checksum=242248e1685039cd8bff2c2ecb7ce6c1546eb50ee3b08519729e6e881aec19c7
+checksum=55f32626b0be647a85e3217ddcdb22db69efc79e8b403b9771eb9ecc696019b5
 # alternatives will be a conflict
 conflicts="python-jupyter_console<=6.0.0_2"
 # Tests fail because stdin is not a terminal
 make_check=no
 
 post_install() {
-	vlicense COPYING.md LICENSE
+	vlicense LICENSE
 }

From b0e27849bc40875eb50a4fc647196c047513781e Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:35:22 +0100
Subject: [PATCH 13/13]  python3-nbclassic: update to 0.3.6

---
 srcpkgs/python3-nbclassic/template | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-nbclassic/template b/srcpkgs/python3-nbclassic/template
index 066ce4adc96b..6d122531347e 100644
--- a/srcpkgs/python3-nbclassic/template
+++ b/srcpkgs/python3-nbclassic/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-nbclassic'
 pkgname=python3-nbclassic
-version=0.3.5
+version=0.3.6
 revision=1
 wrksrc=nbclassic-${version}
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-jupyter_notebook python3-jupyter_server"
+checkdepends="${depends} python3-pytest python3-pytest-fixture-config python3-pytest-subtests"
 short_desc="Jupyter Notebook as a Jupyter Server Extension"
 maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/n/nbclassic/nbclassic-${version}.tar.gz"
-checksum=99444dd63103af23c788d9b5172992f12caf8c3098dd5a35c787f0df31490c29
-# Tarball includes no tests
+checksum=7dbac0a6cb71bbe3afa1fe89369e6e3174d89f42aa08216a327046de45aa9a4f
+# missing fixtures: jp_create_notebook jp_fetch
 make_check=no
 
 conf_files="/etc/jupyter/jupyter_server_config.d/*.json"

^ permalink raw reply	[flat|nested] 52+ messages in thread

* Re: [PR PATCH] [Updated] update few python3 packages
  2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
                   ` (49 preceding siblings ...)
  2022-08-22 16:17 ` dkwo
@ 2022-08-22 16:50 ` dkwo
  50 siblings, 0 replies; 52+ messages in thread
From: dkwo @ 2022-08-22 16:50 UTC (permalink / raw)
  To: ml

[-- Attachment #1: Type: text/plain, Size: 397 bytes --]

There is an updated pull request by dkwo against master on the void-packages repository

https://github.com/dkwo/void-packages pytupd
https://github.com/void-linux/void-packages/pull/35376

update few python3 packages
@ahesford Could you check whether the new jupyter client solves the issue with console?

A patch file from https://github.com/void-linux/void-packages/pull/35376.patch is attached

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: github-pr-pytupd-35376.patch --]
[-- Type: text/x-diff, Size: 18490 bytes --]

From 3e4f8fe156b4ac49140f8513c8606de71de4b883 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:51:55 +0100
Subject: [PATCH 01/13] python3-defusedxml: update to 0.7.1

---
 srcpkgs/python3-defusedxml/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-defusedxml/template b/srcpkgs/python3-defusedxml/template
index 06bdd57a3526..90dc454d120d 100644
--- a/srcpkgs/python3-defusedxml/template
+++ b/srcpkgs/python3-defusedxml/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-defusedxml'
 pkgname=python3-defusedxml
-version=0.6.0
-revision=5
+version=0.7.1
+revision=1
 wrksrc="defusedxml-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="Python-2.0"
 homepage="https://github.com/tiran/defusedxml"
 distfiles="${PYPI_SITE}/d/defusedxml/defusedxml-${version}.tar.gz"
-checksum=f684034d135af4c6cbb949b8a4d2ed61634515257a67299e5f940fbaa34377f5
+checksum=1bb3032db185915b62d7c6209c5a8792be6a32ab2fedacc84e01b52c51aa3e69
 
 post_install() {
 	vlicense LICENSE

From 4648c39eb234347f2e0ac0142ed1e62c83faada3 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:54:30 +0100
Subject: [PATCH 02/13] python3-httplib2: update to 0.20.4

---
 srcpkgs/python3-httplib2/template | 20 ++++++++++----------
 1 file changed, 10 insertions(+), 10 deletions(-)

diff --git a/srcpkgs/python3-httplib2/template b/srcpkgs/python3-httplib2/template
index 7e66bf376c67..eff0501f631c 100644
--- a/srcpkgs/python3-httplib2/template
+++ b/srcpkgs/python3-httplib2/template
@@ -1,26 +1,26 @@
 # Template file for 'python3-httplib2'
 pkgname=python3-httplib2
-version=0.18.1
-revision=4
-create_wrksrc=yes
-build_wrksrc="httplib2-${version}"
+version=0.20.4
+revision=1
+wrksrc="httplib2-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
-depends="python3 ca-certificates"
+depends="python3 ca-certificates python3-parsing"
+checkdepends="python3-pytest python3-pytest-cov python3-pytest-timeout
+ python3-cryptography python3-flake8 python3-six python3-future"
 short_desc="Comprehensive HTTP client library (Python3)"
 maintainer="Orphaned <orphan@voidlinux.org>"
 license="MIT"
 homepage="https://github.com/httplib2/httplib2"
 changelog="https://raw.githubusercontent.com/httplib2/httplib2/master/CHANGELOG"
-distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz
- https://raw.githubusercontent.com/httplib2/httplib2/master/LICENSE>LICENSE.txt"
-checksum="8af66c1c52c7ffe1aa5dc4bcd7c769885254b0756e6e69f953c7f0ab49a70ba3
- 589eec38f72df2be203711d3b8cbece9b908c5e7ff00bc3cab7f63bae9e366b4"
+distfiles="${PYPI_SITE}/h/httplib2/httplib2-${version}.tar.gz"
+checksum=58a98e45b4b1a48273073f905d2961666ecf0fbac4250ea5b47aef259eb5c585
+make_check=no # our cryptography package is too recent, one test fails
 
 post_install() {
 	# use system ca certificates
 	rm -rf ${DESTDIR}/${py3_sitelib}/httplib2/cacerts.txt
 	ln -sf /etc/ssl/certs.pem ${DESTDIR}/${py3_sitelib}/httplib2/cacerts.txt
 
-	vlicense ../LICENSE.txt
+	vlicense LICENSE
 }

From f4072fbc681b61dc44c423cb432e7d3d3b50b3f0 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 13:55:53 +0100
Subject: [PATCH 03/13] python3-ipython_ipykernel: update to 6.8.0

---
 srcpkgs/python3-ipython_ipykernel/template | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-ipython_ipykernel/template b/srcpkgs/python3-ipython_ipykernel/template
index f00e0a3f1a0c..b75796ca0262 100644
--- a/srcpkgs/python3-ipython_ipykernel/template
+++ b/srcpkgs/python3-ipython_ipykernel/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-ipython_ipykernel'
 pkgname=python3-ipython_ipykernel
-version=5.5.4
-revision=2
+version=6.8.0
+revision=1
 wrksrc="ipykernel-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools python3-ipython
- python3-jupyter_client python3-traitlets python3-tornado"
-depends="python3-ipython python3-traitlets python3-jupyter_client python3-tornado"
+ python3-jupyter_client python3-traitlets python3-tornado python3-entrypoints"
+depends="python3-ipython python3-traitlets python3-jupyter_client
+ python3-tornado python3-entrypoints python3-nest_asyncio"
 short_desc="IPython kernel for Jupyter (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/ipykernel"
 distfiles="${PYPI_SITE}/i/ipykernel/ipykernel-${version}.tar.gz"
-checksum=1ce0e83672cc3bfdc1ffb5603e1d77ab125f24b41abc4612e22bfb3e994c0db2
+checksum=67d316d527eca24e3ded45a2b38689615bcda1aa520a11af0accdcea7152c18a
 # checks create a cycle with python3-jupyter_core and python3-jupyter_client
 make_check=no
 

From e86506dedf36232be16fc4cdc9bedb61c354c0f1 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:04:52 +0100
Subject: [PATCH 04/13] python3-jupyter_client: update to 7.1.2

---
 srcpkgs/python3-jupyter_client/template | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-jupyter_client/template b/srcpkgs/python3-jupyter_client/template
index be6aa5594095..c3906f07e7b4 100644
--- a/srcpkgs/python3-jupyter_client/template
+++ b/srcpkgs/python3-jupyter_client/template
@@ -1,19 +1,18 @@
 # Template file for 'python3-jupyter_client'
 pkgname=python3-jupyter_client
-# delay 6.2 until jupyter/jupyter_console#241 is fixed
-version=6.1.12
-revision=2
+version=7.1.1
+revision=1
 wrksrc="jupyter_client-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-traitlets python3-jupyter_core python3-pyzmq
- python3-dateutil python3-tornado python3-nest_asyncio"
+ python3-dateutil python3-tornado python3-nest_asyncio python3-entrypoints"
 short_desc="Jupyter protocol client APIs"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_client"
 distfiles="${PYPI_SITE}/j/jupyter_client/jupyter_client-${version}.tar.gz"
-checksum=c4bca1d0846186ca8be97f4d2fa6d2bae889cce4892a167ffa1ba6bd1f73e782
+checksum=540ca35e57e83c5ece81abd9b781a57cba39a37c60a2a30c8c1b2f6663544343
 conflicts="python-jupyter_client<=5.2.4_2"
 # checks create a cycle with python3-jupyter_core and python3-ipython_ipykernel
 make_check=no

From 56750892dfa0868681b087160793fa13a1054664 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:06:12 +0100
Subject: [PATCH 05/13] python3-jupyter_core: update to 4.9.1

---
 srcpkgs/python3-jupyter_core/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_core/template b/srcpkgs/python3-jupyter_core/template
index d0fa364a6751..5f450d293d4f 100644
--- a/srcpkgs/python3-jupyter_core/template
+++ b/srcpkgs/python3-jupyter_core/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-jupyter_core'
 pkgname=python3-jupyter_core
-version=4.7.1
-revision=2
+version=4.9.1
+revision=1
 wrksrc="jupyter_core-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -11,7 +11,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyter_core/jupyter_core-${version}.tar.gz"
-checksum=79025cb3225efcd36847d0840f3fc672c0abd7afd0de83ba8a1d3837619122b4
+checksum=dce8a7499da5a53ae3afd5a9f4b02e5df1d57250cf48f3ad79da23b4778cd6fa
 conflicts="python-jupyter_core<=4.4.0_3"
 # checks create a cycle with python3-jypter_client and python3-ipython_ipykernel
 make_check=no

From 80b37ac92b5e31403a879416c6e055a3fd87adf2 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:17:21 +0100
Subject: [PATCH 06/13] python3-soupsieve: update to 2.3.1

---
 srcpkgs/python3-soupsieve/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-soupsieve/template b/srcpkgs/python3-soupsieve/template
index aa8f81af5a6e..1c781df83298 100644
--- a/srcpkgs/python3-soupsieve/template
+++ b/srcpkgs/python3-soupsieve/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-soupsieve'
 pkgname=python3-soupsieve
-version=1.9.5
-revision=8
+version=2.3.1
+revision=1
 wrksrc="soupsieve-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -13,7 +13,7 @@ maintainer="Aluísio Augusto Silva Gonçalves <aluisio@aasg.name>"
 license="MIT"
 homepage="https://facelessuser.github.io/soupsieve/"
 distfiles="${PYPI_SITE}/s/soupsieve/soupsieve-${version}.tar.gz"
-checksum=e2c1c5dee4a1c36bcb790e0fabd5492d874b8ebd4617622c4f6a731701060dda
+checksum=b8d49b1cd4f037c7082a9683dfa1801aa2597fb11c3a1155b7a5b94829b4f1f9
 
 post_install() {
 	vlicense LICENSE.md

From 56df9dc08f9e33f84200ade89726f6ab1ea97337 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Thu, 3 Feb 2022 14:20:35 +0100
Subject: [PATCH 07/13] python3-terminado: update to 0.13.0

---
 srcpkgs/python3-terminado/template | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/srcpkgs/python3-terminado/template b/srcpkgs/python3-terminado/template
index 28c65c82ba99..e299a6ca8c4f 100644
--- a/srcpkgs/python3-terminado/template
+++ b/srcpkgs/python3-terminado/template
@@ -1,10 +1,10 @@
 # Template file for 'python3-terminado'
 pkgname=python3-terminado
-version=0.9.4
-revision=2
+version=0.13.0
+revision=1
 wrksrc="terminado-${version}"
 build_style=python3-module
-hostmakedepends="python3-setuptools"
+hostmakedepends="python3-setuptools python3-tornado"
 depends="python3-ptyprocess python3-tornado"
 checkdepends="python3-pytest $depends"
 short_desc="Terminals served to term.js using Tornado websockets (Python3)"
@@ -12,7 +12,7 @@ maintainer="Orphaned <orphan@voidlinux.org>"
 license="BSD-2-Clause"
 homepage="https://github.com/takluyver/terminado"
 distfiles="${PYPI_SITE}/t/terminado/terminado-${version}.tar.gz"
-checksum=9a7dbcfbc2778830eeb70261bf7aa9d98a3eac8631a3afe3febeb57c12f798be
+checksum=713531ccb5db7d4f544651f14050da79809030f00d1afa21462088cf32fb143a
 
 post_install() {
 	vlicense LICENSE

From d80929fdf6c150e02f9e74954e692c12fc503887 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:43 +0100
Subject: [PATCH 08/13] python3-jupyter_server: update to 1.15.2

---
 srcpkgs/python3-jupyter_server/template | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-jupyter_server/template b/srcpkgs/python3-jupyter_server/template
index 4e6d8a6fe52a..e8c98c8f9367 100644
--- a/srcpkgs/python3-jupyter_server/template
+++ b/srcpkgs/python3-jupyter_server/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-jupyter_server'
 pkgname=python3-jupyter_server
-version=1.13.4
+version=1.15.6
 revision=1
 wrksrc="jupyter_server-${version}"
 build_style=python3-module
@@ -9,13 +9,17 @@ depends="python3-anyio python3-jupyter_client python3-jupyter_nbformat
  python3-jupyter_nbconvert python3-terminado
  python3-prometheus_client python3-traitlets python3-tornado
  python3-Jinja2 python3-send2trash python3-websocket-client"
+checkdepends="${depends} python3-argon2 python3-packaging
+ python3-coverage python3-pytest-mock python3-requests
+ python3-pytest python3-pytest-timeout python3-pytest-asyncio"
 short_desc="Backend to Jupyter web applications"
 maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
+changelog="https://raw.githubusercontent.com/jupyter-server/jupyter_server/main/CHANGELOG.md"
 distfiles="${PYPI_SITE}/j/jupyter-server/jupyter_server-${version}.tar.gz"
-checksum=5fb5a219385338b1d13a013a68f54688b6a69ecff4e757fd230e27ecacdbf212
-# Tarball defines no tests
+checksum=56bd6f580d1f46b62294990e8e78651025729f5d3fc798f10f2c03f0cdcbf28d
+# missing pytest-tornasync, pytest-console-scripts
 make_check=no
 
 post_install() {

From d2e4c953946b6a2b3c15cbcd331fef89e2609da9 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Sun, 13 Feb 2022 11:34:59 +0100
Subject: [PATCH 09/13] jupyterlab: update to 3.3.1

---
 srcpkgs/jupyterlab/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/jupyterlab/template b/srcpkgs/jupyterlab/template
index 330d959bc154..ea12f6d4a946 100644
--- a/srcpkgs/jupyterlab/template
+++ b/srcpkgs/jupyterlab/template
@@ -1,7 +1,7 @@
 # Template file for 'jupyterlab'
 pkgname=jupyterlab
-version=3.2.8
-revision=2
+version=3.3.1
+revision=1
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-jupyterlab_server nodejs python3-nbclassic
@@ -11,7 +11,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="custom:jupyterlab"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/j/jupyterlab/jupyterlab-${version}.tar.gz"
-checksum=5e4e99868c4f385372686767781408acbb9004b690b198b45597ba869802334b
+checksum=ce482799379c70aa87e63b59e2c5379779ce18658b92460cd20bb44154865973
 # Tests require unpackaged dependencies
 make_check=no
 

From 9b927d6cd22eda947bc62315a2e260fcd41630ac Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Mon, 21 Feb 2022 10:41:56 +0100
Subject: [PATCH 10/13] python3-nbclient: update to 0.5.12

---
 srcpkgs/python3-nbclient/template | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/srcpkgs/python3-nbclient/template b/srcpkgs/python3-nbclient/template
index 24f9242016fb..50909329ed35 100644
--- a/srcpkgs/python3-nbclient/template
+++ b/srcpkgs/python3-nbclient/template
@@ -1,6 +1,6 @@
 # Template file for 'python3-nbclient'
 pkgname=python3-nbclient
-version=0.5.10
+version=0.5.12
 revision=1
 wrksrc="${pkgname#python3-}-${version}"
 build_style=python3-module
@@ -12,7 +12,7 @@ maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://nbclient.readthedocs.io/en/latest/"
 distfiles="${PYPI_SITE}/n/nbclient/nbclient-${version}.tar.gz"
-checksum=b5fdea88d6fa52ca38de6c2361401cfe7aaa7cd24c74effc5e489cec04d79088
+checksum=0dd7ee6db59753563035f606421c3b558bd8c28b116d7e3ab8a0b4026cb44e38
 # Package might need to be installed for testing
 make_check=no
 

From 6429478f8ae5b6f17abb6600159961d299f90655 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:30:18 +0100
Subject: [PATCH 11/13] python3-traitlets: update to 5.1.1

---
 srcpkgs/python3-traitlets/template | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-traitlets/template b/srcpkgs/python3-traitlets/template
index f9b5819f9177..1cf7e4688617 100644
--- a/srcpkgs/python3-traitlets/template
+++ b/srcpkgs/python3-traitlets/template
@@ -1,7 +1,7 @@
 # Template file for 'python3-traitlets'
 pkgname=python3-traitlets
-version=5.0.5
-revision=2
+version=5.1.1
+revision=1
 wrksrc="traitlets-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
@@ -12,7 +12,7 @@ maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/ipython/traitlets"
 distfiles="${PYPI_SITE}/t/traitlets/traitlets-${version}.tar.gz"
-checksum=178f4ce988f69189f7e523337a3e11d91c786ded9360174a3d9ca83e79bc5396
+checksum=059f456c5a7c1c82b98c2e8c799f39c9b8128f6d0d46941ee118daace9eb70c7
 
 do_check() {
 	pytest

From e44773654a93e903930978012629b542893d29e8 Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:30:45 +0100
Subject: [PATCH 12/13] python3-jupyter_console: update to 6.4.3

---
 srcpkgs/python3-jupyter_console/template | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/srcpkgs/python3-jupyter_console/template b/srcpkgs/python3-jupyter_console/template
index 3124f3854a19..c431d39ed7a6 100644
--- a/srcpkgs/python3-jupyter_console/template
+++ b/srcpkgs/python3-jupyter_console/template
@@ -1,24 +1,24 @@
 # Template file for 'python3-jupyter_console'
 pkgname=python3-jupyter_console
-version=6.4.0
-revision=2
+version=6.4.3
+revision=1
 wrksrc="jupyter_console-${version}"
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-ipython python3-ipython_ipykernel python3-jupyter_client
- python3-prompt_toolkit python3-Pygments"
+ python3-prompt_toolkit python3-Pygments python3-traitlets"
 checkdepends="$depends python3-pytest"
 short_desc="Jupyter terminal console (Python3)"
 maintainer="Alessio Sergi <al3hex@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://github.com/jupyter/jupyter_console"
 distfiles="${PYPI_SITE}/j/jupyter_console/jupyter_console-${version}.tar.gz"
-checksum=242248e1685039cd8bff2c2ecb7ce6c1546eb50ee3b08519729e6e881aec19c7
+checksum=55f32626b0be647a85e3217ddcdb22db69efc79e8b403b9771eb9ecc696019b5
 # alternatives will be a conflict
 conflicts="python-jupyter_console<=6.0.0_2"
 # Tests fail because stdin is not a terminal
 make_check=no
 
 post_install() {
-	vlicense COPYING.md LICENSE
+	vlicense LICENSE
 }

From 134319a0e5505eb7b214bb3c1ae6fe8c890f3c2f Mon Sep 17 00:00:00 2001
From: dkwo <nicolopiazzalunga@gmail.com>
Date: Fri, 11 Mar 2022 18:35:22 +0100
Subject: [PATCH 13/13]  python3-nbclassic: update to 0.3.6

---
 srcpkgs/python3-nbclassic/template | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/srcpkgs/python3-nbclassic/template b/srcpkgs/python3-nbclassic/template
index 066ce4adc96b..6d122531347e 100644
--- a/srcpkgs/python3-nbclassic/template
+++ b/srcpkgs/python3-nbclassic/template
@@ -1,18 +1,19 @@
 # Template file for 'python3-nbclassic'
 pkgname=python3-nbclassic
-version=0.3.5
+version=0.3.6
 revision=1
 wrksrc=nbclassic-${version}
 build_style=python3-module
 hostmakedepends="python3-setuptools"
 depends="python3-jupyter_notebook python3-jupyter_server"
+checkdepends="${depends} python3-pytest python3-pytest-fixture-config python3-pytest-subtests"
 short_desc="Jupyter Notebook as a Jupyter Server Extension"
 maintainer="dkwo <nicolopiazzalunga@gmail.com>"
 license="BSD-3-Clause"
 homepage="https://jupyter.org"
 distfiles="${PYPI_SITE}/n/nbclassic/nbclassic-${version}.tar.gz"
-checksum=99444dd63103af23c788d9b5172992f12caf8c3098dd5a35c787f0df31490c29
-# Tarball includes no tests
+checksum=7dbac0a6cb71bbe3afa1fe89369e6e3174d89f42aa08216a327046de45aa9a4f
+# missing fixtures: jp_create_notebook jp_fetch
 make_check=no
 
 conf_files="/etc/jupyter/jupyter_server_config.d/*.json"

^ permalink raw reply	[flat|nested] 52+ messages in thread

end of thread, other threads:[~2022-08-22 16:50 UTC | newest]

Thread overview: 52+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-02-03 13:22 [PR PATCH] update few python3 packages dkwo
2022-02-03 13:23 ` ahesford
2022-02-03 13:30 ` dkwo
2022-02-03 13:32 ` [PR PATCH] [Updated] " dkwo
2022-02-03 13:46 ` dkwo
2022-02-03 13:47 ` dkwo
2022-02-03 13:58 ` [PR PATCH] [Updated] " dkwo
2022-02-03 14:07 ` dkwo
2022-02-03 14:30 ` ahesford
2022-02-03 15:27 ` dkwo
2022-02-03 15:27 ` [PR PATCH] [Updated] " dkwo
2022-02-13 10:35 ` dkwo
2022-02-13 10:46 ` dkwo
2022-02-13 12:41 ` ahesford
2022-02-13 13:22 ` dkwo
2022-02-13 18:49 ` ahesford
2022-02-14  9:58 ` [PR PATCH] [Updated] " dkwo
2022-02-14 10:00 ` dkwo
2022-02-14 10:08 ` dkwo
2022-02-21  9:42 ` [PR PATCH] [Updated] " dkwo
2022-02-28 12:49 ` dkwo
2022-03-11 17:38 ` dkwo
2022-03-11 17:41 ` dkwo
2022-03-14 19:24 ` [PR PATCH] [Updated] " dkwo
2022-03-14 20:22 ` [PR REVIEW] " paper42
2022-03-14 20:22 ` paper42
2022-03-14 20:22 ` paper42
2022-03-14 20:22 ` paper42
2022-03-14 20:23 ` paper42
2022-03-15 13:40 ` dkwo
2022-03-15 13:41 ` dkwo
2022-03-15 13:45 ` dkwo
2022-03-15 13:46 ` dkwo
2022-03-15 13:48 ` [PR PATCH] [Updated] " dkwo
2022-03-20 22:51 ` [PR REVIEW] " paper42
2022-03-20 22:51 ` paper42
2022-03-20 22:52 ` paper42
2022-03-21  7:46 ` dkwo
2022-03-21  7:51 ` dkwo
2022-03-21  7:54 ` dkwo
2022-03-21  8:07 ` dkwo
2022-03-21  8:11 ` dkwo
2022-03-21  8:19 ` dkwo
2022-03-21  8:23 ` [PR PATCH] [Updated] " dkwo
2022-03-21  8:23 ` dkwo
2022-03-21 10:10 ` [PR PATCH] [Updated] " dkwo
2022-04-11 17:08 ` dkwo
2022-04-11 17:09 ` dkwo
2022-04-23 19:14 ` [PR PATCH] [Updated] " dkwo
2022-06-11 14:11 ` dkwo
2022-08-22 16:17 ` dkwo
2022-08-22 16:50 ` dkwo

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).