Void Linux discussion
 help / Atom feed
* update error MISSING: libssl35-2.2.4_1
@ 2015-10-29  9:31 johnny goodbye
  2015-10-29 12:05 ` Duncaen
                   ` (4 more replies)
  0 siblings, 5 replies; 10+ messages in thread
From: johnny goodbye @ 2015-10-29  9:31 UTC (permalink / raw)
  To: voidlinux

[-- Attachment #1.1: Type: text/plain, Size: 1115 bytes --]

After succesfully updating xbps-install
# xbps-install -Syu
[*] Updating `http://repo.voidlinux.eu/current/x86_64-repodata' ...
x86_64-repodata: 934KB [avg rate: 3058KB/s]
[*] Updating 
`http://repo.voidlinux.eu/current/multilib/nonfree/x86_64-repodata' ...
[*] Updating `http://repo.voidlinux.eu/current/multilib/x86_64-repodata' ...
x86_64-repodata: 357KB [avg rate: 450MB/s]
[*] Updating `http://repo.voidlinux.eu/current/nonfree/x86_64-repodata' ...
MISSING: libssl35-2.2.4_1
Transaction aborted due to unresolved dependencies.

Then trying:
# xbps-install libssl35
libressl-2.2.3_1 broken, needs `libcrypto35-2.2.4_3'
libressl-openssl-2.2.3_1 broken, needs `libcrypto35-2.2.4_3'
libtls6-2.2.3_1 broken, needs `libcrypto35-2.2.4_3'
libressl-2.2.3_1 broken, needs `libssl35-2.2.4_3'
libressl-openssl-2.2.3_1 broken, needs `libssl35-2.2.4_3'
libtls6-2.2.3_1 broken, needs `libssl35-2.2.4_3'
Transaction aborted due to unresolved dependencies.

then
# xbps-install libssl35 libcrypto35 libressl libressl-openssl libtls6
MISSING: libssl35-2.2.4_1
Transaction aborted due to unresolved dependencies.


How to solve?

[-- Attachment #1.2: Type: text/html, Size: 1259 bytes --]

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: update error MISSING: libssl35-2.2.4_1
  2015-10-29  9:31 update error MISSING: libssl35-2.2.4_1 johnny goodbye
@ 2015-10-29 12:05 ` Duncaen
  2015-10-29 12:44 ` johnny goodbye
                   ` (3 subsequent siblings)
  4 siblings, 0 replies; 10+ messages in thread
From: Duncaen @ 2015-10-29 12:05 UTC (permalink / raw)
  To: voidlinux

[-- Attachment #1.1: Type: text/plain, Size: 1284 bytes --]

xbps-install -Su ca-certificates

Am Donnerstag, 29. Oktober 2015 10:31:54 UTC+1 schrieb johnny goodbye:
>
> After succesfully updating xbps-install
> # xbps-install -Syu
> [*] Updating `http://repo.voidlinux.eu/current/x86_64-repodata' ...
> x86_64-repodata: 934KB [avg rate: 3058KB/s]
> [*] Updating `
> http://repo.voidlinux.eu/current/multilib/nonfree/x86_64-repodata' ...
> [*] Updating `http://repo.voidlinux.eu/current/multilib/x86_64-repodata' 
> ...
> x86_64-repodata: 357KB [avg rate: 450MB/s]
> [*] Updating `http://repo.voidlinux.eu/current/nonfree/x86_64-repodata' 
> ...
> MISSING: libssl35-2.2.4_1
> Transaction aborted due to unresolved dependencies.
>
> Then trying:
> # xbps-install libssl35
> libressl-2.2.3_1 broken, needs `libcrypto35-2.2.4_3'
> libressl-openssl-2.2.3_1 broken, needs `libcrypto35-2.2.4_3'
> libtls6-2.2.3_1 broken, needs `libcrypto35-2.2.4_3'
> libressl-2.2.3_1 broken, needs `libssl35-2.2.4_3'
> libressl-openssl-2.2.3_1 broken, needs `libssl35-2.2.4_3'
> libtls6-2.2.3_1 broken, needs `libssl35-2.2.4_3'
> Transaction aborted due to unresolved dependencies.
>
> then
> # xbps-install libssl35 libcrypto35 libressl libressl-openssl libtls6
> MISSING: libssl35-2.2.4_1
> Transaction aborted due to unresolved dependencies.
>
>
> How to solve?
>

[-- Attachment #1.2: Type: text/html, Size: 3632 bytes --]

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: update error MISSING: libssl35-2.2.4_1
  2015-10-29  9:31 update error MISSING: libssl35-2.2.4_1 johnny goodbye
  2015-10-29 12:05 ` Duncaen
@ 2015-10-29 12:44 ` johnny goodbye
  2015-10-29 12:58 ` johnny goodbye
                   ` (2 subsequent siblings)
  4 siblings, 0 replies; 10+ messages in thread
From: johnny goodbye @ 2015-10-29 12:44 UTC (permalink / raw)
  To: voidlinux

[-- Attachment #1.1: Type: text/plain, Size: 577 bytes --]

Thanks for your suggestion; it didn't solve the problem though.

 xbps-install -Su ca-certificates
[*] Updating `http://repo.voidlinux.eu/current/x86_64-repodata' ...
[*] Updating 
`http://repo.voidlinux.eu/current/multilib/nonfree/x86_64-repodata' ...
[*] Updating `http://repo.voidlinux.eu/current/multilib/x86_64-repodata' ...
[*] Updating `http://repo.voidlinux.eu/current/nonfree/x86_64-repodata' ...
libtls6-2.2.3_1 broken, needs `libcrypto35-2.2.4_3'
libtls6-2.2.3_1 broken, needs `libssl35-2.2.4_3'
Transaction aborted due to unresolved dependencies.


How to solve?
>

[-- Attachment #1.2: Type: text/html, Size: 813 bytes --]

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: update error MISSING: libssl35-2.2.4_1
  2015-10-29  9:31 update error MISSING: libssl35-2.2.4_1 johnny goodbye
  2015-10-29 12:05 ` Duncaen
  2015-10-29 12:44 ` johnny goodbye
@ 2015-10-29 12:58 ` johnny goodbye
  2015-10-29 13:02   ` Duncaen
  2015-10-29 23:08 ` johnny goodbye
  2015-10-30 15:26 ` johnny goodbye
  4 siblings, 1 reply; 10+ messages in thread
From: johnny goodbye @ 2015-10-29 12:58 UTC (permalink / raw)
  To: voidlinux

[-- Attachment #1.1: Type: text/plain, Size: 283 bytes --]



Maybe a packaging error?
When searching 
https://github.com/voidlinux/void-packages/search?utf8=%E2%9C%93&q=libssl35-2.2.4_1&type=Code
I only find
libssl.so.35 *libssl35-2*.2.2_1

In http://repo.voidlinux.eu/current/multilib/ you can find
 *libssl35*-*32bit*-*2.2.4_1*.x86_64.xbps

[-- Attachment #1.2: Type: text/html, Size: 385 bytes --]

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: update error MISSING: libssl35-2.2.4_1
  2015-10-29 12:58 ` johnny goodbye
@ 2015-10-29 13:02   ` Duncaen
  2015-10-29 13:10     ` Duncaen
  2015-10-29 14:45     ` Chris Brannon
  0 siblings, 2 replies; 10+ messages in thread
From: Duncaen @ 2015-10-29 13:02 UTC (permalink / raw)
  To: voidlinux

[-- Attachment #1.1: Type: text/plain, Size: 615 bytes --]

The newest version is libssl35-2.2.4_3 
(https://github.com/voidlinux/void-packages/blob/master/srcpkgs/libressl/template)
Maybe you can find out what depends on libssl35-2.2.4_1 with xbps-query -X 
libssl35-2.2.4_1 and update them first.

Am Donnerstag, 29. Oktober 2015 13:58:33 UTC+1 schrieb johnny goodbye:
>
>
>
> Maybe a packaging error?
> When searching 
> https://github.com/voidlinux/void-packages/search?utf8=%E2%9C%93&q=libssl35-2.2.4_1&type=Code
> I only find
> libssl.so.35 *libssl35-2*.2.2_1
>
> In http://repo.voidlinux.eu/current/multilib/ you can find
>  *libssl35*-*32bit*-*2.2.4_1*.x86_64.xbps
>

[-- Attachment #1.2: Type: text/html, Size: 2011 bytes --]

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: update error MISSING: libssl35-2.2.4_1
  2015-10-29 13:02   ` Duncaen
@ 2015-10-29 13:10     ` Duncaen
  2015-10-29 14:45     ` Chris Brannon
  1 sibling, 0 replies; 10+ messages in thread
From: Duncaen @ 2015-10-29 13:10 UTC (permalink / raw)
  To: voidlinux

[-- Attachment #1.1: Type: text/plain, Size: 988 bytes --]

or try xbps-query -x libressl-openssl this one is obsolete and an older 
version of ca-certificates depends on it this is why i suggestet to update 
ca-ceriticates first, that worked for others, maybe there is more that 
depends on libressl-openssl and hast to be updated first.

Am Donnerstag, 29. Oktober 2015 14:02:41 UTC+1 schrieb Duncaen:
>
> The newest version is libssl35-2.2.4_3 (
> https://github.com/voidlinux/void-packages/blob/master/srcpkgs/libressl/template
> )
> Maybe you can find out what depends on libssl35-2.2.4_1 with xbps-query -X 
> libssl35-2.2.4_1 and update them first.
>
> Am Donnerstag, 29. Oktober 2015 13:58:33 UTC+1 schrieb johnny goodbye:
>>
>>
>>
>> Maybe a packaging error?
>> When searching 
>> https://github.com/voidlinux/void-packages/search?utf8=%E2%9C%93&q=libssl35-2.2.4_1&type=Code
>> I only find
>> libssl.so.35 *libssl35-2*.2.2_1
>>
>> In http://repo.voidlinux.eu/current/multilib/ you can find
>>  *libssl35*-*32bit*-*2.2.4_1*.x86_64.xbps
>>
>
[-- Attachment #1.2: Type: text/html, Size: 3120 bytes --]

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: update error MISSING: libssl35-2.2.4_1
  2015-10-29 13:02   ` Duncaen
  2015-10-29 13:10     ` Duncaen
@ 2015-10-29 14:45     ` Chris Brannon
  1 sibling, 0 replies; 10+ messages in thread
From: Chris Brannon @ 2015-10-29 14:45 UTC (permalink / raw)
  To: voidlinux

Duncaen <over...@googlemail.com> writes:

> The newest version is libssl35-2.2.4_3
> (https://github.com/voidlinux/void-packages/blob/master/srcpkgs/libressl/template)
> Maybe you can find out what depends on libssl35-2.2.4_1 with
> xbps-query -X libssl35-2.2.4_1 and update them first.

Yeah, so the offending package here is really libressl-openssl, not
libssl35 or whatever xbps-install was complaining about.
So what the OP really needs to do is update all the stuff that depends
on it:
xbps-query -X libressl-openssl
and xbps-install -Su <list of packages>
After that, I think you can remove libressl-openssl and go on about your
business...

-- Chris

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: update error MISSING: libssl35-2.2.4_1
  2015-10-29  9:31 update error MISSING: libssl35-2.2.4_1 johnny goodbye
                   ` (2 preceding siblings ...)
  2015-10-29 12:58 ` johnny goodbye
@ 2015-10-29 23:08 ` johnny goodbye
  2015-10-30 15:26 ` johnny goodbye
  4 siblings, 0 replies; 10+ messages in thread
From: johnny goodbye @ 2015-10-29 23:08 UTC (permalink / raw)
  To: voidlinux

[-- Attachment #1.1: Type: text/plain, Size: 1949 bytes --]

Indeed
# xbps-query -X libssl35-2.2.4_1
gave nothing
but
# xbps-query -X libressl-openssl 
ca-certificates-20150426_3
and
xbps-install -Su ca-certificates
[*] Updating `http://repo.voidlinux.eu/current/x86_64-repodata' ...
x86_64-repodata: 934KB [avg rate: 4728MB/s]
[*] Updating 
`http://repo.voidlinux.eu/current/multilib/nonfree/x86_64-repodata' ...
[*] Updating `http://repo.voidlinux.eu/current/multilib/x86_64-repodata' ...
x86_64-repodata: 357KB [avg rate: 390MB/s]
[*] Updating `http://repo.voidlinux.eu/current/nonfree/x86_64-repodata' ...
libtls6-2.2.3_1 broken, needs `libcrypto35-2.2.4_3'
libtls6-2.2.3_1 broken, needs `libssl35-2.2.4_3'
Transaction aborted due to unresolved dependencies.


Op donderdag 29 oktober 2015 09:31:54 UTC schreef johnny goodbye:
>
> After succesfully updating xbps-install
> # xbps-install -Syu
> [*] Updating `http://repo.voidlinux.eu/current/x86_64-repodata' ...
> x86_64-repodata: 934KB [avg rate: 3058KB/s]
> [*] Updating `
> http://repo.voidlinux.eu/current/multilib/nonfree/x86_64-repodata' ...
> [*] Updating `http://repo.voidlinux.eu/current/multilib/x86_64-repodata' 
> ...
> x86_64-repodata: 357KB [avg rate: 450MB/s]
> [*] Updating `http://repo.voidlinux.eu/current/nonfree/x86_64-repodata' 
> ...
> MISSING: libssl35-2.2.4_1
> Transaction aborted due to unresolved dependencies.
>
> Then trying:
> # xbps-install libssl35
> libressl-2.2.3_1 broken, needs `libcrypto35-2.2.4_3'
> libressl-openssl-2.2.3_1 broken, needs `libcrypto35-2.2.4_3'
> libtls6-2.2.3_1 broken, needs `libcrypto35-2.2.4_3'
> libressl-2.2.3_1 broken, needs `libssl35-2.2.4_3'
> libressl-openssl-2.2.3_1 broken, needs `libssl35-2.2.4_3'
> libtls6-2.2.3_1 broken, needs `libssl35-2.2.4_3'
> Transaction aborted due to unresolved dependencies.
>
> then
> # xbps-install libssl35 libcrypto35 libressl libressl-openssl libtls6
> MISSING: libssl35-2.2.4_1
> Transaction aborted due to unresolved dependencies.
>
>
> How to solve?
>

[-- Attachment #1.2: Type: text/html, Size: 4371 bytes --]

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: update error MISSING: libssl35-2.2.4_1
  2015-10-29  9:31 update error MISSING: libssl35-2.2.4_1 johnny goodbye
                   ` (3 preceding siblings ...)
  2015-10-29 23:08 ` johnny goodbye
@ 2015-10-30 15:26 ` johnny goodbye
  2015-11-09  8:17   ` Juan RP
  4 siblings, 1 reply; 10+ messages in thread
From: johnny goodbye @ 2015-10-30 15:26 UTC (permalink / raw)
  To: voidlinux

[-- Attachment #1.1: Type: text/plain, Size: 145 bytes --]



Solved it by doing:
# xbps-install -Sf libcrypto35 libssl35 libtls6 ca-certificates 
Everyone  who tried to help me, thanks for your support!


[-- Attachment #1.2: Type: text/html, Size: 185 bytes --]

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: update error MISSING: libssl35-2.2.4_1
  2015-10-30 15:26 ` johnny goodbye
@ 2015-11-09  8:17   ` Juan RP
  0 siblings, 0 replies; 10+ messages in thread
From: Juan RP @ 2015-11-09  8:17 UTC (permalink / raw)
  To: voidlinux

[-- Attachment #1.1: Type: text/plain, Size: 160 bytes --]

The solution is as simple as:

# xbps-install libressl ca-certificates libtls6

Yes, this sucks and was a special case that ain't going to happen 
frequently.


[-- Attachment #1.2: Type: text/html, Size: 223 bytes --]

^ permalink raw reply	[flat|nested] 10+ messages in thread

end of thread, back to index

Thread overview: 10+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-10-29  9:31 update error MISSING: libssl35-2.2.4_1 johnny goodbye
2015-10-29 12:05 ` Duncaen
2015-10-29 12:44 ` johnny goodbye
2015-10-29 12:58 ` johnny goodbye
2015-10-29 13:02   ` Duncaen
2015-10-29 13:10     ` Duncaen
2015-10-29 14:45     ` Chris Brannon
2015-10-29 23:08 ` johnny goodbye
2015-10-30 15:26 ` johnny goodbye
2015-11-09  8:17   ` Juan RP

Void Linux discussion

Archives are clonable: git clone --mirror http://inbox.vuxu.org/voidlinux

Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.archive.voidlinux


AGPL code for this site: git clone https://public-inbox.org/ public-inbox