Void Linux discussion
 help / Atom feed
* failure to boot after install
@ 2017-05-04  8:52 Pierre B
  2017-05-11 12:54 ` Pierre B
  0 siblings, 1 reply; 3+ messages in thread
From: Pierre B @ 2017-05-04  8:52 UTC (permalink / raw)
  To: voidlinux

[-- Attachment #1.1: Type: text/plain, Size: 2105 bytes --]

I have strange case of a machine where Voidlinux fails to install correctly.

Let me start by saying that I'm using Voidlinux on several computers/VMs 
and I'm now getting used to setting it up.
Still there is this one computer where I can't figure out what's going on. 
I'm installing the OS to a usb stick and the computer in question is a 
Core2Quad running on a X38 motherboard.
Also note that a different flavor of Linux installs and runs fine on it.

The install procedure itself completes without error:
<https://lh3.googleusercontent.com/-s6nlWys386o/WQrnVQndiVI/AAAAAAAAC18/trGL4VhsLYQvompN7UDEgXgorbc8d8fhQCLcB/s1600/void%2Binstall%2Blog.jpg>






















What happens afterward it that the PC freezes at the bios level. After 
processor detection, freeze occurs at memory count, only the letter "M" is 
displayed:

<https://lh3.googleusercontent.com/-T3PNnUgO3fk/WQrn6NszN4I/AAAAAAAAC2I/DIxE5EPQPg4nxtb4P42HTTFlXk0XDUOiQCLcB/s1600/bios%2Bfreeze.jpg>

Void-installer boots fine but as soon as the key with newly installed Void 
is plugged in during BIOS screen it freezes.

I tried reinstalling grub manually with verbose output and it doesn't throw 
an error:


<https://lh3.googleusercontent.com/-YiLKCEHGyGE/WQrowWzE2RI/AAAAAAAAC2Q/4kli-ELlYrsR8r_jocwvW_sqiECDaG5pgCLcB/s1600/grub%2Binstall%2Blog.jpg>Just 
a bit curious about this part 
<https://lh3.googleusercontent.com/-YiLKCEHGyGE/WQrowWzE2RI/AAAAAAAAC2Q/4kli-ELlYrsR8r_jocwvW_sqiECDaG5pgCLcB/s1600/grub%2Binstall%2Blog.jpg> --prefix 
'(,msdos1)/boot/grub'
Shouldn't there be a device before the comma ?

Digging a bit deeper, I analyzed MBR on that key after dumping it into 
nonworking.mbr file:

<https://lh3.googleusercontent.com/-N2dPfe5gMb4/WQrp5cEhR0I/AAAAAAAAC2c/IV35RNBY24ocfRrnfHn1XZUzB--hePhlgCLcB/s1600/non%2Bworking%2BMBR.jpg>

What strikes me is that huge part full of zero from offsets 10 to 50. 
Comparing to a working installation there is plenty of data in that area.


Images were also uploaded here: http://imgur.com/a/deBq0


So I'm turning to your expertise.

If you have any idea or hint I'm all ears.




[-- Attachment #1.2: Type: text/html, Size: 4822 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: failure to boot after install
  2017-05-04  8:52 failure to boot after install Pierre B
@ 2017-05-11 12:54 ` Pierre B
  2017-07-22 11:56   ` Pierre B
  0 siblings, 1 reply; 3+ messages in thread
From: Pierre B @ 2017-05-11 12:54 UTC (permalink / raw)
  To: voidlinux

[-- Attachment #1.1: Type: text/plain, Size: 2622 bytes --]

Quick update: I gave Ubuntu 16.04 LTS a spin on that same box and it 
resulted in exactly the same situation: a non bootable usb key that freeze 
completely said host.
I'm more and more thinking this is linked to more recent versions of Grub. 

The Linux that currently runs on it is a Ubuntu 14.xx derivate with an 
older grub version. 


On Thursday, May 4, 2017 at 10:52:24 AM UTC+2, Pierre B wrote:
>
> I have strange case of a machine where Voidlinux fails to install 
> correctly.
>
> Let me start by saying that I'm using Voidlinux on several computers/VMs 
> and I'm now getting used to setting it up.
> Still there is this one computer where I can't figure out what's going on. 
> I'm installing the OS to a usb stick and the computer in question is a 
> Core2Quad running on a X38 motherboard.
> Also note that a different flavor of Linux installs and runs fine on it.
>
> The install procedure itself completes without error:
>
> <https://lh3.googleusercontent.com/-s6nlWys386o/WQrnVQndiVI/AAAAAAAAC18/trGL4VhsLYQvompN7UDEgXgorbc8d8fhQCLcB/s1600/void%2Binstall%2Blog.jpg>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
> What happens afterward it that the PC freezes at the bios level. After 
> processor detection, freeze occurs at memory count, only the letter "M" is 
> displayed:
>
>
> <https://lh3.googleusercontent.com/-T3PNnUgO3fk/WQrn6NszN4I/AAAAAAAAC2I/DIxE5EPQPg4nxtb4P42HTTFlXk0XDUOiQCLcB/s1600/bios%2Bfreeze.jpg>
>
> Void-installer boots fine but as soon as the key with newly installed Void 
> is plugged in during BIOS screen it freezes.
>
> I tried reinstalling grub manually with verbose output and it doesn't 
> throw an error:
>
>
>
> <https://lh3.googleusercontent.com/-YiLKCEHGyGE/WQrowWzE2RI/AAAAAAAAC2Q/4kli-ELlYrsR8r_jocwvW_sqiECDaG5pgCLcB/s1600/grub%2Binstall%2Blog.jpg>Just 
> a bit curious about this part 
> <https://lh3.googleusercontent.com/-YiLKCEHGyGE/WQrowWzE2RI/AAAAAAAAC2Q/4kli-ELlYrsR8r_jocwvW_sqiECDaG5pgCLcB/s1600/grub%2Binstall%2Blog.jpg> --prefix 
> '(,msdos1)/boot/grub'
> Shouldn't there be a device before the comma ?
>
> Digging a bit deeper, I analyzed MBR on that key after dumping it into 
> nonworking.mbr file:
>
>
> <https://lh3.googleusercontent.com/-N2dPfe5gMb4/WQrp5cEhR0I/AAAAAAAAC2c/IV35RNBY24ocfRrnfHn1XZUzB--hePhlgCLcB/s1600/non%2Bworking%2BMBR.jpg>
>
> What strikes me is that huge part full of zero from offsets 10 to 50. 
> Comparing to a working installation there is plenty of data in that area.
>
>
> Images were also uploaded here: http://imgur.com/a/deBq0
>
>
> So I'm turning to your expertise.
>
> If you have any idea or hint I'm all ears.
>
>
>
>
[-- Attachment #1.2: Type: text/html, Size: 7505 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: failure to boot after install
  2017-05-11 12:54 ` Pierre B
@ 2017-07-22 11:56   ` Pierre B
  0 siblings, 0 replies; 3+ messages in thread
From: Pierre B @ 2017-07-22 11:56 UTC (permalink / raw)
  To: voidlinux

[-- Attachment #1.1: Type: text/plain, Size: 2937 bytes --]

After some more testing, I've come to the conclusion that this 
motherboard's BIOS doesn't like 32GB USB drives.

Installing to a 16GB worked as expected.

On Thursday, May 11, 2017 at 2:54:50 PM UTC+2, Pierre B wrote:
>
> Quick update: I gave Ubuntu 16.04 LTS a spin on that same box and it 
> resulted in exactly the same situation: a non bootable usb key that freeze 
> completely said host.
> I'm more and more thinking this is linked to more recent versions of Grub. 
>
> The Linux that currently runs on it is a Ubuntu 14.xx derivate with an 
> older grub version. 
>
>
> On Thursday, May 4, 2017 at 10:52:24 AM UTC+2, Pierre B wrote:
>>
>> I have strange case of a machine where Voidlinux fails to install 
>> correctly.
>>
>> Let me start by saying that I'm using Voidlinux on several computers/VMs 
>> and I'm now getting used to setting it up.
>> Still there is this one computer where I can't figure out what's going 
>> on. I'm installing the OS to a usb stick and the computer in question is a 
>> Core2Quad running on a X38 motherboard.
>> Also note that a different flavor of Linux installs and runs fine on it.
>>
>> The install procedure itself completes without error:
>>
>> <https://lh3.googleusercontent.com/-s6nlWys386o/WQrnVQndiVI/AAAAAAAAC18/trGL4VhsLYQvompN7UDEgXgorbc8d8fhQCLcB/s1600/void%2Binstall%2Blog.jpg>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>> What happens afterward it that the PC freezes at the bios level. After 
>> processor detection, freeze occurs at memory count, only the letter "M" is 
>> displayed:
>>
>>
>> <https://lh3.googleusercontent.com/-T3PNnUgO3fk/WQrn6NszN4I/AAAAAAAAC2I/DIxE5EPQPg4nxtb4P42HTTFlXk0XDUOiQCLcB/s1600/bios%2Bfreeze.jpg>
>>
>> Void-installer boots fine but as soon as the key with newly installed 
>> Void is plugged in during BIOS screen it freezes.
>>
>> I tried reinstalling grub manually with verbose output and it doesn't 
>> throw an error:
>>
>>
>>
>> <https://lh3.googleusercontent.com/-YiLKCEHGyGE/WQrowWzE2RI/AAAAAAAAC2Q/4kli-ELlYrsR8r_jocwvW_sqiECDaG5pgCLcB/s1600/grub%2Binstall%2Blog.jpg>Just 
>> a bit curious about this part 
>> <https://lh3.googleusercontent.com/-YiLKCEHGyGE/WQrowWzE2RI/AAAAAAAAC2Q/4kli-ELlYrsR8r_jocwvW_sqiECDaG5pgCLcB/s1600/grub%2Binstall%2Blog.jpg> --prefix 
>> '(,msdos1)/boot/grub'
>> Shouldn't there be a device before the comma ?
>>
>> Digging a bit deeper, I analyzed MBR on that key after dumping it into 
>> nonworking.mbr file:
>>
>>
>> <https://lh3.googleusercontent.com/-N2dPfe5gMb4/WQrp5cEhR0I/AAAAAAAAC2c/IV35RNBY24ocfRrnfHn1XZUzB--hePhlgCLcB/s1600/non%2Bworking%2BMBR.jpg>
>>
>> What strikes me is that huge part full of zero from offsets 10 to 50. 
>> Comparing to a working installation there is plenty of data in that area.
>>
>>
>> Images were also uploaded here: http://imgur.com/a/deBq0
>>
>>
>> So I'm turning to your expertise.
>>
>> If you have any idea or hint I'm all ears.
>>
>>
>>
>>
[-- Attachment #1.2: Type: text/html, Size: 7909 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, back to index

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-05-04  8:52 failure to boot after install Pierre B
2017-05-11 12:54 ` Pierre B
2017-07-22 11:56   ` Pierre B

Void Linux discussion

Archives are clonable: git clone --mirror http://inbox.vuxu.org/voidlinux

Newsgroup available over NNTP:
	nntp://inbox.vuxu.org/vuxu.archive.voidlinux


AGPL code for this site: git clone https://public-inbox.org/ public-inbox